Serientermine-Darstellung in aCalendar Plus - App

  • 31 Antworten
  • Neuester Beitrag
Diskutiere Serientermine-Darstellung in aCalendar Plus - App im aCalendar(+) im Bereich Kalender.
B

BigWoelfi

Fortgeschrittenes Mitglied
Hallo,
leider finde ich kein Unterforum, in den das Problem passen könnte. In Samsung eher nicht, da es nicht um Samsung direkt geht, obwohl Samsung-Smartphone.
Ich gehe aber davon aus, dass die Pixel-Geräte auch auf Android laufen und dass mein Problem eben auch genau so hier auftreten könnten.

Das Problem, wie ich es an Google zu schicken versucht habe, über die Entwickler-App aus Google-Play, was aber nicht möglich ist offenbar, da laut Antwortmail mitgeteilt worden ist, dass die Mail nicht mehr überwacht wird.

Zitat meiner Mitteilung:
Ich habe auf dem Gerät die Google-Kalender-App in der aktuellsten Version unter Android 12.
Als Kalender benutze ich jedoch die App aCalendar Plus wegen der besseren Darstellung.

aCalendar stellt jedoch nur die Termine aus dem Google-Kalender dar, ohne selbst mit meinem Google-Account zu synchronisieren.
Hier funktioniert die Darstellung von Terminenserien, mit Terminen über mehre Tage, seit einigen Tagen nicht mehr korrekt.

Es wird zwar die Serie am ersten Tag, z. B. am Samstag, angezeigt aber nicht, wie eingestellt, auch am Sonntag.
Bisher hatte das immer korrekt funktioniert.
In der Google-Kalender-App ist die Darstellung/Anzeige noch immer korrekt.
Der aCalendar-Support verweist auf deren Hilfeseite, wo beschrieben wird, dass die Serientermine von der Google-App mit Anzahl Tage 0 an Android übergeben werden neuerdings, was aCalendar als 1 Tag interpretiert und dann auch so nur für den ersten in der eigenen App anzeigt.

Der Support teilt auch mit, das Problem bereits an Google mitgeteilt zu haben.
Wann ist mit einem angepassten Update für die Google-Kalender-App zu rechnen?
Es ist dringend.
Zitat Ende

Beispiel:
Screenshot_20220204-115331_aCalendar+.jpg

In aCalendar wird davon jetzt nur noch der Termin am Samstag angezeigt und wenn man den Termin zur Bearbeitung aufruft, steht der auch tatsächlich nur noch auf 1 Tag und nicht mehr auf 2 Tage.

Kennt hier jemand das Problem oder hat sogar Abhilfe dafür?
 
B

BigWoelfi

Fortgeschrittenes Mitglied
@Cairus

Dein Urlaub ist aber kein "Serien"-Termin, sondern nur eine Termin über mehrere Tage.
So etwas wird bei mir auch korrekt angezeigt.

Serientermine sind Termine über einen oder mehrere Tage, die sich regelmäßig wiederholen.
Beispielsweise eine Regelung bei getrennt lebenden Eltern für die Tage, die ein Elternteil das Kind bekommt.
Bei Schichtarbeit als Beipiel:

Samstag/Sonntag in der Frühschichtwoche mit 3-wöchiger Wiederholung.
Samstag in der Spätschichtwoche mit 6-wöchiger Wiederholung.
drei Wochen später Sonntags in der Spätschichtwoche, auch mit 6-wöchiger Wiederholung.
Alle Terminserien "ohne Ende".

Richtig angelegt kommt dabei in der Kalender-Anzeige heraus:
1. Woche: Samstag/Sonntag
2. Woche: nichts wegen Nachtschicht
3. Woche: Samstag oder Sonntag im Wechsel
Dann wieder von vorne
 
Cairus

Cairus

Ikone
Asso, kann ich Testen hab das dann falsch verstanden
Beitrag automatisch zusammengefügt:

So, Test angelegt, Wiederholung alle 2 Wochen
 

Anhänge

Zuletzt bearbeitet:
B

BigWoelfi

Fortgeschrittenes Mitglied
@Cairus

Das ist aber der Google-Kalender, oder?
Falls ja, da sieht das bei mir auch so aus.

Es geht mir aber um die App aCalendar Plus oder auch due Anzeige im Samsung-Kalender.
Da wird das nämlich ebenfalls nicht korrekt angezeigt, wenn man in dem die Sync mit Google aktiviert.
 
Cairus

Cairus

Ikone
Das ist der a plus, plus synchronisieren mit Google.

Widget ist a plus
 
Zuletzt bearbeitet:
B

BigWoelfi

Fortgeschrittenes Mitglied
@Cairus

Mein Google-Kalender

Screenshot_20220205-131827_Calendar.jpg

Mein aCalendar Widget (das ich sonst nicht nutze. Ich nutze direkt die App als Symbol auf der Start-App-Leiste, die man über alle App-Seiten sieht).

Screenshot_20220205-131628_One UI Home.jpg

Welche Android-Version hast Du, auch 12?

Noch was:
Welche Version hat der Google-Kalender bei Dir?
Ist der laut Google-Play aktuelle Stand?
Das Verhalten soll ja genau damit zusammen hängen.
 
Zuletzt bearbeitet:
mattlaabs

mattlaabs

Erfahrenes Mitglied
Du kannst das Problem durch ein downgrade der Google Kalender App lösen, siehe auch die aCalendar online Hilfe zu Google Kalender, auf die sollten wir eigentlich verlinkt haben, wenn du unserem Support schreibst.
Es gab bereits ein Update von Google Kalender, leider wird der Bug dort nicht behoben. Ob oder wann Google das behebt kann niemand sagen. Es wird für Google keine hohe Priorität haben, da die eigenen Produkte nicht direkt betroffen sind.

Viele Grüße
Matthias
 
B

BigWoelfi

Fortgeschrittenes Mitglied
@mattlaabs

Ich habe den Link.
Ich schrieb ja, dass ich das von Euch habe.
Aber ich wollte den Downgrade eigentlich nicht, weil man gerade unter Android nicht weiß, was danach nicht korrekt funktioniert.

Ich denke, da könnte Absicht bei Google dahinter stecken, um zu verhindern, dass Fremd-Apps nutzen.
Dass Samsung bei denen auch dazu zählt dann, wundert mich aber schon.
 
Cairus

Cairus

Ikone
@BigWoelfi

Google Kalender Version 2022.02.0-420616974-release

Laut Google aktuelle Version


aPlus Version 2.5.3

Android 12
 
Zuletzt bearbeitet:
B

BigWoelfi

Fortgeschrittenes Mitglied
@Cairus

Genau die App-Versionen sind es auch bei mir.

@mattlaabs

Ich habe bei Euch gerade das hier gefunden.
"Um den Kalenderspeicher zu resetten, gehe zu Android Einstellungen - Apps - aktiviere die Option Systemapps/prozesse anzeigen - Kalenderspeicher (nicht aCalendar oder Kalender).
Dort dann auf Speicher gehen und Speicherinhalt löschen drücken."

Gibt es diesen Kalenderspeicher von Android nicht mehr unter Android 12 (UI 2.0) oder finde ich den bloß nicht?
Ich finde nur den Samsung-Kalender und aCalendar als Apps.
Mit aktivierten "Systemanwendungen anzeigen" erscheint auch nur die ganz normale Kalender-App und da kann man dann keinen Speicher löschen, sondern nur die Anzeige oder Funktion der App deaktivieren und wieder aktivieren, mehr nicht.
 
Zuletzt bearbeitet:
B

B.Schwarz

Gast
Vielleicht liefert das ja eine Erklärung:
Screenshot_2022-02-05-15-12-12-365_com.android.vending.jpg
 
B

BigWoelfi

Fortgeschrittenes Mitglied
@B.Schwarz

Dann müsste ich den zusätzlich installieren erst, oder?
Und wenn ich den deinstalliere, bleibt der Workaround erhalten?
Ich meine, wird der im System dauerhaft implementiert, so dass der auch bei aCalendar wirkt?
Ich wollte eigentlich nicht meinen Kalender wechseln.
 
B

B.Schwarz

Gast
Ich wollte nur drauf hinweisen, dass es sich anscheinend um einen Android, bzw. Google, Fehler handelt.
Was Du für ein Chaos anrichten möchtest, musst Du schon selbst entscheiden. 😃😎
 
B

BigWoelfi

Fortgeschrittenes Mitglied
@B.Schwarz

Ich habe ihn installiert, mit dem gleichen Ergebnis, wie bei aCalendar.
Die Serientermine über mehrere Tage werden auch hier nur am ersten Tag angezeigt.
Dass die Schuld bei Google liegt, steht ja bereits in meinem ersten Beitrag, oder?
 
Zuletzt bearbeitet:
B

B.Schwarz

Gast
Okay, dann weiß ich auch nicht mehr.
 
D

darkskater

Fortgeschrittenes Mitglied
Der Workaround beim Business Kalender funktioniert bei mir. Da dieser Workaround in der App implementiert ist, hat dies natürlich keine Auswirkungen auf andere Apps wie aCalendar - hier müsste der Entwickler selbst einen Workaround bereitstellen.
 
Zuletzt bearbeitet:
D

darkskater

Fortgeschrittenes Mitglied
@holms Bei deaktivierter Google Kalender-App ist die Anzeige in aCalendar ordnungsgemäß. Es gibt aber einen unerwünschten Nebeneffekt: Der Sync-Adapter ist mittlerweile in der Google Kalender-App integriert (früher gab es eine separate Sync-App), d.h. die Termine werden nicht mehr mit dem Google-Konto synchronisiert und stehen damit nicht auf anderen Geräten zur Verfügung. Möglicherweise ist das bei Samsung-Geräten anders.
 
Cairus

Cairus

Ikone
@BigWoelfi wenn du die selben Versionen hast, dann sollte es doch bei dir auch gehen.
 
Ähnliche Themen - Serientermine-Darstellung in aCalendar Plus - App Antworten Datum
5
3
10