Apps in der Systempartition integriert, aber nicht startbar

  • 8 Antworten
  • Neuester Beitrag
Diskutiere Apps in der Systempartition integriert, aber nicht startbar im Android Allgemein im Bereich Betriebssysteme & Apps.
M

maengst

Neues Mitglied
Hallo,
da ich des öfteren mein Galaxy S flashe, wollte ich mir die Arbeit erleichtern, und eine update.zip mit allen Programmen machen, die ich so brauche.
Ich nehme also eine update.zip und packe unter system/apps alle diese Programme rein. Nach dem ausführen der update.zip mit CWM sind alle Apps installiert, nur lassen sich manche nicht starten... z.B. N64oid oder Fruit Ninja. Es kommt ein Fenster: "Sorry" bei dem ich nur noch "force close" anklicken kann.

Meine Firmware: Android 2.2.1 (DOC Rom: Base Rom JPJ)

Gruß maengst
 
T

the_alien

Experte
Du flasht ständig das gleiche ROM?
 
M

maengst

Neues Mitglied
Nein, nur hab ich es jetzt mit dem ROM das erste mal probiert...
In der update.zip sind nur die apps drin
 
T

tomcat84

Stammgast
Würde es nicht mehr Sinn machen, die Apps in /data/app zu speichern anstatt /system/app?
Oder willst du wirklich diese Spiele als nicht deinstallierbare System-Apps festlegen?

Ob das ein Grund für diese Abstürze sein kann, weiß ich nicht... kenne mich jetzt auch nicht soo gut aus ;)
 
M

maengst

Neues Mitglied
ja ds stimmt...hab jetzt via sgs tools die beiden system-apps entfernt und dann in data/app mit der update.zip installiert.
es bleibt das gleiche Problem...
Seltsam ist, dass n64oid sich öffnen lässt. Es stürzt erst ab, wenn ich eine rom starten will.
 
ramdroid

ramdroid

Stammgast
vielleicht mal die Cache partition formatieren und dalvik cache leeren?
 
M

maengst

Neues Mitglied
hat leider auch nichts gebracht...immer noch der selbe Effekt
 
Steppo

Steppo

Experte
Oder im Recovery, unter Konsole die Berechtigungen der Apps aktualisieren. Damit sollten die ForceCloses nicht mehr erscheinen und die Apps ohne Probleme funktionieren.

Code:
fix_permissions [ENTER]
Ansonsten gibt es tatsächlich einige Apps, die du erneut installieren musst.

Aber warum du so einen umständlichen Weg gehst verstehe ich jetzt nicht ganz, die App 'Titanium Backup' sichert dir die Apps sogar mit Daten. Und sie funktionieren danach alle wieder!
 
M

maengst

Neues Mitglied
Das mit dem 'fix_permission' hat leider auch nicht geklappt...
Titanium Backup hatte ich schonmal drauf, meinte aber es habe beim Wechsel zwischen verschiedenen Firmware-Versionen Probleme gemacht.
Dann werde ich es mit dem mal wieder versuchen.
Danke für eure Hilfe.
(Falls einer doch ne Lösung hat darf er sie auch posten. Würde mich dennoch interessieren, wo das Problem liegt)