[Gelöst] Sprache bei Apps wechselt nicht (mehr)

  • 4 Antworten
  • Neuester Beitrag
Diskutiere [Gelöst] Sprache bei Apps wechselt nicht (mehr) im Android Allgemein im Bereich Betriebssysteme & Apps.
L

LinuxAtHome

Neues Mitglied
1 empfohlene Antwort(en)
Hallo Gemeinde,
vor kurzem bin ich auf ein seltsames Problem gestossen:
wenn ich in Android 10 bei den Einstellungen die Sprache ändere (z.B. deutsch -> französisch),
dann wechseln sofort auch FAST alle Apps die Sprache ebenso. Nur manche arbeiten stur in Englisch.

das sind Apps wie Google Messages, SBB online, DB Navigator, VRS Fahrpläne
Kann Zufall sein, dass diese vor kurzem aktualisiert wurden (dazu verwende ich Aurora-Store) oder auch nicht?
Manches deutet darauf hin, denn Google Phone und Kontakte App zeigen das Problem (noch) nicht.

SBB online, DB Navigator, VRS Fahrpläne konnte ich "reparieren" durch Downgrade-Neuinstallation auf die vorherige Version,
bezogen über "UpToDown". Danach liefen diese wieder in der Systemsprache DE.
Das geht leider nicht mit dem Messenger (zumindest nicht ohne Datenverlust)

weitere kurze Fakten:
- bis vor ca. 2 Wochen nie ein Problem damit gehabt, trotz vieler Updates
- hab noch NetGuard laufen, hat aber hier keinen Einfluss auf das Problem
- Gerät ist Moto G8 Power mit Android 10 (reteu, build QPES30.79-124-9)
- kein Google-Konto vorhanden, Playstore wird nicht genutzt, auch keine Cloud usw.

Sieht mir nach einem Problem mit Lokalisierungsdaten aus.
Hat jemand dies schon beobachtet?
besten Dank für's Lesen
 
Empfohlene Antwort(en)
DBan

DBan

Ambitioniertes Mitglied
Das könnte mit Aurora-Store zusammen hängen.
Was läuft bei dir an Google-Diensten (noch)?
 
Alle Antworten (4)
DBan

DBan

Ambitioniertes Mitglied
Das könnte mit Aurora-Store zusammen hängen.
Was läuft bei dir an Google-Diensten (noch)?
 
L

LinuxAtHome

Neues Mitglied
Hm, vor kurzem ist ja auch Aurora 4 herausgekommen...
Meinst du, dass hier eventuell nicht alle Resourcen im apk ausgeliefert/installiert wurden?
(Hier laufen einzig die unerlässlichen Google-Play-Services und -Service-Framework)
Ich sollte mal ausprobieren, ob die oben genannten Apps bei Installation/Upgrade z.B. via ApkPure sich anders verhalten.
Komme dann wieder darauf zurück...
 
DBan

DBan

Ambitioniertes Mitglied
Ich frage mich, wie die Installation gesamt mit Google aus sieht.
Ist deine ROM die offizielle Firmware?
gapps installiert?
Ich versuche deine Konfiguration zu verstehen. Klingt nach "möglichst Google-frei".

Meine Phones (kleiner Zoo zum testen) laufen mit 3 Konfig:
- LOS with microG
- eOS
- LOS ohne gapps mit microG (per Hand installiert)
Bei Allen gibts NULL Google-Dienste. Dafür ist microG aktiv. Apps soweit nötig/möglich über F-Droid.
Aurora-Store selbst noch nicht getestet.
Was da an "Google-nach-Hause-telefonieren" in der Firmware im Hintergrund evtl. noch aktiv ist? Noch nichts geprüft.
 
L

LinuxAtHome

Neues Mitglied
So, ich habe "DBan" zu danken für den Schubs in die richtige Richtung!
Alle oben genannten Apps habe ich inzwischen mit ApkPure nachinstalliert und alle sprechen nun wieder deutsch.
Es spricht viel dafür, dass Aurora-Store ein Problem mit der korrekten Paketinstallation hat.
Danke nochmals und um noch Antwort auf die Frage nach meiner Konfiguration zu geben:
- ROM Original inkl. aller Sicherheits-Updates, nicht gerootet
- So wenig Tracking wie möglich, keine Daten nach aussen gehen lassen ausser dem was zwingend für die Funktion nötig ist.
- Apps via F-Droid und nun wohl erstmal ApkPure für nicht-opensource Apps, die ich haben wollte