1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. schoola, 22.06.2011 #1
    schoola

    schoola Threadstarter Neuer Benutzer

    Hi,

    Ich besitze ein Samsung Galaxy S2 und habe ein etwas merkwürdiges Problem mit der Internetverbindung der Apps.

    Die vorinstallierten Apps funktionieren einwandfrei. Sprich, ich kann über den Browser surfen, mit Google Mail meine eMails abrufen und Programme über den Android Market runterladen.
    Das Problem besteht bei Anwendungen, die ich nachträglich installiert habe. Sie melden alle einen Netzwerkfehler ähnlich "Connection Timed Out", "Netzwerkfehler", oder "Could Not Connect To..."

    Ich habe das ganze an verschiedenen Standorten ausprobiert, es liegt also nicht daran, dass ich keinen Empfang habe. Genauso merkwürdig ist, dass die Verbindung über WLAN einwandfrei läuft, bin ich also über ein WLAN mit dem Internet verbunden, funktionieren auch die Apps. Ausprobiert habe ich das ganze bisher mit der Facebook-App, dem DB-Navigator und einer dritten App, überall der gleiche Fehler.

    Das Gerät ist nicht gerooted, Anbieter ist DiscoTel (Vodafone-Netz). Ich bin momental ziemlich ratlos, vllt kennt hier ja jemand das Problem und kann mir helfen.

    Danke schonmal!

    EDIT: Was ich noch hinzufügen sollte: Es sind keine zusätzlichen Antiviren- oder Firewall-Anwendungen installiert, die den Zugriff blocken könnten, lediglich 3G Watchdog, um den "Daten-Verbrauch" zu messen.
     
    Zuletzt bearbeitet: 22.06.2011
  2. schoola, 23.06.2011 #2
    schoola

    schoola Threadstarter Neuer Benutzer

    So, falls jemand das gleiche Problem hat:

    Genau herausgefunden, was die Ursache des Problems war, habe ich nicht. Ich hab mit so ziemlich allen Einstellungen herumgespielt, die es gab, ohne Erfolg. Habe dann das Gerät auf Werkseinstellungen zurückgesetzt (ohne den USB-Speicher zu löschen, falls das eine Rolle spielt), alles neu konfiguriert und jetzt funktionieren auch alle Apps so, wie sie sollten :)
     
  3. Mauzi, 10.04.2013 #3
    Mauzi

    Mauzi Neuer Benutzer

    Hallo,
    ich habe seit einigen Stunden das Problem, dass einige Apps nicht mehr funktionieren, die eine Internetverbindung benötigen. Sprich: die Apps lassen sich zum Teil noch öffnen, nur können sie keine Internetverbindung nutzen.
    Dazu zählen z.B.: WhatsApp, Around me, Simpsons:Springfield und IMDb
    Andere dagegen funktionieren einwandfrei, z.B.: Facebook, Firefox, GooglePlay oder das NTV-App.
    Das Problem habe ich sowohl im WLan als auch mit mobilen Daten.
    Das Note neu starten, Akku/SIM-Karte rein, raus, Router neu starten bringt alles nichts. Hab keine Lust das Telefon zu resetten.
    Hat jemand ne Idee woran das liegen könnte?
     
  4. fragi, 10.04.2013 #4
    fragi

    fragi Android-Guru

  5. Mauzi, 10.04.2013 #5
    Mauzi

    Mauzi Neuer Benutzer

    Möglich, aber dann müssten die Programme ja eigentlich wenigstens über die WLan Verbindung laufen.
     
  6. djzon, 20.12.2013 #6
    djzon

    djzon Android-Hilfe.de Mitglied

    Hallo zusammen,

    ich habe mich heute mit mehreren Fehlermeldungen rumschlagen müssen, denn an meinem Handy lief über Nacht so einiges nicht mehr.

    1. Über Adblock Plus konnten keine neuen Hostlisten mehr geupdated werden mir einer sehr langen Fehlermeldung, die im Endeffekt "no connection" bedeutet. Der Fehler äußerte sich auch noch in drei weiteren Fehlermeldungen (es hätte ggf. sicher noch mehr gegeben):

    2. Zum einen konnte ich nicht auf den Playstore zugreifen und erhielt immer die kurze und wenig hilfreiche Rückmeldung "Keine Verbindung".

    3. Die Youtube-App lief ebenfalls nicht mehr und sagte nur noch "Es gab ein Problem mit dem Netzwerk [500]"

    4. Der Standardbrowser spuckte stets den Hinweis "Keine Sichere Datenverbindung" aus.

    Das Seltsame war, dass die WLAN-Verbindung ausgezeichnet war und der Dolphin Browser beispielsweise noch tadellose Verbindung hatte.

    Ich habe sämtliche erhaltenen Fehlermeldungen gegoogled und scheinbar keine vernünftigen Lösungen gefunden. Bei der Browser-Fehlermeldung wurde oftmals spekuliert, dass es sich um Zertifikatsprobleme handelt. Bei den anderen Apps und ihren Meldungen hieß es in der Regel der Fehler könnt wohl auf Seiten des Servers liegen. Eine vernünftige Lösung habe ich bei keinem der Googletreffer finden können, oft wurde sogar geschrieben, dass eine Neuaufspielung von Android bzw. ein Zurücksetzen auf die Werkseinstellungen vorgenommen wurde aus lauter Verzweiflung. Da sich bei mir die Fehlermeldungen heute so arg häuften, habe ich mal ausgeschlossen, dass es um Fehler von Serverseite geht.

    Ich konnte meine sämtlichen Probleme so lösen:

    - Einstellungen
    - WLAN
    - Verbundenes Netzwerk auswählen
    - Netzwerk ändern
    - Proxyeinstellungen auf "keiner" statt "manuell" setzen und ggf. um auf Nummer sicher zu gehen noch die anderen Proxyeinstellungen (Host & Port) rauslöschen.
    - Änderungen Übernehmen

    Ich hatte mal eingestellt, dass über Proxy-Einstellung manuell "localhost" und 2020 der Datenverkehr zwischengeleitet wurde, damit Adblock Plus diesen filtern konnte. Eine simple An- bzw. Abschaltung von Adblock Plus hatte das Problem nicht behoben, es lag also an der Proxy-Umleitung.

    Mich wundert es sehr, dass es nie ein Problem gab und auf einmal geht nichts mehr, hat dafür evtl. jemand eine Erklärung?

    Diesen Post habe ich hauptsächlich aus dem Grund verfasst, damit Leute, die ebenfalls solche Fehlermeldungen erhalten, nicht nur wie ich auf die weniger hilfreichen Google-Resultate stoßen, sondern hier meine Lösung finden. Vielleicht hilft es ja jemandem weiter.

    Falls es überflüssig war, dafür ein Thema zu eröffnen, darf ein Mod diesen Post auch gerne in ein separates Hilfe-Thema verfrachten oder wo er hingehören soll.

    So, schönen Abend allen zusammen!
     
  7. flyingbull, 19.02.2014 #7
    flyingbull

    flyingbull Neuer Benutzer

    Hallo,

    habe ähnliches Problem mit meinem Samsung Tab 3 - ganz neu.
    Google spielt mir alle Apps drauf die ich auch auf meinem Handy habe...Google Konto ....nettes Feature ...dachte ich.

    Firefox ausprobiert, Adblock Addon ....wieder deinstalliert
    Alles wunderbar bis hierhin.
    (denke hier irgendwo hat der Ärger angefangen)

    Opera drauf und Dolphin ... wollte ich mal ausprobieren.

    Und jetzt gings los:

    WLAN läuft - verbindung steht.

    Google App Store: klappt wunderbar - check
    Spiele zeigen Werbung: ätzz aber klappt - check
    News / Wetter: check

    Standard Browser: keine Verbindung - fail
    Firefox: fail
    Dolphin: fail
    Opera: fail
    Opera Mini: Klappt ??

    erstmal alles versucht: app runter, wieder drauf, netzwerk router resetet, wlan app, haare ausgerauft, getobt, geheult - tab auf werkseinstellungen...Problem bleibt - FAIL :flapper::drool:.

    Durch einen Tipp eines Kollegen schließlich Proxy Einstellung ausprobiert.

    Mit Proxy plötzlich : Alle Browser: Check ...WOW :biggrin:
    Dann konnte ich mich daran erinnern mal gelesen zu haben, dass Opera Mini immer einen Proxy benutzt, da die Websites irgendwie gepackt übermittelt werden, um den Traffic zu reduzieren - Opera MINI nunmal.

    Kleine Ernüchterung: Mit Proxy klappt der App Store nicht :winki:

    Ok - Proxy wieder auf Manuell und App Store klappt wieder .... die Browser klappten nur kurzzeitig bis die App wieder neugestarten...dann wieder WWW Funkstille. :sad:

    Ich versuch jetzt mal die Proxy Einstellung: KEINE zu finden -Und dann mal sehen ob ich Geistig noch bei Verstand bleibe....
     
  8. flyingbull, 22.02.2014 #8
    flyingbull

    flyingbull Neuer Benutzer

    Klappt nicht ... Hilfe ?!
     
  9. Derol, 22.02.2014 #9
    Derol

    Derol Gast

    Etwas was blockt installiert ?

    iptables
     
  10. girouno, 24.02.2014 #10
    girouno

    girouno Gast

    Du hast vermutlich das Prinzip des Ad-Blockers nicht verstanden:

    - Ad-Blocker installieren -> keine Wirkung
    - Ad-Blocker anwenden -> Wirkung (auf hosts-Datei)
    - Ad-Blocker deinstallieren -> Wirkung bleibt bestehen, da geänderte hosts-Datei bestehen bleibt.

    Lösung (einfachste): Adblocker nochmal installieren, anwenden, dann innerhalb der Ad-Blocker-App die Option zum Aufheben des Blockens ausführen, dann wieder deinstallieren.
     
  11. __W__, 24.02.2014 #11
    __W__

    __W__ Android-Ikone

    ... hmmmm, ich glaube, das verwechselst du mit "AdAway", das "verwurstet" die Hosts-Datei.

    "AdBlock" arbeitet mit einem (lokalen) Proxy zum Filtern, daher auch das "geht - geht nicht"-Problem des TE.

    Der Lösungsansatz ist aber einen Versuch wert, und nach jedem Schritt neu starten, damit 's die Dienste auch mitbekommen.

    Gruß __W__
     
  12. flyingbull, 25.02.2014 #12
    flyingbull

    flyingbull Neuer Benutzer

    hallo,
    danke vorab für eure hilfe.
    ich habe adblock erneut installiert. die option für alle deaktivieren ausgewählt und dann alles deinstalliert und das tab neugestartet...leider ohne erfolg.

    jedoch hat es mich stutzig gemacht dass ich per firefox addons downloaden konnte....

    Es hat sich herausgestellt, das ich nur .de seiten nicht aufrufen kann....anscheinen funktionieren .com und .it seiten .....

    z.bsp:
    amazon.de klappt NICHT
    amazon.com klappt

    soweit ich weiss steht in meiner hosts datei nur localhost 127.0.0.1 oder so....muss ich nochmal nachsehen.....

    also wenn jmd. noch eine idee hat...wäre sehr dankbar
     
  13. CRiZ76, 25.02.2014 #13
    CRiZ76

    CRiZ76 Android-Hilfe.de Mitglied

    Darf ich fragen, wo sich die hosts Datei befindet und wie ich den Proxy-Eintrag wieder raus bekomme?

    Ich habe seit der Deinstallation von AdBlockPlus das beschriebene Problem, daß ich weder im PlayStore, noch mit den beiden installierten Browsern eine Verbindung bekomme, aufgrund der Proxy Einstellungen.
    In den erweiterten WLAN Einstellungen ist der Proxy aber nicht aktiv.
    Kriege ich das jetzt irgendwie wieder weg?
     
  14. Otandis_Isunos, 25.02.2014 #14
    Otandis_Isunos

    Otandis_Isunos Ehrenmitglied

    /system/etc :D

    Geht auch /etc bei mir ist auf jedenfall in beiden eine hosts drin :p
     
  15. CRiZ76, 25.02.2014 #15
    CRiZ76

    CRiZ76 Android-Hilfe.de Mitglied

    Gefunden. Dort steht nur 127.0.0.1 localhost
    Das kanns also nicht sein.

    Ich hatte AdBlockPlus von der offiziellen Seite heruntergeladen und installiert.
    Das Programm hatte aber nicht für mich funktioniert, ich konnte nichtmal in die Einstellungen. Wenn die App startete, fror sie ein und ich bekam die Meldung "AdBlockPlus reagiert nicht".

    Daraufhin habe ich das Ding wieder deinstalliert. Leider blieben die Proxy-Einstellungen trotzdem erhalten und daher kann ich keine Seiten mehr aufrufen.

    Was könnte ich noch tun, um die richtigen Einstellungen zu finden ohne das ganze Teil zu resetten?
    Oder kann man die Einstellungen an sich auf Werkszustand setzen, ohne daß die Apps verschwinden?

    EDIT: Ganz einfache Lösung, auf die viele sicher nicht kommen:
    WLAN Settings -> Auf die verbundene Station gehen und "Netzwerk entfernen

    Danach einfach neu verbinden und schon klappts wieder.
     
    Zuletzt bearbeitet: 25.02.2014
  16. Otandis_Isunos, 25.02.2014 #16
    Otandis_Isunos

    Otandis_Isunos Ehrenmitglied

    AdBlock verändert ohne root überhaupt nix an der hosts Datei. Man ist lediglich angehalten, wenn das Programm läuft, einen Proxy für die jeweilig genutzte Verbindung einzurichten, welcher in der Regel 127.0.0.1:8080 sein dürfte.

    Da aber Adblock nur WLAN ohne root filtern kann, reicht es in der Regel den Proxy auch dort zu löschen :o
     
  17. flyingbull, 03.03.2014 #17
    flyingbull

    flyingbull Neuer Benutzer

    Hallo

    habe mein Problem durch das ändern des Primary und Secondary DNS in meinem Router gelöst :thumbsup:

    Ich hatte noch irgendwelche uralt DNS im Router stehen, die dann über mein DHCP an meine Rechner übergegen wurden...Laptop und Desktop hatten kein Problem damit...mein GalaxyTab und auch mein Smartphone aber schon ....
    so konnte ich mit dem Tab keine de Seiten öffnen....nur mit opera mini der automatisch einen proxy verwendet. Ich vermute es lag am Secondary DNS ... habe irgendwo im www gelesen, dass Android oft den Secondary DNS nutzt.

    Habe mich dann für folgende DNS entschieden.

    Primary: 8.8.8.8
    Secondary: 8.8.4.4

    Jetzt klappt alles wunderbärchen...auf Notebook, Desktop und Android.

    Hoffe das Hilft jemandem mit einem ähnlichen Problem.

    Grüße
     
  18. pillipalle, 11.12.2014 #18
    pillipalle

    pillipalle Neuer Benutzer

    Vielen Dank für deinen Beitrag, djzon. Du hast mir quasi meinen Tag gerettet, bzw. viele Stunden rumfummeln mir erspart. Hab gestern den Adblocker gelöscht und nichts ging mehr. Überhaupt ging vieles nicht mehr seit ich den Adblocker hatte. Ich hab mich extra hier registriert, weil ich mich total über deinen Beitrag gefreut habe. Jetzt läuft alles wieder rund.:thumbsup:
     
  19. Rech Fischbach, 23.05.2015 #19
    Rech Fischbach

    Rech Fischbach Neuer Benutzer

    @CRiZ76

    Super, bei mir hat es nach Deinem System vom 25.02.14 geklappt:
    Vielen Dank!:thumbup:
     
  20. Piet2, 07.07.2018 #20
    Piet2

    Piet2 Neuer Benutzer

    Hallo,

    ich hatte seit ein paar Monaten das gleiche Problem, dass manche Apps auf meinem Android-Smartphone keine Verbindung zum Internet per WLAN herstellen konnten.
    Andere Apps konnten dies sehr wohl.
    Das Phänomen trat sehr oft auf, aber manchmal funktionierte es trotzdem.
    Ich habe auch viele Stunden vergeblich im Internet gesurft.

    Bis dann der rettende Post von flyingbull Abhilfe schaffte.

    Die DNS-Einstellungen meines Routers unter
    DNSv4-Server war:
    "Vom Internetanbieter zugewiesene DNSv4-Server verwenden (empfohlen)"
    Jetzt habe ich "Andere DNSv4-Server verwenden" aktiviert und, wie von flyingbull genannt, die beiden DNS-Adressen 8.8.8.8 und 8.8.4.4 eingetragen.
    Endlich funktioniert es wieder wie gewünscht.

    @flyingbull
    Vielen Dank für deinen Beitrag.
    Die lange Suche nach Abhilfe hat nun ein Ende.

    Auch ich habe mich extra wegen dieser Antwort und dem Dank an flyingbull hier registriert.
     
Die Seite wird geladen...

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. android apps keine internetverbindung

    ,
  2. android manche apps kein internet

    ,
  3. proxy localhost 2020

    ,
  4. app hat keine internetverbindung,
  5. app keine internetverbindung,
  6. apps keine internetverbindung android,
  7. localhost 2020,
  8. ntv app keine internetverbindung,
  9. manche apps kein internet,
  10. apps keine internetverbindung,
  11. android apps kein internet,
  12. amazon app keine internetverbindung,
  13. tablet apps keine internetverbindung,
  14. app meldet keine internetverbindung,
  15. android app keine internetverbindung
Du betrachtest das Thema "Keine Internetverbindung für manche Apps verfügbar" im Forum "Android Allgemein",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.