1. Chuwi Hi9 Air LTE Gewinnspiel ! Alle Informationen findest Du hier!
  1. peacemoon, 18.07.2009 #21
    peacemoon

    peacemoon Neuer Benutzer

    komischerweise habe ich für SDK r3 und SDK r2 gleiche Version von adb . Ist das richtig oder ich habe falsh gedownloaded?

    Hast du das unter Windows oder Ubuntu geschafft?
     
    Zuletzt bearbeitet: 18.07.2009
  2. flori9100, 18.07.2009 #22
    flori9100

    flori9100 Android-Experte

    Edit: OK, den Treiber aus dem SDK1.5R3 hab ich jetzt installiert bekommen (Win7 stellt sich da ein bisschen sehr zickig an irgendwie). Nur erkennt adb das Gerät im Moment nicht ("adb devices" liefert leere Liste) - muss man da jetzt noch irgendwas machen? Vendor-IDs eintragen?
     
    Zuletzt bearbeitet: 18.07.2009
  3. kitagua, 18.07.2009 #23
    kitagua

    kitagua Threadstarter Android-Hilfe.de Mitglied

    Erklärst Du mir wie? Ich bin auch grad dabei. Hab zunächst mal versucht das PC Studio unter Windows 7 zu installieren. Gibt ja diverse Fehler bei der Installation der Treiber. Hast Du das hinbekommen ? Als Admin hab ich versucht, evt. muss ich noch den Komp. Modus für XP oder Vista hinzuschalten hmm
     
  4. flori9100, 18.07.2009 #24
    flori9100

    flori9100 Android-Experte

    Also ich habs nicht geschafft, irgendwas von der Samsung-CD zu installieren, wurde alles mit nichtssagenden Fehlermeldungen quitiert. Habe aber keinen Kompatibilitätsmodus probiert, nur 'als Admin ausführen' (wodurch dann andere Fehlermeldungen kamen :rolleyes: )

    Hab dann aber für das Galaxy, das als nicht-erkanntes Gerät gelistet wurde, manuell den USB-Treiber aus dem SDK R3 installiert ... Win7 sträubt sich da und macht das nur, wenn man explizit manuell einen Treiber auswählt und dann eben die *.inf aus dem /usb_driver/-Verzeichnis nimmt .. aber dann wird es laut Gerätemanager korrekt erkannt.

    Nur adb oder DDMS erkennen es noch nicht :(
     
  5. koy

    koy Erfahrener Benutzer

    Kanns du mir vielleicht erklären wie du es unter Ubuntu geschafft hast?

    Ich will nämlich nicht jedesmal Win7 booten um einige Dateien aufs Handy zu kopieren.
     
  6. olafgeibig, 18.07.2009 #26
    olafgeibig

    olafgeibig Android-Hilfe.de Mitglied

    Ich versuche auch schon die letzten Tage mit dem galaxy zu entwickeln, aber es geht einfach nicht. Ich bin auch in dem Thread auf google groups involviert und habe gesehen, dass in aktuellen adb source tatsächlich eine Unterstützung für das Samsung eingebaut ist. Na mal sehen. Den USB Masstorage muss man immmer erst aktivieren indem man auf die USB Notification tippt und dann mountet.

    Gruss, Olaf
     
  7. flori9100, 18.07.2009 #27
    flori9100

    flori9100 Android-Experte

    Ich weiß nicht, was ich angestellt habe, aber bei mir funktioniert inzwischen nichtmal mehr das :o
    Wenn ich das Galaxy anschließe, erkennt der PC zwar, dass ein Gerät dran ist, allerdings werden keine Wechseldatenträger angefügt (auch keine "leeren"). Im Galaxy kommt auf kein Notify, wo ich die Speicher freigeben kann.
    Hab schon die neuen Treiber aus dem SDK deinstalliert, alles zigmal an- und abgestöpselt oder restartet - nichts! :(
     
  8. koy

    koy Erfahrener Benutzer

    Dass es das Galaxy erkennt, aber nicht mal als "leeren" Datenträger auftaucht, hatte ich noch nie.

    Ich würde mal sagen, dass es die falschen Treiber benutzt. Am besten alles deinstallieren (inkl. alle Treiber).

    Wenn man das Galaxy direkt an den PC anschließt, ohne die Samsung Software vorher zu installieren, kann man Vista sagen es soll die Treiber von Windows Update runterladen.
    Dies funktioniert auch sehr gut und erspart einem, die nervige Samsung PC Software zu installieren um an die Datenträger ranzukommen.
     
  9. Maniac, 18.07.2009 #29
    Maniac

    Maniac Android-Experte

    Ich habe es auch mit dem r3 SDK getestet... Win XP akzeptiert aber auch den Treiber noch nicht für das Samsung. Und ohne Treiber wohl kein adb... also noch etwas warten... :(
     
  10. flori9100, 18.07.2009 #30
    flori9100

    flori9100 Android-Experte

    Hab' ich eigentlich schon, einschließlich der zwischengespeicherten Treiberdateien im Systemverzeichnis ... hilft nix :/


    Naja, mal schauen was sich da machen lässt .. aber Windows neu aufsetzen wollte ich jetzt eigentlich deswegen auch nicht :o
    Werd's morgen mal am Netbook (WinXP) testen.
     
  11. skrj2e, 20.07.2009 #31
    skrj2e

    skrj2e Gast

    es tut mir leid, dass ich nicht erklären konnte. ich bekam keine email erinnerung aus android-hilfe für diesen Thread. ich lade hier die von mir geänderte Datei "android_usb.inf" für den Treiber unter XP hoch. Ersetzt den alteren "android_usb.inf" und installiert den Treiber erneut. es funktioniert gut bei mir.
     

    Anhänge:

    Zuletzt von einem Moderator bearbeitet: 20.07.2009
  12. tiran, 20.07.2009 #32
    tiran

    tiran Erfahrener Benutzer

    hey skrj2e läuft wunderbar.

    Danke für den treiber.

    Hab ihn auf WinXP Sp3 getestet.

    Werde es später nochmal zuhause auf meiner Win7 Maschine testen und berichten.

    Besten dank skrj2e
     
  13. player, 20.07.2009 #33
    player

    player Neuer Benutzer

    was habt ihr denn jetzt wo wie installiert und was geht jetzt?
     
  14. tiran, 20.07.2009 #34
    tiran

    tiran Erfahrener Benutzer

    Hi Player,

    der Treiber ist für die ADB(Android Debugging Bridge) für das Galaxy. Somit kannst du direkt auf dem Galaxy programmieren.

    Man muss den Treiber manuell installieren bei der automatischen suche wird dieser nicht gefunden.

    mfg

    p.s. leider geht der treiber unter win 7 nicht :(
     
  15. tiran, 20.07.2009 #35
    tiran

    tiran Erfahrener Benutzer

    nach löschung des alten treibers und neustart lief der treiber dann doch unter win 7 :)
     
  16. player, 20.07.2009 #36
    player

    player Neuer Benutzer

    ah wie schön! endlich den ressourcenfressenden Emulator aus lassen und am Gerät testen :)
     
  17. flori9100, 21.07.2009 #37
    flori9100

    flori9100 Android-Experte

    32bit oder 64bit?
    Weil ich hab's unter x64 nicht zum Laufen bekommen, habe die Ini der 64bit-Treiber exakt so verändert wie die hier gepostete ini-Datei (bis auf die x64-Sachen halt), er installiert auch, erkennt dann aber das Device nicht.
    Trotz deinstall, Neustart, adb-restart etc ...

    Hat's überhaupt schon jemand unter einem 64bit-BS zum Laufen gekriegt?
     
  18. olafgeibig, 21.07.2009 #38
    olafgeibig

    olafgeibig Android-Hilfe.de Mitglied

    Wie gesagt, bei mir unter ubuntu hardy 64 bit läuft es super mit Deiner Binary. Geht alles, wenn man die üblichen Anpassungen für Ubuntu macht (google fragen) und dabei die udev rule auf Samsung's vendor id anpasst:
    [FONT=Courier, Monospaced]
    SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666" [/FONT]
     
  19. tiran, 22.07.2009 #39
    tiran

    tiran Erfahrener Benutzer

    Also ich benutze eine 32bit System auf meinem 64Bit System habe ich es noch nicht ausprobiert.

    Hast du mal Probiert die .dll und .sys Datei aus den Windows Ordnern zu löschen nicht nur einfach im Gerätemanager deinstallieren.

    .dll - windows\system32
    .sys - windows\system32\drivers

    Ich habe die .sys und .dll Datein aus dem Android SDK_r3 benutzt. Ka obs da einen Unterschied zu _r2 gib, hab es nicht verglichen.

    Damit hat es, wie gesagt, bei mir funktioniert.

    grüße

    ps: schau dir den Thread mal an vielleicht findest du da was https://www.android-hilfe.de/forum/samsung-galaxy-i7500.21/adb-jetzt-auch-auf-dem-galaxy.4021.html
     
    Zuletzt bearbeitet: 22.07.2009
  20. flori9100, 22.07.2009 #40
    flori9100

    flori9100 Android-Experte

    Ja, soweit es ging, habe ich das gemacht ... leider gibts bei Win7 einen "DriverStore", ein Ordner in dem alle Treiber gespeichert werden. Und der ist selbst mit Admin-Rechten nicht zu bearbeiten (da sie vom System-User erstellt wurden und System > Admin).
    Absolut bescheuert, genauso wie manch andere Cachefunktion. Da editiert man in den Treiberdateien und Windows liest das nicht neu aus, sondern aus irgendeinem Cache *seufz*
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
App beim Booten starten / Android 8 Android App Entwicklung Donnerstag um 11:44 Uhr
Android Einstellungen Android App Entwicklung 02.05.2019
Entwicklungs Laptop Android App Entwicklung 23.04.2019
Bluetooth Tethering ON / OFF Android App Entwicklung 04.04.2019
Wie beobachtet man LiveData im Repository vom ViewModel aus? (room, Android architecture components) Android App Entwicklung 04.04.2019
Kein Menübutton unter Android 8? Android App Entwicklung 13.03.2019
Android Studio Gradle Problem Android App Entwicklung 27.02.2019
Datenbank mit Kundendaten Android App Entwicklung 13.02.2019
Android playstore pusblishing: no supported devices Android App Entwicklung 11.02.2019
<a href="tel: ..." & <a href="mailto: ..." in Android Sudio webview Android App Entwicklung 29.01.2019
Du betrachtest das Thema "Android Entwicklung mit dem Samsung Galaxy" im Forum "Android App Entwicklung",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.