1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. zx128, 27.01.2009 #1
    zx128

    zx128 Threadstarter Android-Lexikon

    Habe beschlossen hier mein Test-Tool für Android-Entwickler vorzustellen :rolleyes:

    Das Ding heiß AnETTe und ist im Prinzip eine GUI für die Telnet-Schnittstelle vom Emulator aus dem SDK.

    AnETTe's Homepage

    Würde mich über euere Feedbacks/Kritik/Vorschläge freuen :)
     
  2. ses, 29.01.2009 #2
    ses

    ses Administrator Mitarbeiter

    Hi,

    definitiv ein schönes Projekt.

    Ps.: Handelt es sich bei Android-Telefonie.de um deine Seite?
    Wie wäre es mit einem "Forum"-Link auf Android-Hilfe.de ;) ?
     
    Cua gefällt das.
  3. zx128, 29.01.2009 #3
    zx128

    zx128 Threadstarter Android-Lexikon

    Das Projekt ist im Moment leider etwas "eingefroren", vor allem wegen fehlenden Feedbacks :mad:

    Es wäre toll, wenn paar Leute sich paar Features wünschen. Das würde mir dabei helfen, zu entscheiden, was da noch alles rein kann/soll :confused:

    Es läuft aber im Moment so ab, dass die Leute die AnETTe ziehen und für immer verschwinden :(

    Ja, Android-Telefonie.de gehört mir. Ein Link zu diesem Forum wäre kein Thema, ist ja ein schönes Forum hier :)

    Ich könnte aber auch paar eingehende Links gebrauchen, kann man da was machen?
     
  4. zx128, 29.01.2009 #4
    zx128

    zx128 Threadstarter Android-Lexikon

    Freeddi gefällt das.
  5. kanty2ka, 02.02.2009 #5
    kanty2ka

    kanty2ka Erfahrener Benutzer

    Wie läuft das mit SDK eigentlich ... habe es mir gezogen und mal diesen Emulator gestartet .. ausser ein G1 in rot konnte ich nix sehen und machen ^^

    Wie kann ich zb die aktuelle Firmware/os testen unter diesen Emulator ?

    MfG
     
  6. zx128, 02.02.2009 #6
    zx128

    zx128 Threadstarter Android-Lexikon

    Paar Fragen:

    1. Welches Betriebsystem hast du?

    2. Was bedeutet "ein G1 in rot"? War da was auf dem Bildschirm, sprich funtzt der oder alles nur schwarz?

    Eine Antwort:

    Wenn du die aktuelle Firmware testen willst, gibt es zwei Möglichkeiten. Eine aufwendige und eine einfachere.

    Lies erst mal bitte hier den Topic. Dann weiß du eventuell genau, was du machen möchtest.
     
    Zuletzt bearbeitet: 02.02.2009
    Cyanlux gefällt das.
  7. kanty2ka, 02.02.2009 #7
    kanty2ka

    kanty2ka Erfahrener Benutzer

    1. XP
    2. ein Abbild vom G1 , auf dem Display stand nur ANDROID, sobald ich was angeklick habe, sprich tasten des G1, passierte nichts
     
  8. zx128, 02.02.2009 #8
    zx128

    zx128 Threadstarter Android-Lexikon

    Der allererste Start vom emulator kann schon was dauern. Paar Minuten sogar.

    Hast du den Ordner, wo "emulator" liegt zum PATH hinzugefügt?
     
  9. kanty2ka, 02.02.2009 #9
    kanty2ka

    kanty2ka Erfahrener Benutzer

    jo, wie du es gesagt hast , ein paar minuten warten ^^

    mal ne andere frage , das ganze os is ja glaub als system.img ?! oder ??
     
  10. zx128, 02.02.2009 #10
    zx128

    zx128 Threadstarter Android-Lexikon

    Alles was unter "/system" liegt - ist in system.img
     
  11. mak

    mak Neuer Benutzer

    Hallo zx128.
    Habe deine "Anette" auch im Test und finde sie sehr gut.
    Vielleicht kannst Du noch einbauen, dass sie auch SMS
    vom Emulator empfangen kann?
    Schade finde ich nur, dass der Emulator keinen eigentlichen CallAufbau
    macht, sondern direkt eine Verbindung besteht, auch ohne, dass man
    explizit mit "Anette" annimmt.
    Aber das ist ja nicht dein Fehler, sondern der des Emulators.
    Grüße
    Mak
     
  12. zx128, 03.02.2009 #12
    zx128

    zx128 Threadstarter Android-Lexikon

    Hallo Mak,

    freue mich als Entwickler, dass du das Tool nutzt und gut findest :)

    "SMS Emulator ->AnETTe" ist leider nicht möglich. Das Telnet-Interface vom Emulator bietet das(noch?) nicht an.

    Das mit Outbound-Calls vom Emulator - hast du richtig geschrieben. Der Call kommt automatisch zu Stande, ohne auf irgendein Answer zu warten.

    Das einzige was man momentan damit machen kann ist mit "busy" zu beenden. Also als ob der angerufene aufgelegt hätte. Dafür muss allerdings die Rufnummer vom gewählten Call mit der Rufnummerim Feld "Telephony-Phonenumber" übereinstimmen.

    Da gehört (in die AnETTe) eigentlich eine Call-Verwaltungs-Liste hin. Mache ich bei Zeiten.
     
  13. zx128, 03.02.2009 #13
    zx128

    zx128 Threadstarter Android-Lexikon

    Ich hab noch mal genau nachgeguckt. Hast vollkommen recht. system.img ist das OS.

    Ergo: um cupcake mit dem Emulator auszuprobieren reicht das neue system.img irgendwo abzuspeichern und das Emulator mit "-system SYSTEM_IMG_PATH" zu starten.

    P.S. Ich müsste mein Blog-Eintrag zum Thema cupcake mal anpassen.
     
  14. kimjongill, 26.05.2009 #14
    kimjongill

    kimjongill Neuer Benutzer

    Hi,

    habe mir auch gerade das aktuelle SDK geladen und erfolgreich installiert. Im Anschluss daran ein "avd" angelegt und den emulator mit
    Code:
    emulator -avd test01 -verbose -skin HVGA-L
    
    gestartet!

    Habe in vorherigen Posts gelesen, es kann "einige Minuten" dauern. Habe eine Celeron 2,66GHz mit 512MB Arbeitsspeicher. Warte schon eine halbe Stunde und sehe nur das Android Logo (dass animierte).

    Fällt das unter "einige Minuten" oder ist das eher ungewöhnlich bzw. habe ich was falsch gemacht (vielleicht beim anlegen des "avd")?

    Besten Dank für eure Bemühungen

    und viele Grüße
     
  15. krisz, 26.05.2009 #15
    krisz

    krisz Erfahrener Benutzer

    Hast du mal versucht irgendwelche Tasten zu drücken, passiert irgendwas wenn du die Menu-Taste drückst? So lange dürfte das Starten eigentlich nicht dauern, sogar auf meinem Netbook mit 900MHz startet der Emulator innerhalb von weniger als 5 Minuten.
     
  16. kimjongill, 26.05.2009 #16
    kimjongill

    kimjongill Neuer Benutzer

    passiert gar nichts!

    der Ablauf ist wie folgt:
    - Emulator öffnet sich, zeigt das gewählte Handy mit darunterstehender Tastatur und schwarzen Bildschirm an
    - Wenige Augenblicke Später erscheint der Textzug "Android_" mit blinkendem Unterstrich im Bildschirm
    - und im Anschluss daran das animierte Android-Logo

    danach kommt leider bis in alle Ewigkeit nichts mehr...

    Vielleicht noch zur Info: nutze Linux und wenn ich mir die Prozesse anschaue, dann wird folgendes angezeigt:

    Code:
    19228 pts/2    00:00:00 java <defunct>
    habe aber extra den gnu java compiler durch das offizielle Java von Sun ersetzt (Wie auch schon in den Erläuterungen auf der android Seite zu lesen war....)
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Android Studio 4 Knöpfe nebeneinander Android App Entwicklung Gestern um 16:30 Uhr
[OFFEN] Android app selber entwickeln mit Bluetooth Android App Entwicklung Freitag um 12:01 Uhr
[OFFEN] Kostenpflichtige App für Beta-Test hochladen Android App Entwicklung 13.09.2017
[Offen] Android Layout funktioniert nicht Android App Entwicklung 08.09.2017
[ERLEDIGT] LL zur Laufzeit erstellen, Abstand zwischen LL und LL möglich ? Android App Entwicklung 06.09.2017
[OFFEN] App schließt nach Öffnen sofort Android App Entwicklung 04.09.2017
[ERLEDIGT] Um einen Zusatz in einem Programm unter Android zu machen Android App Entwicklung 22.08.2017
[GESCHLOSSEN] Random ListItem ausgeben funktioniert nicht mehr Android App Entwicklung 13.08.2017
[OFFEN] Bild per Intent an ListView übergeben und anzeigen Android App Entwicklung 13.08.2017
[OFFEN] SVN Commit in Android Studio funktioniert nicht mehr Android App Entwicklung 07.08.2017
Du betrachtest das Thema "Test-Tool für Android Emulator" im Forum "Android App Entwicklung",