Welches Eclipse für Android SDK?

  • 34 Antworten
  • Neuester Beitrag
Diskutiere Welches Eclipse für Android SDK? im Android App Entwicklung im Bereich Betriebssysteme & Apps.
zx128

zx128

Experte
litux schrieb:
natürlich ist es sinnvoller mit 1.5 zu arbeiten aber wie gesagt, das ist die vorgabe der auftraggeber.
naja.....
Nur so am Rande ohne irgendwas aufzwingen zu wollen:

Beim SDK 1.5 kannst du unter Projekteinstellungen auch 1.1 als Zielplattform auswählen.
 
L

litux

Neues Mitglied
zx128 schrieb:
Nur so am Rande ohne irgendwas aufzwingen zu wollen:

Beim SDK 1.5 kannst du unter Projekteinstellungen auch 1.1 als Zielplattform auswählen.
danke, gut zu wissen :)
 
S

swordi

Lexikon
geil

auftraggeber sind ja sowas von ... manchmal ;)

naja solange sie es zahlen is egal ;)
 
L

litux

Neues Mitglied
naja zahlen ist nicht drin...
wird wohl sowas wie eine "spende programm" werden :)
 
S

swordi

Lexikon
lol
ohne geld haben sie auch nix zu bestimmen. aber gut, wie du meinst ;)
 
L

litux

Neues Mitglied
ja das passt schon...
das programm ist mein erstes android anwendung, daher ist es so was wie eine übung :)
ich glaub dieser thread hat so langsam seinen sinn verloren :D
 
butzel

butzel

Neues Mitglied
Also bei mir läuft jetzt Eclipse 3.5 (Galileo- Java [nicht javaEE]) mit dem SDK 1.5

Das mit dem Emulator hatte ich allerdings nur unter Windows gehabt - hier hat geholfen den Emulator manuell zustarten. Unter Gentoo ist das Problem nie aufgetaucht.

im gesamten läuft es mit Galileo + 1.5 sehr stabil (allerdings muss ich mich auf meinem Atom (1.6GHz) doch sehr geduldig mit dem Emulator sein ;) vlt hast Du nicht lange genug gewartet bis das AndroidOS gebootet hatte)

hier noch eine VideoAnleitung
:cool:http://www.fosslc.org/drupal/node/449
The Screencast Blog: How to: Google Android in Eclipse
The Screencast Blog: Getting Started with the Android Development Tools
 
Zuletzt bearbeitet:
L

litux

Neues Mitglied
Ich werd das alte Thema mal wieder zum Leben erwecken, in der Hoffnung, dass es mir geholfen wird :)
Also hab jetzt Galileo mit Android-SDK 1.5 zum laufen gebracht...
Das Problem ist der Emulator und zwar wenn ich den zum ersten mal laufen lasse...
Manchmal wird der Emulator sehr schnell hochgefahren und MANCHMALLLLL braucht er mehr als 30 Minuten bis OPENEND :)
Vielleicht hat jemand von euch auch mal das Problem gehabt.
Mein System:
Laptop:
-Ubuntu 9.04
-GNOME 2.26.1
-Kernel 2.6.28-14-generic
-2 Gig Arbeitsspeicher
-Intel Core 2 Dou 1,8 GHz


LOGCAT:
08-02 12:48:10.566: WARN/PackageManager(580): Unknown permission com.google.android.googleapps.permission.ACCESS_GOOGLE_PASSWORD in package com.android.development
08-02 12:48:10.566: WARN/PackageManager(580): Unknown permission com.google.android.providers.gmail.permission.WRITE_GMAIL in package com.android.settings
08-02 12:48:10.566: WARN/PackageManager(580): Unknown permission com.google.android.providers.gmail.permission.READ_GMAIL in package com.android.settings
08-02 12:48:10.566: WARN/PackageManager(580): Unknown permission com.google.android.googleapps.permission.GOOGLE_AUTH in package com.android.settings
08-02 12:48:10.576: WARN/PackageManager(580): Unknown permission com.google.android.googleapps.permission.GOOGLE_AUTH in package com.android.browser
08-02 12:48:10.576: WARN/PackageManager(580): Unknown permission com.google.android.googleapps.permission.GOOGLE_AUTH.mail in package com.android.contacts
08-02 12:48:10.785: DEBUG/dalvikvm(580): GC freed 3089 objects / 175144 bytes in 112ms
08-02 12:48:10.805: INFO/SystemServer(580): Starting Content Manager.
08-02 12:48:10.975: WARN/ActivityManager(580): Unable to start service Intent { action=android.accounts.IAccountsService comp={com.google.android.googleapps/com.google.android.googleapps.GoogleLoginService} }: not found
08-02 12:48:10.975: WARN/AccountMonitor(580): Couldn't connect to Intent { action=android.accounts.IAccountsService comp={com.google.android.googleapps/com.google.android.googleapps.GoogleLoginService} } (Missing service?)
08-02 12:48:10.975: INFO/SystemServer(580): Starting System Content Providers.
08-02 12:48:10.986: INFO/ActivityThread(580): Publishing provider settings: com.android.providers.settings.SettingsProvider
08-02 12:48:11.005: INFO/ActivityThread(580): Publishing provider sync: android.content.SyncProvider
08-02 12:48:11.015: INFO/SystemServer(580): Starting Battery Service.
08-02 12:48:11.025: ERROR/BatteryService(580): Could not open '/sys/class/power_supply/usb/online'
08-02 12:48:11.025: ERROR/BatteryService(580): Could not open '/sys/class/power_supply/battery/batt_vol'
08-02 12:48:11.025: ERROR/BatteryService(580): Could not open '/sys/class/power_supply/battery/batt_temp'
08-02 12:48:11.035: INFO/SystemServer(580): Starting Hardware Service.
08-02 12:48:11.035: DEBUG/qemud(559): fdhandler_accept_event: accepting on fd 10
08-02 12:48:11.035: DEBUG/qemud(559): created client 0x10fd8 listening on fd 11
08-02 12:48:11.035: DEBUG/qemud(559): client_fd_receive: attempting registration for service 'hw-control'
08-02 12:48:11.035: DEBUG/qemud(559): client_fd_receive: -> received channel id 2

 
Zuletzt bearbeitet:
Burki

Burki

Experte
Hier läuft die SuSE 11.1 und ich habe Eclipse (Ganymed) aus dem Repository heraus installiert.
Diese Version scheint keine Möglichkeiten zu bieten, das ADT Plugin einzufügen :(
HELP -> Software Updates -> Meldung :
"Cannot launch the Update UI. This installation has not been cofigured properly for software updates"
Ist da was zu retten :confused:
 
zx128

zx128

Experte
@Burki:

"aus dem Repository" - heißt über SuSE-Installer?

Dann würde ich eine Version von der Eclipse-Seite nehmen.
Die Distri-eigene-Versionen machen schon mal Probleme
 
Burki

Burki

Experte
Ja , ist über den Installer gekommen.
Habe schon mal die Ganymed-Version gezogen.
Jetzt stehe ich vor dem Problem, eine .ZIP-Datei auf der SuSE zu installieren :o
Auch die android-sdk-linux_x86-1.5_r3 habe ich hier vorliegen.
Stehe gerade mitten im Wald und es ist sehr dunkel :o
P.S.
Es wurde Licht :)
Habe Eclipse Ganymed3.4.2 mit dem Android PlugIn zum Laufen bekommen :)
Dann kann ich wohl mit den ersten Gehversuchen anfangen ;)
P.S.
... noch nicht ganz
Ein Handysymbol ist in der Werkzeugleiste vorhanden, das angklickt ein Fenster öffnet, in dem ich aber kein Handy auswählen kann :confused:
Wie bekomme ich da so was wie ein Magic hinein :confused:
 
Zuletzt bearbeitet:
goto

goto

Ambitioniertes Mitglied
In diesem Menü befindet sich ein Reiter der "Create AVD" heißt.

Ich empfehle dir folgendes:
Hello, World | Android Developers

Und bei eclipse ist es wirklich kein Problem die neuste Version (Galileo) von eclipse.org zu benutzen. Einfach runterladen, entpacken und starten. ;)
 
Burki

Burki

Experte
Danke für den Tip :)
Damit komme ich erst mal weiter :)
 
Burki

Burki

Experte
Ich weiß zwar überhaupt noch nicht, was ich da gerade getan habe :rolleyes:
... aber Eclipse läuft mit dem Bildschirmhandy, was gerade Hello Android ausgegeben hat :eek:
Hätte nicht gedacht, das die Bildschirm-Atrappe genauso funktioniert, wie mein kleines Original :eek: :)
Damit kann man aber jede Menge Freizeit vernichten :D
 
S

Scogit

Ambitioniertes Mitglied
Eclipse 3.5 - Galileo funktioniert einwandfrei

Für mehr komfort:
AnyEditTools - Autoformatiert Code und überflüssige Whitespace Entfernung
MoreClipboard - Clippboard mit History
Subversive - SVN Client

evl. noch
Eclipse Git Plugin - Git Client (wenn man sich an anderen Projekten beteiligt die Git nutzen)

Alle Plugins bis auf Git sind auf eclipseplugincentral.com zu finden bzw. Suberversive direkt auf eclipse.org
 
Ähnliche Themen - Welches Eclipse für Android SDK? Antworten Datum
6
5
4