Welches Eclipse für Android SDK?

S

Samsung I7500

Erfahrenes Mitglied
Threadstarter
Hi ho!

Ich habe jetzt mehrere Eclipse Varianten durchprobiert (Eclipse, Eclipse Easy, Eclipse Classic, mit irgendwelchen Zusatzplugins und auch ohne, etc.). Entweder wollte sich das Eclipse Android Plugin nicht installieren lassen auf grund irgendwelcher Konfigurationsprobleme oder fehlenden Plugins, oder aber der Android Emu hat rumgezickt. Jedenfalls wollte das Hello World beispiel aus von den Google seiten einfach nicht laufen.

Nun ja, wie dem auch sei.

Welches Eclipse (also welche Version) läuft mit Android SDK denn ohne Probleme? Gibts evtl. irgendwo ggf. n fertiges Android Pack zum entpacken und loslegen?

Thanx schonmal im voraus! :)
 
S

swordi

Gewerbliches Mitglied
hey
ein fertiges android pack habe ich net gefunden, aber ich hab mir eclipse ganymede mit dem android plug in installiert.

funktioniert einwandfrei
 
Y

yahooooo

Fortgeschrittenes Mitglied
swordi schrieb:
hey
ein fertiges android pack habe ich net gefunden, aber ich hab mir eclipse ganymede mit dem android plug in installiert.

funktioniert einwandfrei
Kann ich bestätigen. Kann sein, dass man das nach der Installation mal neu starten muss, aber grundsätzlich funktioniert das prima.
 
S

swordi

Gewerbliches Mitglied
ja die neuinstallation is sowieso klar ;)
 
S

Samsung I7500

Erfahrenes Mitglied
Threadstarter
Hm, also bei mir hat der zumindest bei der Installation nicht gemeckert wo ich ganymede ausprobiert hab. Allerdings lief der Hallo Welt Tutorial Quellcode mit dem Emulator nicht. Entweder zeigte mir dieser "A N D R O I D _" an, und es ist nichts weiter passiert, oder der Emulator hat irgend nen schwerwiegenden Fehler verursacht und hat dann nen Abgang gemacht... :/
 
S

swordi

Gewerbliches Mitglied
das passiert öfters mal

einfach emulator schließen und neu starten. dann sollte es normalerweise immer gehen.
 
S

Samsung I7500

Erfahrenes Mitglied
Threadstarter
Ja, aber bei mir passiert das andauerd. Keine Chance den Emu zum Laufen zu bekommen... :/
 
S

swordi

Gewerbliches Mitglied
dann wird wohl wo anders der fehler liegen.

am besten alles nochmal wegmachen und neu installieren.
 
S

Samsung I7500

Erfahrenes Mitglied
Threadstarter
Also ich habe nu folgendes ausprobiert:

Eclipse 3.4
Eclipse R2 3.4.2
Eclipse JEE
Android SDK 1.5 R2
ADT Installation über Softwareupdate von Eclipse

Der einzige Fehler der auftritt ist dass Eclipse probleme mit https hat, aber da sagt google man kann einfach das s weglassen und stattdessen http benutzen. Ansonsten treten keine Fehler auf. Das Android Virtual Device lässt sich ebenfalls problemlos erstellen. Aber egal was ich mach, der Emu will einfach nicht... :/
 
S

swordi

Gewerbliches Mitglied
ich hab mir die neuste eclipse version mit java unterstützung runtergeladen
dazu dann das android plugin und fertig
 
S

Samsung I7500

Erfahrenes Mitglied
Threadstarter
Die Galileo? Die machts genauso wenig... :mad:
 
S

swordi

Gewerbliches Mitglied
nö ich ganymede

gibts schon etwas neueres?
 
S

Samsung I7500

Erfahrenes Mitglied
Threadstarter
Ja, Galileo ist raus, 3.5. Frage, da es bei Dir ja zu laufen scheint, könntest Du dein Eclipse Verz. evtl. zippen und irgendwo hochladen (in der hoffnung dass es bei mir auch läuft)? Wäre cool wenn ^^
 
S

swordi

Gewerbliches Mitglied
was hast du eigentlich für ein system?
 
L

litux

Neues Mitglied
also ich habe es endlich mal hingekriegt galileo und andorid sdk.1.1 zum laufen zu bringen.
im grunde SEHR einfach, man muss nur erst mal galileo studieren damit es klappt :D
anscheinend läuft galileo nicht mit dem ADT 0.9XXXXX sonder mit dem 0.8XXX version.
so war es zu mindestens bei mir.
wenn fragen sind dann PN schreiben, da kann ich euch die nötigen links usw... zu kommen lassen :)
 
T

Temar

Fortgeschrittenes Mitglied
litux schrieb:
also ich habe es endlich mal hingekriegt galileo und andorid sdk.1.1 zum laufen zu bringen.
im grunde SEHR einfach, man muss nur erst mal galileo studieren damit es klappt :D
anscheinend läuft galileo nicht mit dem ADT 0.9XXXXX sonder mit dem 0.8XXX version.
so war es zu mindestens bei mir.
wenn fragen sind dann PN schreiben, da kann ich euch die nötigen links usw... zu kommen lassen :)
Warum wollt ihr unbedingt mit dem 1.1er SDK entwickeln? Mit dem SDK 1.5 kann man doch ebenso 1.1 Applikationen schreiben und testen (wenn man den emu auf 1.1 beschränkt). Das SDK 1.5 läuft ohne Probleme mit Galileo.
 
L

litux

Neues Mitglied
wir machen ein projet und da ist 1.1 vorgabe. ich kann es von mir aus nicht ändern, auch wenn das ganze genau so funktionieren würde :)
 
S

swordi

Gewerbliches Mitglied
warum ein projekt auf veralteter basis machen??? wer denkt sich bitte sowas aus???

mind 96% aller android benutzer haben 1.5 laufen.
 
L

litux

Neues Mitglied
natürlich ist es sinnvoller mit 1.5 zu arbeiten aber wie gesagt, das ist die vorgabe der auftraggeber.
naja.....
 
Thread starter Similar threads Forum Replies Date
K Android App Entwicklung 16
Oben Unten