Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

[ROM] CM_7.2_Extended_V2

  • 251 Antworten
  • Neuester Beitrag
Diskutiere [ROM] CM_7.2_Extended_V2 im Custom-ROMs für Huawei Ideos X3 im Bereich Root / Hacking / Modding für Huawei Ideos X3.
Time_Bandit

Time_Bandit

Experte
Dabei würden viele sinnvolle Funktionen verlorengehen. Zumal es möglicherweise auch gar nicht wirklich vorteilhaft bezüglich des Arbeitsspeichers ist (da kann man ja streiten),
immerhin sind aktuelle CMs auch spürbar schneller als Stock(basierte) ROMs.

Letztendlich hat das X3 einfach zu wenig Speicher. Hätte Huawei dem Teil gute 512 MB spendiert, wäre es trotz alter und lahmer CPU vermutlich deutlich flotter ;)
 
Zuletzt bearbeitet:
V

vander

Fortgeschrittenes Mitglied
Funktionen, du meinst die Möglichkeit zu patchen? Welche Nachteile zum Arbeitsspeicher kennst du den, der erhöhte Platzbedarf im Datenspeicher? Damit dürfte es dank µSD und Programmen wie Link2SD keine Probleme geben. Ich bin gar am überlegen ob es nicht sinnvoll wäre alle Programme auf die µSD auszulagern, da beim Speicherbenchmark meine µSD durchweg schneller war als der interne Speicher.
A1 SD Benchmark(com.a1dev.sdbench)
intern 6.6/2.7
µSD 12.9/3.2
Der Unterschied beim lesen ist schon beträchtlich. Stellt sich nur die Frage wozu ich den internen Speicher dann noch verwenden könnte? Eventuell bietet sich da dieser Patch an(ist fürs SGM, müßte also erst jemand fürs X3 porten) der den internen Speicher komplett ausblendet sobald er eine µSD findet. Somit fungiert der interne nur noch als eine Art Backuplösung falls die µSD mal "fehlt".
Macht auf mich den Eindruck als wäre diese Lösung transparenter als A2SD oder Link2SD.

Das die CM schneller sind liegt glaub ich nicht vorrangig am deodex ;)

P.S. Huawei hat auch schon 512MB Speicher spendiert, dadurch ändert sich aber die Modellbezeichnung und ein paar weitere Kleinigkeiten ... :D Ist aber logisch, nach X kommt Y.
 
Zuletzt bearbeitet:
JugoBetrugo

JugoBetrugo

Neues Mitglied
Läuft die die ROM nun stabil oder nicht, einige beschweren sich wegen nem Beschleunigungssensor der nciht mehr läuft? :confused2:
 
MegaTheLance

MegaTheLance

Stammgast
Die rom ist perfekt.
Alles flüssig,habe damals keine Bugs festgestellt.
Lob an Time_Bandit:rolleyes:

Gesendet von meinem MP700 mit der Android-Hilfe.de App
 
X

Xer0

Stammgast
kann mal jemand mit Terminal Emulator / ADB-shell folgendes ausgeben lassen:

stat /cache
stat /cache/download
 
R

rinaldino

Neues Mitglied
Hallo Experten,

als Besitzer eines Ideos X3 und leider Android/Linux-Anfänger lese ich schon seit einiger Zeit im Forum mit. Da mir mein X3 einfach etwas zu lahm ist, wollte ich auf ein etwas dynamischeres CustomRom umsteigen und habe deshalb heute versucht Time_Bandit's CM_7.2_Extended_V2 CustomRom zu installierten. Leider ist es beim Versuch geblieben, denn ich bin nach der Installation von CM_7.2_Extended_V2 gem. Time_Bandit's guter Anleitung beim Booten des neuen Systems nicht über den Android Setup-Bildschirm hinaus gekommen. Ich konnte zwar noch meine PIN eingeben, aber im danach folgenden Bildschirm, wo die Anmeldung des Google-Accounts erfolgt, stürzte das System ab. Der Bildschirm wurde schwarz, oben waren kurz noch ein paar Icons zu sehen, die dann auch gleich verschwanden. Danach war das Gerät überhaupt nicht mehr bedienbar und konnte nur noch durch Entfernen des Akku wieder zum Leben erweckt werden. Obwohl ich mir sicher war alle Schritte wie in der Anleitung beschrieben ausgeführt zu haben, habe ich beginnend mit dem Punkt "- wipe data/factory reset" die Prozedur erneut ausgeführt. Bis zum ersten Boot des CM lief alles erneut ohne Probleme glatt durch und stürzte dann aber wieder beim Android Setup-Bildschirm ab.
Hab ich etwas falsch gemacht oder liegt es an meinem X3. Dieses hat die Build-Nummer: U8510-1V100R001C169B832SP02.

Würde mich über Eure Hilfe sehr freuen.

rinaldino
 
Time_Bandit

Time_Bandit

Experte
Kannst du die Google Anmeldung mal überspringen? Möglicherweise Probleme mit dem vorinstalliertem Playstore.

Ich kann das selber derzeit nicht testen, vielleicht kann da noch jemand anderes was zu sagen.

Alle Partitionen wie beschrieben vor dem Flashen auch formatiert?
 
R

rinaldino

Neues Mitglied
Toll so ne schnelle Reaktion!! Danke.
Einmal ist es mir gelungen die Google-Anmeldung zu überspringen. Der nächste Bildschirm wurde dann nur noch im oberen Bereich aufgebaut bevor das System dann abgeschmiert ist. Es erschien oben noch ne breite Taste, was drauf stand konnte ich nicht mehr lesen weil es so schnell wieder weg war. Ein anderes mal konnte ich gerade noch auf ZURÜCK drücken, dann kam der Startbildschirm mit der Android-Männle wieder und ist dann bevor ich etwas drücken konnte abgeschmiert. Wieder ein anderes Mal hat das System während der PIN-Eingabe den Geist aufgegeben. Es war also nicht immer exakt an der gleiche Stelle bzw. nach der gleichen Bedienung. Aber mit dem Setup muss es wohl zusammen hängen.
Wie gesagt, bin ich genau nach Anleitung vorgegangen: wipe data/factory reset, dann format /boot, format /cache, format /data, format /system, /sdcard und /sd-ext hab ich nicht formatiert. Danach nur noch Dalvik Cache gewiped und dann das zip installiert. Anschließend Reboot Recovery und zum Schluß Reboot System gemacht.

rinaldiono
 
R

rinaldino

Neues Mitglied
Nachdem ich nicht mehr weiter gekommen bin hab ich inzwischen das alte 2.3.3 img wieder drauf gemacht und wollte danach einen Upgrade mit dem offiziellen 2.3.5 Upgrade machen. Bin gerade nur etwas irritiert weil da 2 Stück UPDATE.APP drauf sind. Das zweite ist im Ordner VENDOR. Braucht man das zweite überhaupt?

Werde danach (morgen) mit dem 2.3.5 nochmal Deinen CM_7.2_Extended_V2 drauf spielen.

rinaldino
 
Time_Bandit

Time_Bandit

Experte
Nein, wie beschrieben nur den "dload" Ordner inkl. der darin befindlichen "update.app" auf SD Karte packen und per -> beide Lautstärketasten & Power flashen.

Natürlich ist anschließend die CWM Recovery neu zu installieren.
 
Zuletzt bearbeitet:
R

rinaldino

Neues Mitglied
Time_Bandit, hab soeben nach der Installation des Upgrade auf 2.3.5 das CM_7.2_Extended_V2.1 von Deiner Dropbox runtergeladen und anhand Deiner Anleitung installiert. Dabei ist mir aufgefallen, dass nach advanced -> Reboot Recovery und anschließendem Reboot System das Menu auf die zweite Seite sprang. Dort gab es die Position Yes, boot ..fix...Habs mir dummerweise nicht notiert was genau da stand. Nach der Bestätigung erschien wieder die erste Seite des Menus. Wenn man jetzt "reboot system now" drückt bootet das System und landet nach einiger Zeit wieder im gleichen Hauptmenu. Habs ein paar mal von dort wieder rebootet und komm immer wieder an der gleichen Menustelle raus. Hab dann den Akku kurz raus genommen und normal mit Powertaste gestartet, dann bootet das System und landet wieder im CWM Recovery Hauptmenu. Ich bin also nicht auf den normalen Startbildschirm von CM gekommen. Tolle Schleife....

rinaldino
 
Time_Bandit

Time_Bandit

Experte
Hab das einige mal unter verschiedenen Bedingungen getestet, gab eigentlich keine Probleme.

Ich überprüf das trotzdem nochmal...
 
R

rinaldino

Neues Mitglied
Hallo Time_Bandit, bevor ich mich für heute (?) verabschiede, noch kurz meine Testergebnisse: Hab wegen der Schleife der Version 2.1 wieder die 2.0 drauf gemacht. Beim ersten Booten lief er hoch bis zur PIN-Eingabe. Ich hab zunächst gar nichts eingegeben und einfach mal gewartet. Dann ist er nach ein paar Sekunden wieder abgestürzt. Beim nächsten Boot bin ich dann nach der PIN-Eingabe durch Überspringen des Setups auf den Startbildschirm gekommen. Hab dann ein bisschen mit dem ADW rumgespielt. Dabei ist er nicht abgestürzt. Habs dann mit der Powertaste wieder runter gefahren und anschließen wieder gebootet. Hab dann den Holo gestatet. Dabei ist er wieder abgestürzt.
So und jetzt hab ich keine Lust mehr... Gute Nacht!

rinaldino
 
W

whizkid

Ambitioniertes Mitglied
Gibt es denn ein Changelog zum (neuen?) V2.1? Hast Du nur die Google Apps aktualisiert oder auch noch anderes geändert?

Der ursprüngliche Beitrag von 08:59 Uhr wurde um 09:32 Uhr ergänzt:

rinaldino schrieb:
Time_Bandit, hab soeben nach der Installation des Upgrade auf 2.3.5 das CM_7.2_Extended_V2.1 von Deiner Dropbox runtergeladen und anhand Deiner Anleitung installiert. Dabei ist mir aufgefallen, dass nach advanced -> Reboot Recovery und anschließendem Reboot System das Menu auf die zweite Seite sprang. Dort gab es die Position Yes, boot ..fix...
Selbes Problem. Nach der Installation 'reboot recovery' und dann der Versuch 'reboot now' -> CWM meldet:

--
root access possibly lost? fix yes/no
--

'no' dann häbgt CWM, -> Battery pull dann bootet das Handy wieder ins CWM. Ich teste gerade noch weiter, mal sehen an was das liegt. die V2 hat problemlos funktioniert.

Lösung:

Anschließend einfach die V2.1 nochmal drüber installieren, reboot recovery, reboot now -> dann bootet die CM7.

Soweit, sogut
 
Zuletzt bearbeitet:
Andy

Andy

Ehrenmitglied
Du musst schon "fix: yes" auswählen. Da er einen "möglichen" Rootverlust fixen will. Daher immer auswählen, ansonsten kann es sein, dass du mit der Custom ROM kein Root hast, obwohl dies standardmäßig der Fall ist, und du dann die Custom ROM extra rooten muss, falls dies dann noch möglich ist. (normalerweise schon)

Edit: Oder wie du schon gemerkt hast, einfach die ROM nochmal flashen...
 
Time_Bandit

Time_Bandit

Experte
Konnte das Verhalten tatsächlich reproduzieren, hab aber keine Ahnung woran es liegt. Ein 2. mal Drüberbügeln hilft aber.

Ich hab es erstmal bei der alten Version belassen, die ist fehlerfrei.

Außerdem hab ich ja nur die Google Apps, Launcher und ein paar der zusätzlich integrierten Apps upgedatet. Updates einspielen ist ja sonst auch kein Problem und mit Apps2ROM kann man ja alles selber ins System verschieben.
 
A

annexj

Neues Mitglied
Schade bei der rom kommt nach 3 Tagen reproduzierbar ne pin Abfrage der Sim Karte. Ich geh wieder zurück auf huawei 2.3.6.
 
X

xa.fr

Ambitioniertes Mitglied
Gibts einen PDroid Patch für dir Rom? Habe im Thread keinen gefunden. Danke