[Custom ROM] CyanogenMod 10 (Android 4.1.2) Nightly Builds

  • 4.659 Antworten
  • Neuester Beitrag
Diskutiere [Custom ROM] CyanogenMod 10 (Android 4.1.2) Nightly Builds im Custom-ROMs für Motorola Defy im Bereich Root / Hacking / Modding für Motorola Defy.
F

Freaky69

Neues Mitglied
steveletack schrieb:
Geh nochmal mit RSDLite zurück auf Stockfroyo und installier dann die nightly nochmal neu
Wies aussieht haben sich bei dir viele Installationsfehler eingeschlichen
Probier aber davor mal aus den Cache und den Dalvik Cache in CWM zu Whipen, vielleicht gehts dann besser.
Das war's ---- Läuft jetzt 1A!!! vielen Dank für die Hilfe...

Jetzt brauch ich nur noch einen vernünftigen Launcher....
Jemand ne Idee???
 
K

kadikater

Neues Mitglied
Bei mir läuft die vom10ten echt Klasse!

Erst mal vielen dank an die Programmierer!
 
S

sgdefy

Neues Mitglied
Hallo Leute,

ich habe jetzt auch die Nightly von quarx vom 10.08.12 drauf.

Positiv:

- scheint schneller zu sein
- WLAN verbindet sich schneller und ist stabiler

Negativ:

- Widgets und Apps sind beim Neustart verschwunden
(bei mir: Widgets: Business Calendar, Extended Controls
Apps: Sanfter Wecker, Swift Keyboard)

Ich habe nach dem Neueinrichten der Widgets und Apps mal die SD-Karte formatiert.
Das Verhalten war so wie nach dem Handyneustart: Widgets, Apps und Keyboard Einstellungen waren wieder weg.:crying:

Steffen
 
M

Motorolli

Fortgeschrittenes Mitglied
Freaky69 schrieb:
Jetzt brauch ich nur noch einen vernünftigen Launcher....
Jemand ne Idee???
Ich habe schon länger APEX drauf. Der ist prima.
 
B

bentuy

Neues Mitglied
wofür denn alles, wenn es kein Flash für jelly bean gibt. schadeeee
 
vetzki

vetzki

Guru
Weil es viele gibt die sich keine flash videos aufm Handy anschaun

Gesendet von meinem U9200 mit der Android-Hilfe.de App
 
D

Defier

Experte
bentuy schrieb:
wofür denn alles, wenn es kein Flash für jelly bean gibt. schadeeee
Das Flash von ICS funktioniert aber wohl auch unter JB, lies bitte die anderen Posts in diesem Thread dazu.
 
D

ddkAh

Fortgeschrittenes Mitglied
Ich habe noch eine Frage.
Mein Ram ist nahezu immer gut belegt und fast ausgelastet, also 30-40mb noch frei. Nach einem Neustart sind es knapp über 100MB.
Bei CM7 war das deutlich weniger und das Defy läuft auch nicht so schnell und smooth wie die CM7.

Hat das einen Zusammenhang?
 
D

Defier

Experte
ddkAh schrieb:
Ich habe noch eine Frage.
Mein Ram ist nahezu immer gut belegt und fast ausgelastet, also 30-40mb noch frei. Nach einem Neustart sind es knapp über 100MB.
Bei CM7 war das deutlich weniger und das Defy läuft auch nicht so schnell und smooth wie die CM7.

Hat das einen Zusammenhang?
Also ich habe noch gut 149MB frei, und das obwohl die beiden "persistenten" Apps Contacts und Messaging bereits laufen und zusammen gut 50MB schlucken. Geh doch mal in die Einstellungen und prüfe einfach, was den Arbeitsspeicher belegt.
 
D

ddkAh

Fortgeschrittenes Mitglied
habe ich schon gemacht und es läuft nix außergewöhnliches.
Nun habe ich eben mal die "aktiven Dienste" mit den "prozessen im cache" aufsummiert und komme auf ca. 210MB. Was ja völlig in Ordnung wäre.
Aktive Apps zeigt mir aber ca. 385MB Belegung.:confused2:
eigentlich läuft nur Kontakte, SMS, Einstellungen, Jorte, Whatsapp, 2x Maps, K9, DSPManager, google dienste und swype.
Im Cache laufen noch: trebuchet, google suche, kalenderspeicher, handcent, google account, adfree, 2xmaps


also nix was mich wirklich stört oder neu zu CM7 ist. Außer Trebuchet.
 
C

camelot

Fortgeschrittenes Mitglied
Ram wurde nicht eingebaut um leer zu sein sondern um benutzt zu werden.
 
D

Defier

Experte
ddkAh schrieb:
habe ich schon gemacht und es läuft nix außergewöhnliches.
eigentlich läuft nur Kontakte, SMS, Einstellungen, Jorte, Whatsapp, 2x Maps, K9, DSPManager, google dienste und swype.
Im Cache laufen noch: trebuchet, google suche, kalenderspeicher, handcent, google account, adfree, 2xmaps


also nix was mich wirklich stört oder neu zu CM7 ist. Außer Trebuchet.
Naja, nur der RAM-Verbrauch hängt eben auch davon ab, mit wieviel Daten die Apps momentan arbeiten. Ist aber vielleicht trotzdem ein interessanter Punkt, ich werde mal schauen ob ich den RAM-Verbrauch der verschiedenen ROMs frisch nach einem Fullwipe messen kann.

Der ursprüngliche Beitrag von 13:18 Uhr wurde um 13:48 Uhr ergänzt:

Ich habe das jetzt genau gemessen (naja, so genau wie es eben ging):

Code:
ROM                              MemUsed   MemFree
===================================================
CM10-NIGHTLY-120810q               253       218
CM7.2-stable                        76       307
Wie man aber sieht scheint das alte CM7 den Wert für "MemUsed" anders zu betrachten, evtl. wird dort der Cache nicht mit einbezogen.

Gemessen habe ich wie folgt: Fullwipe, ROM installieren und direkt nach dem Start in die Settings gehen und dort unter "Apps" schauen und sofort den ersten Wert notieren der angezeigt wird.
 
C

camelot

Fortgeschrittenes Mitglied
Und was hast du von freiem RAM?? Ist das mit oder ohne Cache?
 
D

Daenni

Neues Mitglied
Mal ne blöde Frage: ich habe die CM10 vom 04.08 installiert.
Akku aufgeladen 100%... nach zwei Stunden rumliegen ist der Akku auf 85% gesunken.
Gibt es da Optimierungseinstellungen oder muss ich mich damit abfinden?
Laut CPU-Spy:
00:00:53 1000MHz 0%
00:00:04: 800MHz 0%
00:00:17 700MHz 0%
2:02:45 300MHz 98%

Gesamtlaufzeit: 2:04 Stunden.

Deepsleep wurde noch garnicht benutzt?

Grüße und danke
Daniel
 
C

camelot

Fortgeschrittenes Mitglied
Ausschalten wäre ne Maßnahme
 
D

Defier

Experte
camelot schrieb:
Und was hast du von freiem RAM?? Ist das mit oder ohne Cache?
Ich vermute mal die Anzeige bei CM7 ist mit Cache, die bei CM10 ohne. Und das freie RAM steht Anwendungen zur Verfügung die du starten kannst, was ist das denn für eine Frage?

Der ursprüngliche Beitrag von 15:14 Uhr wurde um 15:15 Uhr ergänzt:

Daenni schrieb:
Mal ne blöde Frage: ich habe die CM10 vom 04.08 installiert.
Akku aufgeladen 100%... nach zwei Stunden rumliegen ist der Akku auf 85% gesunken.
Gibt es da Optimierungseinstellungen oder muss ich mich damit abfinden?
Laut CPU-Spy:
00:00:53 1000MHz 0%
00:00:04: 800MHz 0%
00:00:17 700MHz 0%
2:02:45 300MHz 98%

Gesamtlaufzeit: 2:04 Stunden.

Deepsleep wurde noch garnicht benutzt?

Grüße und danke
Daniel
Das ist definitiv nicht normal, mein defy hat beim "rumliegen" (allerdings ohne Mobilfunk) einen Verbrauch von unter 1% / Stunde.
 
D

Daenni

Neues Mitglied
Das Teil geht nach 30 Sekunden in den Standby meine ich... Nach Neustart hat sichs erledigt, DeepSleep hatte irgendwie einen weg.
Danke für die präzise Antwort :rolleyes2:
 
C

camelot

Fortgeschrittenes Mitglied
@Defier: Wie du vermutest? Schau doch nach. Und es ist eben nicht nur "freies" Ram das zur Verfügung steht. Lies dich mal in (Linux)Grundlagen ein
 
D

Defier

Experte
camelot schrieb:
@Defier: Wie du vermutest? Schau doch nach. Und es ist eben nicht nur "freies" Ram das zur Verfügung steht. Lies dich mal in (Linux)Grundlagen ein
Im Apps-Dialog steht nur "Mem used" und "Mem free", wie soll ich da etwas "nachschauen"? Ich wollte anfangs die Ausgabe über das Terminal vergleichen, aber da das Terminal in CM10 deutlich aufgemotzter zu sein scheint hatte ich befürchtet, dass es die Werte verfälschen könnte.

Zu dem Spruch mit den Linux-Grundlagen sage ich jetzt besser mal nix...
 
D

Defier

Experte
Ich habe mir jetzt extra die Mühe gemacht mit Hilfe der App "Another Monitor 1.01" den Speicherverbrauch zu messen. Vorgehensweise:

  • Fullwipe
  • ROM installieren
  • Flugmodus aktivieren
  • Screenshot-Option aktivieren (nur CM10)
  • AnotherMonitor installieren
  • AnotherMonitor starten, Zeichenfunktion in den Einstellungen abschalten (frisst viel RAM)
  • Verknüpfung für AnotherMonitor auf Homescreen legen
  • Reboot ins Recovery
  • Cache wipe
  • Reboot
  • Exakt 30 Sekunden warten
  • Bildschirm entsperren
  • AnotherMonitor starten
  • Exakt 3 Sekunden warten und Screenshot auslösen

Die Ergebnisse habe ich in den beiden Screenshots beigefügt. Man sieht daran sehr deutlich, dass CM10 einen deutlich höheren "Grundbedarf" an RAM hat. Das sollte hoffentlich keine große Überraschung darstellen, denn auch die von Google bezifferten Mindestanforderungen für Android4 sind ja gestiegen...
 

Anhänge