TIPP: Wie verstecke ich Ordner für Mediaplayer & Galerie-Apps?

  • 418 Antworten
  • Neuester Beitrag
Diskutiere TIPP: Wie verstecke ich Ordner für Mediaplayer & Galerie-Apps? im Foto und Multimedia im Bereich Android Apps und Spiele.
SeraphimSerapis

SeraphimSerapis

Lexikon
Hallo, da es sich hier um ein generelles Android "Feature" oder Problem handelt, verschiebe ich mal.
 
V

Vladok

Ambitioniertes Mitglied
Was habt ihr denn so gemacht, damit man das wegbekommt??
 
isaak

isaak

Erfahrenes Mitglied
genau das:

derHaifisch schrieb:
Das stand hier schon irgendwo mal im Forum. Ich glaube, man musste einfach eine Datei ".nomedia" erstellen. Mit Punkt am Anfang und ohne Extension. Die Datei gehört dann in jeden Ordner der Dateien enthält, die nicht als Fotos, Musik oder Videos auftauchen sollen.
 
Tscho

Tscho

Neues Mitglied
Hallo alle zusammen!

Ich bin seit 30.12.09 ebenfalls Galaxybesitzer und bin sogar mit der ausgelieferten Firmware XXIH1 (A1) mehr oder weniger zufrieden, nachdem ich mir einige Apps geladen hatte.
Nun zu meiner eigentlichen Frage! Ich habe über das letzte Monat hinweg, dieses Forum hier wirklich durchforstet, aber bin trotzdem zu keiner Lösung gekommen!

Ich habe MP3s auf meinem Galaxy und dadurch natürlich auch die Coverart der entsprechenden Alben. Nun bekomme ich in meiner Fotogalerie zu jedem eigenen Album einen Ordner mit dem Coverart angezeigt und es wird total unübersichtlich... Ich würde gerne wirklich nur meine Fotos der Kamera sehen. Hier im Forum unter der FAQ habe ich den Tipp mit der leeren Datei .nomedia gefunden, aber dies bewirkt bei mir rein gar nichts...
Ich habe einen WinXP Rechner und habe die Datei im Editor erstellt und ".nomedia" benannt. Anschließend habe ich diese Datei in jeden Unterordner meiner MP3s eingefügt, jedoch blieb der Erfolg aus und meine Galerie ist noch immer so unübersichtlich wie vorher.

Was habe ich falsch gemacht? Funkioniert das nur mit Root? Bzw. hat irgendwer einen Tipp wie es funktionieren könnte?

mfg Tscho
 
Thyrion

Thyrion

Ehrenmitglied
Bist Du sicher, dass die Datei auch ".nomedia" und nicht etwa ".nomedia.txt" heißt? Windows blendet normalerweise die "bekannten Dateiendungen" aus.

Und Notepad (der Editor) hängt gerne mal ein .txt automatisch an.
 
gado

gado

Ehrenmitglied
Muss so sein, da man mit Windows keine .nomedia anlegen kann. Astro laden und damit unbenennen, dann siehst du auch das .txt, wenn du Dateierweiterungen unter Einstellungen setzt.
 
Tscho

Tscho

Neues Mitglied
Ja, es ist tatsächlich eine .txt
Danke schon mal für die Antworten!

D.h. ich kann mit WinXP keine passende leere Datei erstellen? Woher bekomme ich diese dann?
 
Misanthropia

Misanthropia

Erfahrenes Mitglied
gado schrieb:
Astro laden und damit unbenennen, dann siehst du auch das .txt, wenn du Dateierweiterungen unter Einstellungen setzt.
Da hast Du doch die Antwort...
 
Tscho

Tscho

Neues Mitglied
Aus dieser Zeile lese ich eher heraus, dass wenn ich es mit Astro umbenenne nur sehe, dass es sich um eine .txt handelt.
Jedoch schaff ichs einfach nicht. Die .txt Dateien sehe ich im Astro nicht... und irgendwie bekomm ich nicht heraus wie ich sehen kann.

Wie kann ich diese sichtbar machen bzw. geht das nur über den Rechner? Kann ich mit Astro tatsächlich leere Dateien erstellen oder brauche ich etwas anderes dafür?
 
gado

gado

Ehrenmitglied
Du kannst unter Windows keine .nomedia erstellen. Bei Windows kommt dann eine Fehlermeldung. Deswegen einfach die .txt aufs Handy laden. Mit Astro umbenennen und sich freuen. :)

Kann sein, dass du vorher ein Restart machen musst.
 
Tscho

Tscho

Neues Mitglied
Anscheinend bin ich wirklich zu unfähig...
Wenn ich mit ASTRO in den jeweiligen Ordner reingehe in welchem die .nomedia.txt liegt, sehe ich sie nicht. Über die Suche im Astro kann ich sie finden, aber wenn sie dann in der Suche angezeigt werden kann ich sie nicht umbenennen...
Wenn ich draufklicke kommt dann "open file" und "open directory". Bei "open file" kommt "file editor", durch klick auf diesen komme ich zu einem eingabefeld mit tastatur, dort habe ich ".nomedia" eingegeben... Eine andere Möglichkeit gab es nicht irgendetwas an der Datei zu ändern -.-
Außerdem habe ich noch probiert in den "Preferences" unter "Edit File Extensions" die txt auszuwählen und dort dann den "mime type" und "subtype" zu ändern, aber hat auch nix gebracht.
Handy ein/aus hab ich auch schon nach meinen Tests gemacht, aber da diese vermutlich alle falsch waren hat sich nichts getan^^

Es funktioniert einfach nicht... Vielleicht kann mir wer von euch eine deppensichere Anleitung hier reinschreiben. Langsam bin ich am verzweifeln, obwohl es wahrscheinlich so einfach ist, dass ich mir nachher nur am Kopf greifen werde, aber ich weiß echt nicht was ich noch probieren könnte -.-
 
Nepomuk

Nepomuk

Experte
Du kannst doch einfach deine Textdatei auf der SD-Karte erstellen und sie dann mit der MS-DOS-Eingabeaufforderung (unter Windows) umbenennen.

Einfach Windowstaste+R dann 'cmd' eingeben, Enter.
Dann auf das Laufwerk der SD-Karte wechseln ('x:' eingeben, Enter). 'x' natürlich durch den Lauwerksbuchstaben der SD-Karte ersetzen.
Dann mit 'cd Verzeichnis' und jeweils Enter bis in das Verzeichnis hangeln, wo die Textdatei liegt. Und dann 'ren Textdatei.txt .nomedia', Enter.

Fertig!
 
Tscho

Tscho

Neues Mitglied
Super, danke =)
Genau sowas habe ich gesucht! Eine Anleitung mit der man Schritt für Schritt alles nachvollziehen kann. Hat alles wunderbar funktioniert.
Hiermit ist das Problem gelöst und könnte meines Erachtens fast in der FAQ verlinkt werden.
 
Thyrion

Thyrion

Ehrenmitglied
Auch unter WIN kann man eine Datei .nomedia anlegen.

z.B. mit der Eingabeaufforderung:
"type nul > .nomedia" oder "copy nul .nomedia"

oder

Notepad/Editor öffnen -> Datei speichern -> "Alle Dateien" auswählen -> ".nomedia" als Dateiname eingeben -> Speichern. Dann hängt (zumindest XP bei mir) kein .txt mehr an den Dateinamen an
 
Nepomuk

Nepomuk

Experte
Achsoo, "type nul" ist der Trick. Hab schon alles versucht, aber auf das "nul" bin ich nicht gekommen. ^^
Gut, so ist es natürlich am einfachsten.
 
S

satfinder86

Neues Mitglied
Hallo an alle,

der Tipp hat Super geklappt beim Milestone. Kann den Tipp bestätigen. War etwas anders bei mir, sonst war es schnell hinbekommen.
--> mit App Astro
--> auf PC "Neue Textdatei" auf SD schieben und dann im Handy umbenannt nach .nomedia und verschoben.

THX für den Tip.
 
G

giminic

Neues Mitglied
Ich hab mir im root meiner SD einen Ordner mit führendem Punkt angelegt. Die darin befindlichen Dateien werden auch nirgends mehr angezeigt. Es sei denn ich geh mit Astro in den Ordner.

z.B. /sdcard/.bilder

P.S. Ich möchte vorschlagen, dass der Threadstarter bzw. ein Mod im ersten Beitrag einen Edit vornimmt und drauf hinweisst, dass es zu Datenverlust kommen kann. Ich selbst war schneller im Datei erstellen und Bilder verlieren als im Thread lesen ;)
 
Thyrion

Thyrion

Ehrenmitglied
Das liegt daran, dass Linux (und damit auch Android) Datei-/Verzeichnisnamen, die mit einem Punkt anfangen, als versteckt interpretiert. Die Daten sind ja nicht weg, nur nicht immer sichtbar.
 
S

satfinder86

Neues Mitglied
richtig, das ist schon immer so. ich hatte keine probleme gehabt und klappte bei mir auf anhieb. dank der richtigen tipps vom threadstarter und thyrion.
 
Try4Ce

Try4Ce

Experte
Hallo Leute!

Verfolge dieses Forum schon laenger und bin auch seit nunmehr 2 Wochen stolzer Besitzer eines Milestone. Dank vielen fleissigen Usern hier hab ich auch meinen Stein schon sehr schoen eingerichtet und "customized". Erstmal Lob an die Community hier :)

So aber nun auch schon zu meinem Problem.
Ich habe also die 2.1 Apps wie die Gallery, den Music Player und Cam Software etc. drauf und benutze als HOME Software "Home++" .

Meine Musik habe ich unter sdcard/mobile/music gespeichert, meine Bilder unter verschiedenen Ordnern in sdcard/mobile um einige Alben zu kreieren.

Befinde ich mich aber nun im Musikplayer und sage, er soll mal alle MP3's gepflegt gemischt durchspielen, kommen seltsamerweise dazwischen immer wieder Sprachfiles meiner Navi Software dazwischen.
Wenn sich mein Milestone im Dock befindet und sich die huebsche Dock Clock meldet, und ich auf den Slideshow Button druecke, werden ALLE Bilder auf der SD Karte durchgezogen. Zu meinen Wallpapern halt dann auch noch PNG's aus meiner Weather App oder Icons wie Smileys etc aus anderen Apps.

Gibt es da eine Moeglichkeit, die Medienordner quasi zu "limitieren"? Oder sucht die Software immer direkt ALLES ab auf der SD Karte? Denn das nervt schon oftmals.
 
Ähnliche Themen - TIPP: Wie verstecke ich Ordner für Mediaplayer & Galerie-Apps? Antworten Datum
5
3
6