Huawei Ascend P1 startet nicht mehr

  • 93 Antworten
  • Neuester Beitrag
Diskutiere Huawei Ascend P1 startet nicht mehr im Huawei Ascend P1 Forum im Bereich Weitere Huawei Geräte.
vetzki

vetzki

Guru
Sorry, dann brauchst du natürlich die 229er build.prop.
 
N

Nisota

Neues Mitglied
du musst "fastboot boot cwm_touch_recovery_viva_beta.img" eingeben. aber ohne anführungszeichen.^^ ;-)
hast du das image in den plattform-tools ordner verschoben? wenn nicht, mach das am besten. ansonsten müsstest du nämlich die pfadangabe mit rein nehmen ;-)
 
L

Lisah_

Ambitioniertes Mitglied
Nisota schrieb:
du musst "fastboot boot cwm_touch_recovery_viva_beta.img" eingeben. aber ohne anführungszeichen.^^ ;-)
hast du das image in den plattform-tools ordner verschoben? wenn nicht, mach das am besten. ansonsten müsstest du nämlich die pfadangabe mit rein nehmen ;-)
Mensch das war ne Geburt :D
Habe das .img vergessen :blushing:
 
N

Nisota

Neues Mitglied
Gut. Dann kannst dich ja jetzt am Rest versuchen xD
Wenn du weitere Probleme hast, immer raus damit ;-)
 
L

Lisah_

Ambitioniertes Mitglied
Danke, danke.
Jetzt fehlt mir das hier: Android ADB Interface
Was muss ich dazu installieren ?
 
N

Nisota

Neues Mitglied
Du machst die selben Schritte wie beim Fastboot Treiber.
Nur wählst du dieses Mal nach "Auf dem Computer nach Treibersoftware suchen" den Punkt "Aus einer Liste von Gerätetreibern auf diesem Computer auswählen",
klickst auf "Datenträger", "Durchsuchen", und gehst in deinem SDK Ordner auf "sdk\extras\google\usb_driver" und wählst die Datei "android_winusb.inf"
 
L

Lisah_

Ambitioniertes Mitglied
Viva hat jetzt den Gerätetreiber Android ADB interface.
Trotzdem komme ich (trotz neustart vom Laptop) bei dem Punkt: - Wechsel wieder in deine CMD und schaut mit "adb devices", ob dein Handy angezeigt wird.
nicht weiter. error.
 
vetzki

vetzki

Guru
Und wenn du doch erstmal einfach cm installierst? Wäre evtl. einfacher, ins Recovery kommst du ja jetzt, soweit ichs mitbekommen hab. Die nötige zip könntest du ja über pc auf die sd-karte kopieren (anderes gerät, kartenleser, ...).
 
L

Lisah_

Ambitioniertes Mitglied
ich bin ja ClockworkMod Recovery v5.8.4.5
adb devices hat auch geklappt. (Also kein error)
und jetzt ist wieder error bei adb shell chmod 644 /system/build.prop^^
 
N

Nisota

Neues Mitglied
gut. dann versuch doch mal folgendes.
schließ dein gerät an.
dann gibst du "adb kill-server" und danach "adb start-server" ein. und dann versuchs nochmal mit "adb devices"

Der ursprüngliche Beitrag von 23:45 Uhr wurde um 23:46 Uhr ergänzt:

ok. das kopieren hat aber geklappt?
und du hast dran gedacht, die system-partition über cwm zu mounten?
 
vetzki

vetzki

Guru
Genau. Und vorher pushen (sprich kopieren der datei) nicht vergessen :), bevor du adb shell chmod ... eingibst.
 
L

Lisah_

Ambitioniertes Mitglied
Nisota schrieb:
gut. dann versuch doch mal folgendes.
schließ dein gerät an.
dann gibst du "adb kill-server" und danach "adb start-server" ein. und dann versuchs nochmal mit "adb devices"

Der ursprüngliche Beitrag von 23:45 Uhr wurde um 23:46 Uhr ergänzt:

ok. das kopieren hat aber geklappt?
und du hast dran gedacht, die system-partition über cwm zu mounten?
Ja,das kopieren klappt.
Das mounten kommt doch nach adb shell ... oder?
Also: mounts and restore
und dann unmount/system
 
Zuletzt bearbeitet:
N

Nisota

Neues Mitglied
nene. das wäre das unmounten.^^
sobald die cwm recovery gebootet ist, gehst du dort erstmal auf mount und dann auf mount system.
dann kopierst du die datei (push)
anschließend änderst du die berechtigungen (chmod).
und zum schluss wählst du in cwm unmount system ;-)

edit: stimmt.
aber solange die berechtigungen nicht gesetzt sind (chmod) wäre dein system dann nicht bootbar :(
 
Zuletzt bearbeitet:
L

Lisah_

Ambitioniertes Mitglied
Dort gibt es nur
-mount/sdcard
-unmount/system
-mount/data
-mount/ cust
-format/sdcard
-format/system
-format/cache
-format/data
-format /cust

Was muss ich auswählen?

Ich stelle mich wohl echt doof an hm.
 
N

Nisota

Neues Mitglied
also dein /system ist ja noch gemounted.
in diesem zustand solltest du die build.prop pushen und die berechtigungen setzen können.
klappt das denn soweit?
 
L

Lisah_

Ambitioniertes Mitglied
Nisota schrieb:
edit: stimmt.
aber solange die berechtigungen nicht gesetzt sind (chmod) wäre dein system dann nicht bootbar :(
Heißt das ich kann mein P1 doch nicht retten? :(
 
N

Nisota

Neues Mitglied
nene. das nicht.
das problem ist, dass die build.prop zumindest lesbar sein muss. und ich weiß nicht, ob die lesenberechtigung nach dem push standardmäßig gesetzt ist.
ansonsten versuch mal, dein handy neu zu starten und die b229 einzuspielen.
könnte sein, dass es jetzt schon klappt. ich kanns aber nicht garantieren

edit: zum verständnis:

die berechtigung 644 besagt folgendes:

6: besitzer (hier das android system bzw. root) darf lesen und schreiben
4: gruppe darf lesen
4: alle anderen dürfen lesen

@Vetzki, magst du hier für mich übernehmen?
Soweit haben wir das gröbste ja. Jetzt geht es nur noch um die Feinheiten.
Meiner einer muss nachher wieder hoch und schaffen gehen :D
 
Zuletzt bearbeitet:
vetzki

vetzki

Guru
Doch es ist natürlich zu retten, keine Panik ;). Bei twrp gibt es unter advanced auch einen dateimanager mit dem du die Berechtigungen setzen kannst
 
L

Lisah_

Ambitioniertes Mitglied
Bin jetzt unter TWRP auf advanced,File Manger und dann default.prop und dann bei chmod 644 eingeben oder?
und dann neu starten oder wie

Da steht auch etwas von "chmod 755"
 
N

Nisota

Neues Mitglied
755 brauchst du nicht.
das würde einfach nur zusätzlich das recht zum ausführen setzen.
in diesem fall aber unnötig, da es sich weder um eine ausführbare datei, noch um ein skript handelt ;-)