P30 Seit EMUI 11 kein Fernzugiff über VPN auf Fritzbox mit dem P30 möglich

  • 47 Antworten
  • Neuester Beitrag
Diskutiere Seit EMUI 11 kein Fernzugiff über VPN auf Fritzbox mit dem P30 möglich im Huawei P30 / P30 Pro / P30 Lite Forum im Bereich Huawei Forum.
treptowers

treptowers

Experte
Wieso soll man ein Fritz!Box App nutzen wenn es eine eigene Funktion im P30 Pro gibt ? Diese hat zu funktionieren und der Enduser muss nicht mit extra Apps das bewerkstelligen was Huawei wohl vermurkst hat.
 
daywalker1911

daywalker1911

Experte
@treptowers weil genau diese App dafür gedacht und optimiert ist? Na dann mache das so wie du willst..was scheinbar nicht funktioniert..und Ärger dich weiter damit Rum..
 
C

Codi11

Experte
@treptowers

das sehe ich genauso. VPN ist zudem seit Jahren in Android fest integriert und lief bei mir seit Jahren auch ohne Probleme.
Beitrag automatisch zusammengefügt:

daywalker1911 schrieb:
@treptowers weil genau diese App dafür gedacht und optimiert ist? Na dann mache das so wie du willst..was scheinbar nicht funktioniert..und Ärger dich weiter damit Rum..
Hey, darum geht's hier nicht. Hier geht es darum, daß Huawei mit dem Update die androideigene VPN Funktion versaut hat und diese jetzt nicht mehr nutzbar ist. Diese VPN Funktion ist im Normalfall mit jeden Androidsmartphone nutzbar (egal von welchem Hersteller), da es eine Grundfunktion von Android ist.
Ich habe selbst gerade noch einmal mit einem älteren Samsung Handy getestet, auch da funktioniert meine VPN Verbindung zur Heizung und FB problemlos, genau wie mit dem Honor 8 meiner Frau.
Zudem will auch nicht jeder für jeden Scheiß eine extra App installieren, wenn es nicht notwendig ist und eigentlich auch ganz einfach ohne App geht. Mir nützt die FritzboxApp allerdings eh nix, da ich mit der Heizungsapp auf die Android VPN Funktion angewiesen bin und diese nun nicht mehr funktioniert seit Emui11. Über die Fritzbox App lässt sich keine Verbindung zur Heizung herstellen, dafür benötige ich die androideigene VPN Funktion.
Du wärst mit Sicherheit auch sauer, wenn Du Dir für über 200€ eine Heizungssteuerung zugelegt hättest, diese über 5 Jahre problemlos funktioniert und nun mit dem P30 seit EMUI11 keine Fernwartung mehr möglich ist (was jedoch mit allen anderen Smartphones problemlos funktioniert).
Der Fehler liegt hier ganz klar bei Huawei.
 
Zuletzt bearbeitet:
treptowers

treptowers

Experte
@daywalker1911 Deine und gewisser anderer User Ihre bedingungslose Unterstützung für den Schrott was Huawei verzapft kann ich absolut nicht nachvollziehen.
 
C

Codi11

Experte
@daywalker1911

Das Problem ist einfach, das jeder Nutzer sein Smartphone anders nutzt und anders konfiguriert und damit nicht bei jeden die gleichen Fehler, oder überhaupt Fehler auftreten.
Wahrscheinlich würde ich, wenn mein P30 noch genauso laufen würde wie vor dem Update, evtl. ähnlich antworten und die Probleme der anderen nicht nachvollziehen können.
Auch für mich steht definitiv fest, daß hier von Huawei was verkackt wurde, da es vor dem Update noch ging und mit dem Samsung und Honor Smartphone immer noch funktioniert. Somit konnte ich evtl. Konfigurationsfehler in der FB und im Android VPN definitiv ausschließen.
 
Zuletzt bearbeitet:
skybird1980

skybird1980

Stammgast
Codi11 schrieb:
Nutzt du die Fritzbox App, oder hast du auf der FB und auf dem P30 Pro in den Einstellungen ohne App eine VPN Verbindung konfiguriert ?
Eingerichtet wie in der Fritzbox beschrieben über weitere Verbindungen.


Allgemein zum VPN - ist man in seinem eigenen WLAN angemeldet kann die VPN Verbindung nicht klappen. Also immer dran denken wenn man daheim ist auf mobile Daten umzuschalten zum ausprobieren.
 
Zuletzt bearbeitet:
C

Codi11

Experte
@skybird1980

Das die VPN Verbindung nicht im eigenen WLAN funktioniert ist mir schon klar bzw. das weiß ich und das ist definitiv nicht der Fehler.
Und nutzt du am P30 eine App oder das systeminterne VPN?


@all

Gerade mal wegen dem Problem etwas gegoogelt und siehe da, hier im Huawei Mate 20 Pro Beta Forum gibt's die gleichen Probleme mit VPN und EMUI11 und der Clou ist, Huawei hat den Bug in der Finalversion nicht gefixt. 👎

Link: Emui 11 Beta Plauderthread für das Mate 20 Pro

Und im Thread von @treptowers beschreibt ein User 1:1 das gleiche Problem wie ich es habe inkl. keine Verbindung mehr zum Internet (nur Neustart hilft)
Link: P30 Pro New Edition - Nach VPN Verbindung kein WLAN Internet mehr auf dem P30 Pro NE

Man kann nur hoffen das Huawei den Fehler bald gefixt bekommt.
 

Anhänge

Zuletzt bearbeitet:
skybird1980

skybird1980

Stammgast
@Codi11 Am P30 Pro die Systeminterne App
skybird1980 schrieb:
Eingerichtet wie in der Fritzbox beschrieben über weitere Verbindungen.
 
I

Inv3xis

Neues Mitglied
Also ich kann das bestätigen, dass die System VPNs nicht mehr funktionieren. Es scheint so, als sind aber nur ein paar Protokolle betroffen. HTTP(s) auf jeden Fall. Und somit kommst du nicht mehr auf die Box bzw. ins Internet, wenn alles über den Tunnel laufen soll. Ich habe das mit mehreren Fritzboxen getestet. Überall das Gleiche.
Tunnel wird aufgebaut. Ping auf Fritzbox und alles dahinter geht, wie eingestellt. Aber keine Verbindung via HTTP... WhatsApp z.b. geht durch.
Hatte das Theater damals mit meinem Mate 10 nach nem Update auch schon. Hat ca. ein halbes Jahr gedauert und ca. 15 Mails an den Support. 🙆‍♂️

Ich kann dir nur wärmstens empfehlen auf OpenVPN umzusteigen. Ist etwas Einarbeitung und noch n RaspberryPi (möglichst 3) nötig, aber du wirst es nicht bereuen. Das läuft immer und wesentlich performanter.
Ich hab das Android VPN nur noch nebenher mit drauf als 2. Möglichkeit.
 
Zuletzt bearbeitet:
C

Codi11

Experte
@Inv3xis

Danke für dein Feedback und die Bestätigung das die System VPN's nicht mehr funktionieren. Jetzt wo du es als Experte bestätigt hast, werde ich wohl mal ein bisschen den Huawei Support damit nerven müssen.
Es ist mir allerdings unverständlich, wenn mit dem EMUI 11 Update eigentlich nur die Huawei eigenen UI geupdatet werden sollte die dann auch noch im Android System rum fummeln. Sowas erwarte ich bei einem Update der Benutzeroberfläche nicht.
Einen RaspberryPi werde ich mir aber nicht dafür extra zulegen, dann eher ein neues Handy.
 
I

Inv3xis

Neues Mitglied
Hab gerade mal noch ein bisschen probiert. WLAN Hotspot an nem anderen Handy (Samsung) aktiviert dann mein P30 darauf verbunden und schon klappts mit dem VPN.
Das seltsame daran. Anschließend nochmal direkt über LTE die VPN Verbindung gemacht und die geht plötzlich auch. Als hätte das den "Knoten" gelöst.
Kannst das ja mal versuchen. Ist denke ich die praktikabelste Lösung. Ich drück die Daumen 😉

PS: Das workaround funktioniert auch nach nem Neustart. (hatte das bekannte Problem, dass kein WLAN und kein LTE mehr ging) Aber nur für diese eine VPN Verbindung. Die anderen funktionieren weiterhin nicht.
 
Zuletzt bearbeitet:
C

Codi11

Experte
@Inv3xis

Geht bei mir leider nicht.
Wenn ich mich mit dem P30 mit einem Hotspot eines anderen Handys verbinde, bin ich ja über WLAN verbunden und im WLAN kann ich die VPN Verbindung nicht aktivieren.
 
I

Inv3xis

Neues Mitglied
Das sollte aber so gehen. Du bist da ja nicht in deinem Heim WLAN sondern in dem separatem WLAN von dem anderen Handy. Du baust dann praktisch den VPN Tunnel über die LTE Verbindung des anderen Handys auf.
Wenn das so dennoch nicht funktioniert, stimmt was anderes nicht.
Das sollte genauso klappen, wie wenn du bei nem Bekannten im WLAN bist und dann die Verbindung nach Hause aufbaust.
Wichtig ist nur, dass der bekannte keine VPNs in der Fritzbox eingerichtet haben darf, da diese deine Anfrage dann verhindert.
Ich hoffe das ist halbwegs verständlich formuliert. 😅
 
C

Codi11

Experte
@Inv3xis

Danke erstmal für deine Hilfe. Heute kann ich erst einmal nicht weiter testen.
Wenn ich mit WLAN über den Hotspot verbunden bin und VPN aktivieren will kommt nicht verbunden, bin ich im LTE Netz kommt bei VPN Verbunden, aber keine Verbindung zu http.
Fakt ist jedenfalls, der Fehler liegt bei Huawei und sollte auch von Huawei wieder behoben werden. Da die Heizperiode jetzt eh bald zu Ende geht, benötige ich im nächsten halben Jahr eh die VPN Verbindung nicht mehr und werde hoffen das Huawei den Bug bis Oktober gefixt bekommt, oder ich habe bereits bis dahin ein neues Handy wo nicht Huawei drauf steht 😎.
So viel Ärger nach einem Update hatte ich bisher mit noch keinem Handy und das hier war noch nicht mal ein Majorupdate, sonder "nur" ein Update der UI. Warum man da tief im Androidsystem rum fummeln muss kann ich nicht nachvollziehen.
Klar, Fehler können passieren, daß wäre auch kein Problem wenn der Support direkt reagieren würde (Bug beheben statt zu sagen "machen Sie ein Werksreset", aber bei Huawei stehen die Chancen eher schlecht. Ich kann das Wort Werksreset schon nicht mehr hören 🙄
Erst gestern per Chat jemanden wegen dem Problem vom Huawei Support kontaktiert und als Antwort "machen Sie ein Werksreset" bekommen. Scheint bei Huawei das Allheilmittel zu sein 😄 - hilft nur leider nicht. 👎
Wahrscheinlich sind die sogenannten "Betatester" nur User die unbedingt zuerst die neuste Version haben wollen und mit Sachen wie eine VPN Verbindung über das Androidsystem herstellen völlig überfordert sind und dafür irgendwelche Apps nutzen. Der Fehler hätte doch im Betatest auffallen müssen.
 
Zuletzt bearbeitet:
skybird1980

skybird1980

Stammgast
Codi11 schrieb:
Wahrscheinlich sind die sogenannten "Betatester" nur User die unbedingt zuerst die neuste Version haben wollen und mit Sachen wie eine VPN Verbindung über das Androidsystem herstellen völlig überfordert sind und dafür irgendwelche Apps nutzen. Der Fehler hätte doch im Betatest auffallen müssen.
Eigentlich sind das sogar die Technik Affinsten. Otto Normal kommt nicht auf die Idee die Beta Seiten zu prüfen. Andere kommen zu spät.
Und wie gesagt - mein VPN funktioniert hier ohne Probleme.
 
C

Codi11

Experte
@Inv3xis

Bin gerade in einem anderen WLAN und habe meine VPN Verbindung aktiviert, hier funktioniert die VPN. Gehe ich dann aber wieder zurück auf LTE sind die bekannten Probleme wieder da, kein Zugriff auf HTTP.
 
I

Inv3xis

Neues Mitglied
Über welchen SIM Slot läuft deine LTE Verbindung? Ich hab die über die Karte im Slot 1. Vielleicht liegts auch daran. Wäre vielleicht noch n Ansatzpunkt. Aber unterm Strich isses nur Suchen. Schade, dass der Support nichts taugt.
Wie schon erwähnt. Wenn du irgend ne Linux Büchse bei dir am laufen hast, empfehle ich dir mal mit openvpn zu liebäugeln. Das läuft sogar auf ner VU+ Box. Da machst du dich nicht mehr so abhängig von Huawei und das funktioniert einfach. Ohne wenn und aber. Ist halt nur etwas schwierig mit der Erstkonfiguration.
 
C

Codi11

Experte
@Inv3xis

Ich hatte die SIM Karten bereits zum Testen gewechselt, hat aber leider auch nichts gebracht.
 
D

drucksensor

Neues Mitglied
Vielleicht hilft dies ja wem:
FP3: No VPN-Connection over mobile Networks after Android 10 update, vpn over WLAN ok

man muss den APN (in meinem Falle der Telekom) wieder auf ipv4 umstellen:
https://www.telekom.de/hilfe/geraet...et/internetverbindung-manuelle-einstellung/10

Einstellungen->Mobilfunknetz->Mobiel Daten->Zugangspunktnamen->Neuer APN:
Name egal
APN internet.telekom
proxy leer
port leer (!)
bentzer: telekom
pw: telekom
Authentyp: PAP
APN Typ (eingeben): default,supl (kein leerzeichen, alles klein)

Speichern, auswählen neustarten.
Dann erst testen ob man wirklich mobiles Internet hat.

WLAN Call ist aktuell deaktiviert.

Ich nutze fritz!Fernzugang einrichten und erweitere die Konfig und habe mehrere VPN zugänge drin.
Bei einem händisch erstelltem meldet zwar das Handy verbunden und die Fritzbox in den System logs auch verbunden, aber ich kann die fritzbox nicht über die IP ansprechen. Auch ist kein grüner Punkt bei verbunden, obwohl das Log eindeutig sagt, dass es verbunden ist.

in den VPN einstellungen ist dann aber noch der myfritz Zugang eingerichtet (keine Ahnung wann ich das gemacht habe, der läuft nicht über eine reinladbare Config bei der Fritzbox. Damit klappt es (habe einen Dyndns Account). Bei den System Ereignissen unterscheidet sich die Verbindung durch die LT Zeit LT3600 bei normaler config und LT 28800 über den "Standard" Zugang


Edit: Nevermind, hab händisch in der Config rumgespielt und die IP doppelt vergeben, einmal an den VPN PC (war drin) und das Handy, dann wars verbunden und trotzdem ging nix....
 
Zuletzt bearbeitet:
C

Corian

Neues Mitglied
Hallo Zusammen, das gleiche Problem bei mir mit Mate 20 Pro. Gestern hat es noch super funktioniert, seit heute Nacht habe ich EMUI 11 drauf und es geht nicht mehr.
Anmerkung zu den vorherigen Posts. Es geht WEDER die Hauseigene VPN, NOCH die Fritz!Box App. Wir haben 2 gleiche Mate 20 Pro, Fehler ist bei Beiden Handys, beide haben seit kurzem EMUI 11 drauf. Die VPN Verbindung lässt sich über Android selber, sowie Fritz!Box App herstellen, leider ist danach meine lokale Webseite für SmartHome nicht mehr erreichbar. Bei mir läuft dort leider ALLES, d.h. Heizung, Lampen, Xbox, Lautsprecher, Rollladen, usw. ...
 
Ähnliche Themen - Seit EMUI 11 kein Fernzugiff über VPN auf Fritzbox mit dem P30 möglich Antworten Datum
15
7
10