[Anleitung][Pixel 3/3a / 3XL/3aXL] roOt durch Magisk > Update durch OTAs > Update von Magisk

  • 316 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung][Pixel 3/3a / 3XL/3aXL] roOt durch Magisk > Update durch OTAs > Update von Magisk im Root / Custom-ROMs / Modding für Google Pixel 3 / Pixel 3 XL / Pixel 3a / Pixel 3a XL im Bereich Google Pixel 3 / Pixel 3 XL / Pixel 3a / Pixel 3a XL Forum.
C

cosmic_child

Erfahrenes Mitglied
Ich hab nachdem ich Dez org Boot drauf gemacht habe den update ohne reboot gemacht und dann mit magisk das neue Boot gepatcht und per adb eingespielt, und dann erst einen Boot gemacht?
Beitrag automatisch zusammengefügt:

Ok ich nehm mal die Dez Firmware... Melde mich dann nochmal... Kann sein das es das ist. Hab den Jan update zwar eingespielt, aber ohne reboot weitergemacht, wie bei der magisk Methode

hmm bei dez. kommt der gleiche fehler :-(
 
Zuletzt bearbeitet:
Kazama

Kazama

Ehrenmitglied
Puh dann weiß ich leider erstmal nicht weiter. Ich versuch mal noch was im Internet raus zu bekommen.
 
C

cosmic_child

Erfahrenes Mitglied
@Kazama naja zur Not poste ich bei xda heute Abend...
Thx Comic
 
Kazama

Kazama

Ehrenmitglied
Welche Version von adb und fastboot hast du, weißt du das?

Lad dir mal den angehangen Ordner runter und koopiere den Inhalt bei dir in C:\adb.

Außer dein ADB Ordner ist woander. :)

Bzw. hast du adb mit dem 15 sek. Tool installiert?

Und dann nochmal das Januar Factory Image flashen. Erstmal ohne -w, falls deine Daten noch da sind.
 

Anhänge

  • platform-tools_r29.0.5-windows.zip
    6,8 MB Aufrufe: 1
Zuletzt bearbeitet:
C

cosmic_child

Erfahrenes Mitglied
ich hatte mit dem xda tool die adb´s installiert - probier es aber nochmal - vielleicht ein hinweis: über normale adb befehle komm ich nicht mehr auf das handy - wenn ich die flashall_bat nehme rebootet und installiert er (wenigstens teilweise)...
hab jetzt mit dem 15sec tool nochmal die adb´s installiert, gebootet und leider gehts weder mit dem jan noch mit dem dez. update..
die fehler sind auch immer die gleichen...
 
Kazama

Kazama

Ehrenmitglied
Den Ordner von mir hast da rein kopiert? Also entpackt und kopiert. 😊
 
Zuletzt bearbeitet:
C

cosmic_child

Erfahrenes Mitglied
Kazama schrieb:
Den Ordner von mir hast da rein kopiert?
ja, und jetzt hatte ich es nochmal mit ./fastboot flash boot_"slot" boot.img direkt probiert und es ging - aber jetzt liegt der android auf dem boden - und nach ein paar tasten sagt er supported api: 3 wairing for rescue commands.... dauert etwas , dann ist er im gesamten bootmenue , komm da aber auch irgendwie nicht weiter..
 
Zuletzt bearbeitet:
Kazama

Kazama

Ehrenmitglied
Oh ich seh grad du machst es am Mac?

Flash mal in beide Slots und dann noch mal die Flash.sh starten.

Sieht das bei dir so aus:

 
Zuletzt bearbeitet:
C

cosmic_child

Erfahrenes Mitglied
So sah es aus, heute morgen ging ein alarm am Arbeitstisch.... Handy läuft, neuer update drauf, root fehlt zwar aber dafür alles noch da... Uff...

Magisk hat das aktuelle Boot.img ja schon gepatched, spiel ich über fastboot heute abend ein, da dürfte ja nix schief gehen... Schönen dank nochmal für die Unterstützung
Cosmic
 
Kazama

Kazama

Ehrenmitglied
Wow na ein Glück. Ich würde aber das Image sicherhalber neue patchen lassen, falls damit wirklich was schief gegangen ist.
 
C

cosmic_child

Erfahrenes Mitglied
hi leute,
so hab, jetzt den root auch wieder hinbekommen - Empfehlung von mir: das Slot Thema läuft automatisch, dh.
"fastboot flash boot patched_boot.img reicht vollkommen aus :) und man erwischt nicht versehntlich den falschen slot und zerschiesst alles, wie ich beim letzten mal ;-)

cu cosmic
 
Zuletzt bearbeitet:
C

Cordezz

Erfahrenes Mitglied
Gibt es eigentlich auch noch die Möglichkeit das Factory Image ohne löschen der Userdaten einzuspielen?
Früher konnte man einfach den entsprechenden Punkt in der Batch-Datei auskommentieren, heute sieht das alles anders aus...
 
Kazama

Kazama

Ehrenmitglied
Also so weit mir das bekannt ist, geht das immer noch. Image runter laden, entpacken bis man die Datei flashall.bat sieht. Die flash-all.bat mit einem Editor deines Vertrauens öffnen, das -w entfernen und abspeichern . Root ist dann zwar weg und du musst entweder die einzelen Boot.img Datei patchen und flashen oder TWRP temporär booten und die Magisk.zip flashen.
 
Zuletzt bearbeitet:
C

Cordezz

Erfahrenes Mitglied
Ach so, ich wusste nicht wofür der Schalter -w steht. Danke!
 
Kazama

Kazama

Ehrenmitglied
Der Schalter? ^^ also das "-w" steht einmal direkt in der flashall.bat.
 
C

Cordezz

Erfahrenes Mitglied
Kazama schrieb:
Der Schalter? ^^ also das "-w" steht einmal direkt in der flashall.bat.
Ja klar, es wird der Befehlt fastboot -w ausgeführt. "-w" ist ein Schalter oder eine Option, oder wie man es eben nennen mag.
Code:
fastboot flash bootloader bootloader-sargo-b4s4-0.2-6066691.img
fastboot reboot-bootloader
ping -n 5 127.0.0.1 >nul
fastboot flash radio radio-sargo-g670-00036-200114-b-6134202.img
fastboot reboot-bootloader
ping -n 5 127.0.0.1 >nul
fastboot -w update image-sargo-qq2a.200305.002.zip
 
Kazama

Kazama

Ehrenmitglied
Ah alles klar. Ehrlich gesagt wusste ich nicht, dass man das so nennt. Wieder was gelernt. ^^
 
GrandmasterFlash

GrandmasterFlash

Neues Mitglied
Ich brauche Eure Hilfe, ich weiß nicht mehr weiter. Also seit einiger Zeit zeigt mein Pixel 3 keine OTAs mehr an, Stand war Januar, aber jetzt war ja schon das März-OTA draußen. Ich wollte also schonmal die boot.img aus dem neuen Image patchen, aber der Magisk Manager (Canary) hat das nicht gemacht, die App hat sich immer selbst beendet. Also habe ich einfach eine Beta-Version vom Magisk Manager installiert, damit ging es. Das war natürlich ein Fehler, leider habe ich das zu spät bemerkt. Denn jetzt erkennt der Manager das installierte Magisk nicht mehr und es lässt sich nicht mehr deinstallieren. 🤨

Ich habe jetzt mal das neue OTA geflasht (zum Glück funktioniert die Methode von Atomregen wieder, die bei mir lange nicht funktioniert hat), dann mit Magisk Stable 20.3 die boot.img gepatcht und mit Fastboot geflasht. Ergebnis: Magisk ist angeblich nicht installiert.

Kann es sein, dass Magisk Canary noch irgendwie aktiv ist? Wenn ja bekomme ich das aber nicht mehr deinstalliert, weil es der Magisk Manager nicht erkennt. Und den Canary Uninstaller kann ich nicht benutzen, weil ich unter Android 10 kein Recovery booten und schon gar nicht installieren kann. 🤔

Hat jemand noch eine Idee, was ich versuchen könnte? Besten Dank im voraus!
 
C

cosmic_child

Erfahrenes Mitglied
Hi, also ich würde magisk komplett deinstallieren, dann nochmal neu installieren, das Boot.img aus dem installieren download Image extrahieren und mit magidk patchen und mit fastboot über adb installieren...
Cu cosmic
 
Kazama

Kazama

Ehrenmitglied
Ich würde die Magisk App deinstallieren. Danach das aktuelle Factory Image runter laden. Entpacken im der flash-all.bat das -w löschen und danach installieren. Dann das Bootimage mit der aktuellen Stable Magisk Version patchen.
 
Ähnliche Themen - [Anleitung][Pixel 3/3a / 3XL/3aXL] roOt durch Magisk > Update durch OTAs > Update von Magisk Antworten Datum
3
5