[Anleitung][G97xF] Aktivierung des Root-Accounts mit Magisk Manager

  • 692 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung][G97xF] Aktivierung des Root-Accounts mit Magisk Manager im Root / Custom-ROMs / Modding für Samsung Galaxy S10 / S10+ / S10E / S10 5G im Bereich Samsung Galaxy S10 / S10+ / S10E / S10 5G Forum.
hanspampel

hanspampel

Ehrenmitglied
Nein. Wenn's was andere geben würde, gabe es dazu sicher nen Post oder gar nen Thread.;) Von CFAR gibt's schon lange nix mehr da Superuser tot ist.
 
snuffkin

snuffkin

Fortgeschrittenes Mitglied
Das hätte ich mir ( fast ) denken können. Leider....
Ich warte erstmal ab. Denn mit Magisk werde ich mit Sicherheit nicht rooten und mit offenen Bootloader ,den man nicht mehr schließen kann schon gar nicht. Wie gesagt...ist mir doch noch sehr suspekt....:1f633:
 
D

dreamfast

Stammgast
Kann die Argumentation jetzt nicht so ganz nachvollziehen. Bootloader öffnen war doch schon früher bei anderen Herstellern (z. B. Huawei oder Sony) Voraussetzung um Root aktivieren zu können. Da war Magisk noch nicht mal bekannt und man hat mit SuperSu gearbeitet. Da Chainfire ja seine Arbeiten eingestellt hat, kann man ja froh sein, dass John Wu mit seinem Magisk eingesprungen ist.

Und da es offensichtlich immer schwieriger von Seiten Samsung es gemacht wird, den Root Account zu aktivieren, wirst wohl in Zukunft für immer auf Root verzichten müssen, wenn Du kein Magisk nutzen willst.
 
hanspampel

hanspampel

Ehrenmitglied
@snuffkin
Den Bootloader kann man afaik wieder locken.

How to re-lock bootloader

1. Turn off your device.
2. Press Bixby + Volume down and connect your device to a PC to start the download mode (now you can release both buttons)
3. Read the text below on the Download Mode screen
to block or unblock the Bootloader.
4.- Long press the vol (- or +) button as best suits you.
LOCK BOOTLOADER:
5. Long press the volume up button (+) until the computer is restarted (this will erase your data and restart automatically).

Ready! Now you have a device with an OEM lock.
Quelle
Soll angeblich funzen.

Ansonsten kann ich meinem Vorredner nur beipflichten. Was anderes wie Magisk wirds vorläufig nicht geben was immer up-to-date ist. Ergo bleibt einem nix anderes.
Zu dem Bootloader: Auch da kannste nix machen als es zu akzeptieren oder eben lassen. Bei anderen Geräten wars in der Vergangenheit auch schon immer so. Nun halt auch bei Samsung. Who cares? Wenn du rooten willst musste eben einen Tod sterben.
 
snuffkin

snuffkin

Fortgeschrittenes Mitglied
Deswegen habe ich ja mein Vorgängermodell "Sony Xperia XZ1 Compact" auch nicht gerootet,weil man es nur mit offenen Bootloader konnte. Bis zum Z3 Compact konnte man es auch noch mit geschlossenen Bootloader rooten. Danach nicht mehr....
Wenn es mit Samsung nicht mehr funktioniert...na gut...dann lasse ich es. Das ist meine Entscheidung....oder ?
Mit der Methode den Bootloader zu schließen ( siehe oberen Beitrag ) ...muß ich mir noch genauer betrachten....
 
Rennert

Rennert

Lexikon
Hi,

habe mein S10+ jetzt auch nach dieser Anleitung gerootet. Nun wollte ich noch die TWRP draufmachen, habe die img Datei mit Magisk gepatcht und in eine tar gewandelt laut Anleitung. Flash mit Odin ging ohne Probleme.
Aber ich komme einfach nicht in die TWRP, entweder startet die Stock recovery bei zu langem Drücken oder das System bootet mit Magisk.
wie kommt man genau da rein?

Gleich noch ne Frage: der Soldier Mod hatte doch den Patch dabei, das im Hybridslot dann SIM und SD gleichzeitig gehen. Habe noch ne modifizierte Sim/SD im alten Handy. Geht das auch ohne TWRP irgendwie?
 
hanspampel

hanspampel

Ehrenmitglied
Wenn du ins Stock Recovery kommst, ist auch kein TWRP drauf. Dann muss beim Flash was schiefgegangen sein.
 
Rennert

Rennert

Lexikon
komisch, er meckert aber nicht beim Flash. habe mal zum Test die offizielle TWRP tar von twrp.me geflasht, da kann ich in die TWRP booten, aber ist eben kein root mehr da, da sie ja nicht gepatcht ist. Muss ich nochmal neu patchen und testen, hab ich aber schon 3-4x

hatte aber auch schon, das er dann meckerte im Odin, das es unassigned file ist.

Edit: hab ne neuere Version von 7Zip installiert und nun ging das Flashen richtig. TWRP startet auch
 
Zuletzt bearbeitet:
D

dreamfast

Stammgast
Habe vorhin mal die vorab mit Magisk gepatchte ASE7 per Odin geflasht. Danach hatte ich allerdings ein kleines Problem. Ich hatte ja auch in Magisk dieses WLAN/BT Modul installiert gehabt. Nach dem aktuellen Flash funktionierte mit aktivem Modul allerdings kein WLAN mehr. Nachdem ich das Modul deaktiviert habe, ging zwar WLAN wieder, aber die Sim Karten wurden nicht erkannt. Habe das Modul daher jetzt komplett aus Magisk entfernt. Nun funktioniert wieder beides. Vorab natürlich mehrfach Gegenkontrolle gemacht , also mehrfach aktiviert / deaktiviert. Lediglich eine neue Suche und Installation des Moduls in Magisk habe ich jetzt noch nicht probiert.

Ob ich jetzt Probleme mit BT bekomme, weiß ich noch nicht. Wollte daher mal fragen, ob darüber was bekannt ist, also mit Problemen mit dem Modul.

Klar, wenn WLAN und BT problemlos funktioniert, brauche ich es eh nicht. Würde mich aber interessieren, ob hierzu was bekannt ist.
 
Rennert

Rennert

Lexikon
habe einiges mit der TWRP probiert, ist schon ganz nützlich. Habe mehrere Full Backups gemacht und auch schon System und Data erfolgreich wiederhergestellt. Das gepatchte Stock Recovery Image lässt sich auch per Installeren in die Recovery Partition flashen, spart man sich das per ODIN. Nur wieder auf TWRP eben über ODIN.
Ist so schon ganz nützlich, so kann ich schnell mein eingerichtetes S10+ wiederherstellen, falls mal was beim Testen schiefgeht.
 
hanspampel

hanspampel

Ehrenmitglied
Man muss nicht zwangsläufig Odin nutzen um die Recoveries zu wechseln. Ich habs mit der TWRP App gemacht, Flashify habe ich auch erfolgreich probiert. Damit fällt Odin ganz raus.;) Wenn nur die Fummellei mit der Stock FW nicht wäre. Aber da bin ich auch dran.
 
Rennert

Rennert

Lexikon
Naja Odin finde ich nicht schlimm, geht ja auch schnell.ist ja nur um von Stock Recovery wieder auf TWRP zu kommen. Aber muss ich ja nur im Notfall.
 
D

dreamfast

Stammgast
@hanspampel

zu Beitrag #49 hast nicht zufällig irgendwo was gelesen?
 
hanspampel

hanspampel

Ehrenmitglied
Bei der Verwendung des Modules steht im How-To das man die Datei secure_storage_daemon.rc unter /system/etc/init/ ( beim S10(e,+) aber /vendor/etc/init/ ) die letzte Zeile bearbeiten sollte:
Code:
on boot
    start secure_storage
in
Code:
on boot
    stop secure_storage
Das ist kein Schirtt der erforderlich ist, aber verhindert dass der Storgae Daemon unnötig mitläuft. Vielleicht beehebt es ja dein Problem mit den SIM Karten wenn das Modul läuft.

Achja, die Datei kannste mit nem Text Editor bearbeiten. Nach dem Speichern neustarten (zum Recovery natürlich).;)
 
D

dreamfast

Stammgast
Werde ich zumindest nochmals testen.
 
H

Handymann007

Fortgeschrittenes Mitglied
Habe meins heute auch gerottet aber noch ein Problem.

Wenn Ich Fingerabdruck oder Passwort mache und dann Normal Starte ohne Root, nimmt er das Passwort nicht mehr und auch den Finger nicht...

Darf Ich das Nicht einrichten oder mache Ich was Falsch???
 
D

dreamfast

Stammgast
@hanspampel

Habe es heute mal getestet. Leider nicht so erfolgreich. Auch nach der Änderung von secure_storage_daemon.rc verbleibt es bei dem Problem, das ich mit aktivem libsecure... keine WLAN-Verbindung aufbauen kann, dafür funktioniert mobiles Netz und auch BT. Bei WLAN zeigt er mir zwar die verfügbaren WLANs an, lässt aber keine Verbindung zu. Man kann also auf das WLAN tippen, aber keine Reaktion. Bei längerem Drauftippen, kommt die Abfrage, verbinden, löschen .... aber auch hier, keine Reaktion.

Deaktiviere ich libsecure.... , funktioniert mobiles Netz und WLAN. Bei BT habe ich dann aber das Problem, das keine automatische Verbindung mehr erfolgt mit den Geräten, die vorher eine Verbindung bereits hatte.

Seltsam ist das Ganze deshalb, weil es mit der ASE5 funktioniert hat.

Als letzte Möglichkeit fällt mir derzeit nur ein, alles komplett neu zu machen. Fraglich dann, ob es anschließend funktioniert. Scheinbar hat ja zumindest hier kein anderer dieses Problem. Und dann fragt es sich noch, ob es mir den Aufwand wert ist. Aktuell jedenfalls noch nicht, auch wenn die fehlende BT "Automatik" beim verbinden nervig ist.
 
hanspampel

hanspampel

Ehrenmitglied
Also kannst du die Verbindung auch nicht löschen? Habe ich das richtig verstanden?
 
D

dreamfast

Stammgast
Korrekt. Ich kann weder eine Verbindung mit bereits bestehenden Verbindungen aufbauen, noch mit neuen. Aber eben auch keine bestehenden Verbindungen löschen.
 
hanspampel

hanspampel

Ehrenmitglied
Hmm das ist echt strange. Weiß ich derzeit auch keinen Rat. Ausser vielleicht per Odin nur die CP-File mal zu flashen. Also das Modem.
 
Ähnliche Themen - [Anleitung][G97xF] Aktivierung des Root-Accounts mit Magisk Manager Antworten Datum
3
0