Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

Galaxy S3 Bootloop, Brick und andere Gründe für den Nicht-Start des OS

  • 5.552 Antworten
  • Neuester Beitrag
Diskutiere Galaxy S3 Bootloop, Brick und andere Gründe für den Nicht-Start des OS im Root / Custom-ROMs / Modding für Samsung Galaxy S3 im Bereich Samsung Galaxy S3 (I9300) Forum.
F

frank-wtal

Neues Mitglied
Hallo Reinold, leider sehe ich jetzt erst, dass du auf meine Frage geantwortet hast. Danke dafür. Mit der Firmware gab es keine Probleme. Die habe ich mehrfach wieder aufgespielt, eine Bootschleife gab es da nicht. Und auch Lineage funktionierte beim ersten Versuch. Nur als ich es wiederholen musste, ging es nicht mehr. Bisher habe ich nur die eintelige Firmware gennutzt, habe aber auch noch eine vierteilge für das S3 auf meinem Rechner. Jetzt frage ich mich, ob ich es damit versuchen soll. Allerdings weiß ich nicht genau, was der Unterschied zwischen diesen beiden Versionen ist. Und ich weiß auch nicht, ob das neue Probleme verursachen kann, wenn die efs-Partition ersetzt wird. Helfen würde mir auch eine Empfehlung, ob ich beim Löschen vor der Installation nur den einfachen Modus wählen soll. Oder ist es auch sinnvoll, zusätzlich "System" zu löschen? Ich finde da verschiedene Informationen, wie man vorgehen soll.

Frank
 
reinold p

reinold p

Stammgast
@frank-wtal: ich habe oft&viel S3-ROMs geflasht und bei unerklärlichem Fehlverhalten stets die 4tlg Bitstopfen-Firmware geflasht für ne sichere Basis. Also:
* sichere die efs-Partition mit TWRP auf extSdCard,
* kopiere weitere wichtige Daten auf extSdCard,
* flashe die 4tlg ROM mit Repartition (gleich mit Root).
Repartition erstellt alle Partitionen des internen Speichers neu und behebt damit Fehler in der Partitionstabelle. Die efs-Daten bleiben erhalten (sichert Odin wsl). Wenn dir dieser grobe Besen zu heikel erscheint, versuch's ohne den Repartition-Haken.
Vor dem Flashen einer neuen CustomROM immer beide Cashes, System und Data löschen! Wenn das Flash-Script System nicht selbst wiped (sinnvoll bei MinorUpdates), mischst du Reste der Firmware mit Lineage - das wird sicher nix.
 
Zuletzt bearbeitet:
F

frank-wtal

Neues Mitglied
Danke, Reinold. Meine Vermutung war dieselbe, dass Firmware nicht mehr sauber entfernt wurde. Ich hätte jetzt genau das versucht, was du hier beschrieben hast. Allerdings mache ich das viel entspannter, wenn du mir dieser Vorgehensweise empfiehlst.
Das ist nicht so einfach in Android, wenn man keine Ahnung hat, was da wirklich passiert. Beim Neupartitionieren bin ich ähnlich wie in Windows davon ausgegangen, dass damit alle Daten gelöscht werden. Und ich hatte schon gelesen, dass man die efs-Partition nicht verlieren darf. Eine Sicherung auf der externen Karte habe ich aber auch gleich als erstes angelegt.
Dann werde ich jetzt mal sehen, ob es funktioniert.

Noch einen schönen Abend,
Frank
 
SaschaKH

SaschaKH

Ehrenmitglied
frank-wtal schrieb:
Ich hätte jetzt genau das versucht, was du hier beschrieben hast. Allerdings mache ich das viel entspannter, wenn du mir dieser Vorgehensweise empfiehlst.
Hört sich sehr gut an.

Das ist nicht so einfach in Android, wenn man keine Ahnung hat, was da wirklich passiert.
Das ist es nie, nirgends, wenn man keine Ahnung hat, aber bei allem was mit Computern zu tun hat, haben wir ja Google und Foren (eigentlich für sehr viel mehr, nicht nur für Technik).

Beim Neupartitionieren bin ich ähnlich wie in Windows davon ausgegangen, dass damit alle Daten gelöscht werden.
Kannst Du auch. Das betrift übrigens nicht nur das Betriebssystem (Android, Linux (Unix), Windows ...) denn sowas ist noch eine Ebene tiefer und hat eigentlich recht wenig mit dem BS, das Du danach draufmachst, zu tun.

Und ich hatte schon gelesen, dass man die efs-Partition nicht verlieren darf. Eine Sicherung auf der externen Karte habe ich aber auch gleich als erstes angelegt.
Das ist gut, im Prinzip ist das Modem ja fast das Einzige was Smartphones von Computern unterscheidet und ohne die EFS geht das nicht.

Grundsätzlich schadet löschen seltenst (zumindest wenn man ein Backup hat) und lieber zwei- oder dreimal machen als einmal vergessen, obwohl auch oft übertrieben wird, aber wie gesagt, lieber einmal zu viel als einmal zu wenig. :)
 
F

frank-wtal

Neues Mitglied
Hallo Sascha und Reinold,

Leider scheitert schon das Flashen der vierteiligen Firmware mit dieser Fehlermeldung:

<ID:0/022> Can't open the specified file. (Line: 1892)
<OSM> All threads completed. (succeed 0 / failed 1)

Interessant. Beide Versionen hatte ich über SamFirm mit denselben Einstellungen runtergeladen. Die einteilige Firmware geht ohne Probleme, die andere nicht. Fragt sich nur, was ich jetzt machen soll. Aber darüber denke ich morgen nach. Vielleicht könnte ich es noch mit einer anderen Version von Odin versuchen, wie es so oft empfohlen wird. Aber auch das habe ich bisher noch nicht verstanden, warum dieses Programm nicht einfach nur funktioniert. Die Fehlermeldung oben ist mir nicht unbekannt, die hatte ich schon mal bei einem anderen Mainboard gehabt. Habe ich es dann mit einer anderen Version versucht, hat es trotzdem nicht funktioniert. Aber zumindest bekomme ich dort eine andere Fehlermeldung angezeigt, etwas Abwechslung beim Basteln ist ja auch nicht so schlecht. Und nutzen kann ich das Smartphone nach dem Backup ja auch. Mir fehlt nur die Navi-App auf Lineage. Aber zum Radfahren ist es ja gerade sowieso viel zu heiß.

Viele Grüße an euch,
Frank
 
Nufan

Nufan

Guru
frank-wtal schrieb:
Die Fehlermeldung oben ist mir nicht unbekannt,
Die Hinweise aus dem anderen Thread hast du ja sicher beachtet, versuchs evtl auch an einem anderen Rechner und/ oder anderem Kabel.
Ich hatte den Fehler noch nie, flashe generell mehrteilige als Basis, anschließend einmal da hineinbooten, TWRP und dann Backup (wegen der EFS).
 
reinold p

reinold p

Stammgast
@frank-wtal: du schreibst samfirm, ich schrieb bitstopfen (ausführliche Anleitung, optional gleich mit Root).
 
Nufan

Nufan

Guru
Was mir jetzt nicht klar ist, welchen Vorteil bringt ihm das?
 
reinold p

reinold p

Stammgast
Der Grund für og Fehlermeldung kann ne inkompatible Odinversion sein oder ne beschädigte Datei oder falsche Plazierung in die Odinfenster. Das Bitstopfenpaket ist jedenfalls in sich stimmig.
 
Nufan

Nufan

Guru
Verschiedene Odin hat er getestet, Samfirm prüft die Vollständigkeit des Downloads, verbleibt die Datei am Downloadort, sollte das passen.
Die Zuordnung stimmte auch, wenn ich den Screenshot in meiner Erinnerung richtig zuordne.

Ich vermute eine dumme Inkompatibilität seines Windows mit der Repartitionierung, weshalb ich mal den Rechner tauschen oder das PIT-File aus der Firmware extrahieren und separat flashen würde.

Nichtsdestotrotz ist dein Tipp natürlich auch ein Versuch wert.
 
F

frank-wtal

Neues Mitglied
Hallo an euch,

ich war leider zu beschäftigt, um schon eher nachzusehen und bemerke erst jetzt, dass ihr mir wieder geschrieben habt.
Diesmal bin ich anders vorgegangen, das ist jetzt erfolgreich gewesen. Erst habe ich nochmals die einteilige Firmware nach einem Factory Reset installiert. Das habe ich mit derselben Methode mit der vierteiligen Firmware wiederholt. Die Option „re-partition“ habe ich nicht gewählt, das Flashen funktionierte auch so. Dann der übliche Weg über Bootrechte, TWRP flashen und schließlich Lineage installieren. Warum auch immer, aber das ging diesmal ohne Probleme. Danach das Backup aufgespielt und alles war wieder so, wie ich es haben wollte. Sehr schön.
An dem Punkt war ich vor ein paar Tagen schon mal gewesen, dass nur noch das Backup fehlte. Dabei war ich nicht aufmerksam und habe stattdessen das Backup mit dem Google-System gewählt. Wohl auch deshalb, weil ich nicht damit gerechnet habe, dass es bei einem installierten Lineage eingespielt werden kann. Aber das tat es und dann kam ich in Schwierigkeiten.
Am USB-Anschluss, dem Rechner oder den Odin-Versionen hat es nicht gelegen, dass ich bei vielen Versuchen gescheitert bin. Vielleicht war es die richtige Auswahl beim Löschen vor dem jeweils nächsten Schritt. Ihr könnt das vielleicht besser einschätzen wie ich.
Aber danke nochmal an euch, die sich hier für mich Zeit genommen haben. Ohne eure Hilfe aus dem Forum wäre das Gerät wahrscheinlich schon im Mülleimer gelandet. Allerdings werfe ich ungern weg. Obwohl es etwas unverhältnismäßig war, Tage an einem alten Gerät zu basteln, das ja keinen hohen Wert mehr hat. Nur ich nutze es immer noch gern.

Frank
 
H

HartzFear

Neues Mitglied
Hallo,

mein S3 liegt schon Jahre ungebachtet in der Schublade, bis ich es gerade wieder rausgekramt habe. Damals hat es plötzlich seinen Dienst eingestellt. Es ging einfach nichtmehr an, bzw kurz nach dem Einschalten hat ist es bei der Ladeanzeige während des Boots eingefroren.

Wenn ich es jetzt einstecke erscheint noch das Batteriesymbol, aber dann friert es wieder ein.

Sind das die Symptome des bekannten Sudden Death oder könnte es auch nur an der Batterie liegen?

Worum es mir geht sind die Bilder auf dem Handy. Falls irgendwie möglich würde ich die noch gerne retten.
Auf Youtube gibt es ein Video, wie man die Hauptplatine wechselt und so den Sudden Death behebt.

Müsste ich locker hinbekommen und das Ersatzteil ist ja auch unter 10€ zu bekommen.
Ich befürchte nur, dass der Speicher auf der Hauptplatine sitzt, oder? Also wenn ich das Mainboard austausche dann sind auch die Bilder nichtmehr abzurufen?

Danke falls mir jemand weiterhelfen kann!

Grüße
 
html6405

html6405

Gewerbliches Mitglied
HartzFear schrieb:
Worum es mir geht sind die Bilder auf dem Handy. Falls irgendwie möglich würde ich die noch gerne retten.
Auf Youtube gibt es ein Video, wie man die Hauptplatine wechselt und so den Sudden Death behebt.
Also wenn es nicht deinen Speicher erwischt hat und es nicht das SDS ist, dann kann man deine Bilder noch alle direkt aus dem Speicher lesen,
bzw ich.

Du könntest aber auch versuchen, ein TWRP zu flashen und dadurch einfach nur die Daten auszulesen.

Das mit dem Batterysymbol könnte auch einfach an einen fehlerhaften System liegen...
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
HartzFear schrieb:
Ich befürchte nur, dass der Speicher auf der Hauptplatine sitzt, oder? Also wenn ich das Mainboard austausche dann sind auch die Bilder nichtmehr abzurufen?
Richtig.
 
Ähnliche Themen - Galaxy S3 Bootloop, Brick und andere Gründe für den Nicht-Start des OS Antworten Datum
9
7