Cosmo rockt mit ICS !

C

camper3

Neues Mitglied
Aso ok!soory!

Der ursprüngliche Beitrag von 15:45 Uhr wurde um 16:25 Uhr ergänzt:

aso stimmt hat ich zwischen druch auch mal gelesen mit dem loox!
Ja die Kamera ist nicht so gud, aber ich kann es nicht leiden wenn etwas gehen könnte und es ned geht!
Das beschäftigt mich! Immer so!
 
wusel

wusel

Stammgast
ACHTUNG: alles was Ihr mit Euren Tablets anfangt ist auf Eure Gefahr!
Ich bin immer unschuldig und hafte für garnix! Ihr seid gewarnt!!

Hier der Download-Link für die gerootete Version des Odys Cosmo Update 2012-04-18.
Das Archiv enthält eine README.txt die die Änderungen zum Original listet.
Anders als beim Original-Download habe ich den üblichen RK-Flasher dazugepackt den die meisten hier ja schon kennen und der den Vorteil hat dass man die Images auch einzeln flashen kann.

Alle die schon diese Version 2012-04-18 von der Odys-Website installiert haben brauchen nur system.img zu flashen für Root; boot.img ist aber auch empfehlenswert da ich dort ADB aktiviert und gefixt habe.
Installierte Apps und Einstellungen sollten erhalten bleiben.

Alle die eine ältere ICS-Version oder bis jetzt noch kein ICS installiert haben müssen zuerst die Option Erase IDB ausführen, dann alle Images inklusive Loader (!) flashen (also Häkchen setzen für Loader!).
Installierte Apps und Einstellungen gehen verloren und müssen vorher eventuell gesichert werden.

Flashen (Windows):

  • Tablet mit Ladegerät verbinden
  • Tablet mit PC verbinden (Direktverbindung mit Original-USB-Kabel und ohne USB-Hub!)
  • Tablet herunterfahren
  • wenn Tablet ausgeschaltet ist die Laut+ und die Power Tasten beide gleichzeitig drücken und etwa 3 Sekunden festhalten, dann sollte das Tablet im Flashmodus sein (man sieht nichts, Bildschirm bleibt dunkel)
  • Windows-Treiber aus dem beigefügten Ordner USB Driver installieren
  • RKAndroidTool.exe starten (unter Vista/Win7 als Administrator!) und Optionen wie oben beschrieben wählen
Flashen (Mac, Linux):

  • libusb-1.0.x-devel installieren
  • rkflashtool compilieren
  • weitere Anleitung + Script folgen ...

dieses Update wurde von mir auf dem Cosmo getestet und funktioniert soweit ich das im Moment beurteilen kann einwandfrei!

have Fun! :D
 
Zuletzt bearbeitet:
C

columbo4711

Fortgeschrittenes Mitglied
ist das dieselbe Version die du schon einmal hochgeladen hattest? Die läuft bei mir sehr gut.
 
C

camper3

Neues Mitglied
Super Wusel!
Du bist der Beste!
Werde es heute Nachmittag testen!

Thanks!!! :)
 
wusel

wusel

Stammgast
columbo4711 schrieb:
ist das dieselbe Version die du schon einmal hochgeladen hattest? Die läuft bei mir sehr gut.
buhu :crying::crying: warum versteht mich keiner mehr ..... :blink:
schreibe ich denn so undeutlich mittlerweile, sniff ....
nein, ist es nicht! Die erste ICS war eine die sich mit 2012-04-07 meldete und aus einem der ersten ausgelieferten Geräte mit ICS abgesaut wurde; diese hier ist die offizielle Download-Release 2012-04-18 von Odys' Website ...
Odys schreibt da zwar ausdrücklich dass diese Version nur für Geräte ist die mit GingerBread 2.3 ausgeliefert wurden, aber mir ist derzeit nicht klar warum diese Version nicht auch auf neueren Geräten die bereits mit ICS ausgeliefert wurden laufen sollte; eventuell kann es aber sein dass es neuere Geräte gibt die mehr internen Speicher haben (NAND=16GB?) - sowas steht dort mittlerweile auf der Website, und dann könnten andere Parameter nötig sein ...; ist aber derzeit nur eine Vermutung; wer so ein neues Cosmo mit 16GB hat sollte also erstmal abwarten oder aber mich kontaktieren damit wir zuerst die internen Partitionsparamter auslesen können ...
 
C

camper3

Neues Mitglied
Ich versteh dich!
Das kann nicht die selbe version sein!
War mir glech klar das der Beitrag falsch ist!
Gruß
 
C

columbo4711

Fortgeschrittenes Mitglied
camper3 schrieb:
Ich versteh dich!
Das kann nicht die selbe version sein!
War mir glech klar das der Beitrag falsch ist!
Gruß
du bist ja ein ganz "schlauer"; wenn ich mir Deine Beiträge anschaue sieht es aber anders aus! Ich habe auch keinen Beitrag geschrieben; sondern eine Frage gestellt. Aber der Unterschied scheint dir nicht bekannt zu sein.

Wusel: eine andere Bezeichnung der Firmware heisst bei Odys doch noch lange nicht, dass sich etwas verändert hat. Die auf deren Seite zum downloaden hinterlegte 2er-Version war damals auch kein "Update" in dem Sinne. Ist in diesem Forum dann auch festgestellt worden.
 
C

camper3

Neues Mitglied
OK,sorry ich habe das das Fragezeichen übersehen ,ich habe mich verlesen!
War nicht bös gemeint!
Aber ich bin froh das du so schlau bist und das bei dir alles so gud läuft!
Lös das noch mit der cam für Barcode scanner und du bist! perfect!
 
C

camper3

Neues Mitglied
Also der root hat wie immer supi funktioniert!
 
wusel

wusel

Stammgast
columbo4711 schrieb:
Wusel: eine andere Bezeichnung der Firmware heisst bei Odys doch noch lange nicht, dass sich etwas verändert hat. Die auf deren Seite zum downloaden hinterlegte 2er-Version war damals auch kein "Update" in dem Sinne. Ist in diesem Forum dann auch festgestellt worden.
schon klar, aber warum sollte ich 2x dieselbe Version rooten und hochladen??
Der Kernel ist ein neuerer Build, der Loader ist neuer, und die Menues sehen anders aus; also hat sich einiges geändert was mich dazu bewegt es als neuere Version zu benennen ....
aber nebenbei bemerkt: auch wenn die 2er Version ODYS_Cosmo_100244.zip keine nennbaren/sichtbaren Verbesserungen zur Auslieferungs-Version aufweist ist trotzdem der Kernel definitiv ein neuerer Build; somit werte ich die Version dann auch als Update - ich muss es nämlich wissen bzw. differenzieren damit ich den neuen Kernel bei Patch-Modulen berücksichtigen kann wie z.B. hubenable.ko ...; und was die Chinesen da nun tatsächlich am Kernel gebastelt haben kann keiner von uns verifizieren ohne dem Teil mit einem Disassembler zu Leibe zu rücken ...

Der ursprüngliche Beitrag von 18:27 Uhr wurde um 18:58 Uhr ergänzt:

Oma7144 schrieb:
Du mußt das Tool als Admin (Rechtsklick) starten.
danke Oma, ich habe es noch zu #45 hinzugefügt!
 
Zuletzt bearbeitet:
C

camper3

Neues Mitglied
Also Jungs eins ist klar Ahnung hab ich ned so viel von der sache noch wie einige meinen, aber eins meineich hier zu wissen!
Ich habe nun ICS 4.0 druaf mit wusels root das system läuft super!!!
Aber verschiede APP´S Funktionieren einfach nicht mehr flüssig!
DJ Studio3 z.b. ruckelt nur mache App´s mit Cam funzen nicht!
ICH denke einfach das Gerät verbarucht durch´s ICS 4.0 zuviel Recurcen!

Das System mit dem Root einfach Klasse nur wenn nix an Apps richtig funtz wer ich nochmals downgraden! auf 2 wie urzustand und versuche zu Rotten!

oder meint ihr ich habe was falsch bzw am Tab total verstellt!
Vielicht haben die deshalb alles aus web genommen!
 
Oma7144

Oma7144

Lexikon
Threadstarter
camper3 schrieb:
Aber verschiede APP´S Funktionieren einfach nicht mehr flüssig!
Viele Hersteller schieben Updates nach, damit ihre Apps unter ICS sauber laufen. Bitte mal schauen, ob die
jeweils letzten Versionen laufen und ob in der Update-Historie solche Anpassungen zu finden sind.


:thumbup:
 
wusel

wusel

Stammgast
SanShine schrieb:
Ich habs übrigens auch nicht auf die Reihe bekommen :(
Könnte nicht jmd eine detailierte Anleitung schreben, mit Bildern und so?
ich habe das Flashen erfolgreich auf Win7 x64 durchgeführt, und es war absolut problemlos!
Die Probleme die hier immer wieder Leute haben sind mir bestens bekannt (dieselbe Problematik tauchte auch schon bei allen anderen RockChip-basierten Tablets in der Vergangenheit auf) und lässt sich immer wieder darauf zurückführen dass der rockusb Treiber nicht korrekt installiert wurde; auch wenn EraseIDB geht heisst das nicht dass der Treiber korrekt installiert wurde bzw. Windows einen anderen Treiber installierte!
Ich füge jetzt hier mal ein kleines Programm an dass erkennt wenn das Tablet im Flashmodus ist. Dieses Programm braucht keinen Treiber und sollte in einer DOS-Box (cmd.exe) gestartet werden. Wenn das Tablet im Flashmodus ist hat es die USB-Kennung 2207:290A. Ein anderes gutes GUI-Programm zum Anzeigen von verbundenen USB-Geräten ist usbdeview (deutsche Übersetzung ebenfalls vorhanden).
Im Post #45 habe ich die von mir empfohlene Vorgehensweise genau erklärt; es gibt andere, aber diese sind bestenfalls unsicher, oder gar abenteuerlich.
Es liegt also schon an Euch soweit mit dem Betriebssystem Eurer Wahl Windows7 vertraut zu sein dass Ihr in der Lage seid entweder Win7 so zu konfigurieren dass nie automatisch Treiber installiert werden (was ich persönlich empfehlen würde) oder aber nach Auto-Installation den Treiber jeweils upzudaten (was teilweise schon schwierig sein kann).
Bei meinem Test auf Win7 war es so dass Win7 zuerst versucht hat einen Treiber zu installieren dann aber kurz in der Statusbar gemeldet hat das was schiefgelaufen ist; ich habe diesen Info-Dialog angeklickt und da bot sich die Möglichkeit das Verhalten von Win7 beim Erkennen neuer Hardware zu konfigurieren. Danach war aber natürlich trotzdem noch notwendig den Geräte-Manager zu öffnen und den rockusb Treiber manuell zu installieren.
Auf irgendwelche Updates von Odys zu warten ist hier relativ sinnlos - das Update selbst ist ok, und am Flash-Vorgang kann kaum etwas verbessert werden da alle mir bekannten Tools auf den rockusb Treiber aufsetzen;
alternativ kann ich Euch zwar das rkflashtool anbieten das den M$ winusb Treiber benutzt - aber damit ist das Flashen nicht vollautomatisch durchführbar sondern es muss jede Image-Datei separat geflasht werden; wenn jemand diese Methode probieren möchte (die ansonsten auch für Mac und Linux User die einzige Möglichkeit ist) dann werde ich hier ein Paket uploaden.

Edit:
2 weitere Punkte zu Post #45 hinzugefügt die wichtig sind: Ladegerät anschließen und Direktverbindung (kein USB-Hub!)
Edit:
Das angehängte Tool erkennt fälschlicherweise auch bereits das Cosmo mit ID 2207:0000 - das ist aber nicht der Flashmode! Ich werde demnächst das Tool updaten und diesen Fehler beheben.
 

Anhänge

Zuletzt bearbeitet:
B

bladexXx

Neues Mitglied
Ich hatte jetzt vor dem flashen des neuen Updates auch Probleme mit den Treibern, unter Windows 7 64 bit Version, aber das hat Windows dann auch Kennztlich gemacht, ich musste die Treiber einmal neuinstallieren, einmal neustarten dann ging alles.

Zu dem eigentlichen Problem, ich bin bei dem ersten Update also dem Android 2.3 von Odys damals hängen geblieben und bin dann im Internet irgendwo, da ging es nicht speziell um Odys tablets, auf die Lösung gestossen mal ein anderes Kabel zu verwenden. Mit dem Kabel von meinem Handy konnte ich dann mein Cosmo tatsächlich direkt beim ersten Versuch erfolgreich updaten. Ich habe natürlich wenig fachspezifisches Wissen von der eigentlichen Thematik des updatens, und kann nicht beurteilen ob das wirklich ein sinnvoller Lösungsansatz ist, oder eher dem Zufall geschuldet war, aber versuchen kostet ja nichts.
 
wusel

wusel

Stammgast
bladexXx schrieb:
Ich hatte jetzt vor dem flashen des neuen Updates auch Probleme mit den Treibern, unter Windows 7 64 bit Version, aber das hat Windows dann auch Kennztlich gemacht, ich musste die Treiber einmal neuinstallieren, einmal neustarten dann ging alles.
prima, endlich mal wieder was positives zu lesen! :scared:
bladexXx schrieb:
Zu dem eigentlichen Problem, ich bin bei dem ersten Update also dem Android 2.3 von Odys damals hängen geblieben und bin dann im Internet irgendwo, da ging es nicht speziell um Odys tablets, auf die Lösung gestossen mal ein anderes Kabel zu verwenden. Mit dem Kabel von meinem Handy konnte ich dann mein Cosmo tatsächlich direkt beim ersten Versuch erfolgreich updaten. Ich habe natürlich wenig fachspezifisches Wissen von der eigentlichen Thematik des updatens, und kann nicht beurteilen ob das wirklich ein sinnvoller Lösungsansatz ist, oder eher dem Zufall geschuldet war, aber versuchen kostet ja nichts.
absolut richtig! Auch dieses Problem ist schon mehrfach aufgetaucht: Leute nehmen Ihr Handy-Kabel weils länger ist, das originale gerade nicht gefunden wird etc. und dann klappt es nicht! Werde ich sofort hinzufügen zu #45! Danke!
 
Zuletzt bearbeitet von einem Moderator:
C

columbo4711

Fortgeschrittenes Mitglied
hatte mit w7 auch Probleme. Auf meinem 8 Jahre alten Läppi mit W95 ging es sofort. Vielleicht habt ihr auch die Möglichkeit dies mit einem älteren Rechner (Freunde/Bekannte) durchzuführen.
 
C

camper3

Neues Mitglied
Versteh ned ganz was du von mir momentanbeantwortet haben willst?
Gehts um die geschichte Barcodecscanner?:confused:

Der ursprüngliche Beitrag von 09:32 Uhr wurde um 09:47 Uhr ergänzt:

Also wen du meinst das ich vol + und - und einsschalte komm ich dort hin ja nur der android liegt bei mir auf dem rücken und hat bauch auf aber das wird wohl egal sein jenachdem wer gerootet hat mit welchem bildchen!
 
X

xbmcg

Neues Mitglied
... mit w7 gings nicht, mit xp problemlos offizielles update image eingespielt. Cosmo bildschirm bleibt beim update schwarz' kein android mit achtung symbol! Muss noch gerooted werden....Vielen Dank fuer die Tipps - speziell, dass das cosmo nicht s auf dem schirm haben darf, also komplett dunkel ist beim vorbereiten zum flashen...
 
wusel

wusel

Stammgast
xbmcg schrieb:
... mit w7 gings nicht, mit xp problemlos offizielles update image eingespielt.
hähä, mutig, mutig nach all den Warnungen ...; aber gut dass Du es verifiziert hast und uns hier berichtest ...:thumbup:

xbmcg schrieb:
Cosmo bildschirm bleibt beim update schwarz' kein android mit achtung symbol!
ja, das ist immer so; allerdings kommt dieses Bild dann beim ersten Reboot direkt nach dem Flashen bei Oma's Version; bei der Original sowie bei meiner gerooteten Version erscheint da das Cosmo-Logo und unten links werden die Meldungen der Recovery angezeigt die dann die DATA und CACHE formatiert ...
xbmcg schrieb:
Muss noch gerooted werden....Vielen Dank fuer die Tipps - speziell, dass das cosmo nicht s auf dem schirm haben darf, also komplett dunkel ist beim vorbereiten zum flashen...
gut dass es geklappt hat bei Dir! Beweist einmal mehr dass das Update ansich ok ist und die Problematik nur beim Flashen liegt, und offensichtlich auch nur unter Win7.
 
Oben Unten