[Skript] AAHK2 - Root, Debrand, SIM Unlock, S-OFF, SuperCID & Custom Recovery

  • 1.234 Antworten
  • Neuster Beitrag
AMCooper

AMCooper

Neues Mitglied
Hey, mein DHD ist soweit fertig. 4.4.4 und aktuelles recovery ist drauf. ABER das DHD ist total instabil und verliert 1% AKKU alle 2 minuten. Das kann man so nicht lassen. Punkt 7 habe ich nicht gemach, will ich aber machen. Allerdings frisst HBOOT das *.img nicht von der SD Karte. Da kommt für 1 Sekunde wrong Image oder so was (siehe Foto). Da müsste das Problem liegen. Ich Frag mich, was ich falsch gemacht habe?! Ich weiß es nicht! Das CWM recovery 6.0.5.1 hab ich via FASTBOOT geflasht mit command Eingabe (cmd) etc. Wie bekomme ich das richtige Radio drauf? Wie soll ich das machen? Ich hab keinen Plan mehr und deshalb wende ich mich nun an euch. Nebenbei hab ich noch ein HTC HD2, welches ich etliche mal geflasht habe. Trotz meiner kleinen Erfahrung bekomme ich das beim DHD nicht wirklich gut hin, da läuft das flashen anders ab.
 

Anhänge

Zuletzt bearbeitet:
C

Charley

Gast
Hallo und herzlichen willkommen.
Sorry, hast Du die Anleitung gelesen oder nur leicht überflogen? Schritt sieben geht nicht über SD und man macht diesen Schritt vorher. Das riecht stark nach Phiber (Team View):-(
 
P

Phiber2000

Experte
Threadstarter
Hat er schon richtig gemacht. :)

Aber entweder die ZIP-Datei ist nicht korrekt auf der SD-Karte (Screenshot vom Explorer wäre hilfreich) oder man sollte die SD-Karte noch einmal testweise formatieren (FAT32 4KB Sektorgröße)
 
C

Charley

Gast
;-) Jupp, mein Fehler! Hätte gedacht, die Ruu kann man nicht als zip flashen. Ich wäre einen anderen weg als Cooper gegangen und hätte jetzt auch eine andere Lösung gehabt. Aber Du bist der Meister und weißt es besser, klüger und schneller! :) danke Du bist einmalig im Netz!
 
AMCooper

AMCooper

Neues Mitglied
So hab jetzt mal Zeit gehabt Punkt 7 nach zu holen. Ich bin aber nicht wirklich zufrieden mit dem Ergebnis. Es läuft zwar deutlich besser aber insgesamt nicht sonderlich stabil. Ich habs dann ernsthaft in Betrieb genommen und musste es ca. 4-5x am Tag neu starten, weil gapps / Googleplay-Dieste nicht mehr funktionierte oder spontane Neustarts.

Kurz mal im Groben zur Reihenfolge:
1. downgrade
2.unlock/ENG S-OFF
3.neues Recovery via Fastboot geflasht (CWM 6.0.5.1)
3.Custom ROM installiert (4.4.4 CM11 Open Desire Project)
4.GAPPS installiert
4.PD98DIAG.IMG mit hBoot von SD-Karte geflasht (Punkt 7)
5. FACTORY RESET.

Die Problemchen könnten ja verschiedene Ursachen haben, kann es aber nicht gut beurteilen.
Vielleicht liegt's an der Custom Rom selbst oder der Akku ist zu alt.
Möglicher Weise bin ich auch selbst das Problem.

Bin mal neugierig was Ihr zu meiner Prozedur sagen werdet.
IM ANHANG NOCH EIN PAAR FOTOS ZU PUNKT 7.
 

Anhänge

Zuletzt bearbeitet:
TSC Yoda

TSC Yoda

Ehrenmitglied
Da ich mit einer anderen Rom keinerlei Probleme habe, wird es nicht am hier behandelten Verfahren liegen, bitte poste Deine Stabilitätsfragen im Bereich der Rom :)
 
C

CAB42

Ambitioniertes Mitglied
So ein altes Schätzchen unter Windows 10 (64 bit) ohne Probleme befreit, nachdem SkipBOSDescriptorQuery in der Registry eingetragen war. Danke
 
K

Kaltam

Neues Mitglied
So, ich habe mich dann auch mal mitmeinem HDH und dem aahk2 auseinandergesetzt, und mich an die Anweisung gehalten, hänge aber nun hier fest: jemand ne Idee?

UPDATE: Habe vergessen, Fastboot zu deaktivieren
UPDATE2: Hat nun geklappt, nutze nun erfolgreich eine Custom Rom!
 

Anhänge

Zuletzt bearbeitet:
P

plaintext

Neues Mitglied
Ich bin ja nicht so ein Root-Profi, daher hat die Recherche bisher _Stunden_/Tage gedauert und bin jetzt schon äußerst dankbar für Dein Skript.
Das Problem ist, dass ich nur mit meiner vodafone-sim, nicht aber mit Alditalk eine Datenverbindung bekomme ("eingeschränkt" beim Start)
.
Obwohl das Script doch gute Arbeit geleistet hat:
*** Unlocked ***
ACE PVT ENG S-OFF RL
Hboot-0.0.5.2425
Microp-09438
Radio-26.14.04.28_m
emMMC-boot
Apr 12 201, 00:55:45

Könnte mir da jemand einen Tipp geben?

Ausserdem wollte ich ein möglichst aktuelles CM installieren.
Nur sind diese CyanogenMod Downloads hier ja nicht aktuell und mittels revocer ausgepackt, startet zwar das CM-Logo, bleibt aber in einer boot-Schleife.
(Was sich zum Glück mit dem Skript wieder beheben lässt! Halellulja)
Aber wo lädt man denn am besten die aktuellsten ROMs, bzw muss ja nicht CM sein.
 
P

Phiber2000

Experte
Threadstarter
Du musst für Alditalk lediglich die APN Einstellungen nachtragen.
 
P

plaintext

Neues Mitglied
@Phiber2000: Na, klar. Vielen Dank für den Hinweis.
Jetzt habe ich mal CM 12. nightly und snapshot von Open Desire Project ausprobiert.
Läuft super.... bis auf WLAN (GPS geht wohl auch nicht, aber eins nach dem anderen).. obwohl Radio-26.17.14.11-M.
Könntest Du mir noch einen kleinenTipp geben?
 
P

Phiber2000

Experte
Threadstarter
Schritt 7 vergessen!?
 
P

plaintext

Neues Mitglied
@Phiber2000: Hhm, ich dachte nicht. Ok, also nochmal über Los :)
RUU_Ace_Sense30_S_HTC_WWE_3.12.405.1_Radio_12.65.60.29_26.14.04.28_M_release_225512_rooted.zip ist drujf (3.12.405.1, Android 2.3.5)

Aber jetzt ist TeamWinRecovery weg bzw wenn man es starten will kommt das/ein Rotes Dreieck? Was blöde ist, da ja eigentlich CM12 drauf sollte.
 
P

Phiber2000

Experte
Threadstarter
Dann hast du etwas falsch gemacht. Hattest du die Anweisungen in der FAQ: "Wie installiere ich nach dem erfolgreichen Rooten die aktuellste ROM von HTC?" genau so beachtet?
 
P

plaintext

Neues Mitglied
@Phiber2000: Ja, irgendwo bestimmt. Also nochmal alles durch.
Dein aktuelles (HTC-)ROM läuft.
Jetzt kommt aber lustigerweise ein Fehler beim Flashen des CM12 (mit TWRP). "Can't install this package on top of incompatibel data...." (Das ROM lief aber schon mal, aber ohne WLAN)
Habe daher auch TWRP auf 2.8.61 und Raio geupdated und bin nun gerade bei
HBoot-2.00.2728
Radio-26.17.11_M (nebenbei: ich kann mit zwar mit meinem WLAN verbinden, aber beim Scannen findet er keine Netze.... Man kann es jedoch händisch eingeben.)
Sep 7.2011

CM12 lässt sich aber nun nicht mehr installieren. Hmm.
 
P

plaintext

Neues Mitglied
@Phiber2000: Hmh, das hatte ich schon gemacht. Habe es gerade nochmal gemacht. Auch Factory reset über startup als auch über Android.Dett will nicht.
 
P

Phiber2000

Experte
Threadstarter
Schritt 7, dann KitKat-Kit und anschließend CM12 aufspielen. Bislang ging das immer... :confused2:
 
P

plaintext

Neues Mitglied
Genau, da war ich ja schon mal (nur ohne WLAN) daher auch meine Verwunderung.
Dank Deines Skriptes (auch ..aahc2_fastboot!) kann man ja immer mal wieder ne Runde drehen. Nur kann das schon mal Stunden dauern.......
Auf jeden Fall läuft es jetzt doch. Ich vermute, das das Löschen aller "Partition" unter TWRP->Wipe->Advanced (alles ausser sdcarte auswählen) geholfen hat.
Denn Factory Reset und "normales" Wipen hatte ich bestimmt vorher auch schon gemacht..., bestimmt :)
Also wenn man es nicht so oft macht, muss man etwas Geduld mitbringen.... Aber hier ist man in guten Händen.
 
P

Phiber2000

Experte
Threadstarter
Ja. Das war der Punkt: Full-Wipe vor dem CM flashen (beinhaltet die System-Partition) sollte man schon machen!
Darauf bin ich aber jetzt auch nicht gekommen... ;)
Manche Dinge werden von einem Selbst im Laufe der Jahre so selbstverständlich durchgeführt, dass man daran als Fehlerquelle überhaupt nicht mehr denkt...

Gut gemacht!

Phiber
 
Oben Unten