Automatic Root Enabler - Von 0 auf Root in 40 Sekunden

  • 236 Antworten
  • Neuester Beitrag
Diskutiere Automatic Root Enabler - Von 0 auf Root in 40 Sekunden im Root / Hacking / Modding für Huawei Ideos X3 im Bereich Huawei Ideos X3 (U8510) Forum.
lowskill

lowskill

Ambitioniertes Mitglied
DJburner schrieb:
Meine Frage: wie machst du das und wie entscheidest du welche datei dadrin starten soll?
Möglichkeiten, selbstextrahierende Archive zu erstellen, gibt es viele. In diesem Fall habe ich IExpress verwendet, welches allen Windows-Versionen seit Windows XP beiliegt.
 
D

DJburner

Ambitioniertes Mitglied
lowskill schrieb:
Möglichkeiten, selbstextrahierende Archive zu erstellen, gibt es viele. In diesem Fall habe ich IExpress verwendet, welches allen Windows-Versionen seit Windows XP beiliegt.
Hejo, kannst du mir sagen welche Einstellungen du benutzt hast.
Es ist ja eine batch datei die nacheinander die anderen startet. Werden die anderen in den/einen temp ordner gelegt?
 
lowskill

lowskill

Ambitioniertes Mitglied
Welche konkreten Einstellungen interessieren dich denn? Die möglichen Optionen sind ja eigentliche alle recht selbsterklärend.

Ja, die Dateien werden automatisch in einen temporären Ordner entpackt.
 
D

DJburner

Ambitioniertes Mitglied
Und dann gibst du den pfad von dem tempmordner in der batch an?
 
lowskill

lowskill

Ambitioniertes Mitglied
Nein. Die Dateien werden alle in den Temp-Ordner entpackt und anschließend wird die im IExpress Wizard angegebene Datei (z.B. ein Batch-Script) gestartet. Das erledigt so weit alles das von IExpress erstelle SFX.

Das Batch-Script selbst muss gar nicht wissen in welchem Ordner es entpackt wurde. Insofern muss darin auch nicht der Pfad zum temporären Ordner angegeben werden. Falls das Batch-Script eines der mitgelieferten Scripte aufrufen will reicht es den Dateinamen anzugeben, da sich ohnehin alle Dateien im gleichen Ordner befinden.
 
D

DJburner

Ambitioniertes Mitglied
Okey, ich dachte die hauptbatch wird in den ram geladen :D
Nagut, vielen dank für die hilfe :)
 
TSC Yoda

TSC Yoda

Ehrenmitglied
Datei nicht vorhanden...
 
lowskill

lowskill

Ambitioniertes Mitglied
Die Download-Links wurden erneuert und sollten nun wieder funktionieren.
 
woingenau

woingenau

Fortgeschrittenes Mitglied
Habe folgendes Problem:

Ich nutze CWM 4.0.1.4 und wollte eine neuere Version flashen (habe zum flashen sowohl das Toolkit als auch die "normale" Flashmethode über installador.bat benutzt).
Weder 5.0.2.7 noch 5.0.2.8 funktionieren.
CWM startet zwar, aber wenn man einen Menüpunkt auswählen möchte, springt es immer wieder auf "reboot system now" zurück.
Bei der 4.0.1.4 RecoveryClockmodByZaDkYn funktioniert alles normal.
Nutze die Stock-Rom 2.3.5. und habe die Pulse-Treiber (Win XP) installiert.
Hat vielleicht jemand einen Tip?
 
Zuletzt bearbeitet:
Andy

Andy

Ehrenmitglied
Bestätigt wird jetzt nicht mehr mit Power sondern mit Home und anders rum.

Sent from my fingers to your eyes :)
 
woingenau

woingenau

Fortgeschrittenes Mitglied
Oh, da hätte ich ja lange probieren können -> jetzt klappt alles. :)
Danke!
 
F

fliegentöter

Gast
Hi, ich hab mir jetzt ein Huawei Ideos X3 gekauft und komme eig von den "echten" China Handy, sprich den Fälschungen mit Dualsim etc.

Da ich jetzt was mit Garantie hab, wollte ich hier mal erst auf Nummer sicher gehen und nachfragen ;D

Mein X3 hat den O2 Netlock. Das offizielle 2.3.5 Update hab ich bereits installiert.
Jetzt würd ich gerne SystemApps wie GoogleMail loswerden und brauch dazu ja ROOT.

Kann ich das Phone mit dem Lite ROOT Enabler rooten (hab ja den O2 Lock macht das was?), dann die Systemapps löschen und danach den Root wieder entfernen?

Die Root Dateien lassen sich mit nem Root Explorer ja einfach wieder entfernen, steht zumindest ein paar Seiten weiter vorne ;D

Danke schonmal
 
ElTonno

ElTonno

Experte
Das du ein Lock hast macht nix, den hast du auch noch danach! ^^
 
DerGraf1997

DerGraf1997

Experte
Zum Unrooten ist mir persönlich jetzt keine Möglichkeit bekannt.
 
F

fliegentöter

Gast
Dass der Lock bleibt macht ja nix ;D
Aber prinzipiell geht meine Methode oder?

Auf Seite 15 steht:

"So, habe die beiden mit dem Root Explorer jetzt erfolgreich gelöscht... Bin ja mal gespannt, was jetzt passiert... :)
...
Hmmm... Nach Neustart Superuser wieder da...
...
Hat doch geklappt. Ich musste nur das Superuser-Update auch noch deinstallieren.
Jetzt sagt der Root Explorer, dass mein Phone nicht gerootet ist... Yippieh... :)
...
Recovery Mode... Cache gelöscht... Factory Reset... und ich habe wieder ein jungfräuliches Telefon. :)
Vielen Dank für die Hilfe!"


Aber wenns auch n Toolkit zum unrooten gibt,mal schaun welche Methode ich probieren werde ;D

Wollte nur sicher gehen, dass das Lite Programm auch mit 2.3.5 und Netlock geht.
Danke :D
 
S

Stonaged

Erfahrenes Mitglied
lowskill schrieb:
J

Kurzanleitung
  1. Handy am PC anschließen
  2. recovery.bat starten
  3. Backup per CWM-Recovery erstellen
  4. Handy neustarten
Nachfrage: Noch mal ganz genau für DOOFE:
Damit macht man ein komplettes Backup von allen Partitionen etc. OHNE irgendetwas auf dem X3 zu verändern?
Sprich das Gerät bleibt gegebenenfalls im Auslieferungszustand? (Z.B. wegen der Garantie?)
 
Zuletzt bearbeitet:
M

mary-lou

Fortgeschrittenes Mitglied
Die Original-Recovery wird nicht überschrieben, ja.
 
K

Kulessa

Neues Mitglied
@lowskill
Irgednwie scheint es bei mir da ein Problem zu geben... ich hab die USb Treiber installiert und die Automatic Root Enabler (full) Version gestartet. CWM 5.0.2.7 wird auch prima installiert aber dann hängt das Skript und nichts weiter passiert in der DOS box...
Ich hab daraufhin euch die Lite Version probiert aber alles was passiert ist ein Booten nach CWM. dann hängt's wieder. Das hier erscheint in der DOS Box:
-- Booting device into fastboot mode...
-- Booting device into ClockworkMod Recovery...
< waiting for device >
downloading 'boot.img'... OKAY [ 1.093s]
booting... OKAY [ 0.180s]
finished. total time: 1.273s

Und das war's. Irgendwelche Tipps?! Ich hab es auch schon mit YAIX3T 1.0.3.3 probiert, aber ebenfalls ergebnislos. Kein SU, Boot Checker Lite zeigt keine Root Rechte.
Vielen Dank schon mal im Voraus!

Der ursprüngliche Beitrag von 00:05 Uhr wurde um 00:30 Uhr ergänzt:

@lowskill

Never mind... ich hab noch mal alle 20 oder so Sieten hier durchgelesen und nachdem ein paar Leute Probleme mit dem Treiber haten, diesen noch mal weg und wieder hin installiert und dann lief das Lite Skript erfolgreich durch!
Vielen Dank für das tolle Tool!
 
G

gt@

Gast
Leider fehlt im Paket von lowskill immer noch die Sektion für Win7 x64 in der .inf Datei.
Das führt unweigerlich dazu, das Treiberteile nicht installiert werden können, da der Installer die Device nicht finden und zuordnen kann.
Wenn man den Installer entpackt und dann wie in diesem Post beschrieben vorgeht, klappt auch die Treiberinstallation auf Win7 x64.