Sammelthread: ACHTUNG Update I7500XXIH8 (September 2009)

  • 464 Antworten
  • Neuester Beitrag
Diskutiere Sammelthread: ACHTUNG Update I7500XXIH8 (September 2009) im Samsung Galaxy (I7500) Forum im Bereich Samsung Forum.
N

Nicetobe

Neues Mitglied
bekomme immer den fehler ungültige inet verbindung! brauche hilfe!!!!
nps update installiert alle treiber da (die fürs modem tethering, adb interface etc.)
 
Thyrion

Thyrion

Ehrenmitglied
@Nicetobe: Stell mal Dein NPS auf englisch um.
 
Maniac

Maniac

Stammgast
Hat schon jemand das Image so angepaßt, daß es root hat und debugable ist? Das war beim vorherigen Update so schön...

Oder funktionieren die alternativen root Methoden auch mit der neuen Firmware noch?
 
Thyrion

Thyrion

Ehrenmitglied
@Maniac: Das Root habe ich mir einfach mit dem Drakaz-Recovery-Image "besorgt" (siehe auch meine Signatur). Dort gibt es eine schöne Funktion "Enable root"...
 
Maniac

Maniac

Stammgast
Gibt es da irgendwo einen Thread / Anleitung zu? Kenne mich mit den recovery images und solchen Sachen leider noch nicht wirklich aus... :(
 
Thyrion

Thyrion

Ehrenmitglied
Maniac

Maniac

Stammgast
Ok, danke... wie war das jetzt noch, wenn ich das recovery image drauf habe und dann über NPS update, ist das recovery dann wieder weg?

Werd mich wohl morgen mal sowohl ans Update, als auch an root machen... zum Glück habe ich jetzt root und kann mir daher /data sichern... hoffe, dass es danach auch klappt und ich somit zumindest die App-Einstellungen auch wieder zurück sichern kann.
 
Thyrion

Thyrion

Ehrenmitglied
Ja, in dem Update vom Samsung ist ein (Standard-)Recovery-Image mit drin. Das wird also überschrieben. Aber Du kannst ja danach ohne Probleme wieder ein anderes flashen.
 
schischa

schischa

Fortgeschrittenes Mitglied
hab längere autofahrt morgen vor mir und grad keine zeit nochmal komplett durchzulesen (bitte schlagt mich nicht).

wie siehts denn nach diesem update mit der modem funktion aus? hab linux (archlinux) auf dem laptop und wollte fragen wie ich die funktion im galaxy aktivieren kann, bzw. ob es denn nach dem update überhaupt geht. dmesg erkennt mir zumindest kein modem wenn ich das gerät per usb verbinde.

pack mal weiter und schau alle paar minuten hier rein ;)
 
fluxkompensator

fluxkompensator

Enthusiast
scheint wieder zu gehen
 
rowi

rowi

Dauergast
schischa schrieb:
wie siehts denn nach diesem update mit der modem funktion aus? hab linux (archlinux) auf dem laptop und wollte fragen wie ich die funktion im galaxy aktivieren kann, bzw. ob es denn nach dem update überhaupt geht. dmesg erkennt mir zumindest kein modem wenn ich das gerät per usb verbinde.
arch basiert auf slack, oder? Da ist m.W. der Networkmanager nicht mit dabei. Wenn Du ihn doch hast oder einfach nachinstallieren kannst geht es aber ganz einfach, hab es vorhin gebloggt: Tethering mit dem Samsung Galaxy (Android) - Der Standardleitweg (man verzeihe mir dass ich es nicht noch einmal neu schreibe). Wenn Du in dmesg nichts ausser dem Massenspeichersiehst musst Du wie für das Update die Option deaktivieren dass es sich nur als Massenspeicher meldet.
In dmesg sollte dann soetwas auftauchen:
Code:
cdc_acm 1-4.1:2.0: ttyACM0: USB ACM device
Ohne den Networkmanager geht es natürlich auch, ist dann aber Handarbeit, die wollte ich mir mangels Bedarf nicht machen.
 
P

phw

Neues Mitglied
Funktioniert bei mir nur halb. Ich konnte einmalig eine Verbindung aufbauen. Habe die Verbindung getrennt und wollte erneut verbinden, hat aber seitdem nicht mehr funktioniert. Der NetworkManager versucht eine Verbindung herzustellen (animiertes Tray-Icon), bricht dann aber wieder ab.

dmsg zeigt mit die Zeile cdc_acm ... beim anschließen an, soweit scheint es also zu passen.
 
B

billy

Neues Mitglied
ich bekomme immer nur diese meldung beim versuch das update auf mein handy zu bekommen!?!

binary upgrade has failed.please follow these instructions:

1.detach and reattach the mobile phone battery.
2.reconnect the mobile phone while it is turned off.
3.select the mobile phone for emergency recovery in device update and execute update again.

kann mir da einer helfen.habe keine ahnung von der sache....
 
B

BobZero

Ambitioniertes Mitglied
Ich habe da mal etwas geforscht....


Das reset nach dem update ist nicht notwendig wenn man sich die Arbeit macht und den APN neu einträgt. Denn nur die tatsache das kein APN bzw ein falscher eingetragen ist lässt den Prozessbug auftreten bzw. euer Provider kickt euch aus dem Netz oder das Galaxy bricht die normale Verbindung ab da es keine Datenverbindung aufbauen kann.

Die genauen warum Sachen sollen ja auch erstmal egal sein. Fakt ist: falls jmd nach dem update Probleme mit dem Netz hat und die Prozess-fehlermeldung bekommt bitte einmal alle APNs löschen und neu erstellen. Betreibernetz nochmal auswählen. Und reboot. Falls es klappt bitte PN.
 
Melkor

Melkor

Senior-Moderator
Teammitglied
Vllt. kann einer der daselbe Problem hatte, mal das testen was BobZero gechrieben hat und uns dann bescheid sagen...
 
M

maxpain

Neues Mitglied
Ich hab nur den Provider auf O2 eingestellt. Nach dem Reboot keine Absturzmeldung mehr, auch ohne Reset.

Danke für den Tipp.
 
L

logical

Erfahrenes Mitglied
wie merke ich ob meine APNs weg sind? hatte nach dem update über odin keine probleme und hab bis jetzt nicht reseten müssen
 
S

sokrates

Gast
Kann mal jemand ausprobieren, ob der deutsche Server geht? Bei mir kommt nämlich seit gestern abend dauernd "Server Login Fail" wobei das erste Update damals problemlos ging.
 
rowi

rowi

Dauergast
phw schrieb:
Funktioniert bei mir nur halb. Ich konnte einmalig eine Verbindung aufbauen. Habe die Verbindung getrennt und wollte erneut verbinden, hat aber seitdem nicht mehr funktioniert. Der NetworkManager versucht eine Verbindung herzustellen (animiertes Tray-Icon), bricht dann aber wieder ab.
Das ist merkwürdig. Wie weit kommt der NetworkManager denn? Schon eine grüne Kugel (Layer 2 verbindung) oder nicht mal so weit?
Steht in messages was brauchbares?
Sperrt der Provider evtl. wenn Du zu viele Verbindungen parallel aufbaust? Sessions können beim Provider hängen und weiterhin aktiv gelten, gerade wenn sie "hart" abgebaut werden.
 
Maniac

Maniac

Stammgast
So, ich will dann auch mal (etwas ausführlicher) zum Update berichten, einigen damit vielleicht ein wenig helfen, vor allem aber auch flux ne Rückmeldung geben:

Ausgangspunkt ist mein Galaxy der "ersten Stunde". Darauf hatte ich damals dann das erste offizielle Update via NPS geflasht.

Seit dem wurde das Galaxy dann ja vom NPS (ich glaube Version IF2 war das) nicht mehr erkannt. Auch jetzt wo das neue Update verfügbar ist, nicht.

Das NPS selbst meldet, es wäre kein Update vorhanden. Auf der Webseite von Samsung (Home - Samsung Mobile) gibt es nur das NPS 3.1, was offensichtlich nicht fürs Galaxy ist, auch taucht es in der Handy-Liste nicht auf. Gefunden habe ich die neue Version (IH2) nur durch den Link hier irgendwo im Forum.

Das ist ein NO-GO, flux! Wie soll der Otto-Normal-User so das Update hinbekommen? Da muss Samsung dringend was tun!!!

Dann (wurde ja schon oft angesprochen, aber trotzdem nochmal): mit Spracheinstellung auf Deutsch, passen erstens einige Texte nicht in die Dialoge (sehr unschön, wenn man bei so etwas "heiklem" wie nem Update nicht wirklich die Hinweise und Texte lesen kann!).

Außerdem kommt beim Download die bekannte Meldung "Verbindung mit Server fehlgeschlagen". Stelle ich das NPS auf Englisch (UK) Sprache um, funktioniert es. Ebenfalls ein NO-GO!

Was soll der Hinweis vor dem Update, dass die "Abdeckung des Mobiltelefons offen sein soll?" Welche Abdecknung? Wozu? Was soll der Schwachsinn?

Der Rest des Updates hat bei mir dann ohne Probleme, wie auch schon beim ersten mal geklappt. Download durchgelaufen, aufs Handy gespielt und fertig.

Beim ersten Start "hing" das Handy wirklich so 3-4 Minuten beim android-Logo. Hat danach dann aber friedlich weiter gebootet.

Es sind auch alle Daten und Apps erhalten geblieben.

Allerdings hatte ich auch das Problem mit dem abstürzenden Phone-Prozess.

Ich habe dann einmal die SIM-Karte raus genommen, das Handy ohne Karte gestartet, wieder runter gefahren, SIM wieder rein und jetzt läuft es OHNE Hardreset und OHNE abstürzenden Phone-Prozess. Auch UMTS läuft.

Also vielleicht für alle mit dem Problem auch dies mal testen.

@flux: ich kann mir vorstellen, dass der Fehler nicht von Samsung "geplant" ;) war und ggf. schwer zu reproduzieren ist o.ä. Trotzdem bleibt auch das ein NO-GO. Woher soll Otto-Normal-User auf sowas kommen?

Der Weg von BobZero hat bei mir übrigens nicht funktioniert, weil ich (während des Fehlers) gar keine APNs hatte, demnach auch keine löschen konnte auch auch das zurücksetzen auf Standard hat nichts gebracht. Im Logcat habe ich zwar gesehen, dass er die Einstellungen gefunden hat, hat aber keinen APN angelegt. Dieses Verhalten hatte ich damals bei meinem Handy schon einmal beoabchtet. Auch da half es, die SIM-Karte mal neu einzusetzen. Klingt komisch, ist/war aber so...

Ein Hardreset um dieses Problem zu beheben, bzw. generell bei einem Update ist natürlich ebenso unerfreulich und eigentlich NO-GO. Zumal es beim Android-Prinzip eigentlich völlig unnötig ist. Was hat das Firmware-Update mit meinen installierten Apps zu tun? Wenn es bei einigen System-Einstellungen / Programmen Kompatibilitätsprobleme gibt, könnte man ja explizit diese resetten, aber nicht das komplette Phone!

Die App Switchers habe ich nun auch und dafür ist somit auch kein Hard-Rest erforderlich! Allerdings erscheint das Icon nicht automatisch (eigentlich logisch) auf dem Desktop. Es ist aber ganz normal im Launcher (der Programme-Lasche) zu finden und man kann sich wie gewohnt einen Desktop-Shortcut selbst anlegen.

Was mir auch als erstes aufgefallen ist, ist dass das entsperren wirklich schneller geworden ist. Zum Rest kann ich noch nicht viel sagen, mein Galaxy lief vorher auch recht problemlos.

Allerdings ist die Ladedisko NICHT weg! Mein Bootloader ist vom 29. Juni. Aber wie gesagt, ab Werk hatte ich die Disko nicht, d.h. sie ist mit dem 1. Update gekommen, warum ist sie jetzt mit dem 2. Update nicht wieder gegangen??? Auch das ein NO-GO, zumal sich schon "schön" das Batterie-Symbol in meinem Display verewigt hat... langsam werde ich diesbezüglich echt sauer und es gibt wohl bald einen Garantietausch (als Selbstständiger zum Glück innerhalb von 24h, bin ja gespannt, ob das klappt).

Also flux, vielleicht helfen Dir diese Ausführungen ja, es als Feedback richtung Samsung mitzunehmen und denen auf die Füße zu treten...

Da ich selbst Softwareentwickler bin, weiß ich dass vieles nicht so einfach ist und Fehler passieren können. Aber derzeit ist das eine echt schwache Vorstellung! Ich hoffe, da passiert bald was!

vorher:
CSC:I7500VIAIG6
I7500XXIG8

jetzt:
CSC:I7500VIAIH4
I7500XXIH8