Nach Root keinerlei GPS-Empfang mehr

  • 192 Antworten
  • Neuester Beitrag
Diskutiere Nach Root keinerlei GPS-Empfang mehr im ZTE Blade S6 Forum im Bereich Weitere ZTE Geräte.
Pegade

Pegade

Fortgeschrittenes Mitglied
nein, die GPS.conf tut da nichts, meine Originale sah auch so aus wie im GPS Thread, bei einem funktionierte das GPS so, bei mir nicht.

Ich kanns dir nicht sagen woran es liegt. Vlt nutzen die CM Programmierer andere Treiber für die Hardware?
 
7

7Zoll

Stammgast
Scheint leider nicht sonderlich verbreitet zu sein das Gerät, obwohl die Anzahl der Firmwares erstaunlich ist. Praktisch für jeden Winkel der Welt haben die das was fürs S6. Dass sich die HW unterscheidet, also wesentlich, dürfte unwahrscheinlich sein. Obwohl ich laut Karton eine 1.5GHz CPU drin habe, andere aber eine 1.4 und noch andere 1.3.

Hast Du zufällig bei XDA noch mehr Infos zum S6 gefunden?
 
Pegade

Pegade

Fortgeschrittenes Mitglied
ich hab mich da nicht so arg belesen, aber es ist wohl so das z.B. die Australische komplett anders Partitioniert ist als die AS und EU.

Ist aber ansich garnicht schlimm auf die CM zu wechsel, TWRP Bootloader installieren (Originalen vorher natürlich sichern), danach im TWRP das Originale Android sichern und das CM drauf. Alles wieder einrichten wie gewohnt und es läuft, abgesehen vom Kamera Blitz und den momentan zu hellen Tasten, ansonsten ist die Version aber 1a
 
7

7Zoll

Stammgast
Gibt es denn irgendwo eine Beschreibung, wie man das ganz genau macht? Ich trau mich da nicht so recht ran, ohne sichere Anleitung. Und kann man dann wieder zum exakten Original wie jetzt zurück? Gibts dazu auch eine Anleitung irgendwo?

Was genau sind zu helle Tasten und was sonst geht alle noch nicht? GIbts die CM-Firmware denn nun doch irgendwo kostenlos?

Nachtrag:
Ähm, kann man eigentlich auf ein AS und auch ein EU Gerät dieselbe CM12.1 flashen? Wenn das geht, warum gehen dann die normalen ROMs nicht, also EU statt AS? Zumindest wird das behauptet. Aber hat das wirklich jemand schon probiert und das Gerät damit zerstört?
 
Zuletzt bearbeitet:
Pegade

Pegade

Fortgeschrittenes Mitglied
Nein, EU haben eine andere Version, auch beim CM.

hier ist eine Anleitung zum TWRP: Das Minibetriebssystem 2.8.7.0 des Team Win Recovery Projects (TWRP)

Highwaydesigner hat das ganze sehr gut beschrieben. Danach das passende CM von Lightwars runter laden und installieren.

Im Grunde machst du also folgendes:

-Root (aber das hast du ja schon)
-Backup deines aktuellen Bootloader mit flashify
-Installation des TWRP mit flashify
-Backup des aktuellen Systems im TWRP
-Wipe (Cache, Data, Dalvik Cache) im TWRP
-Installation im TWRP von CM und den GAPPS (Google Apps)
-booten und das System einrichten

Sobald dann aber eine aktuellere CM kommt fängt das spiel von wegen Wipe und installation von vorne an, es sei denn man kann ohne Blitz leben ^^
 
7

7Zoll

Stammgast
Vielen Dank. Na super, dann jede Woche einmal neu installieren ;)
Ich hatte CM vor Jahren schon mal auf einem alten Handy, weiß nicht mehr genau, welches. Daher bin ich ja grundsätzlich bereit, es zu versuchen. Aber vielleicht warte ich noch, bis wenigstens die letzten offenen Dinge darin tun. Ich will es ja nutzen und nicht jeden Tag rumbasteln.

Sehe ich das richtig, dass ich mit dem TWRP danach auch wieder das jetzige AS-12 so zurückspielen könnte, wie es jetzt gerade ist, also als 1:1 binär-Backup?
Und dann im Ernstfall würde ich mit dem zurückgespielten AS-12 wieder per Flashify den originalen Bootloader einspielen und könnte dann ZTE Updates einspielen?
 
Pegade

Pegade

Fortgeschrittenes Mitglied
wenn du den TWRP geflasht hast bootet wie gehabt die AS Version, erst wenn du CM installierst bootet er mit CM hoch.

Ja, du kannst ein Backup z.B. auf deine SD Card sichern lassen. Habe ich auch getan bevor ich CM installiert hab und von Fortek CM auf das von Lightwars gegangen bin. Im Notfall ist das in 10 Minuten wieder zurück kopiert.
 
7

7Zoll

Stammgast
Ach so, man könnte dann quasi auch vom CM12 ein Backup machen und dann das Originale zurückpielen und dann wieder auf CM wechseln. Dauert zwar immer, aber so hat man quasi 2 Systeme gleichzeitig vorliegen. Selbst wenn man kein CM nutzt ist TWRP also durchaus sinnvoll, um Vollbackups vom Originalsystem zu machen anstatt nur so quasi Backups per Titanium. Oder?

Da kaum davon auszugehen ist, dass ZTE überhaupt nochmal ein Update für AS liefert, kann TWRP dann wohl eh drauf bleiben.
 
Pegade

Pegade

Fortgeschrittenes Mitglied
ich denke auch nicht das von ZTE nochmal was kommt, und Supportmäßig ists für unsere AS Version in Deutschland eh mau.

Das TWRP ist schon ein Top Bootloader.
 
7

7Zoll

Stammgast
Grad noch ne Frage: Welche Google Apps muss man denn dafür auswählen? ARM 5.1?
 
Pegade

Pegade

Fortgeschrittenes Mitglied
ARM, wobei ich mir nicht sicher bin ob vlt nicht sogar ARM64 gehen würde, Android 5.1 und Variante nach deinem Geschmack
 
7

7Zoll

Stammgast
Danke. Was genau ist gemeint mit "factory reset your device"? Per TWRP? Wird dadurch auch die interne SD gelöscht? Beim stock recovery hatte ich das nämlich letzte Woche gemacht und trotzdem war alles auf der internen SD noch da - worüber ich ganz froh war.
 
Pegade

Pegade

Fortgeschrittenes Mitglied
normal ist das nur auf dem Telefon. Die SD bleibt verschont, aber was hast du vor von wegen Factory reset your device?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
bzw in welchem zusammenhang?
 
7

7Zoll

Stammgast
Das steht auf der CM Anleitungsseite von lighwars.
 
Pegade

Pegade

Fortgeschrittenes Mitglied
das soll heißen das du ein Wipe machen mußt

Wipe von Data, Cache und Dalvik Cache, alles andere bleibt erhalten
 
7

7Zoll

Stammgast
Ah ja, ich habs gefunden, das steht auch so im TWRP unter Wipe. Nun gehts los.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hurra, es läuft. Nur die Leds unten machen einen ja blind. Kann man das abschalten?
Außerdem habe ich nach wie vor nur chinesische Satelliten. Das gibts doch nicht! Und nun?
 
Pegade

Pegade

Fortgeschrittenes Mitglied
in Einstellungen unter Gerät Tasten und dort Hintergrundbeleuchtung, damit kannstes abschalten

hast du mal beide Sim Karten rausgenommen? Probier einfach mal
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
ansonsten bliebe nur mal die Möglichkeit die Version von fortek zu testen ob es da funktioniert.
 
7

7Zoll

Stammgast
Es macht keinen Unterschied, ob ich Mobilfunk abschalte oder die Sims rausnehme. Nur China.
Was auch sehr seltsam ist: Wo ist denn der ganze interne Speicher hin? Ich habe nur noch 2,5GB von 3,9GB frei, aber belegt sind nur 27MB. Das ist die interne SD, von der ich vorhin meinte, dass die beim Original-Recovery-Wipe nicht gelöscht wurde. Scheinbar ist die nun gar nicht mehr vorhanden bzw. wird ausgeblendet. Hier zählt jetzt offensichtlich der App-Speicher mit dazu, das war vorher nicht.

Eigentlich schade, denn CM hat ja schon ein paar nette Features, die man sonst nur umständlich nachinstallieren muss oder gar nicht hat. Aber ohne GPS nützt mir das alles nix.

Wenn ich nicht 100% sicher wüsste, dass GPS schon tat und zwar mit Root, könnte ich ja wenigstens in den allerersten Zustand zurück, aber da gehts ja auch nicht, wie ich bereits getestet habe. Wo kann sich das denn nur reingebrannt haben, dass GPS/Glonass nicht mehr möglich ist? Zum verrückt werden.

PS: Im TWRP steht, dass ich auf der internen SD noch 6,5GB frei habe. Warum sehe ich das in CM12 nicht?

PPS: Hast Du den EU-Kernel verwendet? Ich hab den von AS verwendet, hätte ich den EU nehmen sollen oder startet es dann gar nicht?

P3S: Im Original-System sieht es so aus: 4,4GB ROM, 3,9GB Nutzer ROM (das ist wohl das, was CM nutzt) und 7,7GB interne SD-Karte, die CM gar nicht sieht.

P4S: Ich habe eben mal nachgeschaut: Am 21.12. habe ich nach dem Rooten und Einrichten 2KB Datenverkehr über meine O2-Sim gehabt. Am 22.12. bin ich dann mit dem S6 im Auto gefahren und GPS tat. Danach hab ich dann erstmals 440KB Daten genutzt und die Tage darauf auch, aber kein GPS mehr verwendet, sodass ich nicht sagen kann, ab wann das nicht mehr tat (so um Weihnachten hab ichs wieder versucht und er fixte nicht mehr, aber ich wusste da noch nicht, warum). Es könnte also etwas dran sein an der Vermutung, dass die GPS-Probleme mit den Sim-Karten zusammenhängen. Nur in wie fern?

P5S: Ich hab jetzt mal die Sims rausgenommen und neu gebootet. Jetzt krieg ich 2 Glonass (Nr 74+82) und 3 Chinesen mit dem Contrabass... Mehr is nich.
 
Zuletzt bearbeitet:
Pegade

Pegade

Fortgeschrittenes Mitglied
hast du das Telefon mal ein weig länger suchen lassen? Beim ersten mal, dauerts ne ganze Weile, Stichwort A GPS. Das allererste mal hab ich mein S6 für ~5 Minuten ins Fenster gelegt, mittlerweile findet er die Satelitten innerhalb von Sekunden.
 
7

7Zoll

Stammgast
Ah joh, ewig teilweise. Es ändert sich nichts. Irgendwas ist bei mir verdreht, was man ja daran sieht, dass die Firmware nichts daran ändert. GPS kann aber nicht kaputt sein, Antenne oder so, da ich gestern mal 16 Chinesen gleichzeitig fand. Und einmal hatte ich 2 Russen und später nochmal einen allein. Versuche jetzt gleich mal die EU-Version. Falls das auch nicht klappt, bin ich weitgehend ratlos. Aber bei dem Detachy hatte es ja so geklappt. Letzte Hoffnung.