1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

adb ohne bootendes System?

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von Compufreak, 19.01.2010.

  1. Compufreak, 19.01.2010 #1
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Halli Hallo,

    ich darf mich damit rühmen, als Erster mein Milestone mit Root zerschossen zu haben... Ich vermute, dass das an der gelöschten Gestures.apk liegt, gerne würde ich meine gebackupte Version wieder auf mein Milestone zurückschieben, jedoch bootet mein System nicht mehr (schwarzer Bildschirm nach Motorola-Logo).. Im Recovery-Modus kann ich leider kein ADB verwenden (device not found), ein Wipe und ein erneutes Einspielen der update.zip bringt leider auch nix - jemand eine Idee?

    Achja, das habe ich übrigens gemacht (glaube ich zumindest) :
    - gerootet
    - MotoNav.apk und Gestures.apk gelöscht
    - einen Blick in die Build.prop geworfen
    - Nicht funktionierendes WifiTether getestet (logisch, brauchte ja die Sachen da im Kernel...)
    - MarketEnabler mit unzufriedenstellendem Ergebnis getestet
    - Milestone ausgeschaltet
    - Milestone eingeschaltet
    - Milestone bleibt nach dem Motorola-Logo mit schwarz leuchtendem Bildschirm hängen...

    Danke schonmal...

    /edit : Hmm, hatte gerade die Idee, die Gestures.apk und MotoNav.apk mit in die Update.zip einzufügen - dummerweise habe ich keinen CardReader für MicroSDHC-Karten... Wenn ihr aber meint, das könnte klappen, werde ich mir heute gleich mal einen kaufen ;)
     
    Zuletzt bearbeitet: 19.01.2010
  2. Gast5050, 19.01.2010 #2
    Gast5050

    Gast5050 Gast

    erstmal mein Mitleid
     
    Compufreak bedankt sich.
  3. Compufreak, 19.01.2010 #3
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Danke... Da ich aber mit meinem Galaxy schonmal vor einer noch viel ausweglos erscheinenderen Situation stand (nichtmal Recovery Modus ging noch zuverlässig) und es dank dem Forum hier wieder zum laufen bekam, denke ich, ich/wir kriege(n) das schon wieder hin-gerade weil sich die update.zip so schön einfach flashen lässt... Vermute nur, ich werde mir einen MicroSDHC-Cardreader besorgen müssen (ist aber ja nicht all zu teuer)...

    Aber irgendwie habe ich ein Talent, solche Probleme mit meinen Androidphones zu bekommen xD
     
  4. Gast5050, 19.01.2010 #4
    Gast5050

    Gast5050 Gast

    Ja habe mein Galaxy auch einige male fast zerschossen aber mir wurde immer schnell geholfen denke das hier auch jemand ne Lösung hat nur denke nicht um 4 Uhr nachts.
     
  5. Compufreak, 19.01.2010 #5
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Hehe jop, das ist das Problem, wenn man Nachtmensch ist - nichtmal an einen CardReader kommt man um diese Zeit ;) Aber naja, bin ja noch bis so gegen heute Mittag wach, bis dahin haben dann auch die Läden offen und die ersten helfenden Posts werden sich hier aufzeigen ;) Bin jetzt schon gespannt, ob die Idee mit der update.zip klappt - aber Geduld ist eine Tugend, die ich mir dank dem Galaxy ganz gut antrainiert habe ;)

    So, werde jetzt mal versuchen mich zu motivieren, etwas bei mir aufzuräumen, damit es dann auch bald um 8 ist und die Läden offen haben ^^
     
  6. jannau, 19.01.2010 #6
    jannau

    jannau Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    11
    Registriert seit:
    05.12.2009
    Motonav ist auf jedenfall zu groß, wenn ich mich recht erinnere gehen nur maximal 63k payload. Sobald das richtige update da ist, sollte es aber klappen. Das update enthält, wenn ich es richtig verstanden habe, das komplette system image.
     
    Compufreak bedankt sich.
  7. Compufreak, 19.01.2010 #7
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Hmm habe mich da gerade in der FAQ auch nochmal etwas eingelesen und wenn ich das richtige sehe, dürfte auch das erweitern der update.zip nicht so einfach sein, wie ich mir das vorgestellt habe... Bzw. das 63K-Problem macht mein ganzes Vorhaben eh zu nichte...

    Hoffe mal, dass so langsam die Leute, die mir helfen können, wach werden ^^

    Habe inzwischen die Vermutung, dass ich nach dem fixen erstmal mein Root vergessen kann, da ich wahrscheinlich die originale update.zip einspielen muss, wenn ich nicht adb zum laufen kriege oder auf ein Custom ROM warte... Ich denke, ich werde letzteres tun und in der Zwischenzeit mein Galaxy benutzen...
     
    Zuletzt bearbeitet: 19.01.2010
  8. Specialist, 19.01.2010 #8
    Specialist

    Specialist Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    11
    Registriert seit:
    13.12.2009
    Soweit ich weiß, enthält das Update nur ein Delta, kein komplettes Image.
     
    Zuletzt bearbeitet: 19.01.2010
    Compufreak und AndroidJunkie haben sich bedankt.
  9. Compufreak, 19.01.2010 #9
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Hmm, und wie bekomme ich dann mein Milestone wieder zum laufen? o.0 Cardreader habe ich inzwischen...
     
    Zuletzt bearbeitet: 19.01.2010
  10. Specialist, 19.01.2010 #10
    Specialist

    Specialist Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    11
    Registriert seit:
    13.12.2009
    Du musst nicht unbedingt Motonav zurückspielen, es reicht ja, wenn Du das Script / die App patchst, das/die die Prüfung macht.
     
    Compufreak bedankt sich.
  11. Compufreak, 19.01.2010 #11
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Danke, aber ich denke ja schonmal, dass es eher an Gestures als an MotoNav liegt und ähm... Wie ich das an welcher Stelle rauspatchen soll, keine Ahnung... Bin kein Betriebssystemguru, wollte doch nur die 2 APKs löschen :eek:
     
    Zuletzt bearbeitet: 19.01.2010
  12. pha3ton, 19.01.2010 #12
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    Es liegt definitiv nicht an Motonav !! Das war das erste was geflogen ist und mein Stone bootet ganz normal :D:D
     
  13. KurrKurr, 19.01.2010 #13
    KurrKurr

    KurrKurr Android-Hilfe.de Mitglied

    Beiträge:
    143
    Erhaltene Danke:
    24
    Registriert seit:
    16.01.2010
    Phone:
    Motorola Milestone
    @Compufreak:

    Ich kann dir zwar nicht weiterhelfen, hätte aber gerne gewusst, wie du das Backup gezogen hast. Bin bei Android noch eher unerfahren und ich würde mir, gerne sofort nachdem ich gerootet habe ein Backup ziehen, bevor ich weitermache.

    Das mit Nandroid geht, soweit ich das verstanden hab nur mit einem Recovery Image oder so...

    Wie also hast du das Backup gezogen?

    Chris
     
  14. Spacefish, 19.01.2010 #14
    Spacefish

    Spacefish Android-Hilfe.de Mitglied

    Beiträge:
    83
    Erhaltene Danke:
    31
    Registriert seit:
    12.01.2010
    Phone:
    Motorola Milestone
    also ich hätte hier nen fullbackup des kompletten NAND-Flashs aber das wird dir net viel bringen denk ich. B.z.w. evtl. kannste es über den bootloader (nicht das recoverymenü) flashen, allerdings sind meines wissens die befehle net bekannt.
     
    Compufreak bedankt sich.
  15. Compufreak, 19.01.2010 #15
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Naja, ein wirkliches Backup ist was anderes, ich habe mir einfach die system-apps gezogen mit Hilfe von adb.
    Danke für das Angebot - ich werde wohl einfach warten müssen, bis da die Möglichkeiten bekannt werden, dann komme ich eventuell auf dich zurück ;)
     
  16. Spacefish, 19.01.2010 #16
    Spacefish

    Spacefish Android-Hilfe.de Mitglied

    Beiträge:
    83
    Erhaltene Danke:
    31
    Registriert seit:
    12.01.2010
    Phone:
    Motorola Milestone
    ich sags dir ungern, aber deine chancen stehen sehr schlecht, wenn du kein Zugriff mehr auf das NAND hast (keine Shell mehr aufbekommst). Du müsstest theoretisch über das FlashInterface des Bootloaders das OrginalNAND wiederherstellen und bist jetzt ist nix bekannt wie das geht, weder fürs DROID noch fürs Milestone (stichwort RSD-Lite)
     
  17. Compufreak, 19.01.2010 #17
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Naja, aber ich komme doch immerhin in's Recoverymenü und kann eine update.zip einspielen - meinst du, auf dem Wege wird es keine Möglichkeit geben?
     
  18. Archer, 19.01.2010 #18
    Archer

    Archer Android-Experte

    Beiträge:
    450
    Erhaltene Danke:
    81
    Registriert seit:
    17.07.2009
    hast du mal "adb install Gestures.apk" versucht, wenn das Telefon in der Bootschleife hängt?
     
    Compufreak bedankt sich.
  19. Compufreak, 19.01.2010 #19
    Compufreak

    Compufreak Threadstarter Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    59
    Registriert seit:
    11.07.2009
    Phone:
    Motorola Milestone
    Ja, habe ich... Nix da :(
     
  20. Archer, 19.01.2010 #20
    Archer

    Archer Android-Experte

    Beiträge:
    450
    Erhaltene Danke:
    81
    Registriert seit:
    17.07.2009
    Hattest du USB-Debugging vor der Tragödie an? Wenn ja, sagt "adb logcat" genau, was das Problem ist (damit du nicht so ganz im Blindflug bist)?
     

Diese Seite empfehlen