1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[Gelöst] USB-Port defekt?

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Defy" wurde erstellt von Richi901, 22.02.2012.

  1. Richi901, 22.02.2012 #1
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Hallo alle zusammen :)

    Als ich vor einigen Tagen mein Handy am Laptop laden wollte hat dies nicht geklappt (nutze Sonst immer die Steckdose), auch gestern am Desktop PC funktioniert es nicht. Doch davor hat es immer funktioniert.

    Mein Defy wird vom PC nicht mehr erkannt! Passende Treiber sind installiert und wurden extra erneuert. Der PC erkennt auch keine "unbekannte" Hardware oder ähnliches. Das Defy meldet sich nur kurz das die LED kurz weiß aufleuchtet mehr nicht.

    Laptop = Windows XP
    Desktop PC = Windows 7

    Mehrere Kabel wurden ausgetestet und zwei weiter Computer ebenfalls.

    Mein Defy läuft mit dem Cyanogen Mod 7

    Könnt ihr mir helfen?
     
  2. HENN0, 22.02.2012 #2
    HENN0

    HENN0 Android-Lexikon

    Beiträge:
    1,294
    Erhaltene Danke:
    422
    Registriert seit:
    01.02.2011
    Phone:
    OnePlus One
    Tablet:
    Nexus 10
    versetz es mal in den BOOTLOADER nicht recovery und guck mal obs erkannt wird wenn ja software wenn nein hardware dann ab zu DAT und hoffen das die es machen

    Wenns im bootloader geht:

    erst mal cache wipe
    wenns nicht hilft
    neue version drüber bügeln (maniacs nightly)
    wenn das auch nicht hilft
    Backup und full wipe
    wenn das auch nicht hilft
    komplett neu aufbauen! also mit RSD flashen wenn es denn im bootloader erkannt wird
     
  3. Richi901, 22.02.2012 #3
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Ja auch die Methode im Bootloader habe ich schon erkannt, keine Reaktion vom Computer.
    Wollte so per RSD Lite Frojo wieder drauf flashen. Ging aber leider nicht.

    Okay dann werde ich das Gerät mal einschicken... :/ hoffentlich klappt das :p
     
  4. HENN0, 22.02.2012 #4
    HENN0

    HENN0 Android-Lexikon

    Beiträge:
    1,294
    Erhaltene Danke:
    422
    Registriert seit:
    01.02.2011
    Phone:
    OnePlus One
    Tablet:
    Nexus 10
    dann mach wenigstens ein backup mit Frojo drauf sonst wird das nix mit der garantie
     
  5. RATTAR, 22.02.2012 #5
    RATTAR

    RATTAR Gast

    So man kein Backup von froyo hat, wird es etwas komplizierter. Dann bräuchste du ein Nandroid-Backup das du über Netzwerk-Debugging aus die SD-Karte schiebst oder du installierst den MyPhoneExplorer und schiebst damit das Nandroid-Backup von froyo auf die SD-Karte, danach gehst du ins ClockWorkModRecovery stellst das nandroid-Backup von froyo wieder her, setzt die Boot-Sequenz auf normal testest aus ob dein Handy durchbootet und deinstallierst CWM und ich weiß nicht ob Gingerbreak unrooten kann, wenn ja dann unrootest du und schickst dein Handy zur Reparatur.

    Habe dieses Verfahren noch nicht testen müssen, aber dürfte eigentlich funktionieren.

    EDIT @henno88:

    Weil die USB-Buchse defekt ist und nicht jeder einen Mcro-SD-Reader hat.
     
    Zuletzt von einem Moderator bearbeitet: 22.02.2012
    Richi901 bedankt sich.
  6. HENN0, 22.02.2012 #6
    HENN0

    HENN0 Android-Lexikon

    Beiträge:
    1,294
    Erhaltene Danke:
    422
    Registriert seit:
    01.02.2011
    Phone:
    OnePlus One
    Tablet:
    Nexus 10
    warum so umständlich???
    SD card an den PC backup hier laden auf die SD
    wieder ins handy und drüberspielen
    2ndinit löschen und gut
     
    Richi901 bedankt sich.
  7. Richi901, 23.02.2012 #7
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Meint ihr wirklich das wird nichts? Es handelt sich doch um einen Hardware defekt nicht um irgendwas Software seitiges.

    Derzeit habe ich nämlich das Problem das ich gar nichts drauf habe. Mein Cyanogenmod 7 startet gar nicht mehr weil ich versucht habe es erneut zu installieren.
    Folgender Fehler trat auf:
    Code:
    Can't mount /data!
    Also wollte ich Froyo wieder drauf flashen um dann wieder Cyanogenmod 7 drauf zu installieren. Doch leider funktioniert meine USB Schnittstelle nicht mehr :/

    Wenn ihr meint unbedingt für Gewährleistungs/Garantie Leistungsansprüche, Froyo drauf und unrooten, dann werde ich es versuchen. Also besorge ich mir die Tage einen microSD Card Reader. Könnt ihr mir kurz beschreiben wie ich dann vorgehe? Bzw. habt ihr ja schon aber woher komme ich an so ein Backup?
     
  8. HENN0, 23.02.2012 #8
    HENN0

    HENN0 Android-Lexikon

    Beiträge:
    1,294
    Erhaltene Danke:
    422
    Registriert seit:
    01.02.2011
    Phone:
    OnePlus One
    Tablet:
    Nexus 10
    DAT wird mit CM7 sagen es liegt an der Software du kannst das gegenteil nicht belegen also Pech gehabt.
    Zudem darf CM7 ja garnicht auf dem gerät sein damit verlierst du den ansprach auf Garantie
     
  9. Richi901, 24.02.2012 #9
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Okay danke, habe mir jetzt so einen micro SD auf SD Adapter geholt, wollte nun ein Nandroid Backup drauf laden und dann im ClockWorkModRecovery es wiederherstellen. So wie ihr es mir auch schon beschrieben habt.

    Blöderweise habe ich vorher kein Nandroid Backup von meinem Froyo gemacht. Ich suche schon die ganze Zeit im Forum ob hier jemand ein Backup bereitstellt finde aber leider keins. Könnt ihr mir da helfen?
     
  10. HENN0, 24.02.2012 #10
    HENN0

    HENN0 Android-Lexikon

    Beiträge:
    1,294
    Erhaltene Danke:
    422
    Registriert seit:
    01.02.2011
    Phone:
    OnePlus One
    Tablet:
    Nexus 10
    Richi901 bedankt sich.
  11. Richi901, 25.02.2012 #11
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Beim Restoren bekam ich eine Fehlermeldung:

    Code:
    Checking MD5 sums...
    Restoring system...
    Restoring data...
    Error mounting /data!
    Skipping format...
    Can´t mount /data!
    E:Can´t mount /cache/recovery/log
    E:Can´t open /cache/recovery/log
    E:Can´t mount /cache/recovery/last_log
    E:Can´t open /cache/recovery/last_log
    
    Übrigens kommt wenn ich den ClockworkMod Recovery starte auch folgende Meldung:
    Code:
    CWM-based Recoery v5.0.2.4
    E:Can´t mount /cache/recovery/command
    WARNING: This is the first Recovery v5
                   wich use TAR format to make backups !
    E:Can´t mount /cache/recovery/log
    E:Can´t open /cache/recovery/log
    E:Can´t mount /cache/recovery/last_log
     E:Can´t open /cache/recovery/last_log
    
    Okay... gerade habe ich es mal gebootet
    und nach dem Google Logo erscheint nun das rote animierte Motorola Logo :o

    Leute mein Handy Bootet!!! Ich bin gerade heilfroh das es das tut. Nun werde ich noch versuchen ClockWorkMod runterzuwerfen.

    1. Handy erneut Rooten
    2. damit ich den ClockWorkMod runterwerfen kann
    3. nach der ClockWorkMod deinstallation das Handy wieder unrooten
    4. Fertig ist mein Defy in Werkseinstellungen?!
    Ist das die richtige Vorgehensweise? Oder sollte ich mich an folgende Anleitung halten: ClockWorkMod Recovery Defy (Nandroid)

    Da steht unter anderem:
     
  12. RATTAR, 25.02.2012 #12
    RATTAR

    RATTAR Gast

    Im Prinzip dürfte es reichen wenn du aufrufst und auf Uninstall 2ndInit Recovery gehst. Falls dein Handy nach erfolgreichem entfernen von CWM nicht mehr durchbootet, stört es ja nicht bei der Reparaturfirma wird sowieso eine Neu-Installation vorgenommen.

    Der Nachweis des inoffiziellen BS ist meistens zu aufwendig und wird von der Firma in der Regel nicht geführt wenn etwas einigermaßen offizielles drauf ist.

    EDIT:
    Ich habe eben Defy2ndinit deinstalliert , wie ich vermutet habe bootet das Handy dann nicht mehr hoch (naja muss ich neu flashen und installieren:cursing::cool2::biggrin:), jetzt machst du noch einen Stock-ROM FactoryReset und schickst es so zur Reparatur.

    Das wichtigste war ja, das CM7 und das ClockWorkModRecovery runterzubekommen. Die einzige Möglichkeit wieder Zugriff auf das Handy zu bekommen, ist ein Flash via USB. Was aber nicht geht da die USB-Buchse defekt ist.

    Ja, wenn das Logo rot ist ist es normal, wie ichschon schrieb Zugriff auf den Inhalt des Handys ist jetzt nur noch durch erneutes Flashen möglich, bzw. in deinem Fall unmöglich da das Flashen nur USB geht. Wo kein USB, da kein Flashen. Es muss erst eine neue USB-Buchse bzw. Hauptplatine verbaut werden um wieder Zugriff zu erlangen und auch dann geht das nur durch Flashen.
     
    Zuletzt von einem Moderator bearbeitet: 25.02.2012
  13. Richi901, 25.02.2012 #13
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Aber brauche ich denn keine Rootrechte auf meinem Handy um CWM zu entfernen? Also Defy2ndinit benötigt doch Rootrechte um CWM zu deinstallieren? Oder bin ich da falsch informiert?

    Edit: Hab jetzt noch kein Root freigeschaltet und Defy2ndinit sagt mir "2ndInit Recovery NOT currently installed"

    Edit2: Aber clockworkmod ist doch noch gar nicht runter da beim starten des Handys kurz das Logo erscheint. Okay warte die LED leuchtet gar nicht blau? Ist das google Logo also normal?

    Edit3: Ich hab mal eben nach dem Logo gegoogelt. Hier genau das Logo meine ich. Das ist doch nicht original?
    http://img1.imagebanana.com/img/nl6617jb/DSCN1537_crop.JPG
    Und nach dem Logo kommt das bekannte Rote Motorola Logo...
    Außerdem weiß ich nicht genau was du mit "Stock-ROM FactoryReset" meinst? Etwa wenn ich das Handy mit gedrückt halten der Vol - Taste einschalte und dann Vol- und Vol+ gleichzeitig drücke?
     
    Zuletzt bearbeitet: 25.02.2012
  14. RATTAR, 25.02.2012 #14
    RATTAR

    RATTAR Gast

    Fährt dein Handy noch hoch? Wenn ja, musst du mit Gingerbreak nochmals rooten, die Splashtools installieren (http://www.android-hilfe.de/themes-...tlogo-bootanimation-erstellen-einspielen.html und das originale rote motorola-Logo) wieder einbauen. Erst danach solltest du einen FactoryReset machen wie im Thread http://www.android-hilfe.de/anleitu...pen-zuruecksetzen-hardreset-eclair-froyo.html beschrieben.

    Anbei das Logo in rot. Logo auf die SD-Karte packen, Splashtools aufrufen, das Logo einspielen.
     

    Anhänge:

    Zuletzt von einem Moderator bearbeitet: 25.02.2012
    Richi901 bedankt sich.
  15. Richi901, 26.02.2012 #15
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Wow danke für die detailierte Anleitung :)

    Ja das Handy bootet ja Froyo, alles wie damals. Eigentlich so wie es sein soll. Nur der Splashscreen am Anfang von Google stört halt.

    Ich werde es heute Abend, spätestens morgen sofort testen :)

    Stay tuned ;)
     
  16. Richi901, 28.02.2012 #16
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    So Update. Habe nun alles erledigt. Und siehe das es scheint zu funktionieren. Als erstes erscheint nun das rote Motorola Logo und nicht das Google Logo von CyanogenMod7. Und danach wie gehabt das animierte rote Motorola Logo.
    Das Handy ist jetzt nicht mehr gerootet und dank des Hardresets ist es nun auch von allen Datenmüll befreit.

    Zeit es bei DatRepair einzuschicken.

    Danke nochmal für die Hilfe von euch beiden. Super Forum hier :)

    Gruß Richi

    Edit: Arrg... nach dem Hardreset, befindet sich noch immer die SuperUser App hier drinnen. Naja wird sie halt nochmals von Hand entfernt ;) okay lässt sich nicht deinstallieren. Meint ihr egal und weg damit oder sollte ich mich darum auch noch kümmern?
     
    Zuletzt bearbeitet: 28.02.2012
  17. Richi901, 12.03.2012 #17
    Richi901

    Richi901 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    1
    Registriert seit:
    21.02.2012
    Nur mal ein kurzes Update falls jemand ähnliche Probleme haben sollte.

    Ich hatte nun wieder ein cleanes Froyo auf dem Handy. Leider lies sich die "Superuser" App nicht entfernen.
    Per "Z4root" (siehe xda developers) habe ich das Ende noch einmal geunrootet. Und Laut dieser App ist auch kein root mehr drauf.

    Nichts desto trotz habe ich das Handy eingeschickt. Nach einer schnellen Bearbeitung von DatRepair bekam ich das Defy wieder. Anbei stand im Schreiben das kein defekt festgestellt werden konnte und das man mein USB Kabel nicht testen konnten weil es nicht beilag. Man aber aber trotzdem ein komplettes Software Update gemacht.

    Ich war anfangs etwas gefrustet. Als ich das Handy dann aber einfach gut glück so wie ich es wieder bekommen habe am PC anschloss, funktioniert es der USB Port genau so wie er sollte!

    Also ziehe ich eine positive Bilianz raus, Fehler behoben :razz:

    Danke nochmal an RATTAR und henno88 für eure Hilfe :thumbup:
     
    HENN0 bedankt sich.
  18. o_Honk, 12.03.2012 #18
    o_Honk

    o_Honk Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    1
    Registriert seit:
    04.03.2011
    Hi

    habe das selbe Problem...meins kann ich jedoch leider nicht mehr einschicken.
    Hat dein Defy das USB-Kabel akzeptiert nachdem du dir Froyo geflasht hast? oder nicht getestet?

    Gruß
     
  19. RATTAR, 12.03.2012 #19
    RATTAR

    RATTAR Gast

    Wieso willst du es nicht einschicken?
    Das einzige was passieren kann ist das Reparatur kostenpflichtig ist. Dein Handy sollte vor dem Einschicken halt möglichst froyo haben und die offensichtlichen Anzeichen des ClockWorkModRecoverys sollten nicht erkennbar sein.
    Wenn der USB-Teil deines Handys defekt ist, wird auch der Reparateur keinen Zugriff auf das BS finden können, das heißt die Hauptplatine wird getauscht.

    EDIT:
    Ich schätze mal die Reparatur wird so zwischen 120 und 150 € kosten, du kannst ja mal deswegen unverbindlich bei Anna von dat_repair per PN nachfragen ob sich eine Reparatur noch lohnt.
     
    Zuletzt von einem Moderator bearbeitet: 13.03.2012
  20. o_Honk, 13.03.2012 #20
    o_Honk

    o_Honk Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    1
    Registriert seit:
    04.03.2011
    Es ist ein zerstörtes Froyo drauf cwm müsste gelöscht schein (dadurch Bootfehler). Das Problem ist, dass ich bereits auf der Platine gelötet habe und der Klebestreifen vor der USB-Buchse die Temperatur nicht vertragen hat. Ich habe mir bereits ein anderes Handy bestellt, möchte aber trotzdem beim Defy nicht aufgeben.

    Scheiße so habe ich es garnicht betrachtet....
     

Diese Seite empfehlen