Probleme mit SmartLock

F

fichte_112

Fortgeschrittenes Mitglied
cad schrieb:
@Lemmi Ist jetzt eigentlich offtopic, aber kurz:
- Man installiere sich am PC [TOOL]Minimal ADB and Fastboot [2-9-18].
- Im Phone USB-Debugging aktvieren und per USB anschließen (bei WIndows 10 sind keine Treiber nötig fürs S8)
- Das o.g. Programm starten und "adb devices" eingeben, man sieht die erkannten Geräte danach.
- Dann nacheinander die in SecureTask in der Hilfe genannten adb-Befehle ins Fenster kopieren und jeweils bestätigen
- Nach Trennen des Phones vom PC kann USB-Debugging wieder deaktiviert werden
- Beim gewünschten Task in Tasker dann "Plugin" wählen > SecureTask > Secure Settings. In "Konfiguration" dann "Write" (statt "Read") wählen und dann über die Lupe den Befehl "Lock screen lock after timeout" wählen. Dann kannst du die gewünschte Zeit in Millisekunden (!) angeben.

Wenn ich nach Hause komme und in mein WLAN, wird die Zeit auf 4 Stunden gesetzt. Liegt das S8 tatsächlich mal länger als 4 Stunden ohne Nutzung rum, muss ich halt entsperren. Wenn ich mein WLAN verlasse, wird auf 30 Sekunden gestellt.
Kann man die Zeit auch auf mehr als 4 Stunden einstellen?
 
cad

cad

Guru
@fichte_112 Prinzipiell kannst du da erst mal eingeben, was du willst (in Millisekunden). Ob es da eine Grenze gibt, weiß ich nicht.

Hab auch noch nicht genau getestet, ob alles nach 3 h 59 min noch entsperrt ist. In der Praxis schaue ich in 4 Stunden immer mal aufs Phone. Länger halte ich es nicht aus ;)

Und nachts im Flugmodus (keine WLAN-Verbindung mehr) stellt sich die Zeit wieder auf gewünschte 30 Sekunden zurück.
 
Merlina42

Merlina42

Neues Mitglied
Merlina42 schrieb:
Hi,
ich habe auch grade Probleme mit dem SmartLock. Ich habe seit Samstag das Huawei p20 pro, Sonntag funktionierte noch Alles, seit Heute ist der Bildschirm nur weiß. Es gibt nichts, was man anklicken könnte. War das ein Update, was alles zerstört hat? Oder habe ich vielleicht aus Versehen etwas verstellt? Ich habe erst mal alle Aktionen rückgängig gemacht, die mir einfielen, den Cache gelöscht und neu gestartet. Hilft leider alles nicht. Danke im Voraus.

Lg Katja
Ich habe die Antwort selbst gefunden. Beim Huawei P20 pro geht man folgenden Weg:

Sicherheit & Datenschutz - > Mehr - > Trustet Agents

Diesen Dienst stellt man ab, startet das Handy neu und stellt den Dienst wieder an. Fertig.
 
M

McVision

Erfahrenes Mitglied
Seit dem Wechsel zu Oreo wird bei mir nun auch brav angezeigt , das das Telefon durch Smart-Lock entsperrt wurde. Und endlich funktioniert das ganze auch nach 24 Stunden immer noch perfekt ohne Neustart :)
Ihr glaubt gar nicht was für eine Erleichterung das ist, wenn man im Auto sitzt und muss nicht mehr extra entsperren nur um mal schnell ne Email oder Threema zu beantworten ! (ja ich fahre vorher rechts ran!!)
 
maik005

maik005

Urgestein
Muss es zurücknehmen.
Ging heute den ganzen Tag nicht mehr.
Erst eben nach einem Neustart und anschließender Ortung des Gerätes über Google Maps geht es aktuell wieder ..
 
cad

cad

Guru
Ich zitiere mich mal selbst:
cad schrieb:
@Lemmi Ist jetzt eigentlich offtopic, aber kurz:
- Man installiere sich am PC [TOOL]Minimal ADB and Fastboot [2-9-18].
- Im Phone USB-Debugging aktvieren und per USB anschließen (bei WIndows 10 sind keine Treiber nötig fürs S8)
- Das o.g. Programm starten und "adb devices" eingeben, man sieht die erkannten Geräte danach.
- Dann nacheinander die in SecureTask in der Hilfe genannten adb-Befehle ins Fenster kopieren und jeweils bestätigen
- Nach Trennen des Phones vom PC kann USB-Debugging wieder deaktiviert werden. Gerät besser neu starten)
- Beim gewünschten Task in Tasker dann "Plugin" wählen > SecureTask > Secure Settings. In "Konfiguration" dann "Write" (statt "Read") wählen und dann über die Lupe den Befehl "Lock screen lock after timeout" wählen. Dann kannst du die gewünschte Zeit in Millisekunden (!) angeben.

Wenn ich nach Hause komme und in mein WLAN, wird die Zeit auf 4 Stunden gesetzt. Liegt das S8 tatsächlich mal länger als 4 Stunden ohne Nutzung rum, muss ich halt entsperren. Wenn ich mein WLAN verlasse, wird auf 30 Sekunden gestellt.
Inzwischen kann das Tasker alleine (Punkt "Custom Settings"). Man benötigt also kein zusätzliches Plugin mehr. Klappt zuverlässig.
 
R

Rio Grande

Stammgast
Habe erst seit zwei Tagen eine Bildschirm Sperre aktiviert da sonst Google Pay nicht funktioniert und Smart Lock funktioniert bei mir an allen vertrauenswürdigen Orten einwandfrei. (S8+)
 
maik005

maik005

Urgestein
@Rio Grande
du wechselst den Ort regelmäßig?
Wie oft startest du das S8 neu bzw schaltest es komplett aus?
Welche Version der Google Play Dienste?
 
R

Rio Grande

Stammgast
Google Play Dienste 12.6.85
Ich wechsle den Ort sehr oft und mache einmal in der Woche einen Neustart.
An keinem der vertrauenswürdigen Orte musste ich bisher mit Fingerprint entsperren.
Im Auto wird durch Bluetooth entsperrt, beim tragen in der Hosentasche wird auch entsperrt.
Besser könnte es nicht funktionieren.
 
Zuletzt bearbeitet:
Skipper_pb

Skipper_pb

Neues Mitglied
Mit dem folgenden Vorgehen funktioniert Smart Lock wieder:
- in "Trusted Agents" "Smart Lock" ausschalten
- das Smartphone neu starten
- in "Trusted Agents" "Smart Lock" wieder aktivieren
- zu "Smart Unlock" gehen, das Bildschirmsperrpasswort eingeben und siehe da, die Auswahl für "Smart Lock" ist wieder da!
Gruss Skipper
 
maik005

maik005

Urgestein
@Skipper_pb
die Auswahl ist doch schon lange wieder da und war nur kurzzeitig bei einer Version der Google Play Dienste weg!?

PS:
Smartlock funktioniert bei mir wie es will... mal gehts plötzlich, dann wieder nicht.
Ich stelle auch nichts mehr um. Das Gerät läuft seit über 200 Stunden.
 
R

Rio Grande

Stammgast
Ich kann mittlerweile bestätigen dass Smartlock so gut wie unbrauchbar ist.
Mal funktioniert es, mal nicht.
Wer kann mir erklären warum die Profis das Problem nicht lösen können?
 
M

Mortarion

Neues Mitglied
Hallo, ich habe folgendes Problem, vllt könnt ihr mir hier ja helfen:

Ich besitze ein Galaxy A3 2017, meine Frau ein J5 2016. Wir, sprich ich, meine Frau und die Kinder benutzen alle zusammen ein gemeinsames Google Konto.
Als ich während unseres Urlaubs Zuhause war bekam ich bei meinem Telefon die Meldung "Du entsperrst deine Telefon oft Zuhause, möchtest zu diesen Ort zu einem Vertrauenswürdigen Ort machen" oder so in der Art. Das habe ich getan und fand das recht angenehm, jetzt hat meine Frau diesen Vorschlag auch bekommen, sie hat das bei sich eingerichtet.

Der Haken an der Sache ist nun aber das ich jetzt mein Gerät wieder entsperren muss. Ab und an ist es aber so, das es auch wieder funktioniert, aber nur solange bis meine Frau unterwegs ist und den Bereich verlässt.

Was kann ich tun, das bei meinem und dem Gerät meiner Frau die Entsperrung über den Standort Zuhause funktioniert?
Liegt das an Android? Oder an Smartlock? Oder am Standortdienst?
 
maik005

maik005

Urgestein
@Mortarion
Du musst vermutlich per hand den Standort "zu Hause" zusätzlich bei dir und deiner Frau einrichten.

Einstellungen- Gerätesicherheit - SmartLock - vertrauenswürdige Orte.

Da einen neuen hinzufügen über GPS.
Sollte dann so aussehen.
 

Anhänge

M

Mortarion

Neues Mitglied
sprich ich soll zwei standorte anlegen ?
einen für mich, einer für meine frau?
 
maik005

maik005

Urgestein
@Mortarion
Korrekt. Jeweils auf dem entsprechenden Gerät.
 
M

Mortarion

Neues Mitglied
müssen/solten die standorte auch unterschiedlich benannt werden? also einmal home einmal zuhause.?

wie lange dauert es, bis das dann greifen sollte?

achja, kann es sein das die funktion "Mit Ein/Aus sofort sperren" da auch probleme macht?
auch wenn da steht das es keine einfluss auf smart lock hat...
 
maik005

maik005

Urgestein
@Mortarion
Solle sofort gehen.
Nein, sofort sperren hat darauf keinen Einfluss.
 
M

Mortarion

Neues Mitglied
ok, dann verusche ich das später nochmal, danke für deine zeit,

ich gebe feedback sobald ich kann
 
Oben Unten