Per Datenstick mit dem Androiden ins Internet

  • 268 Antworten
  • Neuester Beitrag
Diskutiere Per Datenstick mit dem Androiden ins Internet im Asus Eee Pad Transformer Prime TF201 Forum im Bereich Weitere Asus Geräte.
Z

zwergenkoenig01

Ambitioniertes Mitglied
Hallo j__k, vielen Dank für Deine Geduld!

bisher habe ich immer folgenden Ablauf gemacht: Stick angesteckt und die app aufgerufen. und da liegt der Hase wohl im Pfefffer: es kommt kein Text.

Ich werde morgen mal Deinen vorgeschlagenen "zweiten" Weg, also erst Stick, dann app aufrufen und schauen, ob ich terminal usw. aufrufen kann.

Nochmals vielen Dank für Deine Mühe.
 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Neuer Versuch:

Stick angesteckt, app aufgerufen - und dann passier nichts. Im unteren Teil der app erscheint kein Text.

Variante 2: erst app aufrufen, dann Stick einstecken: bringt auch keinen Text, den ich Dir mailen könnte.

Muss ich evtl. in den "Entwickleroptionen" den Haken bei "USB-Debugging" entfernen oder hört sich das nach einem Fehler beim Stick an? Am Notebook funktioniert er einwandfrei. (Aber ich kann mir vorstellen, dass hier technisch ein anderer Ablauf ist).
 
J

j__k

Fortgeschrittenes Mitglied
zwergenkoenig01 schrieb:
Neuer Versuch:

Stick angesteckt, app aufgerufen - und dann passier nichts. Im unteren Teil der app erscheint kein Text.

Variante 2: erst app aufrufen, dann Stick einstecken: bringt auch keinen Text, den ich Dir mailen könnte.

Muss ich evtl. in den "Entwickleroptionen" den Haken bei "USB-Debugging" entfernen oder hört sich das nach einem Fehler beim Stick an? Am Notebook funktioniert er einwandfrei. (Aber ich kann mir vorstellen, dass hier technisch ein anderer Ablauf ist).
Ne hat nichts mit den Entwickleroptionen zu tun.

Installier dir mal das Terminal ( im playstore suchen)
Stick anstecken und tipp im Terminal:

dmesg | grep usb

ein und mach nen screenshot

Gesendet von meinem Transformer Prime TF201 mit Tapatalk 2
 
K

Kedge

Ambitioniertes Mitglied
Du hast das "|" in dem Commando vergessen. Deswegen ist es etwas lang geworden :winki:.

Also: 'dmesg | grep usb'. Dann wirds übersichtlicher.
 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Mann oh Mann, das war 'ne schwere Geburt. Hier nun also die "Kurzversion"

app_105@android:/ $ export PATH=/data/local/bin:$PATH
app_105@android:/ $ dmesg | grep usb
<5>[ 2505.613424] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<4>[ 2507.035000] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2514.318287] tegra_usb_suspend+
<6>[ 2514.318881] tegra_usb_suspend: before ehci_halt
<6>[ 2514.319416] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2514.319798] tegra_usb_suspend-
<6>[ 2514.598382] tegra_usb_resume+
<6>[ 2514.606072] tegra_usb_resume-
<5>[ 2514.773946] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<6>[ 2514.844964] usb 1-1: USB disconnect, device number 35
<6>[ 2514.845379] usb 1-1.3: USB disconnect, device number 36
<6>[ 2515.092518] usb 1-1: new high speed USB device number 37 using tegra-ehci
<6>[ 2515.131788] usb 1-1: New USB device found, idVendor=05e3, idProduct=0610
<6>[ 2515.132602] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6>[ 2515.133159] usb 1-1: Product: USB2.0 Hub
<6>[ 2515.222735] usb3_ehci_dock_in_work_handler: usb resume root hub
<6>[ 2515.453064] usb 1-1.3: new high speed USB device number 38 using tegra-ehci
<6>[ 2515.489511] usb 1-1.3: New USB device found, idVendor=058f, idProduct=6366
<6>[ 2515.490092] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 2515.490647] usb 1-1.3: Product: Mass Storage Device
<6>[ 2515.490949] usb 1-1.3: Manufacturer: Generic
<6>[ 2515.491248] usb 1-1.3: SerialNumber: 058F63666433
<6>[ 2515.522277] scsi19 : usb-storage 1-1.3:1.0
<4>[ 2515.526660] usb-storage 1-1.3:1.0 wake_lock_init +
<4>[ 2517.358406] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2534.712270] tegra_usb_suspend+
<6>[ 2534.713132] tegra_usb_suspend: before ehci_halt
<6>[ 2534.713432] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2534.714065] tegra_usb_suspend-
<6>[ 2534.865854] tegra_usb_resume+
<6>[ 2534.873150] tegra_usb_resume-
<5>[ 2535.041968] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<6>[ 2535.109216] usb 1-1: USB disconnect, device number 37
<6>[ 2535.109653] usb 1-1.3: USB disconnect, device number 38
<6>[ 2535.446638] usb 1-1: new high speed USB device number 39 using tegra-ehci
<6>[ 2535.479713] usb 1-1: New USB device found, idVendor=05e3, idProduct=0610
<6>[ 2535.480052] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6>[ 2535.480615] usb 1-1: Product: USB2.0 Hub
<6>[ 2535.486602] usb3_ehci_dock_in_work_handler: usb resume root hub
<6>[ 2535.777275] usb 1-1.3: new high speed USB device number 40 using tegra-ehci
<6>[ 2535.809686] usb 1-1.3: New USB device found, idVendor=058f, idProduct=6366
<6>[ 2535.810056] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 2535.810620] usb 1-1.3: Product: Mass Storage Device
<6>[ 2535.810922] usb 1-1.3: Manufacturer: Generic
<6>[ 2535.811478] usb 1-1.3: SerialNumber: 058F63666433
<6>[ 2535.827317] scsi20 : usb-storage 1-1.3:1.0
<4>[ 2535.831978] usb-storage 1-1.3:1.0 wake_lock_init +
<6>[ 2537.653681] wake_unlock: usb-storage 1-1.3:1.0, start expire timer, 7931
<4>[ 2537.654247] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2546.346577] tegra_usb_suspend+
<6>[ 2546.347424] tegra_usb_suspend: before ehci_halt
<6>[ 2546.347719] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2546.348325] tegra_usb_suspend-
<6>[ 2546.499340] tegra_usb_resume+
<6>[ 2546.506563] tegra_usb_resume-
<5>[ 2546.678341] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<6>[ 2546.743317] usb 1-1: USB disconnect, device number 39
<6>[ 2546.743749] usb 1-1.3: USB disconnect, device number 40
<6>[ 2547.031205] usb 1-1: new high speed USB device number 41 using tegra-ehci
<6>[ 2547.066034] usb 1-1: New USB device found, idVendor=05e3, idProduct=0610
<6>[ 2547.066635] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6>[ 2547.066947] usb 1-1: Product: USB2.0 Hub
<6>[ 2547.122021] usb3_ehci_dock_in_work_handler: usb resume root hub
<6>[ 2547.361723] usb 1-1.3: new high speed USB device number 42 using tegra-ehci
<6>[ 2547.393911] usb 1-1.3: New USB device found, idVendor=058f, idProduct=6366
<6>[ 2547.394514] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 2547.394822] usb 1-1.3: Product: Mass Storage Device
<6>[ 2547.395359] usb 1-1.3: Manufacturer: Generic
<6>[ 2547.395657] usb 1-1.3: SerialNumber: 058F63666433
<6>[ 2547.413251] scsi21 : usb-storage 1-1.3:1.0
<4>[ 2547.419439] usb-storage 1-1.3:1.0 wake_lock_init +
<6>[ 2549.238251] wake_unlock: usb-storage 1-1.3:1.0, start expire timer, 7931
<4>[ 2549.238826] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2549.680765] tegra_usb_suspend+
<6>[ 2549.681368] tegra_usb_suspend: before ehci_halt
<6>[ 2549.681915] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2549.682287] tegra_usb_suspend-
<6>[ 2549.961345] tegra_usb_resume+
<6>[ 2549.968596] tegra_usb_resume-
<6>[ 2550.207469] usb 1-1: USB disconnect, device number 41
<6>[ 2550.207898] usb 1-1.3: USB disconnect, device number 42
<6>[ 2550.384845] usb 1-1: new high speed USB device number 43 using tegra-ehci
<6>[ 2550.418680] usb 1-1: New USB device found, idVendor=05e3, idProduct=0610
<6>[ 2550.419164] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6>[ 2550.419425] usb 1-1: Product: USB2.0 Hub
<6>[ 2550.584879] usb3_ehci_dock_in_work_handler: usb resume root hub
<6>[ 2550.715741] usb 1-1.3: new high speed USB device number 44 using tegra-ehci
<6>[ 2550.765281] usb 1-1.3: New USB device found, idVendor=058f, idProduct=6366
<6>[ 2550.765881] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 2550.766185] usb 1-1.3: Product: Mass Storage Device
<6>[ 2550.766738] usb 1-1.3: Manufacturer: Generic
<6>[ 2550.767036] usb 1-1.3: SerialNumber: 058F63666433
<6>[ 2550.785148] scsi22 : usb-storage 1-1.3:1.0
<4>[ 2550.791809] usb-storage 1-1.3:1.0 wake_lock_init +
<5>[ 2551.178695] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<4>[ 2552.612203] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2560.744905] tegra_usb_suspend+
<6>[ 2560.745500] tegra_usb_suspend: before ehci_halt
<6>[ 2560.746038] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2560.746410] tegra_usb_suspend-
<6>[ 2560.897756] tegra_usb_resume+
<6>[ 2560.904820] tegra_usb_resume-
<5>[ 2561.076797] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<6>[ 2561.141526] usb 1-1: USB disconnect, device number 43
<6>[ 2561.141953] usb 1-1.3: USB disconnect, device number 44
<6>[ 2561.369006] usb 1-1: new high speed USB device number 45 using tegra-ehci
<6>[ 2561.404398] usb 1-1: New USB device found, idVendor=05e3, idProduct=0610
<6>[ 2561.404749] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6>[ 2561.405318] usb 1-1: Product: USB2.0 Hub
<6>[ 2561.518934] usb3_ehci_dock_in_work_handler: usb resume root hub
<6>[ 2561.699862] usb 1-1.3: new high speed USB device number 46 using tegra-ehci
<6>[ 2561.732158] usb 1-1.3: New USB device found, idVendor=058f, idProduct=6366
<6>[ 2561.732757] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 2561.733062] usb 1-1.3: Product: Mass Storage Device
<6>[ 2561.733594] usb 1-1.3: Manufacturer: Generic
<6>[ 2561.733900] usb 1-1.3: SerialNumber: 058F63666433
<6>[ 2561.776151] scsi23 : usb-storage 1-1.3:1.0
<4>[ 2561.781090] usb-storage 1-1.3:1.0 wake_lock_init +
<4>[ 2563.605790] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2569.988883] tegra_usb_suspend+
<6>[ 2569.989732] tegra_usb_suspend: before ehci_halt
<6>[ 2569.990034] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2569.990640] tegra_usb_suspend-
<6>[ 2570.269070] tegra_usb_resume+
<6>[ 2570.276579] tegra_usb_resume-
<6>[ 2576.642982] tegra_usb_suspend+
<6>[ 2576.643578] tegra_usb_suspend: before ehci_halt
<6>[ 2576.644115] tegra_usb_suspend: after ehci_halt, ret = 0
<6>[ 2576.644498] tegra_usb_suspend-
<6>[ 2576.921848] tegra_usb_resume+
<6>[ 2576.929758] tegra_usb_resume-
<6>[ 2577.169439] usb 1-1: USB disconnect, device number 45
<6>[ 2577.170062] usb 1-1.3: USB disconnect, device number 46
<6>[ 2577.466845] usb 1-1: new high speed USB device number 47 using tegra-ehci
<6>[ 2577.503881] usb 1-1: New USB device found, idVendor=05e3, idProduct=0610
<6>[ 2577.504046] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6>[ 2577.504201] usb 1-1: Product: USB2.0 Hub
<6>[ 2577.807408] usb 1-1.3: new high speed USB device number 48 using tegra-ehci
<6>[ 2577.838785] usb 1-1.3: New USB device found, idVendor=058f, idProduct=6366
<6>[ 2577.838882] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 2577.839035] usb 1-1.3: Product: Mass Storage Device
<6>[ 2577.839120] usb 1-1.3: Manufacturer: Generic
<6>[ 2577.839276] usb 1-1.3: SerialNumber: 058F63666433
<6>[ 2577.842060] scsi24 : usb-storage 1-1.3:1.0
<4>[ 2577.846731] usb-storage 1-1.3:1.0 wake_lock_init +
<5>[ 2577.918530] asusdec: [asusdec_chip_init] EC-FW Behavior: susb on when receive ec_req
<6>[ 2578.056784] usb3_ehci_dock_in_work_handler: usb resume root hub
<4>[ 2579.662385] usb-storage 1-1.3:1.0 wake_lock_destroy -
<6>[ 2597.767530] usb 1-1.2: new high speed USB device number 49 using tegra-ehci
<6>[ 2597.799795] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=1446
<6>[ 2597.799990] usb 1-1.2: New USB device strings: Mfr=3, Product=2, SerialNumber=0
<6>[ 2597.800237] usb 1-1.2: Product: HUAWEI Mobile
<6>[ 2597.800368] usb 1-1.2: Manufacturer: HUAWEI Technology
<6>[ 2597.810076] scsi25 : usb-storage 1-1.2:1.0
<4>[ 2597.811708] usb-storage 1-1.2:1.0 wake_lock_init +
<4>[ 2598.835093] usb-storage 1-1.2:1.0 wake_lock_destroy -
app_105@android:/ $


Ich hab keinen blassen Schimmer, sehe zwar den Huawei-Stick, aber nix, was irgendwie mit "Modem" zu tun hat......
 
Butzelmann

Butzelmann

Erfahrenes Mitglied
@Zwergenkönig
nix für ungut, aber besorg dir doch einfach einen E160-Stick für €12.95,- spart enorm Zeit & Nerven ! :winki:
 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Danke für den Tip, Butzelmann. Wenn ich hier des Rätsels Lösung nicht finde,
dann werde ich den E 160 ordern. Ich dachte bisher, er wäre baugleich mit meinem Stick von Bildmobil. Aber das scheint wohl nicht so zu sein.
 
J

j__k

Fortgeschrittenes Mitglied
zwergenkoenig01 schrieb:
Mann oh Mann, das war 'ne schwere Geburt. Hier nun also die "Kurzversion"
Dies wäre die Kurzversion:

<6>[ 2597.767530] usb 1-1.2: new high speed USB device number 49 using tegra-ehci
<6>[ 2597.799795] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=1446
<6>[ 2597.799990] usb 1-1.2: New USB device strings: Mfr=3, Product=2, SerialNumber=0
<6>[ 2597.800237] usb 1-1.2: Product: HUAWEI Mobile
<6>[ 2597.800368] usb 1-1.2: Manufacturer: HUAWEI Technology
<6>[ 2597.810076] scsi25 : usb-storage 1-1.2:1.0


Und nun wäre das ganze nochmal interesannt wie das aussieht nachdem meine app gestartet wurde. 12d1:1446 hab ich im modeswitch mit drin, sollte also ausgeführt werden.
 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Mit gestarteter app sieht das so aus:

<3>[ 8.620893] android_usb: already disabled
<6>[ 67.786665] usb 1-1.2: new high speed USB device number 4 using tegra-ehci
<6>[ 67.825237] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=1446
<6>[ 67.825494] usb 1-1.2: New USB device strings: Mfr=3, Product=2, SerialNumber=0
<6>[ 67.826313] usb 1-1.2: Product: HUAWEI Mobile
<6>[ 67.826960] usb 1-1.2: Manufacturer: HUAWEI Technology
<6>[ 67.838343] scsi1 : usb-storage 1-1.2:1.0
<4>[ 67.841728] usb-storage 1-1.2:1.0 wake_lock_init +
<4>[ 68.873136] usb-storage 1-1.2:1.0 wake_lock_destroy -
app_105@android:/ $
 
J

j__k

Fortgeschrittenes Mitglied
OK jetzt musst du mal schauen ob es die Datei: modeswitch.conf
angelegt hat. Und zwar im Verzeichnis : /data/data/umts.manager.jk/

Dazu brauchst du aber zwingend Root rechte!
also entweder mit dem Root Explorer nachschauen oder wenn du den nicht besitzt dann starte das Terminal und tipp folgendes ein:

su <return>
ls -l /data/data/umts.manager.jk/ <return>

wenn die Datei modeswitch.conf existiert dann:

cat /data/data/umts.manager.jk/modeswitch.conf

dann mach mal nen screenshot und es sollte etwa so aussehen:

 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Den Root-Explorer hab ich leider nicht, deshalb den zweiten Weg genommen, erhalte aber folgende Ausgabe:

app_105@android:/ $ export PATH=/data/local/bin:$PATH
app_105@android:/ $ su
# ls -| /data/data/umts.manager.jk/
sh: /data/data/umts.manager.jk/: cannot execute - Is a directory
#


Hab ich da etwas falsch eingegeben?

Falls ich langsam nerve, dann vergiss den ganzen Klumpatsch. Ich bin gerne bereit 14,oo € in einen E 160 zu investieren und mein Glück noch einmal damit zu versuchen. Vorerst ein herzliches Danke für Deine Hilfe!!!
 
J

j__k

Fortgeschrittenes Mitglied
zwergenkoenig01 schrieb:
Den Root-Explorer hab ich leider nicht, deshalb den zweiten Weg genommen, erhalte aber folgende Ausgabe:

app_105@android:/ $ export PATH=/data/local/bin:$PATH
app_105@android:/ $ su
# ls -| /data/data/umts.manager.jk/
sh: /data/data/umts.manager.jk/: cannot execute - Is a directory
#


Hab ich da etwas falsch eingegeben?

Falls ich langsam nerve, dann vergiss den ganzen Klumpatsch. Ich bin gerne bereit 14,oo € in einen E 160 zu investieren und mein Glück noch einmal damit zu versuchen. Vorerst ein herzliches Danke für Deine Hilfe!!!
Nein ist ja für mich auch interesannt welcher Stick denn nu wirklich funktioniert.
ls -l <-- der kleine Buchstabe L ( das l steht für ausführliche info)

Gesendet von meinem Transformer Prime TF201 mit Tapatalk 2
 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Hallo, nun noch mal mit dem kleinen "L" probiert und folgendes Ergebnis erhalten:

app_105@android:/ $ export PATH=/data/local/bin:$PATH
app_105@android:/ $ su
# ls -l /data/data/umts.manager.jk/
drwxrwx--x app_102 app_102 2012-04-20 11:36 cache
drwxr-xr-x system system 2012-04-20 11:36 lib
drwxrwx--x app_102 app_102 2012-05-09 10:33 shared_prefs
#

Die Datei modeswitch ist also nicht in Sicht:angry:
 
J

j__k

Fortgeschrittenes Mitglied
hmm hast du manchmal ne uralte version hier aus dem forum installiert?
Wenn ja dann geh in den Playstore und installiere von da ( vorher alte version deinstallieren)

Gesendet von meinem Transformer Prime TF201 mit Tapatalk 2
 
Z

zwergenkoenig01

Ambitioniertes Mitglied
Yes, Sir,

genau das war es! Ich Dussel hatte noch eine alte Version installiert. Also Alt raus -Neu installiert, und nach ca. 10 Sekunden war die Verbindung da. Der Huawei E 1762 funktioniert also auch. Ich danke Dir herzlich für Deine Geduld und Deine Hilfe.
 
Zuletzt bearbeitet:
T

Tholo

Ambitioniertes Mitglied
GZ!
Trotzdem ist das ja Ärgerlich, auf die Idee das es ne alte Version ist, hätten wir ja mal früher kommen können. Egal Hauptsache es funktioniert jetzt!

Gesendet von meinem LG-P990 mit Tapatalk 2
 
D

djlars

Fortgeschrittenes Mitglied
Hallo,
also ich habe hier 2 Sticks (ZTE K3565-Z und 4G Systems XS Stick P14). Ich habe allerdings bisher keinen dieser beidem auf meinem Tablet (Sony Tablet S) zum Laufen bekommen. Der ZTE-Stick blinkt zwar blau, aber eine Verbindung habe ich leider nicht :/ braucht ihr irgendwelche Werte? Falls ja, wie bekomme ich die?

EDIT:
in meiner modeswitch.conf steht folgendes:
4G W10/14
DefaultVendor= 0x1c9e
DefaultProduct= 0xf000
TargetVendor = 0x1c9e
TargetProduct= 0x9605
MessageContent= "55534243123456788000000080000606f50402527000000000000000000000"

Edit2:
Vielleicht hilft das hier?! http://forum.ubuntuusers.de/topic/4g-xsstick-p/#post-2999602
 
Zuletzt bearbeitet:
Eismaus

Eismaus

Neues Mitglied
Hallo
Ich habe ein gerootets Sony S Tablet und einenHuawei E1550Stick.
Scheinbar stimmt beim Usb mode switch eteas noch nicht.

<6>[ 142.324739] usb 2-1: new high speed USB device number 2 using tegra-ehci
<6>[ 142.369677] usb 2-1: New USB device found, idVendor=12d1, idProduct=1446
<6>[ 142.378352] usb 2-1: New USB device strings: Mfr=2, Product=1, SerialNumber=0
<6>[ 142.385739] usb 2-1: Product: HUAWEI Mobile
<6>[ 142.389990] usb 2-1: Manufacturer: HUAWEI Technology
<6>[ 142.403210] scsi0 : usb-storage 2-1:1.0
<6>[ 142.409624] scsi1 : usb-storage 2-1:1.1
<4>[ 168.245842] usb 2-1: usbfs: process 2157 (usb_modeswitch) did not claim interface 0 before use
<6>[ 168.257740] usb 2-1: USB disconnect, device number 2
<6>[ 174.154723] usb 2-1: new high speed USB device number 3 using tegra-ehci
<6>[ 174.201838] usb 2-1: New USB device found, idVendor=12d1, idProduct=140c
<6>[ 174.209625] usb 2-1: New USB device strings: Mfr=2, Product=1, SerialNumber=0
<6>[ 174.216900] usb 2-1: Product: HUAWEI Mobile
<6>[ 174.221102] usb 2-1: Manufacturer: HUAWEI Technology
<6>[ 174.242706] scsi6 : usb-storage 2-1:1.4
<6>[ 174.250528] scsi7 : usb-storage 2-1:1.5

app_125@android:/ # cat /data/data/umts.manager.jk/modeswitch.conf
# SCript fuer die App UMTS Manager von j_k > Modeswitch
#####
Huawei E173 E270+ E1762 E1820 E1550 E1750
# Huawei E270+ (HSPA+ modem)
# Huawei E1762
# Huawei E1820
DefaultVendor= 0x12d1
DefaultProduct= 0x1446
TargetVendor= 0x12d1
TargetProduct= 0x1001
MessageContent= "55534243123456780000000000000011062000000100000000000000000000"

Ist hier ein Fehlr zu erkennen?
Danke fur die Hilfe.
Eismaus

Gesendet von meinem Sony Tablet S mit Tapatalk 2
 
D

djlars

Fortgeschrittenes Mitglied
"<4>[ 168.245842] usb 2-1: usbfs: process 2157 (usb_modeswitch) did not claim interface 0 before use"
Ich denke das hat was damit zu tun. Vielleicht kann j__k das da etwas modifizieren, dass es funktioniert auf dem Tablet S. Das wäre echt toll :)
EDIT: bei meinem XS Stick P14 kommt die Meldung auch, bei dem ZTE K3565-Z nicht
Vielleicht hilft das: https://forum.openwrt.org/viewtopic.php?id=31766
 
Zuletzt bearbeitet:
J

j__k

Fortgeschrittenes Mitglied
djlars schrieb:
"<4>[ 168.245842] usb 2-1: usbfs: process 2157 (usb_modeswitch) did not claim interface 0 before use"
Ich denke das hat was damit zu tun. Vielleicht kann j__k das da etwas modifizieren, dass es funktioniert auf dem Tablet S. Das wäre echt toll :)
EDIT: bei meinem XS Stick P14 kommt die Meldung auch, bei dem ZTE K3565-Z nicht
Vielleicht hilft das: https://forum.openwrt.org/viewtopic.php?id=31766
Nur mal zur Sicherheit einen ROOT zugang hast du aber?
ansonsten starte mal den modeswitch im terminal und poste mal die ausgabe.

Terminal öffnen
su
/data/data/umts.manager.jk/usb_modeswitch -c /data/data/umts.manager.jk/modeswitch.conf

jk

Gesendet von meinem Transformer Prime TF201 mit Tapatalk 2