[ROM][OFFICIAL][7.1.2][Moto G4]LineageOS 14.1

  • 593 Antworten
  • Neuester Beitrag
Diskutiere [ROM][OFFICIAL][7.1.2][Moto G4]LineageOS 14.1 im Custom-ROMs für Moto G4 Plus im Bereich Root / Custom-ROMs / Modding für Moto G4 Plus.
PC295

PC295

Erfahrenes Mitglied
Wenn man eine Custom ROM installiert braucht man nicht vorher irgendwelche Systemupdates installieren.
Das Stock System wird schließlich durch die Custom ROM ersetzt.
 
guenter1

guenter1

Stammgast
Das mag ja so gewesen sein, nicht aber beim G4! Ohne vorher das N-Stock zu installieren funktioniert nicht alles: zumindest geht beim Fingerabdruck nur noch einer. Andere kleinere Unstimmigkeiten sind nicht verbürgt. Die Entwickler verweisen ausdrücklich darauf, erst N-Stock zu installieren!

Zum Akku: war beim aktuellen LinOS deutlich schwach - vorherige Versionen waren da besser.
 
K

Klabautermann2345

Dauergast
Ich verstehe echt nicht wieso ich auf meinem anderen g4 nicht die aktuelle Nougat drauf bekomme und nicht von der soak wegkomme.
Die soak hat was mit Versionsnummer 25 und die normale beginnt mit 24,ich denke da liegt es eventuell daran,aber keine Ahnung.
Kann nichts mehr installieren seit die soak Version drauf ist.
 
K

Klabautermann2345

Dauergast
Tausend Dank.
Das hilft mir sehr.
 
ChrisH

ChrisH

Erfahrenes Mitglied
PC295 schrieb:
Wenn man eine Custom ROM installiert braucht man nicht vorher irgendwelche Systemupdates installieren.
Das Stock System wird schließlich durch die Custom ROM ersetzt.
Wenn es nur das Betriebssystem wäre, hättest du recht. Mit dem Systemupdate wird aber auch die Firmware (Treiber, Baseband etc.) aktualisiert.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Pet0r schrieb:
@ChrisH
Wie sieht der Akkuverbrauch aus?
Berichte ich gerne, wenn es dazu Daten gibt - die acht Stunden, die das LOS jetzt drauf ist, hat er schon mal durchgehalten ;)
 
PC295

PC295

Erfahrenes Mitglied
Welche Baseband-Version hast du mit den Soak drauf?
 
K

Klabautermann2345

Dauergast
PC295 schrieb:
Welche Baseband-Version hast du mit den Soak drauf?
Baseband Version ist
M8952_70025.20.03.52R
ATHENE_EMEA_DSDS_CUST
 
PC295

PC295

Erfahrenes Mitglied
Stimmt, ich hab noch eine ältere Version drauf.
Kann man das jetzt noch ohne Datenverlust aktualisieren?

Idee:
1. TWRP Backup erstellen
2. Sock drüberflashen
3. TWRP Backup wiederherstellen
 
ChrisH

ChrisH

Erfahrenes Mitglied
Mit dem Dezember-Patch (NPJ25.93-14) ist das Baseband dann auf M8952_70030.25.03.62R, den also nicht vergessen.
Und was man so liest, kann man den nur mit der Stock-Recovery installieren...
 
K

Klabautermann2345

Dauergast
Pet0r schrieb:
Brauche nochmal Hilfe.
Ich mache diese Schritte:
Download the application RSDLite and install it.
Download and unpack the firmware from rar.
Run RSDLite.
Click on the button with three dots and select flashall.xml.
Reboot your phone into fastboot mode [press the volume down + power button]
Connect your phone to a PC. The program should detect the phone.
Press the Start button and wait until the end of the firmware until the phone restarts.

Problem ist nach dem Telefon im Fastboot Modus ist,schliesse ich es an den Pc an,aber das Programm RDS Lite erkennt das telefon nicht.
Am telefon selber steht Fastboot Mode und Charging nachdem ich es an den Pc angeschlossen habe,aber im programm RDS Lite passiert nichts,auch wenn ich auf Start drücke.
Weiss jemand was ich eventuell falsch mache?
 
ChrisH

ChrisH

Erfahrenes Mitglied
Motorola Device Manager installiert? Vielleicht fehlen nur die Fastboot-Treiber.
Was wird im Windows-Gerätemanager angezeigt?
 
K

Klabautermann2345

Dauergast
Motorola Device Manager ist installiert,und aktuell,und im Windows geräte manager wird das Gerät erkannt.
Wenn ich das Handy im normalen betrieb an den Pc anschliesse,wird es direkt erkannt.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Aber ist doch richtig,das ich das Telefon per Power Taste und leiser Taste in den fast Boot Modus bringe(steht dann Start )und dann Schliesse ich es an den PC an?
Oder muss ich bei Start im Boot Modus noch weiter klicken bis da Recovery steht?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Wenn ich fastboot.exe installieren möchte,kommt übrigens die Meldung Programm kann nicht gestartet werden,da AdbWinApi.dll auf dem Computer fehlt.

Na ja,ich werde dann einfach die Soak drauf lassen,läuft ja soweit gut,und hoffen das ich eventuell irgendwann ein OTA Update angeboten bekomme.
 
soeschelz

soeschelz

Dauergast
Du wirst für diese Soak wahrscheinlich kein OTA-Update bekommen, wenn du nicht in der Soak-Testgruppe bist (ist bei xda auch schon mehrfach erwähnt worden).
Flashe einfach nochmal sauber das Marshmallow-ROM (Build-Nr: MPJ139-23.4) fastboot, findest du hier im Forum angepinnt, dann lässt du das Gerät selbst auf den "Juli Patch" aktualisieren.
Anschließend kannst du im Original Recovery die Version 25.93.11/12 flashen, dann lässt du das Gerät hochfahren und wiederholst das Ganze mit dem neuesten Nougat-Update.

Ist möglicherweise nicht die schnellste Methode, aber ich kann dir garantieren, dass sie funktioniert. Habe das selbst schon bei ein paar Geräten gemacht. Wichtig ist, dass du, wenn du die Marshmallow-ROM flashst nicht auf irgendwelche Negativmeldungen beim flashen achtest, wichtig ist, dass bei "WRITING" immer "OKAY" am Ende steht, alles andere spielt meiner Erfahrung (mit 6 Verschiedenen Motorolageräten - G und X verschiedener Generationen) nach nebensächlich.
Und die GPT.bin flashe ich auch nicht mit, schlägt eh in der Regel fehl und ich musste es nie flashen damit das Gerät läuft.
 
PC295

PC295

Erfahrenes Mitglied
Das Upgrade des basebands hat funktioniert - ohne Datenverlust.
Ich hab jetzt die Version M8952_70030.05.03.60R drauf. Ist zwar nicht die aktuellste, bin aber wenigstens vom Marshmallow runter.

Problem ist nur noch, wie ich nochmal die Bootloader-Unlock-Warnung loswerde... ?

#EDIT: Problem gelöst. Ich musste die logo.bin neu flashen.
 
Zuletzt bearbeitet:
Fraigeizzt

Fraigeizzt

Fortgeschrittenes Mitglied
Hey Leute!

Ich bin nach komplettem Wipe auf der Version vom 24.01.2017. Ich bin damit auch sehr zufrieden, läuft alles sehr geschmeidig und reagiert für mein Empfinden sehr schnell. Der Akkuverbrauch hat sich meiner Meinung nach allerdings verschlechtert, überlebt den Tag aber immer noch ganz gut, es gibt scheinbar auch Probleme mit der Cam, wenn ich bei Whatsapp oder Instagram Video´s aufnehmen will klappt das leider aus den App´s heraus nicht, über die Cam-App direkt ist es aber möglich. Die Lautstärke der Musik über Kopfhörer ist leider wesentlich leiser als auf der alten CM-Version vorher. GIbts für die genannten Probleme schon Lösungsansätze?

Greetz Kev
 
Pet0r

Pet0r

Erfahrenes Mitglied
Alles rund um Lautstärke sollte über einen Kernel gelöst werden können.
 
Fraigeizzt

Fraigeizzt

Fortgeschrittenes Mitglied
Das is' iwie komisch, warum wurde die Lautstärke überhaupt so derbe reduziert? Wie ging das nochmal mit Kernel flashen, geht das auch über CWM oder TWRP, als wenn man eine Costum-Rom flashed?

Greetz Kev