[ROM] CyanogenMod 10 (Android 4.1.1) Nightly Builds

  • 1.752 Antworten
  • Neuester Beitrag
Diskutiere [ROM] CyanogenMod 10 (Android 4.1.1) Nightly Builds im Custom-ROMs für Motorola Defy+ im Bereich Root / Hacking / Modding für Motorola Defy+.
D

derjürgen

Experte
Hallo Fight4Music

Danke für den Hinweis. Wie gehe ich dann vor? Den aktuellen Kernel dann drüber flashen? Oder was muß man beachten?

Gruß Jürgen
 
Fight4Music

Fight4Music

Ehrenmitglied
Einfach drüberflashen, rebooten. Unter CM10 sollte der wohl laufen :) Unter 10.2 gibt es wohl Probleme, aber das ist eine andere Sache :p
 
D

derjürgen

Experte
Danke dir.

Kann man irgendwo nachlesen was durch den neuen Kernel verbessert worden ist? Wenns geht in deutsch.

gruß Jürgen
 
B

Blechdose

Ambitioniertes Mitglied
derjürgen;6296013 schrieb:
Danke dir.

Kann man irgendwo nachlesen was durch den neuen Kernel verbessert worden ist? Wenns geht in deutsch.

gruß Jürgen
Ja entweder in meinem Post, auf github oder bei mir direkt. Wenn Du aber nicht weißt, was es bedeutet einen Kernel zu flashen,
dann würde ich dir davon abraten :)

Englisch ist ein Muss, ist aber in meinem Github-Kommentaren oftmals einfacher als auf xda.
 
D

derjürgen

Experte
Hallo Blechdose.

Danke das du mich bremst. Ich dachte jetzt man könnte ihn einfach flashen und hätte dann nach reboot ein besseres System... wohl doch nicht so einfach.

Gruß Jürgen
 
HammDefy

HammDefy

Stammgast
Soo, hab grad auchmal wieder meine Flasherei gestartet. Rom und Gapps klappten und haben auch korrekt durchgebootet. Anschliessend der neue 10.0 Kernel und beim ersten Versuch Bootloop. dann nochmal Rom/Gapps/Kernel -> Recovery inne Fritten :(

Muss jetzt mit RSD-Lite neu anfangen...

Vielleicht liegts ja dran, dass ich Taki Jeden vorher drauf hatte *am Kopf kratz*

Update: Muss am vorigen Rom gelegen haben. Jetzt nach sbf-flashen funktioniert der neue Kernel. :)

Mal weiter einrichten...

2. Update: Swap fehlt mir :(
 
Zuletzt bearbeitet:
HammDefy

HammDefy

Stammgast
Nächstes Update meinerseits: hatte bisher weder reboots, noch irgendwelche Verluste der Data-Partition mit dem aktuellen Kernel. Allerdings hatte ich auch bei den vorigen Kerneln keine Bugs dieser Art.

Ich bleib bei meiner Meinung: Data-Verluste kommen vermutlich von einem unsauberen "Unterbau" also dem sbf mit dem man anfängt, und NICHT vom Kernel...

Ich benutze seit ner Weile ein bl7 mit Miui (kann grad keinen Link posten). Damit fährt mein Defy zwar nicht hoch, aber ich kann direkt In ein cwm booten und von da Roms installieren. Dieses sbf ist scheinbar aber bug-frei genug um mit nach der Rom-Installation ein stabiles System zu erhalten.

Ich kann mich natürlich auch irren, trotzdem läufts mit diesem sbf und anschließenden Rom - egal ob 10.0 oder 10.2 - einwandfrei und stabil.
 
Fight4Music

Fight4Music

Ehrenmitglied
Kernelupdate:

Blechd0se schrieb:
I guess its kind of the root. In some of my test cases i could reproduce it when the device was inappropriate shutted down, but thats really
hard to tell and not easy to debug.



Last time i checked you logcat i couldn't find any suspicious on the first sight.

Code:
That's what I suspected. More evidence that the data corruption bug has nothing to do with zram or swap. Maybe it's not even a kernel problem?
Its probably kernel related, because its corrupting something. I did enable a safety flush a while back for kernel panic,
maybe i have to check it again.

Anyway, new nightly today!

Nothing really special, except for TRIM-Support :)
Changelog;
* Trim-Support for ext3/ext4, therefore enabled discard in ramdisk (e.g: fstrim -v /data )
* enabled back swap&zram because of popular demand
* small cleanups and fixes (check github for more)

I am tired so no more infos today, as always only tested on 4.2. Happy flashing :)
CM10-Downloadlink
http://forum.xda-developers.com/attachment.php?attachmentid=2226039&d=1377981124
 
Zuletzt bearbeitet:
S

(sic)

Ambitioniertes Mitglied
So nach einigen Monaten JBC V8.2.2 und die letzten 2 Wochen unbedienbares MIUI V5 hab ich mich wieder einer Quarx/Blechdose Rom gewidmet. Konkret die 09/07.

Leider treten Soft-Reboots auf während man Videos abspielt. Egal ob von der SD oder bspw. Facebook.

Hab an den CPU Einstellungen nichts verändert und vor dem Flashvorgang mit Aroma alles formatiert.
 
Fight4Music

Fight4Music

Ehrenmitglied
S

(sic)

Ambitioniertes Mitglied
Dank dir,
werde es morgen mal probieren.
 
HammDefy

HammDefy

Stammgast
Hab eben den neuesten Kernel von Blechdose Installiert. Erst ist alles gut hoch gebootet, dann nach aktivieren von Swap (und knapp 5 Minuten warten) fing mein Defy an immer wieder zu rebooten. Hab dann mal fix im recovery das Rom drüber installiert, ab da war dann mein recovery auch zerschossen.
Musste von sbf an neu installieren - und das mit knapp 36% Akku. Naja Rom drauf und mit 12% hab ichs endlich ans Ladegerät hängen können...

Muss meine Meinung bezüglich dem Data-Loss also doch zurückziehen, scheint doch mit dem Kernel zusammen zu hängen. :(

Wenn doch nur einer beim 10.2 das BT-Headset fixen könnte (dann wär ich auf cm10.2 geblieben).......
 
S

(sic)

Ambitioniertes Mitglied
Das Bluetooth Problem ist für mich ebenfalls ein K.O.-Kriterium, ansonsten würde ich auch auf cm10.1 oder höher gehen. Leider hat es jedoch den Anschein, dass dieser Bug nicht ohne weiteres zu fixen ist und ich somit bis auf weiteres bei 4.1 stecken bleibe.

Sent from my MD_LIFETAB_P9516 using Tapatalk HD
 
HammDefy

HammDefy

Stammgast
Holladiewaldfee....

Hatte die aktuelle CM10.2 drauf, auf einmal neustart und das wars dann: Es bootet genau bis man sieht, dass das Display Saft kriegt und die LED grün leuchtet - ab da nüscht mehr... :(

Irrerweise musste ich erst n SBF flashen und dann 3 verschiedene Roms installieren, damit der Fehler endlich weg war o.O

Probiere jatzt mal die aktuelle CM10.0...
 
K

kullino

Fortgeschrittenes Mitglied
Ah, klasse. Werde ich mir heute nachmittag gleich mal laden und testen :)
 
HammDefy

HammDefy

Stammgast
läuft bisher gut und ist sparsam im Akkuverbrauch :)

Der ursprüngliche Beitrag von 10:37 Uhr wurde um 10:39 Uhr ergänzt:

(sic) schrieb:
Das Bluetooth Problem ist für mich ebenfalls ein K.O.-Kriterium, ansonsten würde ich auch auf cm10.1 oder höher gehen. Leider hat es jedoch den Anschein, dass dieser Bug nicht ohne weiteres zu fixen ist und ich somit bis auf weiteres bei 4.1 stecken bleibe.

Sent from my MD_LIFETAB_P9516 using Tapatalk HD


Abwarten, Quarks kriegt n BT-Headset und will mal auf die Suche nach ner Lösung gehen ;)
 
D

derjürgen

Experte
Hallo Hammdefy.
Das heißt du hast jetzt die aktuelle CM 10 und läuft problemlos?


Gruß Jürgen
 
HammDefy

HammDefy

Stammgast
Jepp, Sauber und bisher Bug-frei :)

Das Runterladen von OSM-Karten in Osmand+ funktioniert auch so wie es soll, in der aktuellen CM10.2 hats zwar runtergeladen, aber beim Installieren der Karten brachs immer mit Fehlermeldung ab....
 
baui0815

baui0815

Neues Mitglied
nach 3 Tagen Bootloop