Extrem viele Wakelocks durch K9-Mail

  • 57 Antworten
  • Neuester Beitrag
Diskutiere Extrem viele Wakelocks durch K9-Mail im K9 / K-@ Mail / Kaiten Mail im Bereich E-Mail.
M

molli2000

Ambitioniertes Mitglied
Ich grüße,
hab K9-Mail ohne Problem 2 Jahre auf nem Galaxy S gehabt.
Seit dem Umstieg auf das Galaxy S Advance zieht mir K9 permanent den Akku leer, egal ob der Task aktiv ist oder nicht.
Die Feststellung dessen erfolgte mit dem Wakelock Detector und BetterBatteryStats
Hab dort 2 IMAP Push-Accounts mit zusammen gut 3O Ordnern.
Einstellung Abfrage auf :Nie
Pushverbindung erneuern auf:24 Minuten-

Ideen ?
 
Zuletzt bearbeitet:
P

PieDieÄj

Experte
Ideen habe ich keine, aber leider das gleiche Problem!

Es sind nicht nur die wakelocks, sondern K9 scheint auch den Prozessor auf Volldampf zu halten, nachdem man mal in K9 etwas nachgeschaut hat, denn später sehe ich in CPU-Spy lange 1400mHz-Zeiten (höchste Frequenz beim S3), obwohl ich K9 nur kurz auf hatte.

Wenn ich K9 nach Benutzung nicht einfach schließe, sondern richtig abschieße, dann startet er sich praktisch neu und bleibt resourcen-friedlich. Mittlerweile habe ich mir das Abschießen angewöhnt, aber toll ist das nicht.
 
M

molli2000

Ambitioniertes Mitglied
Ja, der Prozessor dreht bei mir ebenfalls regelmäßig dermaßen auf, daß es sogar in der Hosentasche unangehmen wird.
Ein zusätzliches Problem bei mir ist auch , daß mich bei inaktven K9 Task kaum noch Mails erreichen.
 
Zuletzt bearbeitet:
S

Seidi666

Ambitioniertes Mitglied
habe das Problem ebenfalls. der Akku geht runter und nicht nur das, K9 zieht sehr viel Daten, obwohl push und kaum Mails kommen rein...
 
P

PieDieÄj

Experte
Ich weiß, ist bei mir oft auch so. Es kommen keine mails mehr automatisch rein, obwohl ich welche am Rechner reinkommen sehe. Dann habe ich totsicher das Abschießen von K9 nach dem Lesen vergessen und ich kann das dann richtig reproduzieren: ich gehe rein in K9 und schieße ihn ab! Dann kann ich zusehen, wie das WLan-Icon des S3 nach den restart von K9 sofort loslegt und die mails reinkommen.

Ich kann euch nur eines raten: schießt K9 jedesmal, nachdem ihr ihn auf hattet, einfach mal ganz konsequent über den task-Manager richtig ab! Ihr werdet sehen, dass die mails korrekt gepusht werden und der Akkuverbrauch sinkt.
 
M

molli2000

Ambitioniertes Mitglied
PieDieÄj;6397583 schrieb:
Ich kann euch nur eines raten: schießt K9 jedesmal, nachdem ihr ihn auf hattet, einfach mal ganz konsequent über den task-Manager richtig ab! Ihr werdet sehen, dass die mails korrekt gepusht werden und der Akkuverbrauch sinkt.
Funktioniert bei mir nicht wirklich, auch auf meinem Note 10.1 nicht. IMAP Mailempfang nur bei aktiven K9 Task........
 
Zuletzt bearbeitet:
M

molli2000

Ambitioniertes Mitglied
Also, nach meinen neuesten Erfahrungen steht die K9 Wakelelock-Aktivität
anscheinend im Zusammenhang mit wechselnden Datennetzverbindungen.
Zuhause (WLAN natürlich deaktiviert) verzeichne ich so gut wie keine
K9 Wakelocks, sodaß der Akkuverbrauch sehr gering ist, bin ich jedoch unterwegs, geht´s wieder los.
Daß der Akkuverbrauch unterwegs natürlich immer höher ist, versteh sich von selbst, die vermehrten Wakelocks kann ich jedoch nicht nachvollziehen.
Werd morgen die Datennetzverbindungen versuchsweise mal auf 2G beschränken .
 
Zuletzt bearbeitet:
Trend43

Trend43

Experte
Moin,

ich habe jetzt seit drei Tagen K9 auf dem Phone und exakt die gleichen Probleme wie ihr. Der Akku hält nur noch halb so lange und bei den Wakelocks ist K9 natürlich führend. Bin schon langsam am überlegen ob ich K9 nicht wieder deinstallieren und zurück auf MailDroid gehen sollte? Damit gab es die Probleme nicht.
 
P

PieDieÄj

Experte
Man könnte natürlich auch mal versuchen, gänzlich ohne push auszukommen und nur noch einmal pro Stunde Mails abrufen lassen, denn ich könnte mir vorstellen, dass push das Problem ist.
 
Trend43

Trend43

Experte
PieDieÄj;6409828 schrieb:
... Man könnte natürlich auch mal versuchen, gänzlich ohne push auszukommen und nur noch einmal pro Stunde Mails abrufen lassen...
Genau das habe ich gestern eingestellt, hat aber nicht viel gebracht.
 
M

molli2000

Ambitioniertes Mitglied
Begrenzung auf 2G hat nicht wirklich was gebracht.
Die Wakelocks sind absolut nicht reproduzierbar, mal so..mal soo.
null Systematik. Hab jetzt echt die Faxen dicke und versuchs mit AquaMail.
By the way:
Hab K9 ohne (!!) jegliche Akkuprobleme auf meinen Galaxy Note 10.1 ( nur Wifi) sowie dem Galaxy Note 8.0 (Wifi+3G) meiner
Frau.
 
Zuletzt bearbeitet:
P

PieDieÄj

Experte
Vielleicht haben wir Glück und die Problematik kommt auch bei den Entwickler an. Liest jemand von hier dort in dem entsprechenden Forum mit?
 
M

molli2000

Ambitioniertes Mitglied
So, der Test mit AquaMail verlief sehr erfreulich.
In 10 Stunden nur so um die 20 min Wakelocks...Klasse !
Nur fürs Tablet ist die ansonsten ganz gute App in meinen Augen leider unbrauchbar, da man für die
Mailansicht nie die komplette Breite des Screens zur Verfügung hat, was das Originallayout verzerrt
und die Schrift teilweise zu klein werden lässt.
Ich kann mit der Lösung jedenfalls sehr gut leben.
 
Zuletzt bearbeitet:
Trend43

Trend43

Experte
@molli2000 hast du es auch schon mal mit MailDroid versucht? Ist fürs Tablet sehr gut geeignet.
 
M

molli2000

Ambitioniertes Mitglied
Ich hab sie wirklich alle durchprobiert.
K9 ist und bleibt für mich das Nonplusultra.
 
SavanTorian

SavanTorian

Ehrenmitglied
Ich habe mal die Anzahlz der Pushs von 6 Minuten auf eine Stunde gestellt. Das ergab eine deutliche Verbesserung auf meinem S3 :)
 
Trend43

Trend43

Experte
Wo stellt man das denn ein? /Kontoeinstellungen/Häufigkeit der E-Mail-Abfrage? Oder gibt es für Push noch eine andere Einstellung.
 
M

molli2000

Ambitioniertes Mitglied
Bei Push fragt, anders als bei POP3, niemand etwas ab, deshalb bleibt dies Häufigfigkeit der Abfrage auf "Nie"
Die "Erneuerung der Pushverbindung" kannst Du unter "Kontoeinstellung"-"Nachrichten abrufen"- "Erweitert" einstellen.
Leute, wenn ich ganz ehrlich bin, dann hab ich den Sinn dieser Einstellung bis heute nicht verstanden und leider lieferte auch Google keine wirkliche Hilfe. Vielleicht weiß das ja einer von Euch??
Hatte mit dieser Einstellung , ohne Ergebnis, übrigens auch rumgespielt.
 
Zuletzt bearbeitet:
Trend43

Trend43

Experte
Vielen Dank @molli2000, ich habe Push jetzt auch mal auf 1 Std. eingestellt. Mal schauen was das bringt.
 
M

molli2000

Ambitioniertes Mitglied
molli2000 schrieb:
Ich hab sie wirklich alle durchprobiert.
K9 ist und bleibt für mich das Nonplusultra.
Ich muss mich doch korrigieren.
Da ich ja jetzt AquaMail auf dem Smartphone hab, habe ich mich
noch mal genauestens mit den Option beschäfigt und musste feststellen,
daß das vermeintliche KO-Kriterium fürs Tablet gar nicht existiert.
AquaMail ist default nämlich so eingestellt, daß auf Tablets links die Verzeichnisse und rechts die Mailansicht ist. Durch den entsprechend geringen Platz werden viele Mailinhalte rechts abgeschnitten, was natürlich ein absolutes nogo darstellt. Wie ich jetzt aber feststellen konnte, lässt sich diese 2 spaltige Ansicht gottseidank abschalten, so daß man die von K9 gewohnte Ansicht hat. Da mir der Client optionnsmäßig und optisch sowieso deutlich besser gefällt, werde ich komplett dorthin wechseln.
 
Zuletzt bearbeitet:
Ähnliche Themen - Extrem viele Wakelocks durch K9-Mail Antworten Datum
0
4
8