Lenovo Motorola Smart Assistant

A

ardolas

Stammgast
Threadstarter
Hallo zusammen,

durch das leidige Thema "Android 9 für Moto G6 Plus" bin ich in den unendlichen Weiten des WWW auf ein Tool von Lenovo gestoßen, das mal richtig nett ist. Der Name des Tools steht schon im Titel, der Link ist am Ende zu finden. Auf der Downloadseite gibt es sogar ein Handbuch für das Tool, nenne ich mal durchdacht. Eine Liste der unterstützten Geräte habe ich nicht gefunden, im Lenovo-Forum heißt es, dass es für alle Android-Smartphones von Lenovo und Motorola ist.

Für die Nutzung ist kein entsperrter Bootloader oder root nötig (keine Ahnung ob es damit dann noch funktioniert), die einzige Voraussetzung ist aktiviertes USB-Debugging. Laut Anleitung soll es auch über WiFi funktionieren, aber wenn es um Flashen geht, vertraue ich WiFi nicht.

Das Tool unterstützt neben Updates auch Backups, Screenshots und es ist auch noch ein Ringtone-Maker (aus mp3's) mit eingebaut. Mein G6 Plus ist immer noch auf Android 8, hab im Moment keine Zeit zum flashen, das Tool zeigt mir jedoch an, dass ich die neue Version flashen könnte. Es sieht sogar danach aus, als wenn man damit unerwünschte System-Apps deinstallieren könnte, probiert habe ich es nicht - und wer das macht, tut dies auf eigene Gefahr!

Hier ein paar Screenshots zu diesem Tool

lmsa-01.PNG lmsa-02.PNG lmsa-03.PNG lmsa-04.PNG lmsa-05.PNG lmsa-06.PNG

Und hier noch der Link zum Download:

Lenovo MOTO Smart Assistant (Installs on PC) - DE

Vielleicht hilft es ja dem einen oder anderen (nein, ich weigere mich Gender-Neutral zu schreiben! :p )

Ralf
 
hajo56

hajo56

Fortgeschrittenes Mitglied
System Apps lassen sich nicht unter Android 9.0 löschen,habe es mit Outlook und
YouTube versucht. Wird zwar angezeigt löschen,aber passiert nichts!
Leider ist auch keine Deutsche Sprache anwählbar.
 
A

ardolas

Stammgast
Threadstarter
hajo56 schrieb:
System Apps lassen sich nicht unter Android 9.0 löschen
Leider ist auch keine Deutsche Sprache anwählbar.
Ich schrieb ja auch, dass es danach aussieht, nicht, dass es funktioniert :)

Ja, das mit der Sprache stimmt leider, ist nur auf englisch, aber das normale Schulenglisch sollte wirklich ausreichen, wirkliches Fachchinesisch ist das nicht.
 
D

d-nogger

Erfahrenes Mitglied
Hat das mit dem Update über den Assistant schon bei jemanden funktioniert?
Bei mir wird angezeigt, dass das Update bereit steht, es wird im Assistant heruntergeladen und nach Klick auf Upgrade wechselt das Moto G6 Plus in das "schwarze Android Menü" und es erscheint eine Meldung im Assistant, dass die Verbindung unterbrochen wurde. Bei 51% bleibt der Fortschritt im Assistant stehen.
Man soll dann lt. Assistant-Meldung das Smartphone kurz abstöpseln und wieder neu einstecken. Dann gibt es nur die Möglichkeit "ok" zu klicken. Der Fortschritt setzt sich danach allerdings nicht fort und bleibt bei 51% stehen.
Es bleibt nur, dass Programm zu beenden und das Telefon neu zu starten. Das Smartphone ist danach zum Glück weiter normal benutzbar.
 
D

d-nogger

Erfahrenes Mitglied
Fazit: Geduld haben!
Ich habe es nun noch einmal versucht, abgewartet und auf dem Smartphone die Logs anzeigen lassen. Dort sah ich dann auch, dass sich etwas tut. Nur auf dem PC im Assistant wurde keine Fortschritt angezeigt.
Aber nach ein paar Minuten hat das Moto G6 Plus neu gebootet und es war Android Pie 9 (1.Dez 2018) installiert.

Danke @ardolas für den Tipp mit dem Moto Assistant! :1f44d:
 
A

ardolas

Stammgast
Threadstarter
d-nogger schrieb:
Fazit: Geduld haben!
Aber nach ein paar Minuten hat das Moto G6 Plus neu gebootet und es war Android Pie 9 (1.Dez 2018) installiert.
Aber gern doch. Ich hab leider erst am Wochenende Zeit für diese Aktion, im Moment ist es etwas arg stressig.

Eine Bitte habe ich aber, könntest Du mal nachschauen, ob GPS funktioniert? Auf verschiedenen Seiten, u.a. XDA laß ich von Problemen mit GPS nach Upgrade auf Android 9, es wurden keine Satelliten gefunden. Das war aber bei allen, die das OTA-Update gemacht haben.
 
H

howdy1811

Neues Mitglied
Was heißt denn Geduld haben?
Ich habe es ungefähr 1,5 Stunden laufen lassen und es ging nicht über die 51 Prozent hinaus.
 
A

ardolas

Stammgast
Threadstarter
hajo56 schrieb:
@ardolas
war zwar nicht gemeint,aber gps unter 9.0 funktioniert. Pie
manuell installiert. Mal schnell vom Balkon getestet.
Danke für die Info. GPS ist für mich sehr wichtig, das war das einzige, was mir ein wenig Bauchweh bereitete :)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
howdy1811 schrieb:
Was heißt denn Geduld haben?
Ich habe es ungefähr 1,5 Stunden laufen lassen und es ging nicht über die 51 Prozent hinaus.
Hat es mittlerweile geklappt?
Ich für meinen Teil mache vor Updates aus Prinzip vorher immer einen Neustart des Smartphones, hatte daher mit den ganzen Moto G's und auch mit meinem Samsung nie Update-Probleme. Manchmal kann sich ein Update-Prozess auch verhaspeln, kann Dir auch bei OTA passieren.
 
H

howdy1811

Neues Mitglied
Ne habe es unterbrochen weil wirklich nichts mehr weiter ging, werde es am Wochenende nochmals probieren und einfach mal laufen lassen.
 
D

d-nogger

Erfahrenes Mitglied
Du kannst während des Assistant-Updates durch Betätigen der Laut-/Leiser-Tasten auf dem Smartphone zum Log-Screen wechseln.
Dort sieht man dann, dass sich etwas tut.
Wie bereits erwähnt, hatte ich bei den ersten Versuchen auch keinen Erfolg. Beim letzten Mal ging es dann aber auf einmal recht flott.
Es sind aber ja auch einige Dateien (1,9GB), die rübergeschaufelt werden. Das dauert schon etwas.
 
H

howdy1811

Neues Mitglied
Oh ok, danke. Mit den Laut/Leiser Tasten wusste ich nicht.
Ja mit den 1,9GB habe ich gesehen.
 
A

ardolas

Stammgast
Threadstarter
Endlich Zeit zum flashen und was ist?
Der Download tröpfelt mit 2-3Mbit rein :1f629:
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
mblaster4711 schrieb:
Der Download kann je nach Tageszeit länger dauern.
Und wenn sich auf dem Log-Screen, wie bei mir, auch nichts tut und mal wider länger dauert, dann schnapp dir ein Snickers diesen Treiber
Mit aktuellem Windows 10 mag der Treiber von 2014 (der auch für das Moto G ist, nicht G2/3/4/5/6/7) nicht mehr, nur so als Info.
 
H

hollydark

Neues Mitglied
Hallo zusammen,

klinke mich mal in die Diskussion ein. Habe 2 Moto G 6 plus. Beide Geräte haben vor Beginn die selbe Softwareversion 8.0.0 und sind auch so identisch. Habe beim ersten wie oben beschrieben das Update gemacht. Funktionierte auf Anhieb. Danach gleich das zweite Telefon auch angestöpselt. Dort funktioniert das Update nicht. Wenn ich beim zweiten Telefon den Update Button am PC drücke, startet das Telefon wie auch beim ersten Telefon neu. Nur gelangt dieses Smartphone nicht in den Fastboot Modus. Das Telefon bleibt schwarz mit eingeschalteter Hintergrundbeleuchtung. In diesem Zustand war das Telefon mit keiner Taste mehr bedienbar. Der Update Prozess bleibt dort eine Ewigkeit bei 51% stehen. Es passiert dann nichts mehr. Nachdem ich dann das USB Kabel abgesteckt habe, dauerte es noch ca 10 Minuten, dann startete das Handy plötzlich wieder mit dem alten Android. Habe dann bei diesem Gerät versucht, manuell in den Fastboot Modus zu gelangen. Leider mit dem selben o.b. Ergebnis. Warum das Telefon nicht in den gewünschten Modus startet, weiß ich nicht. Aber vielleicht hat einer von euch eine Idee, warum das beim zweiten Telefon partout nicht geht.

Grüße
Holger
 
A

ardolas

Stammgast
Threadstarter
Wenn ich denn mal so weit kommen würde. Seit Stunden versuche ich das Image herunterzuladen, aber bei 1,8Gb ist dann Feierabend - und an meiner Leitung liegt es nicht. Hab zwischen 2 Downloadversuchen mal ein Debian-Image gezogen, das flog mit 380Mbit rein, das Android-Image knapp 5Mbit.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Nach etlichen Checksum-Fehlern hats nun geklappt.
Das flashen selbst ging ziemlich schnell (USB3 Port) und trotz Hinweis des LMSA-Tools, das alle SMS verloren gehen, sind sie nach wie vor da. GPS funktioniert einwandfrei, die Einstellungen sind gewöhnungsbedürftig und ziemlich bunt geworden. Das einzige was ich vermisse (oder nicht gefunden habe), ist das explizite Konfigurieren der Standortgenauigkeit, das hatte ich unter Android 8 auf GPS only, das scheint wohl nicht mehr zu gehen.Inkedscreencap_LI.jpg
 
mblaster4711

mblaster4711

Lexikon
ardolas schrieb:
Mit aktuellem Windows 10 mag der Treiber von 2014 (der auch für das Moto G ist, nicht G2/3/4/5/6/7) nicht mehr, nur so als Info.
Was meinst du mit "mag ..... nicht mehr"?

Installation lief bei mir durch.

Ich verwende neu installiertes Win 10 1809 in Version Home x64 und Pro x64, keinerlei vorherige Installation von irgendwelchen Treibern o. Software für Android Geräte, ich habe lediglich die Smart-Assi.-Software installiert. Bei beiden wird ohne den Moto-Treiber im Gerätemanager ein nicht funktionierendes Gerät "fastboot evert s“ angezeigt wenn das Moto im Fastboot ist, nach Installation wird ein Gerät "Android Device" angezeigt und dann tatsächlich sich endlich etwas in den Logs auf Moto und das flashen funktionierte.
 
Zuletzt bearbeitet:
Oben Unten