Das Droid 4 ist da - ein paar HOWTOs

  • 933 Antworten
  • Neuester Beitrag
Diskutiere Das Droid 4 ist da - ein paar HOWTOs im Motorola Milestone 4 / Droid 4 Forum im Bereich Weitere Motorola Geräte.
C

cuco

Experte
Nostrex schrieb:
Also denke ich mal das nur der Akku Cache Spinnt ?
Kann man den Irgendwie Zurrücksetzen ? :)
Früher konnte man das mal, das war eine bestimmte Datei, die man in der Recovery löschen konnte oder auch mit diversen Apps im System mit Root-Rechten. Das war aber zuletzt zu Android 2.3 Zeiten. Seit Android 4.x-Zeiten sind die Apps und die Einträge in den Recoveries verschwunden. Ehrlich gesagt habe ich keine Ahnung, aber ich kann mir das nur so erklären, dass es entweder diese Kalibrierungsdatei nicht mehr gibt oder dass das ganze nun so gut funktioniert, dass löschen es nur schlimmer statt besser macht.

Manchmal hilft es, wenn man so einen Hänger bei 1% hat, so lange zu warten, bis das Handy dann tatsächlich herunterfährt. Das hilft manchmal, dass er sich danach neu anpasst. Wohlgemerkt: Manchmal. Denn wenn der Akku wirklich ne Macke hat, hilft nicht mehr viel außer auswechseln oder so langehinnehmen, wie der Akku halt noch so einigermaßen geht.
 
N

Nostrex

Ambitioniertes Mitglied
Danke für die Aufklärung, hab grad mal einen Bestellt :)
LG
 
paysano

paysano

Fortgeschrittenes Mitglied
Wollte nochmal rückmelden: Habe jetzt einfach mal rotzfrech auf einem Zweitgerät ein komplettes Safestrap Backup des Erstgeräts eingespielt. Wichtig war nur auf dem Zweitgerät zuerst einen Backup-Folder zu erstellen (In dem Fall einen leeren Android-Secure Folder). Danach habe ich die kompletten Daten in diesen Ordner hineinkopiert. Fehlermeldungen "unable to mount osh" habe ich jeweils ignoriert bis alle Partitionen drauf waren. Funktioniert 1a.

Cheers Pay
 
B

benningmk

Fortgeschrittenes Mitglied
Ich wollte mein Droid4 zum Verkauf noch einmal komplett neu aufsetzten nach dieser Anleitung.
Leider komme ich schon beim flashen der Stock Firmware nicht weiter.
- Handy wird erkannt beim anschließen als ADB Interface.
- WindowsUtility.bat als Admin gestartet.
- Folgende Fehlermeldungen kommen da:


Könnt ihr mir weiterhelfen?
Gruß
 
C

cuco

Experte
Das habe ich noch nie gehabt, aber er scheitert bei jeder Datei schon beim Laden derselben. Ich habe das Utility noch nie als Admin gestartet - magst du es auch mal OHNE Adminrechte probieren?
 
B

benningmk

Fortgeschrittenes Mitglied
Habe den Fehler gefunden. Das Gerät wurde im Gerätemanager erkannt als "Android USB Devices - Mot Single ADB Interface".
Treiber noch einmal von Hand installiert, dann ADB Interface ausgewählt. Danach wurde es erkannt als " ADB Interface - Mot Composite ADB Interface".

Danach konnte ich nach Anleitung alles installieren, Gerät wird nun verkauft.

Danke
 
M

Moertel01

Neues Mitglied
Hallo Leute, bin neu hier und hoffe das mir jemand Helfen kann.

Nun zu meinem Problem, wie oben bereits beschrieben bekomme ich einfach kein Empfang mit meinem Droid 4. Ich bin IT Techniker und habe wirklich schon alles versucht denke ich. Mein Gerät habe ich nach der How To Anleitung von Cuco gerootet (Das Droid 4 ist da - ein paar HOWTOs) was auch wunderbar funktioniert hat. Doch egal was ich mache und egal welche Cyanogenmod ich verwende ich habe einfach kein Netz.

Ich habe immer wenn ich was neues Probiert habe immer alles neu Installiert, damit ja kein Datenmüll Probleme machen kann.

Bis jetzt habe ich CM11, CM12 und sogar CM10 getestet. Ich habe es mit TobbysMod und Metors.37 GSM Patch probiert (wobei ich nicht weiß ob ich bei Metors alles richtig gemacht habe). Ich habe die Stock ROM mal modifiziert und mal nicht. Aber jedes mal bekomme ich maximal 2G zum laufen UMTS nie.

Ich hoffe es kann mir jemand Helfen, mittlerweile kenne ich das Smartphone in und auswendig nur benutzen kann ich es leider nicht.
 
C

cuco

Experte
Hi

Ich schätze mal, vor dem Rooten nach HowTo-Anleitung hast du vorher auch das aktuellste Stock-ROM auch nach Anleitung draufgespielt?

Und du hast nur TobbysMod ODER Mentors Patch benutzt, oder?
 
S

siradlib

Fortgeschrittenes Mitglied
Hast Du mal geschaut, welche Netze Dein Handy nutzen darf?
In der Telefon-App folgendes wählen: *#*#4636#*#*
Es erscheint ein Menü, dort "Telefoninfo" wählen.
Bei Netzwerktyp wählen: CDMA AUTO(PRL)
 
M

Moertel01

Neues Mitglied
Hallo und Danke erst einmal für eure schnellen Antworten. Ich bin gar nicht mehr dazu gekommen das zu lesen.

Also zu der Frage von cuco:

Ja ich habe das aktuellste Stock Rom. Android 4.1.2 und System Version 98.72.188.XT894.Verison.en.US. Ich habe es entweder mit TobbysMod oder mit Mentors Rom versucht (Mentors Patch ist glaub nur für custom Roms und die Rom für Stock Roms , wie oben erwähnt bin ich mir bei Mentor nicht ganz sicher) ich weiß das beide sich überschneiden und das Mentors deutlich aggressiver ist, deswegen wäre mir TobbysMod eig. lieber.


Zu siradlib`s Frage:

Habe geschaut und es Stand mal GSM auto (PRL) und mal GSM/CDMA auto (PRL). Das es aber CDMA Auto (PRL) sein muss höre ich jetzt das erste Mal, kann es ja mal versuchen umzustellen und gebe Bescheid.

Edit:

Also die CDMA Auto (PRL) hat nichts gebracht, sehe ich auch als quatsch an da wir in Deutschland GSM/WCDMA benutzen und alle anderen Handys von mir sind auf WCDMA preferred eingestellt.

Momentan habe ich übrigens überhaupt keinen mod drauf, habe nachdem ich den diese Frage hier im Forum gestellt habe gestern mal wieder alles komplett neu gemacht. Das einzigste was ich heute Tat war die APN manuell einzutragen, aber wie gehabt empfang GSM dann auch 2G dann kein Signal mehr.
 
Zuletzt bearbeitet:
M

Moertel01

Neues Mitglied
Bitte helft mir. Hat denn niemand das Problem? Ich muss noch dazu sagen das ich keine gapps installiere (nutze alternative apps) macht das was aus? Und ist es schlimm das ich die System Version upgedatet habe? Und muss bei cdma Abonnemen RUIM SIM oder NV sein? Und bring es vllt was cyanogenmod in den stock zu installieren??

Was mir noch aufgefallen ist, wenn ich im stock manuell das Netz Suche findet er BASE+ mit unterschiedlichen Nummern in klammern. Aber wenn ich im cyanogenmod nach Netz Suche findet er nur Eplus 2G und 3G registrieren kann ich mich nur in 2G.
 
Zuletzt bearbeitet:
M

mozart12

Stammgast
Frage mal Cuco schön freundlich ob er das Gerät für dich einrichten kann (wenn es überhaupt möglich ist)
 
C

cuco

Experte
CDMA Auto ist natürlich auch Quatsch... Bei mir ist GSM/CDMA auto (PRL) ausgewählt. Allerdings habe ich gerade keine SIM drin, um damit zu testen. Allgemein ist von dem *#*#4636#*#* Menü auch abzuraten. Ich weiß nicht mehr, was es war, aber vor "langer" Zeit gab es mal Probleme, dass man dort zum Teil Dinge einstellen konnte, die sich dann nicht wieder zurückstellen ließen. Also man konnte sie zwar im Menü zurückstellen, aber in Wirklichkeit passierte es nicht. Auch ein komplett neuer Flashvorgang half dann nichts mehr, das Handy war dann gebrickt... also besser Finger weg von dem Menü.

Die anderen GApps bzw. nicht-GApps dürften eigentlich nicht das Problem sein. Zum Testen kann man sie ja einfach mal weglassen, um es wirklich auszuschließen.

Was bei CDMA-Abonnement (RUIM-SIM/NV) eingestellt ist, müsste für GSM egal sein.

CyanogenMod kann man in den Stock installieren, braucht man aber eigentlich nicht, ich habs auf jeden Fall nicht im Stock.

Hast du mal 'ne andere SIM-Karte probiert? Eventuell kommt das Droid 4 mit dem National-Roaming von Eplus & O2 nicht klar. Das habe ich noch nie probiert... Wenn du irgendwo eine SIM von Vodafone oder T-Mobile zum Testen auftreiben könntest, wäre das denke ich hilfreich.

Ich biete den Leuten hier im Forum auch immer an, mir das Handy zuzuschicken und ich mache das fertig. Kostet nichts, nur Rückporto und ich freue mich über 'ne kleine Spende. So wie es für mich klingt, machst du aber schon alles richtig - ich würde also nichts anders machen, schätze ich...
 
M

Moertel01

Neues Mitglied
Danke für deine Tipps Cuco. Das einzigste was ich wirklich ausprobieren kann wäre eine andere SIM Karte, nur das bei uns hier niemand Vodafone oder T-Mobile hat. Dieser Test wird also noch dauern.

Ich frage mich ob es ein Problem ist das ich die System Version Upgadatet habe. Wenn ich nämlich nach deiner Anleitung das neuste JellyBean ROM aufgespielt habe bietet er mir unter den Einstellungen wenn ich in nach Updates suche das Update auf System Version 98.72.188.XT894.Verison.en.US welches ich drauf habe, diesen Punkt beschreibst du nämlich in deiner Anleitung nicht. (witziger weise behebt das laut Verizon 2G/3G Probleme)
 
C

cuco

Experte
Das ist komisch. Das sollte eigentlich nicht sein... Wenn du also den ersten Teil der Anleitung durch hast (in den Grundzustand zurücksetzen und auf den neuesten Stand bringen) und das Stock-ROM bootest, dann bietet er dir an, dass du die Firmware updaten sollst? Auf 98.72.188.XT894? Was zeigt er dir denn an, welche Version zu dem Zeitpunkt bereits installiert ist? Eigentlich sollte mein Tool nämlich genau dafür sorgen, dass eben genau diese Firmwareversion installiert wird.
 
M

Moertel01

Neues Mitglied
Also zumindest bei mir macht sie das nicht. Ist mir nach dem zweiten oder dritten mal aufgefallen. Also wenn ich mit deinem tool flashe habe ich Android Version 4.1.2 mit der System Version 98.72.182.XT894.Verizon.en.US. Wenn du darin ein Problem siehst muss ich noch andringen das ich es wie gesagt schon Upgadatet habe.

Aber vllt. mache ich ja was falsch wenn diese Version gar nicht installiert sein sollte. Oder hast du das auch zum ersten mal?
 
C

cuco

Experte
Dann klappt da irgendwas beim Flashen schon nicht... Sonst wäre am Ende nicht trotzdem noch die 182er drauf, sondern die 188er. Kannst du mal den Output des Flashvorgangs hier posten?
 
M

Moertel01

Neues Mitglied
Ich habe ein Video vom kompletten Flash Vorgang gemacht, ich hoffe das du daraus irgendwas erkennen kannst.
 

Anhänge

  • clip0001.rar
    301,7 KB Aufrufe: 64
C

cuco

Experte
Hmm das sieht alles absolut ok aus, genau so wie es sein sollte...

Irgendwas läuft da trotzdem schief, wenn am Ende weiterhin nicht die v188 drauf ist. Ich schätze mal, beim anschließenden Boot nach dem Flashen arbeitet das Handy für eine ganze Weile, ich glaube mit einem Android-Männchen als Logo und einem Balken, der unten durchläuft, bis der eigentliche erste Boot-Vorgang mit dem "Droid"-Geräusch startet?

Wenn du sagst, er bietet dir im Stock-ROM das Update an - kannst du das von dort einspielen? Oder klappt das auch nicht?

Eine Vermutung wäre noch, dass der Flashspeicher hinüber ist. Viele Flashspeicher gehen kurz vor ihrem Tod in einen Read-Only-Modus, denn lesen geht im Gegensatz zum Schreiben bei Flashspeichern quasi unbegrenzt oft. Wäre mir aber neu, das Droid 4 von meiner Freundin hat sich eher umgekehrt verhalten. Hat noch munter Daten auf den Flash geschrieben, nur auslesen konnte man den Speicher nicht mehr...

Einzige Alternative wäre noch, dass es sich um eine mir unbekannte Hardware-Revision des Handys handelt, welches meine Firmware-Dateien nicht annimmt.
 
M

Moertel01

Neues Mitglied
Ja genau so ist der Bootvorgang nachdem Flashen, alles genau wie du es beschrieben hast.

Und ja ich kann das Update machen und dann funktioniert auch alles wenn ich nach deiner Anleitung weiter mache. Jedoch funktioniert es auch ohne separates Updaten indem ich mein Smartphone einfach direkt mit dem "Droid 4 Utility XT894 Jellybean Created by mattlgroff" Flashe und dann mit deinem Tool weiter mache.(muss man dann auch da mattlgroff nur Safestrap 3.1 mit integriert hat) Also wie gehabt und gesagt, ich habe wirklich schon alles ausprobiert getestet und mich belesen.

... nur ein anderes Netz habe ich noch nicht getestet außer O2 gestern. Ich bin mir aber mittlerweile ziemlich sicher das es an BASE+ bzw. BASE und O2 liegt. Vermutlich kommt das Smartphone einfach nicht mit diesem Netzwerkroaming zurecht, wie du es bereits ziemlich am Anfang vermutet hast. Seit heut habe ich übrigens vollen H+ empfang durchweg in der Stock ROM, dafür aber kaum noch bis keinen Empfang. Wie das jetzt in der CM ROM aussieht weiß ich noch nicht teste ich jetzt erst und schreib nochmal.

Habe gestern mit BASE telefoniert und die meinten das auch manche von ihren neuen Smartphone Modellen solche Probleme haben und durcheinander kommen. Momentan nutzen nämlich alle das 3G Netz von BASE und alles andere von O2 und die Umstellung dauert noch ein paar Monate bis es letztlich komplett umgestellt ist meinte er dauert es bis zu 3 Jahre.

Sollte dieses Roaming hin und her Probleme machen habe ich außer einen Netzwechsel keine Optionen und Möglichkeiten mehr oder sehe ich das falsch?