FroYo 2.2 Sammelthread Fehler & Fragen [Bitte lesen]

  • 407 Antworten
  • Neuester Beitrag
Diskutiere FroYo 2.2 Sammelthread Fehler & Fragen [Bitte lesen] im Motorola Milestone Forum im Bereich Weitere Motorola Geräte.
C

christian7301

Experte
TheSpiritof69 schrieb:
Am besten mal durchwipen und die Schritte oben wiederholen..

An und für sich muss das so gehen..
Also dann nur das hier eingeben?

rm -rf /data/dalvik-cache
mkdir /cache/dalvik-cache
chown 1000.1000 /cache/dalvik-cache
chmod 771 /cache/dalvik-cache
ln -s /cache/dalvik-cache /data/dalvik-cache


Oder soll ichs anders probieren?

Ich hatte auf 2.1 MEMHACK, dann MEMHACK über Androidiani MEMHACK wieder deinstalliert und dann über MSU auf 2.2.1 upgedatet.
Da müsste es ja jungfräulich sein und es sollte nichts mehr vom MEMHACK von 2.1 vorhanden sein oder?
 
TheSpiritof69

TheSpiritof69

Experte
Wenn du geupdatet hast über MSU kann das sein...da bleibt /data ja erhalten, hängt davon ab, wie gut das Entfernen war.

Hast du denn aus der Androidiani den 2.2.1 Memhack ausprobiert?

Trotzdem, einfach die Schritte oben wiederholen..
 
C

christian7301

Experte
TheSpiritof69 schrieb:
Wenn du geupdatet hast über MSU kann das sein...da bleibt /data ja erhalten, hängt davon ab, wie gut das Entfernen war.

Hast du denn aus der Androidiani den 2.2.1 Memhack ausprobiert?

Trotzdem, einfach die Schritte oben wiederholen..
Ja, der MEMHACK von Androidiani hat danach nicht funktioniert.

Habs wieder probiert und es klappt nicht.
 
C

christian7301

Experte
TheSpiritof69 schrieb:
Wenn du geupdatet hast über MSU kann das sein...da bleibt /data ja erhalten, hängt davon ab, wie gut das Entfernen war.

Hast du denn aus der Androidiani den 2.2.1 Memhack ausprobiert?

Trotzdem, einfach die Schritte oben wiederholen..
Also soll ich jetzt einen Fullwipe machen, danach das hier eingeben

rm -rf /data/dalvik-cache
mkdir /cache/dalvik-cache
chown 1000.1000 /cache/dalvik-cache
chmod 771 /cache/dalvik-cache
ln -s /cache/dalvik-cache /data/dalvik-cache

und dann Data-restore vom Backup machen?
Was hälst du davon?
 
C

christian7301

Experte
Bringt MEMHACK auch irgendwelche Nachteile mit sich?
 
-FuFu-

-FuFu-

Ikone
-.-
ich sag da mal nichts zu jetzt...

um den memhack zu nutzen, muß man nur das passende script in kombination mit dem mot_boot_mode hack nutzen... aber das sollte eigentlich bekannt sein...

und der memhack aus der androidiani or sollte weiterhin funktionieren, man muß allerding irgendwo in der androidiani or den eintrag "apply boothack" oder so ähnlich suchen und aktivieren, damit es klappt...

und der einzige nachteil ist, das man keine OTA updates mehr ausführen kann, ansonsten ändert sich nichts...
 
G

Gelangweilter

Ehrenmitglied
Moin, mirist heute was aufgefallen, was ich seit dem Update habe (nicht mehr habe)

Im Stock Kalender wird in der Monatsuebersicht kein Tagestermin mehr angezeigt, auch keine Geburtstage, keine Feiertage. Nur die Termine, die eine eingetragene Zeitspanne haben, zB 15 - 16 Uhr. In der Tagesansicht, Wochenansicht wird alles angezeigt, nur in der Monatsansicht nicht mehr. :angry:

hat jemand nen Tip dazu? Oder einen guten Kalender aus dem Market, kann auch was kosten.

@Edith sagt, hat sich erledigt. Hab mir einen anderen Kalender im Market gekauft.
 
Zuletzt bearbeitet:
S

scut52

Neues Mitglied
Gelangweilter schrieb:
Im Stock Kalender wird in der Monatsuebersicht kein Tagestermin mehr angezeigt, auch keine Geburtstage, keine Feiertage. Nur die Termine, die eine eingetragene Zeitspanne haben, zB 15 - 16 Uhr. In der Tagesansicht, Wochenansicht wird alles angezeigt, nur in der Monatsansicht nicht mehr. :angry:
Naja, das stimmt nicht ganz. Im Stock Kalender werden die ganztägigen Termine dadurch in der Monatsansicht gekennzeichnet, dass die Datumszahl eines solchen Tages in "fetter" Schrift dargestellt wird. Allerdings muss ich dir recht geben: diese Hervorhebung ist ehrlich gesagt nur bei genauem Betrachten auch sichtbar und kann dementsprechend leicht übersehen werden...
 
G

Gelangweilter

Ehrenmitglied
Vor dem Update waren die farblich hinterlegt, wie die normalen Termine. Bin mit dem neuen Kalender aber sehr zufrieden, deutlich besser als Stock. Haette ich mir auch eher kaufen sollen.
 
C

christian7301

Experte
Nach langem Testen habe ich festgestellt, dass MOTONAV unter 2.2.1 nur dann läuft, wenn der JIT-Compiler deaktviert ist.
Habs mit CM6 gestest. Mit JIT-Compiler kommt es auch unter CM 6 zu Reboots, aber ohne JIT-Compiler läuft es einwandfrei.

Hat jemand eine Ahnung wie mal auch bei der Stock 2.2.1-Dach den JIT-Compiler deaktivieren kann?
 
M

myjoern

Fortgeschrittenes Mitglied
christian7301 schrieb:
Nach langem Testen habe ich festgestellt, dass MOTONAV unter 2.2.1 nur dann läuft, wenn der JIT-Compiler deaktviert ist.
Habs mit CM6 gestest. Mit JIT-Compiler kommt es auch unter CM 6 zu Reboots, aber ohne JIT-Compiler läuft es einwandfrei.

Hat jemand eine Ahnung wie mal auch bei der Stock 2.2.1-Dach den JIT-Compiler deaktivieren kann?
Nun ja, in letzter Zeit war ich öfters mit Motonav unterwegs und hatte keine Reboots mehr, warum auch immer.

Habe zwischenzeitlich aber nichts am System oder den Einstellungen gegenüber früher geändert, als ich noch ab&zu Reboots hatte.
Verwende Android 2.2.1, Launcher Pro+, Custom Car Home.

Hoffe, es bleibt weiterhin so stabil. :)

Wie kann ich denn erkennen, ob der JIT-Compiler läuft?
Gruß Pat
 
C

christian7301

Experte
myjoern schrieb:
Nun ja, in letzter Zeit war ich öfters mit Motonav unterwegs und hatte keine Reboots mehr, warum auch immer.

Habe zwischenzeitlich aber nichts am System oder den Einstellungen gegenüber früher geändert, als ich noch ab&zu Reboots hatte.
Verwende Android 2.2.1, Launcher Pro+, Custom Car Home.

Hoffe, es bleibt weiterhin so stabil. :)

Wie kann ich denn erkennen, ob der JIT-Compiler läuft?
Gruß Pat
Hm...,hast du es auch lange genug verwendet?

Manchmal dauerts ja auch über eine Stunde, bis ein Reboot kommt.

JiT_Compiler ist einer der Vorzüge von 2.2.1 und immer dabei. Beschleunigt das System.... Der ist immer aktiv und gabs unter 2.1 nicht.
 
rauke

rauke

Experte
Ist aber schon ein Armutszeugnis, wenn eine Anwendung das Betriebssystem zum Reboot bringen kann. Dass die Anwendung sich beendet ist ja noch irgendwo ok, aber das gleich der Kernel einen Panic schiebt darf einfach nicht sein.
 
M

myjoern

Fortgeschrittenes Mitglied
christian7301 schrieb:
Hm...,hast du es auch lange genug verwendet?

Manchmal dauerts ja auch über eine Stunde, bis ein Reboot kommt.
So, war am Wochenende im Auto unterwegs und hatte wieder Motonav an. Auf der Hinfahrt ca. 3,5 Stunden ohne Mucken, alles lief glatt.
Auf der Rückfahrt, innerhalb der ersten 5 Minuten ein Reboot, danach lief aber auch wieder alles glatt.

Wie kann man das nun mit dem JIT-Compiler erklären?
Habe Stock-Android 2.2.1 und LP+. Neben Motonav war Custom Car Home aktiv (da Handy in Fahrzeughalterung), BT eingeschaltet und mit Headset verbunden.
Verwende keine Taskkiller o.ä. Tweaks.
Habe lediglich über OR Androidiani ein OC auf 800MHz laufen.

Gruß
 
C

christian7301

Experte
Ich war am Wochenende auch unterwegs und habe mit CM 6 jedesmal den JiT-Compiler deaktiviert, wenn ich MOTONAV genutzt habe. Kein einziger Reboot. Läuft einwandfrei....

Mach mal mit Androidiani ein Nandroid Backup von deinem System und klopf dann in die Console einfach

setprop dalvik.vm.execution-mode int:fast

rein.
So sollte der JiT-Compiler deaktiviert sein und es sollte keine Reboots unter MOTNAV mehr geben.
Habs sebler noch nicht ausprobiert, da ich jetzt CM 6 laufen habe, aber es müsste so klappen!
Bitte dann um Feedback obs funktioniert hat!
 
C

christian7301

Experte
christian7301 schrieb:
Ich war am Wochenende auch unterwegs und habe mit CM 6 jedesmal den JiT-Compiler deaktiviert, wenn ich MOTONAV genutzt habe. Kein einziger Reboot. Läuft einwandfrei....

Mach mal mit Androidiani ein Nandroid Backup von deinem System und klopf dann in die Console einfach

setprop dalvik.vm.execution-mode int:fast

rein.
So sollte der JiT-Compiler deaktiviert sein und es sollte keine Reboots unter MOTNAV mehr geben.
Habs sebler noch nicht ausprobiert, da ich jetzt CM 6 laufen habe, aber es müsste so klappen!
Bitte dann um Feedback obs funktioniert hat!

ACHTUNG FEHLER!!!
Funktioniert so nicht, wie ich es vorher geschrieben habe.
Du musst mit Rootexplorer unter /system/build.prop/ diese Zeile dalvik.vm.execution-mode=int:fast

reinschreiben, speichern und dann neu starten.

Aber bitte vorher ein Backup machen, da keiner weiß ob es auch wirklich so funktioniert.