[Firmware][8.0.0] OxygenOS Open Beta 25 [Oreo]

  • 116 Antworten
  • Neuester Beitrag
Diskutiere [Firmware][8.0.0] OxygenOS Open Beta 25 [Oreo] im Original-Firmwares für OnePlus 3 im Bereich OnePlus 3 Forum.
F

flummi17

Neues Mitglied
macht beim 3T keine Probleme.
 
AcmE85

AcmE85

Lexikon
Gestern und heute das gleiche Spiel:
Ca. 1h Autofahrt morgens mit Podcast (kein GPS) verbrauchen ca. 30-35%.
Ich versorge OnePlus fleißig mit Logs, bisher gab es außer eine kurze "Danke"-Mail keine weitere Aussage.
Ein "Beta-Test" ohne beiderseitiges Feedback ist... :rolleyes2:
Ich teste heute mal den Heimweg mit dem Beta 24 Modem, am Wochenende ist auch Zeit für einen clean flash.

edit:
Es gibt ein erstes Substratum Theme für OOS Oreo womit man die UI nach seinen Vorlieben anpassen kann.
Ozone: Substratum module to tweak OxygenOS Oreo

edit:
Mail vom Support, die logs und Screenshots wurden ans Dev-Team weitergeleitet.

edit:
Kann hier jemand testen ob die Verbindung zu Chromecast/cast-fähigen TV funktioniert?!

edit:
Nach einem Clean flash funktioniert die Verbindung zum Chromecast auch wieder problemlos.

Habe alle Apps per Titanium Backup wiederhergestellt und über Nacht
mit LTE liegen lassen. Nach 8 Stunden noch bei 100% mit minimalen Wakelocks laut Akkuanzeige.

Ich habe mittlerweile den Verdacht dass der Verbrauch während der Nutzung/Aktivität einfach höher ist. Auf dem Heimweg gestern habe ich festgestellt dass der Verbrauch beim Podcast hören und abgeschaltem Display ansteigt und das Gerät auch nur dann spürbar wärmer wird. Halbe Stunde ohne Podcast im deepsleep zeigten keinen Verbrauch.
 
Zuletzt bearbeitet:
madX5

madX5

Fortgeschrittenes Mitglied
Auch bei mir hat nur ein Reset zur Reduzierung des Akkuverbrauchs beigetragen. Habe allerdings nicht komplett auf Werkseinstellungen zurück, sondern Bilder und Musik behalten. Nun hat sich der Akkuverbrauch wieder eingependelt. Muss aber noch testen, ob beim Hörbuchhören der Verbrauch wieder merklich ansteigt und das Gerät wieder merklich warm wird.

Testweise nutze ich jetzt mal den Oneplus Launcher anstatt Nova. Naja.... nicht so dolle außerdem habe ich hier merkliches Stocken beim wiederholten Aufwecken. Plötzlich ist kein Touchscreen mehr möglich und lässt sich nur durch zweimal Drücken der On-Taste wieder zum Leben erwecken. Nicht sehr vertrauenerweckend. Denke diese Beta ist noch arg verbuggt.
 
Dennis der Dachs

Dennis der Dachs

Experte
AcmE85 schrieb:
edit:
Mail vom Support, die logs und Screenshots wurden ans Dev-Team weitergeleitet.


Ich habe mittlerweile den Verdacht dass der Verbrauch während der Nutzung/Aktivität einfach höher ist. Auf dem Heimweg gestern habe ich festgestellt dass der Verbrauch beim Podcast hören und abgeschaltem Display ansteigt und das Gerät auch nur dann spürbar wärmer wird. Halbe Stunde ohne Podcast im deepsleep zeigten keinen Verbrauch.
Kannst du kurz erklären, welche Logs du schickst und wie du die generierst?

Meinst du derzeit lohnt also ein clean flash nicht?



madX5 schrieb:
Denke diese Beta ist noch arg verbuggt.
Also die Beta ist eine der der entspannten, da habe ich schon ganz andere gesehen. Läuft doch grob alles. Als tägliche Version locker nutzbar, auch wenn noch einiges zu verbessern gibt.
 
AcmE85

AcmE85

Lexikon
@Dennis der Dachs
Meine mit SysLog erstellten Logs waren nicht "korrekt", die sollen mit ihrem LogKit erstellt werden:
[How To] Take Log's on OOS/H2OS | Oneplus Logkit | Beta Testers | Bug Reports |
Du aktivierst damit quasi das loggen und lässt es im Hintergrund laufen. Sobald der Fehler oder das komische Verhalten auftritt
gehst du erneut ins LogKit und speicherst das ganze ab.

Der Clean Flash hat schon ein wenig gebracht, die Laufzeit (in Verbindung mit Displayzeit) von Nougat erreiche ich aber noch immer nicht.
Der Deepsleep ist hingegen ausgezeichnet. Hier mal der aktuelle Stand:

8h Deeplsleep über Nacht mit LTE


hauptsächlich WLAN


Unter Nougat erreiche ich die 2h Displayzeit im WLAN locker bei 70%.

Was man leider auch wieder sieht ist der markierte Bereich mit aktivem Bildschirm. Das System scheint hier nicht korrekt zu arbeiten.
Teilweise war das Nachts und das Inaktivitätsdisplay ist immer aus, abgesehen davon dass ich keine Benachrichtigungen bekommen habe.
Aber da ich das Gerät heute auch schon benutzt habe wird die "aktive" Phase überhaupt nicht mehr korrekt angezeigt.

Da ich seit dem Clean flash nicht viel unterwegs war kann ich das aber erst die kommenden Tage richtig bewerten. RCS habe ich auch wieder mit Titanium Backup deaktiviert, diesmal taucht es aber auch nicht mehr auf. Das ist ja vor dem Clean flash erst ganz verschwunden nachdem ich die apk gelöscht habe.

Gestern war ich kurz unterwegs. Der erste GPS-Fix nach dem Clean flash kam bereits nach 8 Sekunden mit 19 m Genauigkeit (hohe Genauigkeit).
Maps konnte direkt navigieren und das GPS ist während der kurzen Fahr (15 Minuten) nicht abgebrochen bei ca. 10 m Genauigkeit.
 
Zuletzt bearbeitet:
Dennis der Dachs

Dennis der Dachs

Experte
Danke, ich werde aus der Anleitung nicht ganz schlau, wann ich jetzt was machen soll.

Sobald ich ein Fehler feststelle, alle Schritte? Oder vorher einige und beim Fehler die restlichen?
 
Mark Aber

Mark Aber

Experte
Klingt für die erste Oreo-Beta gar nicht mal so schlecht, bei der nächsten Beta werde ich vermutlich einsteigen...
 
AcmE85

AcmE85

Lexikon
Der Verbrauch bei Musik/Podcasts hat sich seit dem clean flash leider nicht wirklich verbessert.
Ich kann auch nicht genau festmachen woran es letztendlich liegt.
Am Wochenende waren wieder 35% in 1,5 Stunden weg beim Podcast hören mit mobilen Daten.
Der Wechsel in den Flugmodus brachte währenddessen auch keine Besserung.
Der oem_log Ordner auf dem Gerät hatte danach eine Größe von fast 4 GB,
gepackt noch 1 GB. Hoffe OnePlus findet das Problem.

Verbrauch über Nacht war 1%.
Heute früh im Zug habe ich das Gerät dann einfach mal in Ruhe gelassen und nur ein Paar mal kurz gesurft.
Nur 2% Verbrauch im Deepsleep mit mobilen Daten in einer Stunde bei wechselnder Netzabdeckung.

Derzeitiger Stand: 67% Restakku, vom Netz seit fast 16 Stunden, 1h55min Displayzeit.
Display bei 7%, Mobilfunk-Standby 6%.
Sieht sehr ordentlich aus. Jetzt bitte nur noch die Bugs fixen.
 
Zuletzt bearbeitet:
Mark Aber

Mark Aber

Experte
Danke AcmE85 für deine fundierten Rückmeldungen, daran kann ich mich orientieren [emoji106]
 
Dennis der Dachs

Dennis der Dachs

Experte
Ich glaube, dass der Verbrauch ohne Wifi derzeit stark ansteigt.
Ich war gestern den ganzen Tag im Wifi und habe abends 2h DoT gehabt und noch so 73%

Fand das ok

Heute sieht es wieder so aus



OpenVPN hält bei mir aber generell die Mobilfunk Schnittstelle offen. Trotzdem ist der Verbrauch höher als sonst
 
Ch3ck3rM0n

Ch3ck3rM0n

Erfahrenes Mitglied
Also zum Akkuverbrauch kann ich noch nichts sagen, GPS scheint aber wirklich besser geworden zu sein. PoGO nervt mich nicht mehr so häufig mit GPS-Fehlern.

Was mir aber negativ auffällt:
- Smartwatch per Bluetooth intabil und erst mit Werksreset der Uhr koppelbar
- erhöhte Hitzeentwicklung (hatte ich bisher nur bei extrem grafiklastigen Spielen)
- Performanceverluste (20% in Antutu + Spieleruckler wie z. B. in Into the Dead 2)
- WLAN-/Mobilfunkverluste bzw -reconnections
- ...

Positives jedoch:
+ Patchlevel
+ Fehlerfreies OTA-Upgrade

Neutral gestimmt:
~ Unbekannte Quellen (müssen bei Installation jedes Mal erlaubt werden)
 
Zuletzt bearbeitet:
AcmE85

AcmE85

Lexikon
MX Player während der Heimfahrt im Auto mit Audio und abgeschaltetem Display, 30 Minuten = 20% Verbrauch.
Schaue ich über MX Player hingegen Videos bei mäßiger Helligkeit sind es knapp 10% pro Stunde. xD

Bin dann auf die Idee gekommen den Energiesparmodus einzuschalten und was soll ich sagen.
Restliche 25 Minuten mit nur 2% Verbrauch.

Edit:
Trotz Energiesparmodus das gleiche Spiel heute morgen.
Deutliche Wärmeentwicklung und hoher Verbrauch bei Podcasts...
Kaum bin ich im Büro und das Handy schläft, es ist auch sofort im Deepsleep (gerade Linie).
War wohl Glück gestern. Ich bin überfragt.

Edit:
Es liegt wohl an der App und nicht an OOS. Hätte ich auch früher googlen können... :cursing:
Twitter
Twitter

Das gleiche gilt dann wohl auch für MX Player bei abgeschaltetem Display.
Eine Info dazu habe ich allerdings nicht finden können.
 
Zuletzt bearbeitet:
Ch3ck3rM0n

Ch3ck3rM0n

Erfahrenes Mitglied
AcmE85 schrieb:
Es liegt wohl an der App und nicht an OOS. Hätte ich auch früher googlen können... :cursing:
Naja, zum Teil muss es aber auch am OOS liegen. Mit OOS auf 7.1 hatten wir die Probleme nicht. Da muss definitiv noch Tuning für Android 8.0 her seitens Oneplus und seitens Appanbieter.
 
AcmE85

AcmE85

Lexikon
Oreo, nicht OOS. Liegt wohl an der Änderung wie Anwendungen im Hintergrund agieren dürfen,
die ich übrigens sehr begrüße.
So einen geringen Standby Verbrauch hatte ich noch nie!
Wenn ich jetzt mal die "Problemapps" außen vor lasse, komme ich praktisch auf die gleiche Displayzeit bei deutlich längerem Standby.

Wie man an meinen Links sieht tritt es auf anderen Geräten mit Oreo genauso auf. Und wie ich ja schon zuvor zum MX Player geschrieben habe ist der Verbrauch im Vordergrund bei eingeschaltetem Display genauso niedrig wie unter Nougat.

edit:
Es tut sich was auf OnePlus' Github:
OnePlus Open Source Software · GitHub
android_vendor_oneplus_8996O steht wohl klar für Snapdragon 820/821 Oreo.
Auch wenn noch die commits fehlen...

Eigentlich wollte ich heute mein Beta 24 TWRP Backup zurückspielen, aber vielleicht warte ich noch ein wenig.
Kurz zusammengefasst die letzten Paar Tage:

- Ich merke oftmals einen deutlichen Performanceverlust / Lag, besonders nach dem entsperren.
- Wenn ich etwas teile (URL, Bild,...) dann lädt das von unten hochfliegende Teilen-Overlay 2-5 Sekunden
alle meine meistgenutzten Kontakte und Apps. In dieser Zeit werden mir runde Platzhalter angezeigt.
- Heute hatte ich mehrfach einen sehr hohen Akkuverlust im Deepsleep und das Gerät wurde oftmals sehr warm.
- Die Beta schränkt meine Nutzung doch sehr ein (Podcasts, usw...)
Art+Cache wipe hat nichts gebracht.

In einer Woche geht's in den Urlaub, dann kann ich keine zufälligen Bugs gebrauchen.
 
Zuletzt bearbeitet:
D

dasacom

Stammgast
Hi zusammen, was meint ihr bekommen wir für das OP3 auch Oreo 8.1? Hat OP sich mal dazu geäussert?
 
AcmE85

AcmE85

Lexikon
@dasacom Die Aussage war das Update auf die nächste Android Version (Oreo).
Ich glaube da kann man nur raten...
Da 8.1 noch nicht mal final mit freiem Code veröffentlicht wurde denke ich dass wir da, wenn überhaupt,
noch lange warten müssen. Das OP5 will ja auch aktualisiert werden.

Bin wieder auf Beta 24 und es ist ein Unterschied wie Tag und Nacht in allen Bereichen.
Bin noch immer bei 91% Akku seit 6 Uhr (22 Minuten Display, 1+h Podcast).
Da muss schon eine deutliche Verbesserung kommen in der nächsten Beta.
 
Zuletzt bearbeitet:
D

dasacom

Stammgast
Ja da hast du recht. Ich liebe custom Roms und root. Aber habe in letzter Zeit nur Ärger mit Banking apps ( Sparkasse mit Kwitt Funktion, SEQR mit kontaktlosem bezahlen, push tan usw.). Daher achte ich da vermehrt drauf.

Gruß, dasacom
 
B

blackseven

Experte
Beta 26 ist verfügbar...
 
Lord Amalon

Lord Amalon

Neues Mitglied
Großes Problem.
Wollte auf die Beta updaten, vorgehensweise:

Ausgang:
Android 7.1.2
TWRP 3.1.1.2
SuperSU v2.82-201705271822

Steps Followed:
Backup
Booted to Recovery
Factory Reset
Updated TWRP to the TWRP-Oreo-Oneplus-3-3T
Flashed SuperSu-v2.82-SR5-20171001224502
Cleared Cache and Dalvik
Flashed Oxygen OS Open Beta 25

Danach nochmal zur Sicherheit die Recovery und SU geflashed.

Beim Restart bleibt das Gerät nun beim schwarzen Startbild mit dem OP-Logo hängen.
Nix passiert sonst.

Habe den Flash nochmal wiederholt, selbes Resultat.

Jede Hilfe erwünscht ! :)

DAnke