Rooten vom A3 (2017)

Irischok

Irischok

Neues Mitglied
Ich habe niemanden der das kann:crying:
Ich habe mal einem alten Handy eine neue Androidversion mit Odin verpasst.
Aber auch nur zum Spaß. Ganz unbewandert bin ich nicht :o
Dachte nur dass das Rooten doch etwas anderes wäre. Denn nach dem neuen Android hatte ich damals auch keine extra Rechte oder so.. ich wollte nur eine neuere Androidversion haben. Das neu Aufsetzen falls alle Stricke reißen könnte ich auch. Ich werde es mit CF-Auto Root versuchen.

Dankeschön für die Antwort :thumbsup:
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
SaschaKH schrieb:
1. Versprechen tun die das alle. :)

2. Da kann ich nicht widersprechen. Ich würde sagen, wenn man nicht in der Lage ist ein Smartphone wenn der GAU auftritt, auch wieder komplett neu aufzusetzen, sollte man doch sehr vorsichtig sein und es im Zweifelsfall lieber lassen.

OK bei 2/16 GB kann ich es schon verstehen, dass man Probleme mit zuwenig Speicher bekommt. Chip würde ich jetzt nicht gerade für die beste Quelle halten, gerade wenn es um Smartphones geht, aber deren Empfehlung wird schon OK sein.

Ich würde aber die Vorgehensweise mit CF-Auto-Root bevorzugen, die ist eigentlich sehr einfach, das muss man aber auch mit Odin machen und wenn man das Tool nicht mal kennt.
:(

Ich würde sage, Du hast drei Möglichkeiten es zu machen:
1. Du machst es wie bei Chip beschrieben, wenn dann was schief geht, frag besser dort im Forum, hier werden Dir da eher nicht zu viele Leute helfen können.
2. Lies Dich hier etwas mehr ein, v.a. eben auch wie Odin funktioniert. In die Tiefe musst Du da aber auch nicht gehen, ist aber wohl schon Zeitaufwändiger. Mag aber auch kein Fehler sein, wenn man dabei etwas lernt.
3. Lass es von einem Bekannten machen, der sich da besser auskennt.
Danke, SaschaKH, für dein Engagement.
Ich würde mein Handy auch gerne etwas erleichtern. Das hab ich mit früheren Modellen schon erfolgreich durchgeführt, es liegt aber schon ein paar Jährchen zurück.
Mir geht es nun nach meinen gestrigen Erstversuchen aber auch so, dass ich das Rooten als nicht ganz so easy erfahre, wie ich es aus früheren Tage kenne.
Bei meinem A3 2017 mit 8.0 stelle ich fest, dass es mal nicht klappt mit Odin. Da kommt ne Fehlermeldung.

Der Beschreibung nach müsste ich aufgrund der Android-Version wohl Data+Cache löschen und damit ist schon ziemlich viel kaputt. Wenn man danach erst feststellt, dass die Sache aus einem weiteren Grund dann doch nicht klappt, hat man viel Zeit verloren, bis das Handy wieder eingerichtet ist.
Es würde mich immerhin freuen, wenn ich deine Meinung hören könnte. Liege ich mit meiner Vermutung (Wipe Data+Cache) wohl richtig, oder?
Ist das der Grund, warum Odin nicht klappt?

Beste Grüße
Martin
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Naja, anfangs meldet odin brav Added!
Dann bewegt sich der Balken am Smartphone, der bei einem Drittel hängenbleibt.
Und die Meldung Costom Binary (Recovery) Blocked by FDP Lock (falls ich mich nicht verlesen habe, das ist sehr klein)

Odin meldet:
<ID:0/008> Added!!
<ID:0/008> Odin engine v(ID:3.1301)..
<ID:0/008> File analysis..
<ID:0/008> Total Binary size: 51 M
<ID:0/008> SetupConnection..
<ID:0/008> Initialzation..
<ID:0/008> Get PIT for mapping..
<ID:0/008> Firmware update start..
<ID:0/008> NAND Write Start!!
<ID:0/008> SingleDownload.
<ID:0/008> recovery.img
<ID:0/008> cache.img
<ID:0/008> FAIL!
<ID:0/008>
<ID:0/008> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
 
maik005

maik005

Urgestein
burnieflash schrieb:
Costom Binary (Recovery) Blocked by FDP Lock (
Du musst in dem Entwickleroptionen am Smartphone zwingend OEM Unlock aktivieren.
Danach wird das Gerät aber vermutlich auf Werkszustand zurücksetzt (Zumindest beim S9 ist es so).
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Wow, danke, das ist sehr freundlich, so schnell zu antworten. Danke auch für die Warnung ;-)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Also allein OEM Unlock aktivieren hat keine Rückstellung auf Werksteinstellungen verursacht, was ich auch nicht erwartet habe. Du hast vermutlich ohnehin gemeint, dass dies durch das Rooting passieren könnte, oder?
 
maik005

maik005

Urgestein
@burnieflash
Ich meinte es schon so wie ich schrieb.
Durch das rooten mit TWRP ist ja eh ein Werksreset erforderlich.
Seit dem Galaxy S9 wird nach Aktivierung von OEM Unlock und anschließendem Neustart ein zwingender Werksreset durchgeführt .
Da ich mir nicht sicher war ob es beim A3 (2017) vielleicht auch so ist schrieb ich es besser dazu ;)
 
Gerimo

Gerimo

Erfahrenes Mitglied
@burnieflash
Wichtig: Nimm bitte auch die aktuellste Odin Version. Hatte auch schon mal Probleme damit, dass der Flashvorgang auf einmal eingefroren ist.
 
burnieflash

burnieflash

Fortgeschrittenes Mitglied
Vielen Dank. Derzeit bin ich noch am Lesen, weil ich noch nicht wirklich durchblicke, welche Schritte nun wirklich zu setzen sind. CWM Recovery kenne ich von früher. TWRP ist mir neu. Die beiden scheinen zwei gleichwertige Alternativen zu sein?
Wenn man nun den SuperSU mit Odin flasht, was man dann hat, ist mir auch nicht klar. Ist dann die CWM Recovery mit dabei, oder TWRP, oder ist das Smartphone dann nur gerootet, keine Ahnung. Aber das wird.
 
SaschaKH

SaschaKH

Super-Moderator
Teammitglied
SuperSU geht nicht mit Odin zu flashen, dazu brauchst Du schon ein Custom Recovery (CWM, PhilZ, TWRP). Du könntest eventuell Auto-Root meinen, da ist kein Recovery bei.

Mit dem alten CWM konntest Du eigentlich auch schon alles machen, es hat halt nur den Touchscreen nicht unterstützt.
 
N

nieb

Fortgeschrittenes Mitglied
Vielleicht kann mir hier jemand helfen ?!

A3 2017 erfolgreich mit Magisk 18.0 gerootet.
Doch leider hält der SafteyNet Status (true) nur ein paar Stunden manchmal auch 24h an, dann ändert es sich wieder in false.
Bei einem reboot ist es wieder auf grün und true. (Banking App funktioniert auch super)
Nach mehreren Stunden ändert es sich dann wieder auf rot.

Nun weiß ich nicht genau wo ich ansetzen soll.
Magisk Hide ist aktiv. Playstore, BankingApp und Dienste Framework sind alle auf hide.
Wie schon erwähnt, mehrere Stunde hält es auch.
 
SaschaKH

SaschaKH

Super-Moderator
Teammitglied
nieb schrieb:
Magisk Hide ist aktiv. ...
Sicher dass es das auch wirklich die ganze Zeit lang ist?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Denke es ist auch nicht falsch den aktuellen MagiskManager-v6.1.0 zu haben. OK hat du wohl schon, wollte es nur noch erwähnt haben.

Übrigens so Probleme können immer wieder vor, auch bei anderen Smartphones, vielleicht wurde das Problem schon bei einem ganz anderen Modell gelöst. So ähnliche Diskussionen gab es z.B. schon in:
Magisk: SafetyNet Test
App erkennt Root trotz Magisk Hide
 
Zuletzt bearbeitet:
N

nieb

Fortgeschrittenes Mitglied
Ja 6.1.0 ist installiert.
Ich hab auch schon von anderen gelesen, mit dem selbigen Problem - eine dauerhafte Lösung gibt es anscheindend nicht.
Manchmal dauert es wenige Stunden, manchmal hält es einen Tag durch bis safteynet wieder durchfällt.

Welche App jetzt genau auf hide gestellt werden soll, da gibt es auch widersprüchliche Aussagen.
Einige stellen sogar Ihre Kamea auf hide.
Ich suche einfach mal weiter ! XDA bringt leider auch keine Lösung.

Welche Log könnte darüber Aufschluß geben ?
 
SaschaKH

SaschaKH

Super-Moderator
Teammitglied
Tut mir leid, von Magisk hab ich keine Ahnung, noch nie benützt.
 
N

nieb

Fortgeschrittenes Mitglied
Nicht weiter tragisch, ich beschäftige mich einfach damit wenn ich Zeit und Lust habe.;)
 
Gerimo

Gerimo

Erfahrenes Mitglied
Ich habe ein gerootetes Smartphone das mit Magisk und Xposed läuft. Als Launcher benütze ich "Nova". Ausserdem habe ich einen grossen Teil mit MacroDroid automatisiert. Das beinhaltet z.B. automatisches ein-abschalten von GPS/Bluetooth/AOD etc.
Nach dem Update auf Android 8.0 und entsprechenden Root Befugnisse sowie Xposed Modulen laufen bei Macrodroid die entsprechende Befehle für das ein-ausschalten von GPS/Bluetooth etc. nicht mehr. Es kommt zwar der Hinweis Root Rechte erhalten, aber es passiert nichts.
Auch das automatische abschalten mittels Nova Launcher über das entsprechende Icon reagiert nicht mehr!
Woran kann das liegen???

Allen weiterhin frohe Festtage.
 
Zuletzt bearbeitet:
borisbecker01

borisbecker01

Fortgeschrittenes Mitglied
Hallo und FROHE WEIHNACHTEN :)

Ich habe meiner Freundin ein A3 2017 mit aktuellstem Oreo geschenkt.
Wie es sich gehört soll es natürlich direkt gerootet werden und mit einem Recovery versehen werden.
Doch bei einlesen in die RootThematik habe ich mit schrecken festgestellt daß das mal so eben nicht mehr klappt.
Ich habe seit jeher alle meine Handys gerootet usw.
Beim Huawei P10 war ich mir sicher : SCHLIMMER gehts NICHT mehr was das rooten angeht.

Nun muss ich aber erkennen, beim A3 2017 ist es fast genauso schlimm!

Die Informationen sind spärlich und jeder sagt was anderes.
Deshlab meine Frage direkt an DICH :

Wie hast DU dein A3 2017 Oreo gerootet ?

Anscheind rootet man über TWRP?
Für TWRP habe ich , glaube ich, den passenden Threat zu gefunden.
[recovery][twrp 3.2.3] A3 2017 [Official]

ABER wie gehts weiter?
Welche root habt ihr benutzt ?
 
I

imu81

Neues Mitglied
Hallo Leute,

ich suche schon seid einiger Zeit eine Rootanleitung für mein A3 2017 SM-A320FL, konnte aber bis jetzt keine finden. Mein Speicher ist ständig durch die Apps voll und meine 32GB Speicherkarte kann ich somit kaum nutzen. Leider kann ich die speicherkarte auf meinem Gerät auch nicht als internen Speicher Formatieren, keine Ahnung warum. Als Firmware habe ich Android 8.0.0 drauf.

Ich hoffe ihr könnt mir weiter helfen, da ich gerne das A3 wegen der grösse behalten wollte.

Gruss
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von hagex - Grund: Gerätebezeichnung vor Threadmerge im Post ergänzt, Gruß von hagex
SaschaKH

SaschaKH

Super-Moderator
Teammitglied
Auch für dieses Modell gibt es CF-Root Download und einfacher geht es doch kaum. Ja, für dieses alte Model gibt es leider keine ausführliche Anleitung und ich glaube nicht das sich dies noch ändert. Im Prinzip stehe ich auch hier wieder bei Rooten vom A3 (2017) auch wenn dies sicher nicht zu freundlich gesagt war, der Inhalt ist heute noch so richtig wie damals.
 
R

Richand

Neues Mitglied
Hallo allerseits,

Ich hatte mein 320FL lange mit Magisk gerootet. Jetzt hatte ich es mir zerschossen... Und wollte alles neu aufsetzen.

Also neueste Stock runtergeladen und geflashed. Jetzt wäre es 8, also Oreo. Ich bin mir mir peinlicherweise nicht sicher ob es vorher auch schon Oreo war... Aber ich seh keine Unterschiede. Also vielleicht war es noch 7er. Twrp drauf und versucht Magisk zu flashen.

Leider geht das nicht... Scheinbar gibt es Probleme wegen encrypt... Auch wipen vom Cache und Daten beschwert sich mit encrypt... Kein einbinden.

Daher die Fragen:
- Liegt es an 8.0? Müsste ich alte 7er Stock nehmen?
- Oder habe ich ein encrypt Problem...
- und wie bekomme ich das ggfs gelöst.

Vielen Dank für eure Hilfe!

Richard
 
Oben Unten