[Anleitung][G97xF] Aktivierung des Root-Accounts mit Magisk Manager

  • 314 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung][G97xF] Aktivierung des Root-Accounts mit Magisk Manager im Root / Custom-ROMs / Modding für Samsung Galaxy S10 / S10+ / S10E / S10 5G im Bereich Samsung Galaxy S10 / S10+ / S10E / S10 5G Forum.
S

Skippy64

Erfahrenes Mitglied
Habe es probiert, - keine Probleme.
 
B

beterman1990

Fortgeschrittenes Mitglied
alles klar danke für die info dann ist ja alles wie bei pie dann werde ich mich später mal dran machen =)
 
H

hannsheinz

Ambitioniertes Mitglied
Rooten habe ich nach dem üblichen Procedere (mit Magisk patchen etc.) hinbekommen, aber TWRP nicht. Lief jedes Mal auf einen Bootloop raus.
Viper4Android habe ich zB auch nicht zum Laufen bekommen, auch da gab's Bootloops.
 
Zuletzt bearbeitet:
B

beterman1990

Fortgeschrittenes Mitglied
twrp funktioniert auch noch nicht
 
hanspampel

hanspampel

Ehrenmitglied
hannsheinz schrieb:
aber TWRP nicht. Lief jedes Mal auf einen Bootloop raus.
Das habe ich genau hier 4 oder 5 Posts über deinem geschrieben und auch den Grund dafür genannt.😉
 
pachi81

pachi81

Fortgeschrittenes Mitglied
Ahhh, Hilfe,
ich habe Mist gebaut... Nachdem Flashen mit Odin habe ich unbewusst noch mal auf Starten gedrückt und dann ist nix mehr passiert.
Odin ging nix mehr, das Telefon hat weiterhin den Download Mode mit vollem Balken angezeigt.
Tja nach ewigen Warten habe ich nun den Salat. Das Telefon zeigt nur die Startseite mit der roten Warnung an und ich komme weder in Revocery noch sonst wohin...
Kann ich da irgendwas machen? Oder habe ich jetzt nen teuren Briefbeschwerer???????
Kann mir jemand bitte helfen???

Danke!!!
 
maik005

maik005

Urgestein
@pachi81
Foto??
 
pachi81

pachi81

Fortgeschrittenes Mitglied
@maik005
Sieht so aus:
https://www.androidinfotech.com/wp-content/uploads/2019/04/Samsung-Galaxy-S10-Bootloader-Warning.jpg

Ich vermute, dass das sogar so aussehen muss, aber ich komme nicht weiter. Es reagiert nur auf Bixby+Vol-Down+Power, dann startet es anscheinend neu, aber keine Chance ins Recovery oder Download Modus zu kommen.
Ich könnte vielleicht noch warten, bis der Akku leer ist und dann noch mal schauen, aber das dauert noch etwas...
So was blödes auch, da habe ich mich selten dämlich angestellt...
 
Zuletzt bearbeitet:
Rennert

Rennert

Lexikon
Hatte ich auch mal, musst bissel probieren mit den Tasten und schnell sein.
Power und Vol down drücken und sobald der Bildschirm dunkel wird schnell Vol down und Bixby und Kabel anstecken.
Es klappt vielleicht nicht beim ersten Mal, aber Übung macht den Meister.
 
pachi81

pachi81

Fortgeschrittenes Mitglied
Habe ich schon mehrfach probiert, aber bisher habe ich nur geschafft, dass der Bootloader Unlocked Bildschirm etwas länger bleibt, aber ich werde es weiter probieren, gerade das Kabel gleichzeitig anstecken ist ne Herausforderung...
Danke!!!
 
Rennert

Rennert

Lexikon
Ja ist es, aber nicht unmöglich 😉
 
pachi81

pachi81

Fortgeschrittenes Mitglied
Vielen Dank, das gibt mir zumindest etwas Hoffnung...
 
pachi81

pachi81

Fortgeschrittenes Mitglied
So, ich habe es geschafft. Nachdem das Telefon aus war (Akku leer), habe ich wie folgt eingeschaltet:
Bixby+Volume Down und dann den USB in den PC. Danach gehts sofort in den Download Modus.
Also noch mal neu geflasht und danach versucht in den Recovery zu kommen. Irgendwie will das einfach nicht funktionieren.
Mittlerweile habe ich noch mal die nicht gepatchte Original Version geflasht, dann verschwindet auch die rote Meldung, dass es sich um eine Custom Rom handelt, aber trotzdem keine Chance ins Recovery zu kommen und das Telefon startet auch nicht.
Funktioniert das vielleicht nicht mit Android 10? SamFirm, als auch Frija bieten mir nur die gleiche Android 10 Version für SM-G970F mit DBT an.
Problem, aktuell startet das Telefon nur am USB Port, da der Akku fast leer sein wird.
Also drücke ich Vol-Up+Bixby+Power und stecke den USB Stecker rein, sobald der Bootloader Unlock-Schirm kommt, halte ich nur noch Vol-Up gedrückt. Dann passiert paar Sekunden nix und dann kommt der normale S10e Bootscreen und nix passiert.
Habe ich noch irgendwas entscheidendes übersehen? Habe mir die Anleitung nun schon mehr durchgelesen, kann aber nix erkennen...
Bin für jeden Tipp dankbar!
 
pachi81

pachi81

Fortgeschrittenes Mitglied
Ahhh, es geht!!! Ich habs hinbekommen.
Ich habe die ganze Zeit gedacht, dass der Splash Screen der Bootloader Screen ist und nachdem das Samsung Logo kam habe ich aufgegeben. Tja, nun weiß ich, dass das erst der Splash Screen ist und ich einfach länger halten muss... 😦
Danach konnte ich im Recovery alles löschen und nun startet doch tatsache mein Telefon.
Naja, man sollte sowas vielleicht doch im Weihnachtstrubel machen.
Vielen Dank und euch ein frohes Fest!!!
 
Farron

Farron

Experte
hanspampel schrieb:
3. Magisk Manager über den Canary Channel installieren
Bin am überlegen ob ich mir ein 10 hole und sofort roote. Die Anleitung auf Seite 1 klingt gut, ist übersichtlich und verständlich aber schon beim zitierten Punkt 3 hapert es schon ... "not found" 😟
 
hanspampel

hanspampel

Ehrenmitglied
Moin
Der Dev hat den Link geändert. Habs im OP geändert. Die Stable Version sollte imho reichen.
 
Zuletzt bearbeitet:
O

Osterhazi

Neues Mitglied
Hallo zusammen,

ich habe ein Problem mit meinem S10+.
Das Gerät ist von Anfang an gerootet, gemäß den Anleitungen hier im Forum.
Hat alles auf Anhieb, ohne Probleme geklappt.
Auch Updates haben nie Probleme gemacht, auch das Update auf Android 10 im Dezember nicht.
Jetzt wollte ich wieder das aktuelle Update installieren, jetzt ist plötzlich Root weg, im Magisk Manager steht 'Magisk ist nicht installiert'.
Dann habe ich mir gedacht, daß möglicherweise bei patchen der AP Datei etwas schief gegangen ist, also alles nochmal von vorne:
AP gepatcht, TWRP gepatcht, TWRP in AP eingebaut, flashen, Multidisabler flashen, boot to Recovery(wie hier beschrieben), leider wieder dasselbe.
Bin mir eigentlich ziemlich sicher alles richtig gemacht zu haben.
Habe dann versucht ein Downgrade auf die vorherige Version zu machen, weil ja bis dahin alles funktioniert hat. Die gepatchten(funktionierenden) Dateien hatte ich noch.
Hatte dann zwischenzeitlich das Problem, daß meine Pin nicht akzeptiert wurde, aber das habe ich wieder hinbekommen.
Leider funktioniert Magisk auch nach dem Downgrade nicht wieder, im Magisk Manager steht wieder 'Magisk ist nicht installiert'.
Hat jemand noch einen Tip für mich?

Uwe
 
Farron

Farron

Experte
Moin,
obwohl ich andere Handys habe, habe ich diese Meldung vom MM auch schon gesehen und Root war weg.
Du hast ja eine Menge davon geschrieben, was du getan hast inkl. Downgrade ... nun, mag eine völlig andere Situation sein aber bei mir hat das simple Neuinstallieren von Magisk geholfen.
 
O

Osterhazi

Neues Mitglied
Hallo Farron,
die Situation beim S10 ist tatsächlich anders, das patchen und flashen der Firmwaredateien einspricht der Neuinstallation von Magisk.