Reduzierung der Ladeendspannung bei höheren Ladezyklen

  • 90 Antworten
  • Neuester Beitrag
Diskutiere Reduzierung der Ladeendspannung bei höheren Ladezyklen im Root / Custom-ROMs / Modding für Samsung Galaxy S7 im Bereich Samsung Galaxy S7 (G930F) Forum.
Cloud

Cloud

Senior-Moderator
Teammitglied
Screenshot_20190124-221405_AccuBattery.jpg

Screenshot_20190124-221355_DeviceKeystring.jpg

Zwar nicht ganz 4,35V aber besser als 4,23V wie es bisher war ;)
 
maik005

maik005

Urgestein
@audianer
lies mal die batt_inbatt_voltage aus.
die dürfte 4.35 sein.
Die Apps zeigen immer etwas weniger an, bis du einmal die Datei ausgelesen hast. Dann stimmen auch die Apps - solange du das Gerät nicht neu startest.
 
Cloud

Cloud

Senior-Moderator
Teammitglied
Da steht jetzt grade 422 drin...

Ist aber auch nicht mehr ganz voll ;)
Die 4,285V hatte der Akku übrigens bei 93% erreicht.
 
Zuletzt bearbeitet:
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Danke Cloud!

Also Rooten hat geklappt. Das S7 musste ich zwar komplett zurücksetzen, aber habe noch eine SmartSwitch Sicherung da. Von daher halb so wild. Jedenfalls sagen mir zwei Root Checker Tools, dass es gerootet ist und das SU-Programm ist auch drauf und aktiv.
Einzig, ob ich die OEM-Entsperrung wieder ausschalten soll, ist mir nicht klar. Wenn man diverse Anleitungen googelt, widersprechen diese sich teils.

Was ich mich frage:
Wo finde ich dieses Root-Verzeichnis?
 
Zuletzt bearbeitet:
Cloud

Cloud

Senior-Moderator
Teammitglied
SP-Fotodesign schrieb:
Einzig, ob ich die OEM-Entsperrung wieder ausschalten soll, ist mir nicht klar.
AUF KEINEN FALL!!!!!!
Beitrag automatisch zusammengefügt:

/efs/factoryapp/batt_discharge_level

Root ist das Hauptverzeichniss "/"
 
Zuletzt bearbeitet:
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Ja, das weiß ich. :)
Aber ich bin da wahrscheinlich zu blöd dafür. Ich finde es weder im Smartphone unter Eigene Dateien im internen Speicher, noch im Windows Explorer, wenn ich das SM angeschlossen habe.

Grad kommt auch immer wieder die Meldung vom Security Log Agent, dass nicht authorisierte Vorgänge erfasst wurden und ich das Gerät neustarten solle.
 
Zuletzt bearbeitet:
Cloud

Cloud

Senior-Moderator
Teammitglied
Das findest du nur mit einem Explorer der Root unterstützt.

z.B. Total Comander
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Das probier ich gleich mal. Danke Dir!
Zumindest die Datei lesen, wenn es klappt. Bearbeitet bzw zurücksetzen werde ich sie erst, wenn der Akku nebst Dichtungen da ist.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Alles klar, super! Konnte die Datei finden und es zeigt 70128 an, was 701 Ladezyklen sein müssten. Mit zwei Programmen konnte ich gestern 700 in Erfahrung bringen.
Dann kann ich den Zähler mit dem neuen Akku getrost zurücksetzen. Vielen Dank für die Info!

Gekauft habe ich nun alles bei der Fa. Stellatech, wo man zwischen Originalakku (S7 ohne Edge) (~25€ und Nachbau ~13,50€) wählen kann.
Dazu noch Zwei Klebefolien/Klebedichtung für die Rückseite. Da scheint es eine Dichtung A und B zu geben, sowie eine Klebefolie für den Akku.
Insgesamt habe ich nun 45,64€ bezahlt. Den Tausch nehme ich selber vor.
 
Zuletzt bearbeitet:
Cloud

Cloud

Senior-Moderator
Teammitglied
Super, wir freuen uns immer über Erfahrungsberichte ^^
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Jetzt check ichs. Die Beiträge wurden verschoben. 😅 Und ich dachte mir schon, mein Browser spinnt.
Ich hoffe, dass der Akkutausch genauso gut klappt, wie das softwareseitige rooten und gebe Euch natürlich gerne bescheid. :)

Nochmal kurz zu dem Hinweis vom Security Log Agent, welcher scheinbar vom integrierten McAfee kommt:
Es will immer das Gerät neustarten, um nicht authorisierte Aktionen rückgängig zu machen.
Ich bin grad überfragt. Neustarten muss ich eh irgendwann wieder mal, aber deaktivieren kann man das Ganze scheinbar nicht.
Wird der Root dadurch rückgängig gemacht?
 
Cloud

Cloud

Senior-Moderator
Teammitglied
Ich weiß leider nicht wie du gerootet hast. Aber gut möglich dass das dann wieder weg ist...
 
Zuletzt bearbeitet:
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Gerootet habe ich mit der Autorootanleitung.
Habe jetzt mal neugestartet, dann kann gleich nach dem Androidlogo so eine Art Sim-Sybol auf blauem Hintergrund. Danach ein Neustart mit normalem Boot. Root ist immer noch vorhanden. Sonst keine Änderung.
Meldung ist aber wieder gekommen, nachdem ich PhoneInfo SU-Rechte erteilt habe.
Ich könnte mir vorstellen, das McAfee dies erkennt und als Sicherheitsproblem ausweist.
 
Cloud

Cloud

Senior-Moderator
Teammitglied
Äh... was für ne Android Version? Welche Autoroot Datei?
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Android 8.0.0 (Hatte die letzte offizielle Version drauf)
Autorootdatei von Chainfire: Link

Aber ich glaube, ich habe es herausgefunden.
Eh mit Google habe ich die Lösung hier im Forum gefunden. Da gibts im PlayStore den "Security Log Agent Disabler", welcher den Dienst deaktiviert. Nach einem Neustart ist unter "Gerätesicherheit" nur noch der Schriftzug da. Der Dienst selber scheint nun abgeschaltet zu sein.

Prinzipiell scheint das Ganze von der Schwierigkeit sehr überschaubar, wenn die Anleitung gut passt.
Nur wenn man es das erste Mal macht, wirft es doch einige Fragen auf, aber das meiste ist erlesbar und für die restliche Hilfe bedanke ich mich ganz herzlichst! :)

Ich melde mich wieder, um bescheid zu geben, ob es mit dem Akku geklappt hat - oder nicht. :D
 
Zuletzt bearbeitet:
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Jetzt würde mich noch was technisches interessieren.
Ist das Ganze schonmal nachgemessen worden?

Da es bei meinem Akku jetzt völlig egal ist, wie er behandelt wird, habe ich die Zyklen mal von 701 auf 401 gesenkt. Konnte aber in der vorausberechneten Zeit bis zur vollständigen Ladung keine Änderung feststellen. Ich meine die Ladestromstärke ist um 100mA höher.
Aber das kann auch eine Schwankung sein.

Hat das auch damit zu tun, dass ich das Smartphone an einer Powerbank mit 2A Ausgangsleistung habe? Schnellladen ist am Handy nach wie vor ausgeschaltet.

Ich hätte jetzt mal folgendes probiert. Ich lasse es mal so laden bis es voll ist und setze den Zähler mal auf 0 und schaue, ob dann nochmal was reingepumpt wird.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
@SP-Fotodesign
was für eine Änderung willst du sehen?
Die Auswirkung auf die Ladezeit wird minimal sein - kaum messbar.
Das einzige was du siehst ist die deutlich höhere Lade-End-Spannung.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Genau. Um das geht es mir.
Quasi der 'handfeste' Beweis, dass es auch so funktioniert.
Mit dem jetzigen Akku kann ichs ja machen. Da ist es mir egal ob der jetzt leidet oder nicht.

Ich könnte auch mal ganz legair probieren, die Ladezyklen spaßhalber auf 2000 setzen und den Akku vollzuladen und die Spannung ablesen. Danach den Wert auf 0 stellen und nochmal dranhängen. Das sollte dann für eine größere Spannungsdifferenz sorgen.
 
maik005

maik005

Urgestein
@SP-Fotodesign
genau.
Probier das mal.
fg_inbatt_voltage ist die Datei die dir die aktuelle Spannung in der Batterie anzeigt.
Diese ist i.d.R. etwas höher als die Spannung die du mit den ganzen Apps auslesen kannst.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Genau diese Datei habe schon versucht zu finden. Ich glaube auf der ersten Seite stand da was. Wo finde ich diese?
Im FatctoryApp Verzeichnis ist diese leider nicht bei mir. Sonst schau ich mir das gerne an. :)