Reduzierung der Ladeendspannung bei höheren Ladezyklen

  • 90 Antworten
  • Neuester Beitrag
Diskutiere Reduzierung der Ladeendspannung bei höheren Ladezyklen im Root / Custom-ROMs / Modding für Samsung Galaxy S7 im Bereich Samsung Galaxy S7 (G930F) Forum.
maik005

maik005

Urgestein
@SP-Fotodesign
/sys/class/power_supply/battery/
zumindest beim S8/S9+ (bis einschließlich Android 8)
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Super danke Dir!

Ich habe jetzt mal auf 1401 Zyklen gestellt. Lasse jetzt vollladen und schaue mir die Dazei dann an.
Danach ändere ich mal auf 51 Zyklen und stecke das Ladegerät nochmal an. Habe es nun direkt am Ladegerät. Nicht mehr an der Powerbank.
Danach schaue ich mir die Datei nochmal an, wenn das Phone dann mit geänderten Werten, also den 51 dann dranhängt und vollgeladen ist.

Was meinst du zu der Vorgehensweise?


Edit: die genannte Datei ist da nicht drin, dafür eine fg_full_voltage.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
SP-Fotodesign schrieb:
das ist die Spannung die er erkannt hat als "Akku voll"
Die wird aber gelernt und glaube ich nicht sofort aktualisiert bei jedem Ladevorgang.

Dann nimm z.b. Accubattery (da kannst du gleich die Kapazität während des ladens mit messen) und siehst im "Aufladen" Tab auch die aktuelle Akkuspannung.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Okay. Danke. Falls ich wo einen Denkfehler drin habe, berichtigt mich gerne. :)

Also das Phone ist nun voll aufgeladen.

In der Datei wird mir ein Wert von 42375 angezeigt. Ich denke wie auf der ersten Seite beschrieben dürften das dann 4,2375V sein.

Aida64 zeigt 4,234V an.
AccuBattery: 4,233V

Das Handy hängt noch am Ladegerät.

Was mir aber gleich ins Auge gestochen ist, dass laut AccuBattery der Akkuzustand bzw Gesundheit nun auf 61% gefallen ist, die geschätzte Kapazität auf 1833mAh.

Vorher waren es 81% und etwa 2400-2500mAh.

So, jetzt ändere ich die Zyklen mal auf 51, starte das Gerät neu und hänge es nochmal an.

Edit:

So, Daten geändert.
Der Wert beträgt nun 43500.


Ich lasse grade noch ein paar Mal den 3DMark laufen, damit sich der Akku etwas leert.
Mal schaun vll auf so 60-70% und dann lasse ich nochmal Laden. Melde mich dann später nochmal.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
SP-Fotodesign schrieb:
Also das Phone ist nun voll aufgeladen.
erkennst du an was genau?
charge_now = 0 ?

SP-Fotodesign schrieb:
Was mir aber gleich ins Auge gestochen ist, dass laut AccuBattery der Akkuzustand bzw Gesundheit nun auf 61% gefallen ist, die geschätzte Kapazität auf 1833mAh.
wie viel Prozent hast du am Stück ohne Pause/Geräteneustart/... geladen?
Beitrag automatisch zusammengefügt:

SP-Fotodesign schrieb:
So, Daten geändert.
Der Wert beträgt nun 43500.
heißt also das Ändern der Ladezyklen funktioniert.
Jetzt lass mal den Akku leerlaufen und lade ihn ab <5% wieder voll auf - bis kein Strom (>100mA) mehr in den AKku fließt.
Was sagt AccuBattery dann als Kapazität?
 
Zuletzt bearbeitet:
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Zu 1:

Da habe ich leider net aufgepasst. Habe abgewartet bis die Status LED grün geleuchtet hat.
Charge_now kannte ich nicht.

Zu 2:

Ca 60% Ladung hatte er zu dem Zeitpunkt noch.

Zu 3:

Okay, dann lass ich den Bench bis 5% laufen. Könnte aber sicher ne Stunde oder zwei dauern.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
SP-Fotodesign schrieb:
Habe abgewartet bis die Status LED grün geleuchtet hat.
dann ist er noch lange nicht voll.

SP-Fotodesign schrieb:
Ca 60% Ladung hatte er zu dem Zeitpunkt noch.
dann sagte der Wert fast nichts aus.

Vorschlag:
Ladezyklen auf 51 oder 1401 stellen.
Gerät von <5% bis komplett voll (Strom in den Akku <100mA) aufladen.
Jetzt Spannung und geschätze Akkupakazität in Accubattery im Aufladen Tab auslesen.

Nun machst du das ganze mit dem anderen Wert als vorher nochmal.

Dann kann man auch etwas dazu sagen wie viel Kapazität durch die Reduzierung der Spannung tatsächlich verloren geht.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Puhhh, viel Aufwand. 😅

Da der Akku eh grad geleert wird, stelle ich dann wieder auf 1401 Zyklen um und lade voll bis die Ladeschlussstärke auf unter 100mA ist.
Dann das selbe mit 51 Zyklen.

Denke aber, dass ich mich dazu erst morgen melden werde.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Mich wunderts, dass das noch keiner gemacht hat.
Naja, irgendwann ist immer das Erste Mal. 😅
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Sodala, bin nun mit den Tests durch.

Was mir auffiel, erstmal vorweg: Vor dem Rooten (und der Neueinrichtung) sagte mir AccuBattery einen Akkuzustand von 81% und ich glaube so 2400-2500mAh Restkapazität.

Zum Test:

Voreingestellt für beide Durchgänge:
- Jeweils am Samsung Schnellladegerät (9V @ 1,67A bzw 5V @ 2A) geladen...
- ... bis die Laderate auf 0mA bis zur Ladungserhaltung gefallen war.
- Schnellladen am Smartphone ausgeschaltet
- Original Samsungladekabel, welches damals beim S7 dabei war
- Akkuwerte über AccuBattery ausgelesen. (Zusätzlich habe ich auch bei Aida64 die Spannung abgelesen)


Durchgang 1:

- System eingestellt auf 1500 Zyklen
- Akku bis auf 5% entladen, anschließend geladen.

Ergebnis 1:

- fs_full_voltage: 42375
- Akkuzustand: 66%
- geschätzte Kapazität: 1970mAh
- Akkuspannung bei voller Ladung: 4,199V

Durchgang 1:

- System eingestellt auf 50 Zyklen
- Akku bis auf 5% entladen, anschließend geladen.

Ergebnis 1:

- fs_full_voltage: 43500
- Akkuzustand: 69%
- geschätzte Kapazität: 2082mAh
- Akkuspannung bei voller Ladung: 4,345V


Nicht viel Unterschied, finde ich.
Ich denke, dass das ganze sehr schwierig zu messen ist und die Programme nicht wirklich stimmen.
Vor allem zeigte mir AccuBattery vorher deutlich bessere Akkuwerte an.

Ich denke, was letztendlich bleibt, ist schlicht und einfach der subjektive Eindruck nach dem Akkuwechsel und evtl bei ähnlicher Nutzung wie vorher über die DOT Rückschlüsse auf den neuen Akku ziehen, was ich auch machen werde, wenn er da ist.

Ich weiß noch, wie das S7 damals neu durchgehalten hat und wie lange ich mit einer Akkuladung auskam.
Daran werde ich mich orientieren, wenn der neue Akku (erfolgreich) verbaut und eingefahren ist.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
@SP-Fotodesign
Es ist also noch der alte Akku?!
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Natürlich. Habe ich ja etliche Posts vorher schon geschrieben.
 
Cloud

Cloud

Senior-Moderator
Teammitglied
Ist es dann nicht logisch dass da kein großer Unterschied ist?

Du pumpst ja nur mehr Energie in einen alten Akku der nicht mehr seine volle Kapazität hat.

Das zurücksetzen macht ja nur Sinn wenn man einen neuen Akku drin hat....
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Das hättet ihr aber auch gleich schreiben können... Zeit verschwendet...
 
Cloud

Cloud

Senior-Moderator
Teammitglied
Cloud schrieb:
Achtung!
1. Bitte nicht den Wert zurücksetzen wenn ihr den Akku nicht getauscht habt. Wir wissen nicht wie sich ein alter Akku verhält der wieder ganz voll geladen wird.
Noch deutlicher hätte ich es in meiner Anleitung nicht schreiben können....
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Ja, ich denke mal, dass das auf einen evtl. Schaden hin gemeint war, den ein alter Akku nehmen könnte. Aber da mir der grade verbaute Akku egal ist, ob der nun seinen Geist aufgibt oder nicht, habe ich es gemacht.

Aber prinzipiell kann man sagen, dass man es auch nicht gewiss sagen kann, ob das Ganze auch bei einem neuen Akku funktioniert oder nicht, da es sich kaum bis gar nicht nachweisen lässt.

Genauso könnte es sein, dass die Funktion nicht zum Schutz des Akkus gemacht worden ist, sondern der Obsoleszenz wegen.

Zb bei meinen Kameraakkus: Die werden immer randvoll geladen. Egal wie alt die sind. (Mit Multimeter nachgemessen).
Habe auch ältere, die schon 6-7 Jahre alt sind. Da klappt das auch.

Also wenn ihr mich fragt, ist diese Funktion nicht zum Schutz des Akkus, sondern, damit das Gerät nach einer gewissen Zeit einfach abgestoßen werden soll.

Werde dann den neuen Akku einbauen und gut ist.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
SP-Fotodesign schrieb:
Aber prinzipiell kann man sagen, dass man es auch nicht gewiss sagen kann, ob das Ganze auch bei einem neuen Akku funktioniert oder nicht, da es sich kaum bis gar nicht nachweisen lässt
Klar lässt es sich nachweisen.
Hast du doch gezeigt.

SP-Fotodesign schrieb:
Genauso könnte es sein, dass die Funktion nicht zum Schutz des Akkus gemacht worden ist, sondern der Obsoleszenz wegen.
Eher das Gegenteil.
 
S

SP-Fotodesign

Fortgeschrittenes Mitglied
Naja, 100mAh ist schon wenig.
Das kann auch ein Messfehler sein. Ich glaube, man müsste das Ganze extern messen um genauere Werte zu erhalten.

Aber dass sie die Ladespannung senken, kommt mir schon arg komisch vor.
Voll geladen habe meine Kameraakkus und meine Eneloopakkus immer die dieselbe Spannung und auch wenn ein paar schon echt alt sind, funktionieren sie noch tadellos. Klar haben die auch nachgelassen, aber das Ganze ohne die Spannung zu senken und gute Kameraakkus kosten auch 20-30€. (Ich rede hier nicht von VHBW usw.. Diese Billigheimer kann man vergessen)

Bin schon auf den neuen Akku gespannt. :)
 
B

borg17a

Erfahrenes Mitglied
@SP-Fotodesign Cool, dass du das mal mit dem alten Akku getestet hast. Hätte es was gebracht, hätte ich einen Grund mehr, mein Handy zu rooten. Bin mit roundabout 3 Std. DOT eigentlich ganz zufrieden nach so vielen Jahren.