Aktivierung des Root-Accounts beim Xcover 2

  • 490 Antworten
  • Neuester Beitrag
Diskutiere Aktivierung des Root-Accounts beim Xcover 2 im Root / Custom-ROMs / Modding für Samsung Galaxy Xcover 2 im Bereich Samsung Galaxy Xcover 2 (S7710) Forum.
F

Funni

Gast
Na dann hab Freude mit deinem Xcover und bade es nicht zu viel :D
 
T

TheBoegl

Fortgeschrittenes Mitglied
email.filtering schrieb:
Die zweite Partition der Speicherkarte wird Dir Windows nie freiwillig anzeigen; unter anderem deswegen, weil es das dort verwendete Dateisystem nicht kennt.
Per PTP kann ich auf meine ext4 formatierte SD-Karte zugreifen, ergo liegt die Anzeige "nur" an dem intern verwendeten Dienst zum Anzeigen der Daten.
Mir erschließt sich allerdings der Grund nicht, wofür man auf die /data/sdext2 zugreifen sollte. Auf /data will dies ja aus Sicherheitsgründen auch keiner...

Funni schrieb:
Also ich glaube in der Vold.fstab in /system ist die Mountingtabelle kaputt.
SD-Karten werden in Android nicht nur per mount bzw. vold gemountet sondern danach per FUSE mit
Code:
/system/bin/sdcard /storage/sdcard0 1000 1015
geladen. 1000 entspricht der uid von system und 1015 der gid von media_rw bzw. sdcard_rw.
 
E

email.filtering

Gast
Du kannst per PTP vom großen, Windows-betriebenen Computer nativ auf einen ext4-formatierten Datenträger zugreifen? :confused:
 
T

TheBoegl

Fortgeschrittenes Mitglied
Ja - da war ich selbst erstaunt.
Es war auch Zufall, dass ich vor Windows saß und das S7710 zufällig am Hub angesteckt war.
 
G

gloeckge

Neues Mitglied
hallo!
Ich sitze inzwischen die ganze Nacht an diesem Problem.
Vielleicht kann wer helfen!

Ich nutze das Mac OS und verwende daher VMWare um mit dem emulierten Windows XP mittels ODIN 3.10 meinen Androiden zu flashen.
XXAMB6
Die Buildnummer war vor meinen Versuchen zu flashen: XXANI3

Habe es zuerst mit der DEOEXED und später mit der ODEXED versucht.

Bis 12. klappt (meiner Meinung nach) alles. Bei ODIN 3.10 heißt der Button nicht mehr PDA sondern AP.

Nachdem ich das File S7710XXAMB6_S7710OXEAMB3-20130713.tar.md5 (also die DEOEXED) gewählt habe und start geklickt habe erfolgt ein Neustart.

Bei Punkt 14 (Fehlermeldung) steht dann bei mir nicht nur
E:signature verification failed

sondern

E:failed to verify whole-file signature
E:signature verification failed

nun wähle ich im Minibetriebssystem noch wipe cache partition
und anschließend
reboot system now

Aber habe noch immer keine Root-Rechte am Gerät.


Hier die komplette Message von Odin 3:
<ID:0/003> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> S7710XXAMB6_S7710OXEAMB3-20130713.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> SingleDownload.
<ID:0/003> boot.img
<ID:0/003> NAND Write Start!!
<ID:0/003> cache.img
<ID:0/003> hidden.img
<ID:0/003> modem.bin
<ID:0/003> STE_boot1.img
<ID:0/003> STE_boot2.img
<ID:0/003> system.img
<ID:0/003> RQT_CLOSE !!
<ID:0/003> RES OK !!
<ID:0/003> Removed!!
<ID:0/003> Remain Port .... 0
<OSM> All threads completed. (succeed 1 / failed 0)
 
Zuletzt bearbeitet von einem Moderator:
T

TheBoegl

Fortgeschrittenes Mitglied
Laut Log wird alles passend geflasht. Wie hast du die Root-Rechte getestet?
 
G

gloeckge

Neues Mitglied
Ok, du hattest recht! Habe Root-Rechte; zumindest Root Checker Basic behauptet das!
 
Zuletzt bearbeitet von einem Moderator:
N

Nagelwerk

Neues Mitglied
Hallihallo!

Ich habe gerade mit Kingo ROOT den Root-Account aktiviert; angeblich ist das Ding durch.

Jetzt habe ich folgendes Problem: Ich kann über den Anwendungsmanager keine vorinstallierten Apps deinstallieren.

Kann mir mal einer sagen wo ich den Fehler gemacht habe?

Danke schon mal!


P.s.: Benötige ich SuperSU Pro dafür?
 
Zuletzt bearbeitet von einem Moderator:
F

Funni

Gast
Hast du einen SU manager (Super SU oder Superuser) installiert? Ohne den bringt dir root nix, da eine APP das ganze ja verwalten muss mit Zugriff und co.
https://play.google.com/store/apps/details?id=eu.chainfire.supersu
Edit: bekommst du ein Fenster mit einer Abfrage "Möchten sie dieser APP root rechte gestatten" oder ähnliches?
 
N

Nagelwerk

Neues Mitglied
Ich muss auch sagen, dass Kingo ROOT für einen technisch in der Vergangenheit Lebenden wie mich echt eine Rettung ist!
 
Zuletzt bearbeitet von einem Moderator:
S

Suomi74

Neues Mitglied
Das Xcover 2 steht nicht auf der Kompatiblen-Liste. Es hat bei dir aber gefunkt, oder?

LG, Suomi74
 
Zuletzt bearbeitet von einem Moderator:
N

Nagelwerk

Neues Mitglied
einwandfrei auf anhieb!
 
M

meschi

Neues Mitglied
Ich habe im Forum "Aktivierung des Root-Accounts beim Xcover 2" von einem User gelesen, der sein Xcover 2 mit Kingo Root gerootet hat. Ich dachte mir, das wäre am einfachsten und wollte es ihm gleich tun. Nun zeit das Smartphone seit längerem "Downloading... Do not turn off target!!" an und Kingo Root meint "Waiting for device". Es geht offenbar gar nichts mehr. Jetzt weiß ich nicht, was ich tun soll? Wenn ich die Verbindung zum PC trenne wird's wohl futsch sein?!

Wie lange hat das denn gedauert? Bei mir steht jetzt schon ewig lange "Downloading... Do not turn off target !!!" auf dem Smartphone Screen.

Ist das Rooting da schon in der heißen Phase? Wie reagiere ich richtig, wenn die Anzeige nicht ändert?
 
Zuletzt bearbeitet von einem Moderator:
M

mknaus

Neues Mitglied
Habe das gleiche Problem.
Handy steht schon ne halbe Stunde auf Download und nix passiert.
Hab auch den Kingo Root verwendet.
 
Ice23

Ice23

Stammgast
Anscheinend ist Kingo-Root (mir nicht bekannt ) Glücksache .

Nutzt doch einfach die Schritt für Schrittanleitung auf der ersten Seite .
Tragt in Odin (ab 3.09 unter AP ) euer ausgewähltes vorgerootetes Image ein .

Eure Entscheidung :
- Wollt ihr nur Root mit der "aktuellsten JB 4.1.2" , dann nehmt die XXAND2 .
- Wollt ihr Root und evtl. anschließend auf Vanir KK 4.4.4 , dann nehmt die XXAMB6 . (Nur diese ist mit Vanir kompatibel)
 
5n00p3r

5n00p3r

Erfahrenes Mitglied
Was auch noch wichtig zu erwähnen ist:
Keinen USB Hub benutzen! Damit funktioniert das Flashen nicht bzw. äußerst selten. Die beste Wahl ist ein USB Anschluss auf der Rückseite (direkt am Mainboard) bzw. direkt am Laptop.
Hat das Flashen bei euch denn schonmal geklappt oder ist es ein Erstversuch?
 
M

mknaus

Neues Mitglied
Also bei mir war es der erste Versuch!
Ich bin außerdem absoluter Anfänger in diesen Dingen und dachte daß das mit Kingo-Root der einfachere Weg ist.
Weiter oben hat ja jemand beschrieben, daß das funktioniert hat.
Aber ich werde dann wohl doch versuchen zu verstehen wie das mit Odin geht :confused2:

Danke und Gruß Michael

PS: Melde mich wieder wenn ich's nicht kapiere:winki:
 
H

holzwurm1971

Neues Mitglied
Juten Tach,
ich besitze ein Samsung Xcover2 und finde das Teil immer noch klasse. Aufgrund der bekannten Problematik mit dem zu kleinen Speicher möchte ich das Teil gern rooten, bin aber zu doof dazu...
Kann einer von euch Cracks hier mal eine Anleitung raushauen, die auch von Dummies wie mir in die Tat umgesetzt werden kann?
Ich wäre zu großem Dank verpflichtet!
 
5n00p3r

5n00p3r

Erfahrenes Mitglied
Hallo Holzwurm.
Woran hakt es denn bei dir? Die Anleitung ist für mich vollständig, deshalb finde ich gerade keinen Ansatzpunkt. Das Flashen (der hier erforderliche Vorgang zur Aktivierung des Root-Accounts) des Xcover 2 ist verhältnismäßig simpel. Es wird ja schlicht die vorhandene Software (Betriebssystem) überschrieben.
Die Vorarbeiten können durchaus umfangreich ausfallen (Sichern von Kontakten, Daten, Bildern...), sind aber unvermeidlich, sofern du an deinen Daten hängst.

Grüße
5n00p3r
 
G

Glas

Neues Mitglied
Mein XCover 2 habe ich mit diesem Root lt. Anleitung und Link2SD genutzt. Ich möchte es nun verkaufen, wie setze ich das Gerät wieder auf die original FW zurück?