A2Lite rooten / xposed / Magisk

  • 111 Antworten
  • Neuster Beitrag
Max Mustermann

Max Mustermann

Experte
November Update? hab nichts bekommen...
 
H

harv

Erfahrenes Mitglied
Threadstarter
Geduld Brauner, kommt schon noch ;)-old. Vielleicht machen die das ähnlich wie Samsung, dass die Updates nach Chargen/Herstellungsdatum/Countrykennung ausgeliefert werden.

Vermutlich wird man es in spätestens 2 Tagen als DIFF bei XDA finden können; immer brauchbar für die manuelle Installation via fastboot, wenn was schiefgeht mit OTA.

[Nachtrag]
Ähh- 9.6.10 ist schon jetzt auf XDA verfügbar, war ich mit meiner 2 Tage-Schätzung etwas daneben :rolleyes2:
Wenn du es also nicht abwarten kannst..... Allerdings wird dort auch von Problemen mit dem Update berichtet, scheint aber auf bestimmte Sprachen/Simcards beschränkt zu sein.
Bei mir funktioniert bisher alles normal (dualsim mit O2 + VF), beide mit PIN gesichert.
 
Zuletzt bearbeitet:
F

fraggix

Fortgeschrittenes Mitglied
November Update hier auch sauber durchgelaufen.
 
R

ralle77

Fortgeschrittenes Mitglied
Hallo zusammen,

ich habe die Schritt-für-Schritt-Anleitung von @PC295 befolgt und komme auch in das temporär gebootete TWRP-Image.
Doch dann zeigt es mir die beiden zip-Files nicht an, die ich vorher per Dateiübertragung vom PC aus auf das Handy kopiert habe.
Sprich: /sdcard ist "leer".
Muss ich da noch irgendwas mounten oder woran liegt das?

Habe mir jetzt erstmal mit dieser Anleitung [GUIDE] Install Magisk with proper support for OTA updates das magisk-gepatchete boot.img draufgepackt, aber TWRP wäre schon schön.

Ich hoffe, Ihr könnt mir helfen :)

VG
 
H

harv

Erfahrenes Mitglied
Threadstarter
Imo musst du NACH dem booten von twrp das twrp.zip mit adb aufs phone pushen. Aber was will man mit einem twrp, bei dem backup/restore nicht zu nutzen sind? Zudem OTA damit auch nicht mehr geht.
 
R

ralle77

Fortgeschrittenes Mitglied
Ok, das ist natürlich bescheiden ;-)
Was ist denn dann die sinnvollere Lösung?
Die gepatchete boot.img von xda?
Oder gibt's keine "Dauerlösung" für normales OTA-Verhalten?
 
PC295

PC295

Erfahrenes Mitglied
Die TWRP-Version kann man derzeit vergessen.
Für Root kannst du die gepatchte boot.img von XDA nehmen (auf Versionsnr. achten!) oder mit Magisk selber patchen (wie in Anleitung beschrieben).

für OTA-Updates muss dann das originale Boot-Image geflasht werden.
Wenn mit Root jedoch weitere Systemmodifikationen durchgeführt wurden, funktioniert das automatische OTA-Update jedoch auch nicht.
 
R

ralle77

Fortgeschrittenes Mitglied
Alles klar, da weiß ich Bescheid.
Vielen Dank!
 
V

vapor_s04

Erfahrenes Mitglied
Könnt ihr mir helfen. Irgendwie steht ich aufm Schlauch. Was meint die XDA Anleitung mit folgendem: move to the directory where the Android platform tools are placed and unlock the bootloader with the following command.

In welches Verzeichnis muss ich denn jetzt?!
 
H

harv

Erfahrenes Mitglied
Threadstarter
na in das, in dem du die tools entpackt hast (wo adb.exe, fastboot.exe drin sind, bzw. deren Linux-Varianten)
 
V

vapor_s04

Erfahrenes Mitglied
Danke für die Hilfe. Habe es eben hinbekommen gehabt und konnte mit Magisk auch Rechte an Adaway verteilen. Auf einmal schaue ich bei Magisk rein und da sagt er mir , ich hatte Magisk nicht installiert? Eine Idee an was das liegen könnte? Es ging ja alles.

Edit: Neustart erforderlich. Und wieder ist Magisk nicht mehr installiert und ich müsste das Boot Image flashen. Was mache ich falsch?
 
Zuletzt bearbeitet:
H

harv

Erfahrenes Mitglied
Threadstarter
Du sollst das bootimage nicht flashen, sondern nur davon booten! Wenn du das modifizierte image geflasht hast, erstmal das originale flashen. Und dann magisk die Installation überlassen.
 
V

vapor_s04

Erfahrenes Mitglied
Ja .Sorry . Hab mich falsch ausgedrückt. Hab natürlich über fastboot boot patched.img gebootet. Hab es jetzt nochmal neu gemacht und hoffe jetzt das es hält. Ich hab Mal Magisk Hide deaktiviert, das wurde bei XDA auch als Fehlerquelle betitelt.
 
H

harv

Erfahrenes Mitglied
Threadstarter
Das Hide hatte ich noch nie aktiviert. Mag sein...
 
V

vapor_s04

Erfahrenes Mitglied
Weiter gehts. Ich hab bei Magisk jetzt mal paar Module durchgeschaut, und da war u.a. ein YouTube Mod dabei. Installiert, und Handy neugestartet. Jetzt hänge ich im Bootloop fest. :-( Habt ihr eine Idee was ich machen kann? In Fastboot komm ich nach wie vor problemlos rein.

Edit: Hab es hinbekommen, musste das gepatchte Boot.img erneut über fastboot booten. Total komisch. Ganz warm werde ich nicht mit der Magisk Geschichte. Funzt bei euch Adaway einwandfrei? Ich hab das Gefühl Werbung in Apps taucht sporadisch ab und an immer noch auf.

Wie seid ihr vorgegangen? Einfach im Magisk-Manager die Systemlosen Hostdateien aktiviert und dann Adaway die neuste APK runtergeladen, installiert, und gestartet, oder? Danke für die Hilfe.
 
Zuletzt bearbeitet:
H

harv

Erfahrenes Mitglied
Threadstarter
zu deiner Frage nach adaway-Installation: Ja
Und natürlich kann eine App noch Werbung anzeigen, wenn der Host in den adaway-Listen nicht bekannt ist. Ich habe zusätzlich afwall installiert, und bei mir bekommen nur Apps Internetzugang, die ich entsprechend benötige. Uhren, Wecker, Office gehört da bestimmt nicht zu.

PS: Falls mal gar nichts mehr geht, sieh mal hier: Anleitung: Manuelles OTA-Update.

Damit solltest du das A2 wieder zum Laufen bringen können ohne Datenverluste (auch wenn da OTA im Titel steht). Wenn das nicht hinhaut wird es haarig.
 
V

vapor_s04

Erfahrenes Mitglied
Ist es bei euch auch so, dass jeder reboot in einem bootloop endet? Ich muss ernsthaft jeden Reboot über das gepatched Boot.img durchführen.
 
PC295

PC295

Erfahrenes Mitglied
Du musst nachdem start die Magisk Manager App öffnen und auf "Installieren -> Installieren -> "Direkt installieren (empfohlen)" gehen.
 
S

scottel

Neues Mitglied
Hallo zusammen,

ich bin absoluter Xiaomi-Neuling ( habe vorher immer Galaxy's gehabt ), kenne mich aber grundsätzlich mit root aus.

Mein MI A2 lite habe ich seit 1,5 Wochen, ich habe es erfolgreich mit Magisk gerootet.

Es zeigt mir Android 8.1.0 an, mit Stand der Sicherheitsupdates vom 01.11.2018. Wenn ich manuell nach Updates suche heisst es dass das System auf dem neuesten Stand ist. Bin ich von dem OTA-Problem betroffen oder kann es sein dass bei mir noch kein Update angekommen ist?


Wie äussern sich die Update-Problem?
Werden die Updates angezeigt aber nicht installiert oder ist es so wie bei mir dass mir angezeigt wird das alles ok ist?
Bei Samsung kenne ich das so dass es eine Meldung gab dass das System verändert wurde ich deshalb nicht installiert werden kann.

Sorry für die vielen Fragen, auch dafür wenn einige vllt. schon mal gestellt wurden.

Gruß

Thomas
 
H

harv

Erfahrenes Mitglied
Threadstarter
OTAs können runtergeladen aber dann nicht installiert werden. Es scheint noch keine neues Update zu geben, bin auch auf dem Stand. Die beiden vorherigen OTAs liefen ohne Probleme bei korrekter Vorgehensweise mit Magisk.
 
Ähnliche Themen - A2Lite rooten / xposed / Magisk Antworten Datum
0
Ähnliche Themen
Keine Schreibrechte als root
Oben Unten