[Diskussion] Root + CWM Recovery + Systemapps entfernen + Auslieferungszustand

  • 451 Antworten
  • Neuester Beitrag
Diskutiere [Diskussion] Root + CWM Recovery + Systemapps entfernen + Auslieferungszustand im Root / Hacking / Modding für Huawei Ideos X3 im Bereich Huawei Ideos X3 (U8510) Forum.
P

peter37

Neues Mitglied
Windows XP: Verschiedene Treiber und beim Flashen des Images endet es mit einem BSOD (Bug Code USB Driver).

Windows 2000: Der Treiber aus der Treiber.zip funktioniert; die Befehle "erase" oder "reboot" (fastboot.exe) funktionieren ebenfalls, nur beim "flash" bricht es mit "too many files open" oder "too many links" ab.

Ubuntu 12.04: "reboot" und "erase" funktionieren, "flash" bricht mit "value too large for defined data type" ab.



Der Zugriff auf das Gerät als Massenspeicher und mittels USB-Debugging (adb.exe) funktioniert unter jedem OS problemlos.

Was mir aufgefallen ist: Per "adb devices" meldet sich das Gerät mit einem Hex-String (denke das ist normal); bei "fastboot devices" bekomme ich jede Menge Fragezeichen als Gerätenamen.
 
ElTonno

ElTonno

Experte
was möchtest du denn bei "flash" eintippen??
bzw. welchen Befehl tippst du ein?
 
P

peter37

Neues Mitglied
Das was in der Batch steht (fastboot flash recovery recovery.img).
 
Andy

Andy

Ehrenmitglied
Entferne mal den Akku vom X3, warte einige Sekunden bis du den wieder einlegst. Dann startet du mit der Tastenkombi in den Fastboot und wartest bis du beim Logo hängst. Stecke erst dann das USB-Kabel an. Vlt. hilfts.

Das Problem haben andere auch: http://forum.xda-developers.com/showthread.php?t=478820

- anderes USB-Kabel probieren oder Port
USB 1.1 oder 2.0?
 
ElTonno

ElTonno

Experte
beim Versuch das Recovery zu flashen startet da dein Handy auch in den fastboot-Modus?
 
P

peter37

Neues Mitglied
Ein anderes Kabel habe ich nicht.

Akku raus, warten, rein; Tastenkombination (Ein + Vol-) für 10 Sekunden drücken und anschließend Kabel anschließen - so bin ich praktisch immer vorgegangen.


So, jetzt habe ich meine Tastatur abgezogen und das Handy dort angeschlossen. Treiber hat es neu installiert und die Batch lief in einem Rutsch durch (es hat also funktioniert). Ziemlich krass, obwohl ich schon mal einen anderen Port probiert hatte und meiner Meinung nach die Ports alle am selben Controller hängen.

Danke!
 
Louvre20009

Louvre20009

Neues Mitglied
Hi ,

mir brummt schon der Kopf vom lesen und nicht verstehen.

Ich weiß der Thread schon sehr lange on ist aber ich habe jetzt nen problem mit meinem X3.

Habe soweit ich gelesen hab alles gemacht bis auf den Explorer da er geld kostet hab ich den nicht geladen und dachte das ich dann mit MPE auch daten aus dem System löschen kann aber puste kuchen es hat nichts geklappt. Naja jetzt wollte ich das ding wieder auf Auslieferung zurücksetzten und komme da nicht weiter.

Ich kann leider nichts finden (bis Seite 21) was mir dabei hilft es wieder so zurück zu setzten wie ich es gekauft habe.

Es gab zwar hier ein paar Links aber diese sind nicht mehr Zugänglich. Ich woltle daher mal fragen ob mir einer Helfen kann es wieder so hin zu bekommen sprich also:

das einer was hochläd was mir dabei hilft uns es so gut wie es gut zu beschreiben wie ich es dann machen muss denn ich habe echt keinen durch blick mit dem was hier so rumgeschmissen worden ist.

Ich bitte euch HELFT MIR HELFT MIR HELFT MIR.

Bedanke mich schon mal im Vorraus für die Hilfe.

P.S.: ICH BIN ECHT VERZWEIFELT!!!!!!!!!!!
 
Louvre20009

Louvre20009

Neues Mitglied
Erstmal Danke für die schnelle Antwort, aber ich muss sagen das ich am anfang nirgends gelesen hab das man ein Backup machen soll mit CWM das hab ich erst gesehen als ich bei dem Schritt angekommen bin: Zurück zum Auslieferungsstand.

Und desweiteren wurde hier geschrieben das man es mit den Daten die dort angegeben worden sind nicht wieder in den Ori stellen kann da es mit der recovery.img nicht klappt, es wurde ja dann irgendwie doch mal geschafft es wieder so hinzubekommen wie es war aber das is ja off.

Das mit dem Rom zu 2.3.5 hört sich gut an wenn ich das geladen habe wie gehe ich dann weiter vor? gibt es dazu eine Anleitung wie ich das mache oder muss ich in Foren suchen wie das geht?
 
STEFANPEPE

STEFANPEPE

Experte
hallo zusammen!
ich habe mir die cyanogen 7.0.2 RC1 geflasht laüft auch alles super .
leider komme ich nicht mehr ins recovery rein .
weder über die tastenkombi noch vom recovery manager.
wie kann ich denn die recovery jetzt noch mal flashen .
ich komme nämlich auch nicht mehr in den fastboot modus .
wäre echt super wenn mir da jemand einen tipp geben könnte.
gruß stefan
 
Andy

Andy

Ehrenmitglied
Normalerweise ist eine Anleitung dabei, aber auf die Kürze.

Die .zip entpacken und auf die Speicherkarte die update.app in den Ordner "dload" kopieren. Der Ordner muss selbst angelegt werden.

Danach hältst du beide Lautstärketasten gedrückt und betätigst die Einschalttaste. Diese auch gedrückt halten. Dann müsste kurz drauf nen Screen erscheinen, wo er "updatet".

Edit: Richtig war für louvre bestimmt. Haben uns wohl überschnitten.^^
 
Zuletzt bearbeitet:
STEFANPEPE

STEFANPEPE

Experte
wow das ging ja echt flott :scared:
danke für deine schnelle antwort.
du meinst die zip oder ?
RecoveryClockmodByZaDkYn.zip
 
R

Ryuk

Experte
das war bestimmt auf louvres post bezogen...

flash doch die recovery nochmal so, wie du sie vorher geflasht hast...also per fastboot nehm ich an...
 
Andy

Andy

Ehrenmitglied
STEFANPEPE schrieb:
hallo zusammen!
ich habe mir die cyanogen 7.0.2 RC1 geflasht laüft auch alles super .
leider komme ich nicht mehr ins recovery rein .
weder über die tastenkombi noch vom recovery manager.
wie kann ich denn die recovery jetzt noch mal flashen .
ich komme nämlich auch nicht mehr in den fastboot modus .
wäre echt super wenn mir da jemand einen tipp geben könnte.
gruß stefan
Gehe ich richtig davon aus, dass du übern den ROM Manager die Recovery flashen willst bzw. darin booten? Wenn ja wäre das falsch, da der ROM Manager das U8510 nicht unterstützt aber das U8150.
 
STEFANPEPE

STEFANPEPE

Experte
hat sich erledigt habs hinbekommen .
hab die zip nochmal gefasht und jetzt gings
danke nochmal
gruß stefan
 
Diamond-X

Diamond-X

Experte
Louvre20009 schrieb:
Erstmal Danke für die schnelle Antwort, aber ich muss sagen das ich am anfang nirgends gelesen hab das man ein Backup machen soll mit CWM...
Das sollte selbstverständlich sein...
 
Louvre20009

Louvre20009

Neues Mitglied
Echt ein riesen DANK an alle

Mein Ideos hat jetzt 2.3.5 Android und somit ist alles andere weg von dem was ich vorher getan habe. Jetzt startet es auch schneller was mich gewundert hat aber nun muss wohl so sein.

Ja da war eine Anleitung mit drin, mit der hab ich das System auch aufgespielt was mich dabei gewundert hatte ist das in der Anleitung steht dass das Handy neu startet (bei mir hat es 2 neu gestartet und beim 3 mal ist es dann komplett hichgefahren) und das man dann den 2 Ordner auf der SD-Card machen soll und dann nochmal aktualisieren soll das wollte ich auch so machen aber das Handy schreibt das es keine Aktuallisierung finden kann.

Hatte das jemand von euch auch so gehabt oder hat es bei euch so geklappt wie in der Anleitung steht?

Der ursprüngliche Beitrag von 14:07 Uhr wurde um 14:12 Uhr ergänzt:

Diamond-X schrieb:
Das sollte selbstverständlich sein...
Sorry aber ich habe von sowas keine ahnung und ich bin neuling in solchen sachen daher wäre es vllt besser es für neulinge reinzuschreiben das man das vorher unbedingt machen sollte.

Es sollte auch von mir nicht BÖS gemeint sein nur ich wusste das nicht und habs daher auch nicht getan. aber jetzt funtz es wieder und ich bin glücklich.
 
Diamond-X

Diamond-X

Experte
icho40 schrieb:
Welche Version von Linux hast du denn? Ab z.B. Ubuntu 12.10 Quantal ist das SDK nicht mehr notwendig. Fastboot wird dort mit der Konsoleneingabe "sudo apt-get install android-tools-fastboot" installiert. Und kann in jedem Pfad ausgeführt werden.