Internetverbindung per USB-Tethering oder doch per USB-Modem?

  • 397 Antworten
  • Neuester Beitrag
Diskutiere Internetverbindung per USB-Tethering oder doch per USB-Modem? im Samsung Galaxy (I7500) Forum im Bereich Weitere Samsung Geräte.
Thyrion

Thyrion

Ehrenmitglied
Er meint: Einstellungen -> Anwendungen -> Entwicklung -> USB-Debugging
 
F

Fege

Neues Mitglied
da der einstiegsbeitrag noch nicht editiert wurde, frage ich mal einfach ganz dumm inne runde: wie funktioniert tethering mit windows vista ? o2 connection manager wurde ja schon erwähnt, aber für win-vista/I7500 gibts nix, nur für andere samsunghandys... oder geht das auch völlig anders ?
 
Thyrion

Thyrion

Ehrenmitglied
Ich habe es eben mal mit Bordmitteln von Windows XP versucht. Hat funktioniert, hat aber den gleichen Wackeleffekt wie schon unter Linux hier mehrfach berichtet.

Folgendes habe ich gemacht (die Daten hab ich aus dem Linux-Schwester-Thread übernommen):
  • Das Samsung Mobile Modem wurde bei mir ohne Probleme erkannt, als ich das Handy via USB angeschlossen habe. Also habe ich nun über den "New Connection Wizard" eine neue Verbindung hinzugefügt.
  • Verbindung zum Internet -> Manuelles Einrichten -> Über Modem verbinden
  • Name kann frei gewählt werden (ich hab "O2" genommen)
  • Telefon-Nummer: *99#
  • Benutername: Internet / Passwort: O2

Als ich mich dann eingewählt habe kam das hier bei heraus:







Edit: Bei meinen Wiederholungen kam er dann bis "Verifying user name and password" oder "Registering your computer on the network" bevor ein Timeout auftrat. Also irgendwas läuft noch nicht rund.
 

Anhänge

P

Psycholein

Stammgast
Thyrion schrieb:
Edit: Bei meinen Wiederholungen kam er dann bis "Verifying user name and password" oder "Registering your computer on the network" bevor ein Timeout auftrat. Also irgendwas läuft noch nicht rund.
bei mir das gleiche, aber nun schon deutlich besser als mit Auslieferungsfirmware, da hatte ich in 20% der Fälle oder weniger Erfolg
 
Melkor

Melkor

Senior-Moderator
Teammitglied
Irgendwie klappt das bei mir auch nach 20 Versuchen nicht. Bekomm immer eine Fehlermeldung, dass was mit der Hardware nicht stimmt. Bin für Vorschläge offen ;)
 
Thyrion

Thyrion

Ehrenmitglied
Die Meldung hatte ich auch gelegentlich. Kurz Debug-Modus aus/an hat bei mir oft geholfen. Oder das Modem rausschmeißen und neu einrichten - Ich habe das aber auch seit meinem Post oben nicht intensiver verfolgt. Hast Du irgendwelche Init-Strings gesetzt oder geändert? Das war bei mir z.B. nicht nötig.
 
D

derlangeron

Neues Mitglied
Hallo ihr,
da mein Telko-Provider offenbar schwer verwirrt ist und uns versehentlich den Anschluss gedropped hat, muss ich schnellstens über mein Galaxy tethern können. Bis heute morgen war noch Firmware G am Start, weswegen ich die bisher erfolglosen Versuche darauf geschoben habe. Jetzt allerdings ist die frische H-Firmware drauf und es geht immer noch nicht. Wie zuvor terminiert pppd nach einem lcp timeout. Ich habe alle lcp Parameter so ausgeweitet, dass er fünf Minuten lang die echo frames sendet, was mir aber auch keinen Erfolg beschert hat. Einziger APN ist surfo2, mein System ist ein Debian Lenny. Falls jemand die gleiche Konfiguration fährt, wäre ich für wvdial- und pppd-configs, mit denen es geht, seeehr dankbar. Ansonsten sind generell sachdienliche Hinweise natürlich auch willkommen.
Gruß Ron
 
Thyrion

Thyrion

Ehrenmitglied
Und was ist mit den Einstellungen die Lubomir in Post #25 geschrieben hat?
 
D

derlangeron

Neues Mitglied
Hi, nein, mit den Standarteinstellungen geht es halt nicht. Btw ist internet der APN fur o2s "Handy-Internet" mit den Musik- und Klingelton-Diensten, surfo2 hingegen reiner Datendienst für Hdspa-Sticks und -Schlaufone. Aber trotzdem empfehlenswert;)
 
L

Lubomir

Experte
Welches Datenpaket hast du den? Wenn du ein ganz normales Internet Pack M mit 200mb und danach Drosselung für 10€ hast oder Internet Pack L mit 5gb und danach drosselung für 25€ (alt-tarife können abweichen ;) ) dann kannst du frei wählen welchen APN du benutzt(bei internet pack s bin ich mir nicht sicher aber mit den 30mb oder was da angeboten wird kommst du eh nicht weit). Wer hat dir den in den Kopf gesetzt, dass der APN internet für Handy sei und surfo2 für Datenkarten? Was stimmt ist, wenn man ein uraltes surf@home paket hat, darf man den internet APN nicht benutzen, da dieser nicht zwischen homezone und nicht homezone unterscheiden kann und sollte deshalb den surfo2 nehmen. Ist aber schon laaange her wo es den Tarif noch gab :D

Für dich müsste die richtige config für wvdial so aussehen:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","surfo2"
Modem Type = USB Modem
Username = "o2"
Password = "o2"
Modem = /dev/ttyACM0
Baud = 921600
Phone = *99#
Stupid Mode = 1


Bei Username und PW ist es bei vodafone und o2 egal was man da einträgt(glaub o2 mag da einfach nur ein leerzeichen nicht so...). wvdial möchte ein pw und ein username - also einfach iwas eintragen - zb wie ichs gemacht habe den Providernamen.

Ach ja, und wenn man bei o2 vergisst den APN einzutragen oder trägt einen falschen ein(zb einfach einmal auf die tast hauen - fadsfwsrfd), dann wird surfo2 als APN sozusagen verwendet. Wurde vor einigen Monaten so gemacht, damit die leute die nicht in der Lage sind ihr Handy/Datenkarte einzustellen auch das Internet nutzen können :p
 
Zuletzt bearbeitet:
F

_Frank

Neues Mitglied
derlangeron schrieb:
da mein Telko-Provider offenbar schwer verwirrt ist und uns versehentlich den Anschluss gedropped hat, muss ich schnellstens über mein Galaxy tethern können.
Falls das nichts wird, so nimm azilink. Für die Einrichtung habe ich wenige Minuten benötigt.

https://www.android-hilfe.de/forum/...ch-per-usb-modem.3654-page-10.html#post-63851

Für das Samsung benötigt man eine spezielle "adb". Ein Link dazu gab es im Forum. Wenn du nichts findest, so sende mir eine PN oder Mail. Das SDK benötigst du damit vermutlich nicht mehr, da nur "adb" verwendet wird.

Ich habe mir ein Skript geschrieben welches die Verbindung herstellt:

--start.sh--
#!/bin/sh
sudo ./adb kill-server
sudo ./adb start-server
sudo ./adb wait-for-devices
sudo ./adb forward tcp:41927 tcp:41927

sudo cp resolv.conf /etc/resolv.conf

sudo openvpn --config azilink.ovpn
--

--resolv.conf--
nameserver 208.67.222.222
nameserver 208.67.220.220
--

--azilink.ovpn--
dev tun

remote 127.0.0.1 41927 tcp-client
ifconfig 192.168.56.2 192.168.56.1

route 0.0.0.0 128.0.0.0
route 128.0.0.0 128.0.0.0
route 0.0.0.0 0.0.0.0

#socket-flags TCP_NODELAY
#keepalive 10 30
ping 10
ping-restart 60

dhcp-option DNS 208.67.222.222
dhcp-option DNS 208.67.220.220
--

--/etc/udev/rules.d/51-android-rules--
SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"
--
 
D

derlangeron

Neues Mitglied
Guten Morgen,
die Info zu der bevorzugten Nutzungsart der APNs stammt von o2.
Wie ich bereits geschrieben habe, klappt es mit der wvdial.conf nicht. Der Verbindungsvorgang scheint im wvdial-Teil ja zu funktionieren, wenn pppd involviert wird, gehts nicht weiter. Deswegen vermute ich auch eher ein Problem mit den pppd-Optionen.

Unter Windows7 funktioniert es übrigens auch nicht.

_Frank: Danke für den Tipp, aber ich muss mit diversen VPNs da durch, weswegen durchgetunneltes Portforwarding da komplett ausscheidet.
 
Zuletzt bearbeitet:
F

Fege

Neues Mitglied
Hat sich irgendwer jetzt weiter damit beschäftigt ? Finds komisch, dass es bei mir erst funktioniert hat und jetzt auf einmal ist auch bei "*99# wird gewählt" bzw bei "benutzername und Kennwort werden überprüft" hängen bleibt und mir sagt, dass das Modem einen Fehler gemeldet hat...

hab zwischenzeitlich nur einmal den APN gelöscht und den standard APN wieder hergestellt aber daran kanns eigentlich nicht liegen, weil sich ja nix geändert hat...
 
Melkor

Melkor

Senior-Moderator
Teammitglied
Mhh, bei mir kommt ein Fehler mit dem Remotecomputer^^
 
F

Fege

Neues Mitglied
Kann ich auch bestätigen, es kam auch schonmal der fehler, dass "im modem ein hardwarefehler aufgetreten sei" ...
 
S

SilkSpectre

Neues Mitglied
Also bei mir funktioniert das alles nicht.

Ich krieg immer:

Fehler 692: Hardwarefehler im Modem (oder einem anderen angeschlossenen Gerät)
 
N

NewIceDragon

Fortgeschrittenes Mitglied
kann wer vll.nochmal ne "neue" möglichkeit für vista oder XP posten? ich habs einige threads vorher schonmal geschrieben mit proxyid oder so gehts ned weil wenn ich treiber installieren will werden die treiber nicht erkannt >.<
 
W

Wuslor

Neues Mitglied
Als ich es das erste mal Ausprobiert habe, hat es funktioniert. ( Vista )

Jedoch seitdem nicht mehr. Wenn er Benutzername / Passwort abfragt kommt nach einer gewissen Zeit die Fehlermeldung mit dem Remotecomputer.

Aber wie gesagt . es hat mal funktioniert ... :mad::mad::mad:

Gruß
 
Thyrion

Thyrion

Ehrenmitglied
Bin gespannt, ob es nach dem Update auf II5 noch/wieder geht.
 
Y

yglodt

Fortgeschrittenes Mitglied
Habe das update auf I7500XXII5 heute gemacht und Tethering unter Fedora 11 mit dem Gnome Network-Manager-Applet hat geklappt.