Link2SD: Einrichtung und Probleme

  • 2.016 Antworten
  • Neuester Beitrag
Diskutiere Link2SD: Einrichtung und Probleme im Tools im Bereich Android Apps und Spiele.
N

Neuling367

Neues Mitglied
Hallo,

Problem: Apps die auf die externe SD Karte verschoben sind, starten nur so lange das Handy nicht ausgeschaltet wurde. Nach dem wieder Einschalten kommt entweder die Fehlermeldung, Programm xy wurde beendet, oder es wird gleich wieder geschlossen. Werden die Apps von der SD-Karte auf den Handyspeicher zurück geschoben, neu gestartet, dann funktionieren die Apps wieder.

Die SD Karte ist zur ersten Hälfte mit FAT32 und zur zweiten Hälfte mit ext4 formatiert und beim Erststart von Link2SD der Punkt ext4 ausgewählt und bestätigt und ich denke, somit eingebunden.

Aber nach einem Neustart des Handys geht mit den Apps nichts mehr.
 
magicw

magicw

Ehrenmitglied
Na dann schau mal ob die 2. Partition sauber eingebunden und "befüllt" ist. Unter "Einstellungen -- Speicherinformation" kannst du sehen ob die 2. Partition erkant wurde und benutzt wird oder eben nicht.
 

Anhänge

det-happy

det-happy

Ehrenmitglied
Wie schnell ist die SD? Class 2?
 
N

Neuling367

Neues Mitglied
Danke erst mal für die Antworten

magicw schrieb:
Na dann schau mal ob die 2. Partition sauber eingebunden und "befüllt" ist. Unter "Einstellungen -- Speicherinformation" kannst du sehen ob die 2. Partition erkant wurde und benutzt wird oder eben nicht.
So, ich denke das mit dem Einbinden hat geklappt? Ich kann weder Fehler noch ob alles i. O. erkennen.


det-happy schrieb:
Wie schnell ist die SD? Class 2?
Es ist eine 64 GB Sandisk Extrem Pro mit Class 10UHS‑Class 3UHS‑I, lesen bis 95 MB/s, schreiben bis 90 MB/s.

Sollte eigentlich doch reichen?

Aber nach dem Starten laufen die Apps nicht mehr. Ging mir ja haupsächlich um Navigation und da hätte ich die Karten etc gerne auf der SD-Karte.

Was mich aber beim Formatieren gewundert hat, dass auf der ext4 Partition fast 2 GB belegt waren. Habe die Formatierung nochmals durchgefüht gehabt, aber es war immer noch/schon 2 GB der Linuxpartion belegt.
 

Anhänge

magicw

magicw

Ehrenmitglied
Hm, vom screenshot her scheint deine 2. Partition sauber eingebunden zu sein - wobei die 2. Partition mit 28GB deutlich zu überdimensioniert ist. Mehr als 4GB macht m.E. Kein Sinn. Ist aber auch nur Nebenbaustelle.
Was sagt die App-Ansicht - also wenn du in der App-Einzelansicht die Dateipfade anschaust. Schau dir das mal direkt nach dem Neustart an. Evtlt. lässt sich daraus was schließen.
 

Anhänge

N

Neuling367

Neues Mitglied
magicw schrieb:
- wobei die 2. Partition mit 28GB deutlich zu überdimensioniert ist. Mehr als 4GB macht m.E. Kein Sinn.
Ich dachte, die Karten Apps werden dorthin verschoben? Bei "nur" 4 GB und Mittel- und Osteuropa reicht es dann aber bei mir nicht.


Jetzt bin ich mal den Weg der kompl. Neuistallation des Navigationsprogrammes und Karten gegangen.
Läuft vom internen Speicher sowohl vor als auch nach dem Verlinken einwandfrei solange kein Neustart erfolgt.
Habe probeweise einen Neustart vor dem Verlinken gemacht. Läuft.
Nach dem Verlinken ohne Neustart läuft immer noch.
Nach dem Verlinken und Neustart erscheint die Meldung Apps werden aktualisiert, dann starte ich das Navigationsprogramm und der Bildschirm bleibt weiß.

Warum stellt eigentlich Link2SD die Frage, ob auf der ersten oder zweiten Partion die Daten verschoben werden sollen?
Unten habe ich die mal die Meldungen, Auswahl und die Partion vor und nach dem Verlinken angefügt.
Meldung, nur eine SD Karte.png vor dem Neustart 1.png vor dem Neustart 2.png Auswahlmenü Partion Link2SD,.png nach dem Neustart 1.png nach dem Neustart 2.png
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von magicw - Grund: großes Bild gespoilert von @magicw
magicw

magicw

Ehrenmitglied
Also du hast L2SDplus.

Hast du nach Neustart mal aus dem linken Menü "Rebind all external folders" gedrückt bevor du den Navigator das erste mal gestartet hast?

Beim verlinken der "(ext.)Data" fragt er deshalb beide Partitionen ab, weil du nun die Möglichkeit hast die Appdaten aus
/storage/sdcard0/Android/data/appname entweder nach

1. Partition /storage/sdcard1/Android/data/appname - also für dich als Nutzer sichtbar
2. Partition /data/sd2ext//appname - also für dich als Nutzer (eher) unsichtbar

verschieben kannst.
 
qu1gon

qu1gon

Erfahrenes Mitglied
Habe auf meinem Galaxy Y S5360 alles ganz neu installiert + die Link2SD Geschichte ausprobiert.
Soweit sah alles gut aus. Habe nur die Facebookapp, FB-Messengerapp und Skype mal installiert.
Anfangs hatte ich etwas mit 130MB von 200MB frei. Nach der Installation der Apps wurde das
schon weniger (Google Play Store hat sich glaub auch noch ein Update gegönnt).

Habe dann mal die Facebookapp geöffnet und die hat dann wohl vollends noch Daten auf die 200MB
Data Partition des Handys geschrieben, warum auch immer. Jetzt hab ich nur noch paar MB und
es kommt wieder wie früher die Meldung - geringer Speicher. Enttäuschung pur, alles jetzt umsosnt?

Nächstes Problem, nach neustart:
Im App-Launcher sowie im Link2SD werden die Apps nicht mehr angezeigt. Nur die von mir auf der
Startseite erstellten Verknüpfungen sind noch da. Bei dem Versuch eine der Apps zu starten kommt
nur noch "App ist nicht installiert" ??
 

Anhänge

magicw

magicw

Ehrenmitglied
Jo, mit jedem App-Update wird die zugehörige Dalvik/ART-Runtime-Datei neu erzeugt - und bei falscher Einstellung im Telefonspeicher belassen. Das scheint bei dir der Fall zu sein.
Geh in der Kopfleiste auf das zentrierte Dreieck und wähle "verknüpfte" aus.
Dann gehst du in das 3-Punkte Menü rechts in der Kopfleiste und wählst "Mehrfachauswahl"
In der Mehrfachauswahl tappst du dann auf das linke der drei Symbole - damit sollten alle verlinkten Apps auf einmal markiert worden sein.
Danach tappst du auf das rechte 3-Punkte-Menü und wählst "Link erstellen" aus.
Somit werden auf einen Rutsch alle Dalvik-Dateien wieder in die 2-Partition verschoben.

Langfristabhilfe:
Geh in die Settings und checke diese 2 Kästchen bei "Automatisches Verknüpfen":
 

Anhänge

qu1gon

qu1gon

Erfahrenes Mitglied
Problem ist wie gesagt die Apps werden nicht einmal angezeigt.

Die Einstellungen auf deinem Screenshot sind schon so von mir eingestellt gewesen.
 
magicw

magicw

Ehrenmitglied
ah ok - letzten Abschnitt "überlesen" :rolleyes2:
Naja - da hilft dann nichts anderes als die FB-App mal zu deinstallieren, um wieder Platz zu gewinnen.
Die FB-App speichert m.W. so ziemlich alles im App-Daten-Bereich unter /data/data/Appname. Diese Inhalte bekommst du nur mit der Plus-Version auf die ext.SD-Karte geschoben.
 
qu1gon

qu1gon

Erfahrenes Mitglied
Ok sollte ich mir wohl die Plus-Version holen. Werde dann wohl manuell löschen müssen, versuche es und berichte sogleich.
 
qu1gon

qu1gon

Erfahrenes Mitglied
Finde die Dateien nicht.
 
magicw

magicw

Ehrenmitglied
Hm, was passiert in L2SD wenn du dort per Longpress auf die FB-App gehst und im Pop-Up-Menü dann "Deinstallieren" wählst? (ebenso mit den anderen nicht mehr funktionierenden Apps)
 
qu1gon

qu1gon

Erfahrenes Mitglied
Das ist ja das komische, wie gesagt die werden nicht mehr angezeigt. Vor dem Neustart waren die noch vorhanden.
Jetzt ist alles was geblieben ist die beiden Vknüpfungen auf dem Homescreen. Irgendwo müssen die Daten aber
sein, da nur noch 13 MB oder so frei sind in der Daten-Partition.

Brauch ich nen bestimmten Fileexplorer oder so?
 
magicw

magicw

Ehrenmitglied
Ja klar, die /data-Partition ist vollgemüllt. Wenn du noch einen intakten Root-Explorer hast, dann kannst du dort aufräumen - ansonsten evtl. Werksreset und neu einrichten.
 
qu1gon

qu1gon

Erfahrenes Mitglied
Blick jetzt gar nichts mehr. Hab mir TotalCommander als .apk geladen und auf Micro-SD, dann wollt ich den installieren und
Handy ist abgestürzt bzw. nicht komplett neu gestartet sondern kam die Animation wo auch bei booten kommt.
Aber gleich nach dem "Absturz". Jetzt sind plötzlich die Apps wieder da... ?!

Edit:
Hab nun die Apps deinstalliert. TotalCommander mal installiert auch zum Test. L2SD hat seine Arbeit
wohl auch richtig gemacht. Hab jetzt ca 107 MB frei.
Jetzt installiere ich mal den Messenger und die FacebookLite App und mal sehen was dann noch über
bleibt an freiem Speicher.

Edit2:
Super, hab noch nicht einmal was installiert schon hat sich Google Play Dienste installiert.
Ca. 50 im internen und 50 auf SD Speicher belegt. Somit so schon nur noch ca. 43MB frei
auf der Datenpartition :( - Nervt nur noch langsam.
 
Zuletzt bearbeitet:
N

Neuling367

Neues Mitglied
magicw schrieb:
Also du hast L2SDplus.
Dachte mir, dass die gut 2 € Fehler ausschließen sollten, dass irgendetwas nicht funktioniert, oder dass man über irgendwelche Umwege erst ans Ziel kommt
magicw schrieb:
Hast du nach Neustart mal aus dem linken Menü "Rebind all external folders" gedrückt bevor du den Navigator das erste mal gestartet hast?
Habe das jetzt gemacht und wie unten zu sehen, gibt es keine Ordner etc zum Einbinden. Nur den Dalvik-Cache lies sich neu verknüpfen. Alle anderen Neuverknüpfungen gibt keine Dateien oder keine Ordner zum Verknüpfen.
magicw schrieb:
1. Partition /storage/sdcard1/Android/data/appname - also für dich als Nutzer sichtbar
Das war meine Unwissenheit, da ich dachte, Apps usw. müssen auf die zweite ext4, da sonst nicht vom System darauf zugegriffen werden könnte.
 

Anhänge

Ähnliche Themen - Link2SD: Einrichtung und Probleme Antworten Datum
0