Mit dem Android ins Eduroam

  • 644 Antworten
  • Neuester Beitrag
Diskutiere Mit dem Android ins Eduroam im Android Allgemein im Bereich Betriebssysteme & Apps.
MueLLe

MueLLe

Neues Mitglied
Bei mir an der Uni gibt es da eine fertige wpa_supplicant.conf:

Code:
ctrl_interface=/[COLOR=#000000][B]var[/B][/COLOR]/run/wpa_supplicant
ap_scan=[COLOR=#cc66cc]2[/COLOR]
eapol_version=[COLOR=#cc66cc]1[/COLOR]
 
[COLOR=#808080][I]# WiTUC - Campus WLAN (TKIP/EAP-TTLS/PAP)[/I][/COLOR]
network=[COLOR=#66cc66]{[/COLOR]
        ssid=[COLOR=#ff0000]"WiTUC"[/COLOR]
        scan_ssid=[COLOR=#cc66cc]1[/COLOR]
        proto=WPA
        key_mgmt=WPA-EAP
        pairwise=TKIP
        group=TKIP
        eap=TTLS
        anonymous_identity=[COLOR=#ff0000]"anonymous@tu-clausthal.de"[/COLOR]
        identity=[COLOR=#ff0000]"@tu-clausthal.de"[/COLOR]
        [COLOR=#0066cc]password[/COLOR]=[COLOR=#ff0000]""[/COLOR]
        ca_cert=[COLOR=#ff0000]"/etc/wpa_supplicant/certs/chain.txt"[/COLOR]
        phase2=[COLOR=#ff0000]"auth=PAP"[/COLOR]
[COLOR=#66cc66]}[/COLOR]
natürlich muss man da noch den ca_cert Teil anpassen und das Zertifikat irgendwo aufm Handy speichern, aber das versteht sich ja von selbst. In der conf steht jetzt zwar SSID="WiTUC", das lässt sich aber bei uns einfach durch eduroam ersetzen (so hab ich das zumindest bei meinem Lappy im gentoo eingertichtet).

Dashier habe ich einfach komplett weggelassen:
Code:
ctrl_interface=/[COLOR=#000000][B]var[/B][/COLOR]/run/wpa_supplicant[FONT=monospace]
[/FONT]ap_scan=[COLOR=#cc66cc]2[/COLOR][FONT=monospace]
[/FONT]eapol_version=[COLOR=#cc66cc]1[/COLOR]
In der bcm_supp.conf stand nämlich vorher auch schon was vor dem ersten network-Block, das hab ich natürlich gelassen:
Code:
ctrl_interface=DIR=/data/misc/wifi GROUP=system
update_config=1
Edit: Ich nutze übrigens die original II5 von Samsung
 
M

m1m1

Fortgeschrittenes Mitglied
dann teste ich das bei Gelegenheit nochmal, mit dem II5 hatte ich es noch nicht probiert.
 
R

razibu

Neues Mitglied
Habs nochmal abgeändert und nun funktionierts.

Ich schreib da später nochmal was zu
 
R

razibu

Neues Mitglied
network={
ssid="eduroam"
scan_ssid=1
proto=WPA
key_mgmt=WPA-EAP
pairwise=TKIP
group=TKIP
eap=TTLS
anonymous_identity="anonymous@tu-berlin.de"
identity="benutzername@tu-berlin.de"
password="passwort"
phase2="auth=PAP"
}

Ihr müsst oben genannte Config in die bcm_supp.conf eintragen. Dazu öffnet ihr ein Terminal. Wechselt in das Verzeichnis „tools“ im Android SDK und führt dann folgende Kommandos aus:
sudo ./adb shell
su
echo 'hier fügt ihr die Config ein' > /data/misc/wifi/bcm_supp.conf (Wichtig, es müssen ' sein und nicht „“)
 
D

Demophobie

Ambitioniertes Mitglied
Hm genau das hatte ich gemacht. Aber das Galaxy wird dann EXTREM langsam und schmiert mir ab. Habt ihr das nicht?
 
R

razibu

Neues Mitglied
Also ich kann das Teil ohne Einschränkungen weiter benutzen wie bei jedem anderen Wlan.

Ist nichts weiter modifiziert, das aktuellste update fürs Galaxy ist drauf und halt der notwendige root-zugriff.
 
D

Demophobie

Ambitioniertes Mitglied
Moment, wieso brauchst du denn gar kein Zertifikat?
 
R

razibu

Neues Mitglied
Gute Frage. Es geht halt ohne. Wieso kann ich dir auch nciht erklären.
 
D

Demophobie

Ambitioniertes Mitglied
Ah okay. Ich probiers morgen an der Uni mal mit deiner config.
 
N

nanonym

Neues Mitglied
Moin,
ich habe das CustomROM von MoDaCo drauf. Da gibt es aus mir unbekannten Gründen weder eine wpa_supplicant.conf unter /data/misc/ noch eine bcm_supp.conf unter /data/misc/wifi/
Um genau zu sein ist unter /data/ überhaupt nichts. Statt dessen scheinen alle Daten auf /system/ zu liegen und dort gibt es auch eine wpa_supplicant.conf. Ich habe einfach mal dort die Werte eingetragen. In nem Kurztest hat er allerdings überhaupt nichts gefunden. :-\ Aber ich bin mir auch nichtganz sicher ob dort wirklich eduroam vorhanden war wo ich getestet habe.
Jemand ne Idee dazu?

nano
 
M

m1m1

Fortgeschrittenes Mitglied
in der Datei müssen ja auch deine bestehenden eingetragenen Netzwerke stehen.
 
D

Demophobie

Ambitioniertes Mitglied
nanonym schrieb:
Moin,
ich habe das CustomROM von MoDaCo drauf. Da gibt es aus mir unbekannten Gründen weder eine wpa_supplicant.conf unter /data/misc/ noch eine bcm_supp.conf unter /data/misc/wifi/
Um genau zu sein ist unter /data/ überhaupt nichts. Statt dessen scheinen alle Daten auf /system/ zu liegen und dort gibt es auch eine wpa_supplicant.conf. Ich habe einfach mal dort die Werte eingetragen. In nem Kurztest hat er allerdings überhaupt nichts gefunden. :-\ Aber ich bin mir auch nichtganz sicher ob dort wirklich eduroam vorhanden war wo ich getestet habe.
Jemand ne Idee dazu?

nano
Du musst die Data auch mounten. Haste sicher im Recovery Mode gemacht wa?
Schließ das Samsung mal im angeschalteten Zustand an und geh dann in die shell. Dann müsste data gemountet sein.
 
N

nanonym

Neues Mitglied
Demophobie schrieb:
Du musst die Data auch mounten. Haste sicher im Recovery Mode gemacht wa?
Schließ das Samsung mal im angeschalteten Zustand an und geh dann in die shell. Dann müsste data gemountet sein.
Hi,
ja das habe ich jetzt auch festgestellt. Da hatte ich dann überhaupt nicht dran gedacht. Thx.

Edit: Ich habe jetzt die richtige Datei geändert. Scheinbar bleibt das Telefon stehen und hängt sich auf, wenn man in der bcm_supp.conf (wpa_supplicant.conf) die Tabs vergisst oder weg lässt. Mit der gleichen Konfig mit Tabs läuft das System. Ohne nicht... Nur leider findet er das eduroam nicht. :-\ Es ist zwar laut Laptop verfügbar, aber im Phone nicht...

nano
 
M

m1m1

Fortgeschrittenes Mitglied
dann installiere dir mal G-Mon, dann weißt du ob dein Telefon das wirklich nicht findet. Das Programm zeigt nämlich auch die nicht unterstützten Netze an. Dein Lap hat ja ne viel größere Reichweite, vielleicht liegt es daran.
 
D

Demophobie

Ambitioniertes Mitglied
nanonym schrieb:
Hi,
ja das habe ich jetzt auch festgestellt. Da hatte ich dann überhaupt nicht dran gedacht. Thx.

Edit: Ich habe jetzt die richtige Datei geändert. Scheinbar bleibt das Telefon stehen und hängt sich auf, wenn man in der bcm_supp.conf (wpa_supplicant.conf) die Tabs vergisst oder weg lässt. Mit der gleichen Konfig mit Tabs läuft das System. Ohne nicht... Nur leider findet er das eduroam nicht. :-\ Es ist zwar laut Laptop verfügbar, aber im Phone nicht...

nano
Bei mir hing er sich auch mit Tabs auf. Kannst mir mal genau deine bcm_supp.conf zeigen? (nich vergessen die passwörter zu x-en) ;)
 
M

m1m1

Fortgeschrittenes Mitglied
habe es heute auch nochmal probiert, nachdem bei der Beispiel-Config meiner Uni auch die Tabs nicht korrekt waren.
Hängt sich nun nicht mehr auf, aber findet das Netz ebenfalls nicht, obwohl es unter G-Mon angezeigt wird.
 
N

nanonym

Neues Mitglied
Demophobie schrieb:
Bei mir hing er sich auch mit Tabs auf. Kannst mir mal genau deine bcm_supp.conf zeigen? (nich vergessen die passwörter zu x-en) ;)
Hier meine bcm_supp.conf mit der eduroam läuft und funktioniert.

Code:
ctrl_interface=DIR=/data/misc/wifi GROUP=system
update_config=1

network={
    ssid="eduroam"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-EAP
    pairwise=TKIP
    group=TKIP
    eap=TTLS
    identity="<name>@mytum.de"
    anonymous_identity="anonymous@mwn.de"
    password="xxxxxx"
    ca_cert="/sdcard/eduroam/rootcert.crt"
    phase2="auth=PAP"
}
Damit werden mir die Netze als gespeichert angezeigt und verbinden sich automagisch sobald ein Netz in Reichweite kommt. Ich weiß nicht ob das etwas ausmacht, weil ich es nicht getestet habe, aber ich habe noch eine Leerzeile am Ende.
 
Z

Zac

Neues Mitglied
Das mit dem importieren von den Zertifikaten klappt, nur komme ich noch immer nicht ins Eduroam. Als Sicherheitsmodus wird beim Magic (Vers. 1.6) auch kein WPA2 Enterprise angezeigt, kann es somit gar nicht funktionieren?

Die Linux Einstellungen sieht man auf folgender Uni Seite ganz gut: Linux @ TU Braunschweig
 
S

Schemen

Erfahrenes Mitglied
j_d_ schrieb:
zertifikate musst du über den browser importieren, damit du sie auswählen kannst.
bei mir an der uni komm ich ohne zertifikat ins eduroam.
Danke für die Antwort, aber ich verstehe es noch nicht ganz - die URL des Zertifikats in den Browser eingeben? Für das Linux Zertifikat? Oder gibts eine Option im Browser dafür irgendwie?
 
arctic

arctic

Erfahrenes Mitglied
Könnte nicht jemand bitte eine Anleitung schreiben?
Ich komme damit auch nicht klar =/
Kann nur eins von 3 Zertifikaten nach dem Download auswählen und weiss sonst auch nicht wirklich, was ich eingeben soll =/

Habe nen
Benutzernamen@uni-xxx.de
und nen passwort dazu...

Vielleicht schreibt ja jemand nettes was, das könnte man dann pinnen!
Würde mich sehr freuen!
 
Ähnliche Themen - Mit dem Android ins Eduroam Antworten Datum
2
1
5