Mit dem Android ins Eduroam

  • 644 Antworten
  • Neuester Beitrag
Diskutiere Mit dem Android ins Eduroam im Android Allgemein im Bereich Betriebssysteme & Apps.
arctic

arctic

Erfahrenes Mitglied
^^

Ich habs leider immernoch nicht hinbekommen mich ins eduroam einzuloggen?
Kann denn niemand helfen?
 
j_d_

j_d_

Stammgast
also ich kann dir gerne sagen, was ich bei mir eingestellt habe:

ssid: eduroam
sicherheit: wpa-eap
eap-methode: peap
phase 2-authentifizierung: keine
identität: (benutzername vpn der uni)
passwort für wireless-zugang: (das passwort zum benutzernamen)

alle anderen felder wie CA-/Client-Zertifikat, passwort für den privaten schlüssel und anonyme identität sind bei mir leer.


ich hoffe mal, dass die angaben stimmen, da ich meine einstellungen nicht direkt ansehen kann und sie deshalb versucht habe aus der wpa_supplicant.conf zu rekonstuieren.
aber wenn ich mich richtig erinnere, müsste das so stimmen.
 
Q

qwasdenn

Neues Mitglied
Hat das schon jemand mit dem Milestone geschafft? Der ist ja noch nicht gerootet ...
 
M

moppelg

Stammgast
Bin auch am probieren mit dem Milestone. Leider klappt es nicht. Habe es nach folgendem Schema probiert:

eduroam mit Ubuntu - Hochschule Esslingen

Hat den Android 2.0 WPA 2 Enterprise?

Warum muss unsere HS überhaupt sowas benutzen. Bei anderen HS geht das auch ohne 10000 Sicherheitsschleusen...

Gruß

moppel
 
MueLLe

MueLLe

Neues Mitglied
Android 2.0 unterstützt WPA2 Enterprise wohl auch nur so halb.. hier einige Infos: Issue 1386 - android - Feature req: support WPA2-Enterprise with EAP extensions - Project Hosting on Google Code Info daraus: 2.0 kann noch nicht mit .cer Zertifikaten umgehen :(
Allerdigs gibt es von der Ohio State Uni eine Anleitung für WPA2 Enterprise: OSU Wireless-Network: Setup for Motorola Droid (Android OS). Die OSU is nicht im eduroam, daher sind natürlich die Authentifizierungsmethoden nicht richtig... Nach meinem Kenntnisstand ist die Authentifizierung im eduroam immer gleich, woran es jetzt beim Droid scheitert kann ich (mangels Gerät) nicht sagen. Aber n Bekannter wird sich wohl demnächst eins besorgen, ich werd dann mal berichten obs klappt :)

Grundsätzlich sollte das aber mit Gerät rooten und config anpassen auch in 2.0 laufen.

Über das für und wider von eduroam bzw WPA2 Enterprise an Universitäten will ich hier eigentlich nicht diskutieren, aber es ist wohl die beste Lösung für die Unis. Man kann ja schlecht 08/15 APs in die Gegend hängen und sagen: "Hier habt ihr WLAN." Für 95% der User is es ja auch nur ein Programm installieren und läuft, die Linux User sind dann erstmal etwas gekniffen und müssen basteln, aber so is das nun mal ;)

@Mods: vllt sollte man den Thread hier mal splitten und ins Droid Forum packen. Bis wir auf dem Galaxy 2.0 haben dauert es ja noch etwas ;)
 
M

moppelg

Stammgast
Danke Muelle,
dann heißt es wohl warten.
Aber noch eine Amerkung zu den *.cer Zertifikaten, bei mir verlief die Installation problemlos über den Browser und wurde dann auch im Passwortbereich des WLANs angezeigt. Ob das dann von Android 2.0 richtig benutzt wird ist wiederum eine andere Frage...

An anderen HS und Unis braucht man zumindest kein Zertifikat oder etwas verminderte Einstellungen bzgl. der Sicherheit (soweit mein Stand, wenn ich andere Android-Eduroam FAQs durchlese...

Zur Not bekomme ich vielleicht das VPN der Hochschule eingerichtet :mad:

Also abwarten und Tee trinken.

P.S.: Nettes Galaxy Forum
 
L

limx

Neues Mitglied
Hi,

weiß jemand ob sich das Samsung Spica mit Eduroam, also dem Uni-Netz verbinden kann?

Mit dem Hero (was afaik auch nur Android 1.5 hat) soll es wohl klappen.

mfg
 
mactron

mactron

Erfahrenes Mitglied
Also eduroam=wpa2 enterprise. Soweit ich weiss unterstützt eine ungerootetes Gerät mit Android 1.5 nicht. Das Galaxy kann es auf jeden Fall nicht. Soll aber mit Android 1.6 bzw. 2.0 kommen.
 
L

limx

Neues Mitglied
Kann man denn überhaupt mit einem Update auf 2.0 rechnen? Eduroam hätte ich auf dem Spica schon ganz gerne. :) Weiß jemand wie es bei Symbian aussieht? Kann das Nokia 5800 z.B. wpa2 enterprise?

mfg

edit: Die Option soll beim Hero wohl PEAP/MS-CHAPv2heißen. Gibts das beim Spica oder Galaxy wirklich nicht?
 
Zuletzt bearbeitet:
J

joyride

Erfahrenes Mitglied
WPA2 Enterprise (damit eduroam) geht NUR auf einen gerooteten Samsung.
Damit zur Zeit nicht auf dem Spica.

Bernd

PS: die anderen Fragen ergeben sich durch lesen selbst...
 
B

bonanza

Neues Mitglied
Hi,

ich hab seit kurzen das Milestone und schon ein wenig mit Eduroam an der RWTH rumprobiert, kriege es aber nicht wirklich auf die Reihe...
hat schon das schon jmd hinbekommen mit Android 2.0 ?
 
S

Schemen

Erfahrenes Mitglied
Soweit ich weiß gibts recht wenig Änderungen von Android 1.6 auf 2.0 und auf 1.6 funktioniert es mit folgenden Eingaben:

EAP: PEAP
Phase2: MSCHAP2
CA: n/a
Client: n/a
Private key password: Passwort das man von der Uni bekommt
Identität: benutzerkennung@rwth-aachen.de (NICHT vorname.nachname@rwth-aachen.de)
Anonyme Identität: benutzerkennung@rwth-aachen.de (wieder NICHT vorname.nachname@rwth-aachen.de)
Wireless Passwort: freilassen

Ich weiß aber nicht, ob man auch anderes auswählen kann und es dann immernoch geht, hab einfach ein bisschen rumprobiert und so hats geklappt.

Bei CA evtl ein Zertifikat auswählen (installieren über Anklicken des Links zu den Zertifikaten im Android Browser) sonst ist die Verbindung nicht verschlüsselt, glaube ich.

Habs heut mit den Zertifikaten probiert, hat nicht hingehauen, ich probiers wahrscheinlich morgen nochmal.
 
D

deralexx

Ambitioniertes Mitglied
Hallo an alle!

Erstmal: Super Forum hier, ich konnte schon einige Problemchen mit meinem Galaxy durch den klasse Support hier lösen.

Nun möchte ich die bcm_supp.conf wie am Anfang dieses Threads erklärt, ergänzen, um bei mir in der uni ins wlan zu kommen.

Ich habe das IK5 mit Odin draufgespielt und mit dem drakaz Recovery4.4 die root-rechte aktiviert (Enable SU).

Ich nutze Win7 64 bit und habe auch die Treiber aus dem SDK1.6_USB_Galaxy Archiv installiert.
Das Galaxy wird auch angezeigt wenn ich "adb device" eingebe (in der Windows-Eingabeaufforderung).
Wenn ich nun aber eine Kopie mit "adb pull /data/misc/wifi/bcm_supp.conf bcm_supp.conf" von der Datei erstellen möchte kommt trotzdem: Permission denied.

Ist das Galaxy doch nicht richtig gerootet oder was hat das zu bedeuten?
Oder hab ich irgendetwas übersehen oder falsch gemacht?
 
R

razibu

Neues Mitglied
Hast du dir mit "su" auch rootrechte geholt?

Die Anwendung als Admin gestartet?
 
D

deralexx

Ambitioniertes Mitglied
Windows kennt ja den Befehl su nicht.
Geh ich mit adb auf die shell und benutz dann su, wird adb nicht mehr gefunden.

Wenn du mit der Anwendung die Eingabeaufforderung von Windows meinst, ja die läuft als Admin!

Also das Problem ist wohl unter Windows an die Datei bcm_supp.conf ranzukommen, krieg das irgendwie nicht hin...kann da irgendjemand das Vorgehen erläutern?
 
R

rotateh

Gast
aehm wird der befehl adb shell ausgeführt ?
wenn ja dann bist du in der shell da musst du zuerst wieder mit exit aus der shell herraus ergo kein adb su eingeben sondern nur su
 
D

deralexx

Ambitioniertes Mitglied
Also nachdem ich adb shell ausführe, steht da ein $, tipp ich jetzt "su" ein, kommt eine #, dort wird dann der befehl adb nich mehr erkannt (adb: not found), geh ich mit "exit" wieder auf $, und versuche adb zu benutzen, kommt permission denied, nochmal "exit" und beim versuch zu kopieren: failed to copy .... : permission denied.
Was mach ich denn falsch?

Das Handy ist übrigens nicht im recovery sondern im ganz normalen betrieb eingestöpselt und wird erkannt als "Android ADB Interface". Das sollte ja schon mal so richtig sein, oder?
 
Thyrion

Thyrion

Ehrenmitglied
Deine ADB-Shell hat keine root-Rechte.

Möglichkeit 1: Du machst das ganze im Recovery-Modus
Möglichkeit 2: Du schiebst Dir in der root-Shell (die mit # ) die Datei auf die SD-Karte (vermutlich mit "cat /data/misc/wifi/bcm_supp.conf > /sdcard/bcm_supp.conf" und holst sie Dir dann auf Deinen Rechner (via ADB oder USB-Verbindung). Ebenso dann auch der umgekehrte Weg.
 
D

deralexx

Ambitioniertes Mitglied
Danke schön! Möglichkeit 2 hat einwandfrei funktioniert!

Morgen werd ich mal schauen, ob auch die Verbindung zu eduroam klappt,
als gespeichertes Netzwerk wird es schon mal angezeigt...
 
D

depa

Neues Mitglied
Hallo alle miteinander, habe neuerdings auch ein Motorola Milestone mit Android 2.0. Nun habe ich auch das Problem mich über eduroam mich am unigelände einzuloggen (RWTH Aachen). Bin, wie mein Postcounter schon hinweist, komplett neu in der Android szene und daher habe ich keine ahnung was ich mit den ganzen begriffen hier anfangen soll. Würde mich freuen, wenn mich einer schritt für schritt nocheinmal genau aufklären kann und mir auch genau erklären kann, wo ich was schreiben muss! Diese komische Textsnipsel wo man die Daten eingibt habe ich auch nicht gerafft (also dieser vorschlag hier im forum) Würde michüber eine antwort freuen

MfG Depa