Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

LineageOS 14.1

  • 117 Antworten
  • Neuester Beitrag
Diskutiere LineageOS 14.1 im Custom-ROMs für Sony Xperia Z3 Compact im Bereich Root / Custom-ROMs / Modding für Sony Xperia Z3 Compact.
Kazama

Kazama

Ehrenmitglied
okij schrieb:
Die Entwicklung wurde aber mit Sicherheit nicht eingestellt, zumal mehrere Entwickler zusammen an der Z2-, Z3- und Z3c-ROM arbeiten, da die Hardware fast identisch ist.
Kannst du mir ein Member nennen der das für das Z3 Entwickelt?

Oder ist das der Thread hier.

PS:

Hat sich erledigt. Tomascus wird gleich am Anfang namentlich erwähnt und ihm wird für die Mithilfe gedankt.
 
O

okij

Ambitioniertes Mitglied
@Kazama: Ja, das ist der Link zum Z3 Thread von nailyk und hier ist noch der zugehörige Z2 thread von rcstar6696.

Wie man auf Nailyks Gerrit sehen kann, sind auch noch andere Entwickler beteiligt. Dort kann man auch verfolgen, woran gerade gearbeitet wird.
 
snoopy-1

snoopy-1

Ehrenmitglied
okij schrieb:
..CarbonROM ist zum Glück auch noch nicht tot, lt. dem Thread solls am Dienstag das nächste Build geben.
Das würde mich ja nun wirklich freuen, hoffe aber dennoch auf weitere ROM's aus der Szene! Sieht man sich auf xda aber im z3c Bereich etwas um ist eigentlich das meiste seit Monaten tot.

okij schrieb:
..Nutzung des Marshmallow-Stock-Kernels und ohne Notwendigkeit für intakte DRM-Keys (d.h. Bootloader kann offen sein)
Bist du dir da schon sicher? Das wäre ja gar nicht die herangehensweise, weil egal ob nun CM oder sonstige AOSP basierten ROM's nicht mit dem Original Kernel arbeiten, sondern immer schon einen eigenen benutzt haben. Darüber hinaus, können sie nicht bei einem Stock Kernel ihr Label (3.4.0-linage-gddc....) so ohne weiteres darüber setzen. Solange sie das ganze nicht mit einem Stock Kernel machen ist das Thema DRM ohnehin irrelevant und das ist ja eigentlich genau das Prinzip von CM/AOSP basierten ROM's! Also irgendwas kann da so zumindest nicht ganz in deiner Aussage passen!

okij schrieb:
..Eigentlich gerade noch zum richtigen Zeitpunkt, da Sony ja die ROMs für Z2/Z3/Z3c nicht mehr weiterentwickelt.
Na ja, rechtzeitig ist was anderes! Das letzte was von Sony kam war glaube ich vor knapp einem Jahr und das Gerät selbst ist seit knapp drei Jahren am Markt. Also auch hier haben sich schon die meisten der Nutzer von dem Gerät verabschiedet, zumal eben an alternativen ROM's gar nichts kam. Es gab eigentlich genügend, die hier sogar sehr lange drauf gewartet haben und regelmäßig enttäuscht wurden. Viele haben es eben bereits abgestoßen und wie gesagt, auch viele Entwickler haben sich bereits von der Serie verabschiedet und werden sicher nur vereinzelt wieder zurück kommen, weil eben wieder die möglichen Nutzer fehlen.
Allein schon die Misere mit dem Codenamen, eigentlich nur "aries" und warum auch immer, bei so einigen einfach nur z3c, insbesondere so auch bei TWRP bezeichnet, was ständig zu Problemen bei der Installation von diversen ROM's führte, weil bei den ROM entwicklern als Kennung wieder der korrekte Codename aries verwendet wurde und so regelmäßig TWRP erst mal den Installationsdienst verweigerte.
Also auch hier ist echt so einiges schon mal in der Entwicklerszene schief gelaufen. TWRP steht mittlerweile bei der Version 3.1.1-0, aber auch hier kommt von "someone755" gar nichts mehr, der eigentlich auch ein Stück weit für die darüber benannte Misere (zc3/aries) mit verantwortlich ist.

Um es also mal ganz einfach in ein paar Worte zu kleiden....so viel Chaos bei einem Gerät habe ich bisher noch nicht erlebt, wie hier bei der Z3 Serie

okij schrieb:
Wenn alles gut geht, dann geht die ROM demnächst auch über die offizielle LineageOS-Seite online, also Daumen drücken!
Das wäre natürlich mehr als Wünschenswert, weil so wie jetzt ist es sonst nur wieder eine Frage der Zeit. Mein altes Xperia V ist nun schon fast fünf Jahre alt und gibt immer noch aktuelle Linage Builds von der ihrer offiziellen Seite.
Gruß,

snoopy-1
 
V

Vorador85

Neues Mitglied
snoopy-1 schrieb:
Kann es sein das du da so eine von den billig Dockingstationen hast, die dann gerne mal unter Last einbrechen. Da haben wir hier schon so einige Beiträge mit diesen Dingern, die oft zu sehr seltsamen Verhalten führen. Ich habe zwar keine Dockingstation, sondern nur so einen Magnetlader, ist aber im Grunde genau das gleiche vom Prinzip. Damit habe ich jedenfalls dieses Problem nicht und habe aber aktuell zwei Z3c mit LinageOS zur Hand.
Insofern kannst mal davon ausgehen das es an deiner Ladestation liegt!
Gruß,

snoopy-1
Habe nun mal ganz normal über Micro USB aufgeladen und das Problem besteht immer noch. Also sobald ich das Gerät wecke, muss ich die PIN eingeben. Vielleicht sonst noch jemand ne Idee?
 
O

okij

Ambitioniertes Mitglied
snoopy-1 schrieb:
okij schrieb:
..Nutzung des Marshmallow-Stock-Kernels und ohne Notwendigkeit für intakte DRM-Keys (d.h. Bootloader kann offen sein)
Bist du dir da schon sicher? Das wäre ja gar nicht die herangehensweise, weil egal ob nun CM oder sonstige AOSP basierten ROM's nicht mit dem Original Kernel arbeiten, sondern immer schon einen eigenen benutzt haben. Darüber hinaus, können sie nicht bei einem Stock Kernel ihr Label (3.4.0-linage-gddc....) so ohne weiteres darüber setzen. Solange sie das ganze nicht mit einem Stock Kernel machen ist das Thema DRM ohnehin irrelevant und das ist ja eigentlich genau das Prinzip von CM/AOSP basierten ROM's! Also irgendwas kann da so zumindest nicht ganz in deiner Aussage passen!
Stimmt, es ist nicht der 3.4 Stock Kernel, aber die Stock-Fotoqualität wird durch Nutzung der Sony Stock Kamera-Blobs erreicht, wie hier bestätigt wurde. Und das geht wohl nur durch Nutzung eines 3.4-er Kernels und nicht mit dem (eigentlich neueren 3.10-er Kernel), worüber hier und in den nachfolgenden Posts und hier gesprochen wurde. Der Entwickler Nailyk gibt dazu in diesem Post ein paar interessante Informationen.

Zusammengefasst: Die Entwickler haben unter dem 3.4-er Kernel irgenwie geschafft (der Trick ist bisher zumindest in den Foren nirgendwo verraten worden), den DRM-Schutz für die Stock Kamera Blobs von Sony auszuhebeln, sodass unter Custom-ROMs, die darauf aufbauen, die von Stock gewohnte Kameraqualität erreicht wird. Die angekündigte neue Verson des Carbon ROMs wird aus diesem Grund jetzt auch auf dem 3.4-er Kernel aufbauen.

Alles in allem ist das ein riesen Fortschritt, nachdem die Custom ROM Entwickler jahrelang auf die Sony AOSP Blobs setzen mussten, welche einfach Mist sind (Rauschen, "Reversed Fish Eye Bug" usw.) und eine Sackgasse dargestellt haben. Ich vermute, dass Sony in den DRM-geschützten Blobs irgendwelche patentgeschützten Algorithmen einsetzt, die sie nicht in den AOSP Blobs veröffentlichen wollen bzw. dürfen.

Du hast natürlich auch Recht, der Durchbruch kommt ein bisschen spät. Aber ich hatte und habe bisher kein Problem damit, die letzte 23.5.A.1.291 Stock ROM (gerootet und debloated) zu benutzen, da alles sehr stabil und zuverlässig läuft. Wenn Sony zumindest noch Sicherheitspatches für die Marshmallow-ROMs veröffentlichen würde (was man ihnen wirklich ankreiden kann), dann hätte ich gar kein Problem damit, weiter dabei zu bleiben.

Nougat bietet auf dem Z3c eigentlich keinen großen Mehrwert und ein paar wenige aktuelle 3D-Spiele laufen in der Konstellation z.B. gar nicht, da sie vom Play Store unter der Annahme installiert werden, dass mit Nougat auch die Vulkan API vorhanden ist (was ja eigentlich Voraussetzung ist), welche auf dem Snapdragon 801 aber nun mal nicht da ist, weshalb das Spiel dann nicht startet. Da wäre Marshmallow wieder im Vorteil, weil automatisch die funktionierende ältere OpenGL API genutzt würde. Mir soll das aber egal sein, weil's bisher nur ein paar wenige (Renn-) Spiele betrifft, die ich sowieso nicht spiele.
 
Kazama

Kazama

Ehrenmitglied
Mh dann bin ich mal gespannt ob die Rom tatsächlich noch Official wird. Dann würde ich das bei meiner Freundin am Z3C mal testen.

Wenn das für das Tab und das Z3 auch noch kommt wäre das cool.
 
O

okij

Ambitioniertes Mitglied
Z3 soll auch offiziell werden, wird ja vom gleichen Team parallel zu Z3c und Z2 entwickelt.

Das Tab Z3 ist leider nicht dabei, obwohl die Hardware - so weit ich weiß - ähnlich zu den genannten Smartphones ist, der Mehraufwand für die Entwicklung also überschaubar sein sollte.
 
Kazama

Kazama

Ehrenmitglied
Mh na vll nimmt sich jemand das Z3 tab vor wenn er quasi die Basis dafür schon hat.

Ich hab hier im Forum und bei XDA schon mal Zwecks einer Romportierung eines Z3 Roms für ein Z3C angefragt. Da kam bisher keine Antwort. Ich denke mal das ist nicht so einfach wie man sich das vll denkt.

Ich hab davon so gar keine Ahnung. Root und Flashen etc ja das ist fast bei allen Devices änlich. Aber ein ROM bauen oder ne App. Keine Ahnung. xD
 
snoopy-1

snoopy-1

Ehrenmitglied
Vorador85 schrieb:
Habe nun mal ganz normal über Micro USB aufgeladen und das Problem besteht immer noch. Also sobald ich das Gerät wecke, muss ich die PIN eingeben.
Na ja, vielleicht solltest auch mal selbst erst mal mehr Info geben, wie z.B. zum verwendeten Netzteil (Ladeleistung in mA), aber auch mal Info zu dem was du selbst bisher zur Abhilfe versucht hast! Hast überhaupt schon mal zurück gesetzt oder gar mal neu installiert? Welche Version von Linage verwendest aktuell?

So wie es aussieht stehst du mit dem Problem ja ziemlich alleine da, insofern kann es an der ROM ja nicht wirklich liegen, wenn es nicht gerade eine der ersten daraus ist!
Gruß,

snoopy-1
 
V

Vorador85

Neues Mitglied
snoopy-1 schrieb:
Vorador85 schrieb:
Habe nun mal ganz normal über Micro USB aufgeladen und das Problem besteht immer noch. Also sobald ich das Gerät wecke, muss ich die PIN eingeben.
Na ja, vielleicht solltest auch mal selbst erst mal mehr Info geben, wie z.B. zum verwendeten Netzteil (Ladeleistung in mA), aber auch mal Info zu dem was du selbst bisher zur Abhilfe versucht hast! Hast überhaupt schon mal zurück gesetzt oder gar mal neu installiert? Welche Version von Linage verwendest aktuell?

So wie es aussieht stehst du mit dem Problem ja ziemlich alleine da, insofern kann es an der ROM ja nicht wirklich liegen, wenn es nicht gerade eine der ersten daraus ist!
Gruß,

snoopy-1
Das benutzte Netzteil ist das original von Sony und die verwendeten Roms sind die letzten 3 Versionen. Habe auch schon zurückgesetzt und auch schon neu installiert. Immer das selbe Spiel. Nur mit den Sony Roms lief es ohne Pineingabe
 
O

okij

Ambitioniertes Mitglied
@snoopy-1: Es gibt jetzt ein neues Build der CarbonROM, welches auf dem aktuellen LineageOS 14.1 basiert. Die Kamera hat daher nun auch dort Stock-Qualität. :)

Der XDA-Thread ist hier und die ersten Feedbacks mit Bug Reports sind auf Seite #53 f. zu finden.
 
snoopy-1

snoopy-1

Ehrenmitglied
Danke den Thread kenne ich natürlich weil ich die seit Januar zur Verfügung gestellten ROM's natürlich alle immer probiert hatte. Geladen wird die neue ROM schon mal und testen werde ich sie wohl dann heute Abend oder morgen!
Gruß,

snoopy-1
 
B

Blockadefan

Neues Mitglied
snoopy-1 schrieb:
Na ja, vielleicht solltest auch mal selbst erst mal mehr Info geben, wie z.B. zum verwendeten Netzteil (Ladeleistung in mA), aber auch mal Info zu dem was du selbst bisher zur Abhilfe versucht hast! Hast überhaupt schon mal zurück gesetzt oder gar mal neu installiert? Welche Version von Linage verwendest aktuell?

So wie es aussieht stehst du mit dem Problem ja ziemlich alleine da, insofern kann es an der ROM ja nicht wirklich liegen, wenn es nicht gerade eine der ersten daraus ist!
Gruß,

snoopy-1
Ihr habt das wahrscheinlich beide übersehen: Der Bug ist bekannt und in Bearbeitung (siehe auch hier #60, dritter Absatz). Das Telefon rebootet, wenn es über Nacht geladen wird. Ich glaube auch etwas von einer Uhrzeit, 2:00 Uhr oder 3:00 Uhr, gelesen zu haben, bin mir da aber nicht mehr ganz sicher.
Im XDA-Forum ist davon auch berichtet worden und ich habe ebenfalls das Problem (ROM vom 25.05. installiert). Ich bin aber froh, dass Wecker trotzdem funktioniert. ;) Daher stört mich das nicht zu sehr.

Ich hatte aber bei der neuen ROM bisher zwei mal das Problem, dass die mobilen Daten nicht mehr funktioniert haben. Das lies sich jedoch durch einen Reboot beheben.
 
snoopy-1

snoopy-1

Ehrenmitglied
Nein, eigentlich nicht wirklich, nur das mit dem "über Nacht" habe ich wohl ein wenig ignoriert. Hatte das am Anfang meine ich schon auch mal gelesen gehabt, aber eigentlich auch gedacht es hätte sich mittlerweile erledigt. Meine auch noch zu wissen das es da am Anfang vor allem Probleme gab mit dem laden bei ausgeschaltetem Gerät, wo sich das Display nicht völlig abgeschaltet hatte.
Da ich mit den reboots keine Probleme hatte dachte ich natürlich auch, es hätte sich mittlerweile komplett erledigt und wäre bereits gefixt, aber das bezog sich wohl nur auf die Displaysache bei abgeschalteten Gerät.

Na ja, wie auch immer, die Ladezeiten kann man ja im Grunde steuern. Das laden über die Nacht sollte man ja ohnehin nicht machen, weil es neben dem überhitzen des Akkus mitunter zu den schlechtesten Sachen gehört die man dem Akku antun kann. Die 1.1/2 bis zwei Stunden sollte man auch noch machen können solange man Wach ist!
Gruß,

snoopy-1
 
D

dreamar

Ambitioniertes Mitglied
Hallo,

ich nutze auch das aktuelle LineageOS und habe mal ne Frage zur Performance. Es passiert häufiger das das Handy erst nach einer Denkpause Apps öffnet, oder Denkpausen zwischen zwei Aktionen hat. Zum Beispiel die App Facebook hakt sehr oft beim scrollen. Diese Denkpausen ziehen sich durch so ziemlich alle Apps und dauern schonmal etwas länger oder die App stürzt ab. Hat jemand ähnliche Probleme? Bin kurz davor wieder auf Stock zu gehen.

PS. Das mit der fehlenden mobilen Internetverbindung habe ich auch ab und zu. Zu beheben nur durch einen Neustart.
 
V

vortexor1

Fortgeschrittenes Mitglied
Hallo!

Ich möchte auch Lineage flashen. Aktuell ist CM12.1 installiert.
Ist folgende Vorgehensweise richtig?
in der CM-recovery: wipe system, data, cache, dalvik cache, rom flashen, gapps flashen und los gehts?

Vielen Dank im Voraus und mfG Wolf
 
D

djon

Fortgeschrittenes Mitglied
Es gibt wieder eine neue Version vom 20170607.
 
snoopy-1

snoopy-1

Ehrenmitglied
@vortexor1
Du musst erst mal noch TWRP in die fotapartition installieren. Steht aber so auch im verlinkten Beitrag auf "xda" ganz oben dabei und da findest auch einen Link zu TWRP!
Gruß,

snoopy-1
 
V

vortexor1

Fortgeschrittenes Mitglied
@snoopy-1
Danke! Das wäre meine nächste Frage gewesen ob man TWRP zwingend braucht. Somit ist alles klar.
Vielen Dank!
 
hipi0101

hipi0101

Fortgeschrittenes Mitglied
Gibt es noch eine andere Möglichkeit das neue twrp zu flashen außer mit fastboot im adb tool?