Fragen & Diskussion betreffend die (Anleitung zur) Aktivierung des Root-Accounts

A

annsomann

Neues Mitglied
weil ich aus diesem grund die probleme habe...habe nach wiki gearbeitet
 
A

arnulf

Gast
Moin,
Frage:
Du hast die recovery.img Datei im selben Ordner gehabt in dem du die adb-fastboot.zip Datei entpackt hast?
Gruß Arnulf
 
A

annsomann

Neues Mitglied
ja habe ich...jetzt habe ich den zustand dass mein g600 nur im cwm startet....immer und immer wieder

windows erkennt es auch nicht....im gerätemanager: andere geräte...full
 
Zuletzt bearbeitet:
Andy

Andy

Ehrenmitglied
Also wenn es nur noch in das CWM Recovery startet hast du doch schon mal einen Lichtblick:

1. Entweder hast du dir zufällig noch die CWM Recovery in die boot-Partition geflasht oder du hast im CWM Recovery z.b. /system formatiert und keine ROM mehr drauf.
2. Ich würde daher einfach ein Backup über CWM Recovery über den Punkt "backup & restore" wiederherstellen. Falls du kein eigenes erstellt hast, musst du darauf warten und hoffen, dass dir hier jemand ein Backup zur Verfügung steht.
3. Alternativ kannst du auch eine Firmware per dload flashen (eine passenden update.app im Ordner "dload" auf die Speicherkarte packen)
 
A

annsomann

Neues Mitglied
danke...das gibt mir wieder hoffnung....also wer mag mir weiterhelfen:thumbsup:
 
Q

quaddel

Neues Mitglied
annsomann schrieb:
2. Copy recovery.img (stock recovery you just extracted using method above) to your android-sdk-windows\platform-tools directory

welches recovery.img soll ich wohin kopieren.....ich habe panik etwas falsch zu machen:mellow:
Die in recovery.img umbenannte system.img kopierst Du in das Verzeichnis, von dem Du das cwm geflasht hast. Dort sollte schon eine Datei namens recovery.img liegen, in der das cwm steckt. Die überschreibst Du - oder besser benennst vorher die alte wieder um dann die extrahierte recovery.img kopieren zu können.
annsomann schrieb:
und das mit perl...habe es installiert, aber in der anleitung sehe ich nix über perl ??
Perl hast Du schon benutzt als Du damit eine Perl-Programm-Datei ausgeführt hast. In der Datei split_updata.pl stehen die Anweisungen, die der Perl-Interpreter nach und nach ausführt. Das Ergebnis war der output-Ordner mit den herausgezogenen Dateien darin.

annsomann schrieb:
Mit einem Hexeditor, z.B HxD vor dem Flashen der Recovery.img anschauen. wozu mache ich das? und vor allem wie??
Das dient nur dazu, das du in den Header reinschaust. HxD installieren, starten und die recovery.img laden. Das ist nur nochmal zur Kontrolle, damit du nicht ausversehen eine falsche Datei erwischt hast.
Ziemlich am Anfang steht dann was von "androidboot.hardware=huawei loglevel=1" und die Datei fängt mit "ANDROID!" an.
Wenn Du strikt nach der Anleitung gegangen wärst, hättest Du jetzt garantiert eine falsche Datei geflasht und die Folgen stellt Dir besser nicht vor.

Ein zusätzlicher Test ist das Kontrollieren einer Prüfsumme. So stellt man fest, ob eine Datei noch genauso ist, wie sie beim Erstellen der Prüfsumme war und sich nicht verändert hat. Es gibt zig Varianten dieser Perl Datei, manche funktionieren, manche nicht. Die Dateien die dabei heraus kommen sind dann natürlich auch unterschiedlich. Also Check die Prüfsumme.

Mit den Tipps aus Beitrag #68 geht es erst weiter wenn es hier nicht mehr weiter geht (weil nichts mehr da ist, was man booten könnte)
AnyAndroid hat es angeblich ja geschafft, sein G600 so wieder zu booten.

Ansonsten versuche wirklich (vorher) zu verstehen was Du machst. Führe nicht blind einfach irgendetwas aus. Hol Dir vieleicht jemanden dazu, der dir hilft. Hier antwortet Dir das große Master Control Program.
 
A

annsomann

Neues Mitglied
using command D:\android-sdk-windows\platform-tools


Mein G600 startet nur ins cwm menü....im Kommandofenster erscheint nur "warte auf handy" ...?? wie mache ich es, dass
"Type fastboot flash recovery recovery.im" ausgeführt werden kann??
 
det-happy

det-happy

Ehrenmitglied
In dem du in der Kommandozeile eingibst:

Code:
adb reboot-bootloader
Das Gerät sollte neubooten und ascheinend einfrieren

Dann
Code:
fastboot devices
Wenn er was findet, weitermachen
 
A

annsomann

Neues Mitglied
gerät nicht gefunden :confused2:

Der ursprüngliche Beitrag von 16:34 Uhr wurde um 17:14 Uhr ergänzt:

det-happy schrieb:
In dem du in der Kommandozeile eingibst:

Code:
adb reboot-bootloader
Das Gerät sollte neubooten und ascheinend einfrieren

Dann
Code:
fastboot devices
Wenn er was findet, weitermachen

das geht nicht!! Gerät nicht gefunden
 
A

annsomann

Neues Mitglied
Hat noch jemand eine Idee????

Zitat von det-happy
In dem du in der Kommandozeile eingibst:

Code:
adb reboot-bootloader
Das Gerät sollte neubooten und ascheinend einfrieren

Dann
Code:
fastboot devices
Wenn er was findet, weitermachen

Ich hänge immer wieder im cwm menü
 
Andy

Andy

Ehrenmitglied
Ich verstehe immer noch nicht, warum du die CWM Recovery neu flashen willst, wenn du sowieso ins CWM Recovery rein kommst.
Selbst wenn du das flasht, wird sich nix daran ändern, dass er nicht normal bootet. Wie oben schon geschrieben, hast du entweder die CWM Recovery fälschlicherweise noch in die boot Partition geflasht oder er bootet automatisch ins Recovery weil z.b. kein bootbares Androidsystem vorhanden ist.

Daher bleibt meiner Meinung nach nur der Weg entweder ein Backup wiederherzustellen oder über "dload" eine neue Firmware zu flashen.

Du könntest aber, da du ja ins CWM Recovery kommst, z.b. unter "mounts & storage" die einzelnen Partitionen mounten und am PC in der Eingabeaufforderung ein "adb shell df" eingeben. Dann sieht man ob die einzelnen Partitionen überhaupt belegt sind oder ob man die versehentlich/absichtlich formatiert hat.
 
A

annsomann

Neues Mitglied
Ein Backup habe ich nicht. Wie mache ich das, Firmware über "dload" flashen??
 
Andy

Andy

Ehrenmitglied
Ups, doch falsch geschaut. Es gibt ja gar keine original Firmware von Huawei. Dann muss dir wohl zwingend jemand ein Backup von sich zur Verfügung stellen, dass du über CWM Recovery restoren kannst.
 
A

annsomann

Neues Mitglied
Gibt es noch eine Möglichkeit in fastboot zu kommen??

Oder wer kann mir die Firmware zukommen lassen??
 
det-happy

det-happy

Ehrenmitglied
Fastboot : POWER PLUS LEISER beim booten halten.

So ist es beim Y200

...using tapatalk on my huawei honor smartphone
 
A

annsomann

Neues Mitglied
So ist es auch beim g600.....eigentlich! Aber so komme ich halt nur ins cwm :sad:
 
Q

quaddel

Neues Mitglied
annsomann schrieb:
Danke! Aber jetzt komme ich nicht mehr ins cwm

Der ursprüngliche Beitrag von 12:41 Uhr wurde um 12:42 Uhr ergänzt:

nur das HUAWEI Logo und dann bleibt es so....
Da warst Du im Fastboot!

Also nochmal ganz langsam:
- USB-Kabel abziehen
- Gerät ganz ausschalten, ggfs. Akku raus und wieder rein
- Leiser Taste drücken und gedrückt halten
(Das ist die unterste Taste, unten ist da, wo der Fußboden ist)
- Erst jetzt zusätzlich die Powertaste drücken und ebenfalls gedrückt halten
- Nach ca. 10-15 Sekunden beide Tasten loslassen.
- Die Taste zwischen den gedrückten Tasten ist die Lauter Taste. Diese Taste nicht berühren.

Du landest so wirklich im CWM?

Erst jetzt das USB-Kabel anstecken und mit dem Rechner verbinden.

Wird das Gerät erkannt? Wenn nicht, was wird im Gerätemanager von Windows als unbekannte Hardware angezeigt?
Nicht zufällig etwas was Ählichkeit mit
Code:
;Huawei CWM ADB
%CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_D001&MI_01
hat?

Jetzt das ganze nochmal fürs Recovery:
Also nochmal ganz langsam:
- USB-Kabel abziehen
- Gerät ganz ausschalten, ggfs. Akku raus und wieder rein
- Lauter Taste drücken und gedrückt halten
(Das ist die mittlere Taste)
- Erst jetzt zusätzlich die Powertaste drücken und ebenfalls gedrückt halten
- Nach ca. 10-15 Sekunden beide Tasten loslassen.

Wo landest Du da?

PS: Die Tasten sind in Ordnung und leichtgänging und nicht durch unsachgemäße Deckelentfernung in Mitleidenschaft gezogen worden?
Nicht das eine Taste klemmt!
 
A

annsomann

Neues Mitglied
Vielen Dank an alle!!!!!!!!!!!!!!!!!!!!!

Mein G600 läuft wieder...rooooot :thumbsup:

habe es nun endlich geschafft, nach der Anleitung von AnyAndroid


@quaddel: einen besonderen Dank an dich....für deine Geduld und den entscheidenden letzten Tippppp
 
capedroid

capedroid

Stammgast
@eifelzwerg: Auch wenn du in der Zwischenzeit deinen Code bekommen hast, will ich einer Antwort nicht schuldig bleiben. Anfrage am 21.02., positive Antwort am 01.03., also acht Tage.

Gesendet von meinem HUAWEI U8950N-1 mit der Android-Hilfe.de App
 
Zuletzt bearbeitet:
Oben Unten