Aktivierung des Root-Accounts

  • 218 Antworten
  • Neuester Beitrag
Diskutiere Aktivierung des Root-Accounts im Huawei Ascend Y330 Forum im Bereich Weitere Huawei Geräte.
E

erbsensuppe

Ambitioniertes Mitglied
usrname schrieb:
Soweit ich mich nun weiterhin belesen habe, kam ich vorerst zu dem Ergebnis, dass es derzeit garnicht möglich ist die B133 Firmware zu downgraden(?)
doch das geht, klick.
das tutorial funktioniert einwandfrei, sofern man die benötigten treiber korrekt am laufen hat. danach lässt sich das handy dann auch rooten.
 
Andy

Andy

Ehrenmitglied
Der verlinkte Beitrag sollte fast als extra Thread ausgelagert werden. Viele wollen wahrscheinlich downgraden und finden den Beitrag nicht. (Geschweige denn, wie man mit dem Flashtool umgeht ...)
 
H

handyworm

Neues Mitglied
thor2001 schrieb:
@handyworm

Mobileuncle geht natürlich eingeschränkt. Einfach auf anderem Handy ziehen und das TB-BU auf dem 330 recovern.

Es wird kein CWM-Recovery geben, da du NUR signed Dateien flashen kannst, also original Softwareup-/downgrade!

Danke, das mit mobileuncle hat so funktioniert.

Schade, so ein cwm-recovery is eigentlich das einzige das mir fehlt.
Gibts eigentlich noch andere Möglichkeiten sich Nandroid Images anzulegen und diese dann eventuell über das SP Flashtool zurück zu flashen?
 
U

usrname

Neues Mitglied
KatyB schrieb:
Der verlinkte Beitrag sollte fast als extra Thread ausgelagert werden. Viele wollen wahrscheinlich downgraden und finden den Beitrag nicht. (Geschweige denn, wie man mit dem Flashtool umgeht ...)
Wäre vielleicht passend, habe den Thread bestimmt bis Seite 10 durchstöbert und nichts gefunden, weils auf Seite 12 war :D

Also es hat nun geklappt das Handy zu rooten, ich danke sehr!
 
E

erbsensuppe

Ambitioniertes Mitglied
Der Umgang mit dem Flashtool wird ja auch erklärt, zumindest in einer Weise wie mans ohnehin benötigt. Nervig fand ich die VCom Treiber unter Windows 8. Jetzt läufts, aber warum das versteh ich nicht wirklich.
 
U

urizano

Neues Mitglied
Ich habe leider AdAway auf dem Y330 nicht dazu bringen können, die veränderte host-Datei zu schreiben. Offenbar ist das ganze /system/etc nicht Schreibzugriffen zugänglich. Ich habe mit verschiedenen AdAway-Versionen probiert, mit dem gleichen Ergebnis.

Hat jemand hier Erfahrungen?
 
thor2001

thor2001

Stammgast
Wie du richtig bemerkt hast ist es Schreibgeschützt, wie diverse andere Ordner/Dateien.

Im Prinzip analog nachfolgenden Schema, Schritte 01 bis 05:
https://www.android-hilfe.de/forum/...-und-co-auf-dem-y330-u01-build123.630871.html

Mensch, da steht sogar Y330 und Adaway im Titel, was für ein Zufall ... Sachen gibt's ;)

urizano schrieb:
Ich habe leider AdAway auf dem Y330 nicht dazu bringen können, die veränderte host-Datei zu schreiben.
Hat jemand hier Erfahrungen?
 
Zuletzt bearbeitet:
TSC Yoda

TSC Yoda

Ehrenmitglied
Moin zusammen.

Ich mache das hier jetzt zu und gucke mir an, was sich machen lässt.



Gruß
Markus
 
C

chris2006

Neues Mitglied
Habe mit dem "Nandroid Backup *online*" Tool aus dem Playstore ein komplettes Backup ziehen können (Build 133). Root ging mit Kingo Root App problemlos.
 
A

Aeskulap-01

Neues Mitglied
Ein herzliches Hallo an alle y 330-Besitzer, habe seit gestern auch so ein Gerät. Funktioniert eigentlich ganz gut. Habe da bloss ein Problem. Im WLan-Bereich komme ich einwan dfrei ins Internet. Doch ausserhalb funktioniert es nicht. Die Sim-Karte ist natürlich fürs Internet frei geschaltet. Ist sicherlich nur eine Einstellungssache.
Danke für eure Hilfe
 
Markus007

Markus007

Erfahrenes Mitglied
Ist die mobile Verbindungseinstellung des Providers. Bei tmobile oder eplus einfach über den pc die Hauptseite aufrufen und dann bei Serviceleistungen den handykonfogurator starten. Handynummer eingeben und dann wird eine Konfigurations sms an dein handy geschickt. Sms öffnen und ausführen und das handy wird automatisch eingerichtet.
 
K

klaus45

Neues Mitglied
Hallo zusammen..

ersma ein lob ans forum, hier findet man wirklich alles was zum rooten vom huawei y330/123 nötig ist.
habs dann auch erfolgreich hinbekommen.
habe zb schreibrechte für system/etc um hosts etwas zu "füllen".
inner shell mit setprop net.dns1 usw, lässt sich auch der dns-server anpassen.
leider immer nur temporär, nachm reboot is wieder der default dns-server eingetragen, (wifi mein isp dns).
wollte dann in system,etc,dhcpcd,dhcpcd-hooks, setprop net.dns1 usw inner 20-dns.conf eintragen um zu sehen ob dass persist ist.
aber keine schreibrechte dort, bin nur bis dhcpcd-hooks gekommen via mount & chmod 755.
weiss nun echt nich mehr weiter, hab alle mount befehle durch, inner set_immutable.list, oder mit lsattr sehe ich keine ausnahme für den 20-dns.conf pfad.
mal abgesehen davon ob dass ganze auch funzt, wurmts mich dass ich da keine schreibrechte bekomme.
hat von euch vielleicht jemand eine idee dazu wies funzen könnte ??
 
K

klaus45

Neues Mitglied
hab das anders gelöst..

setprop dhcp.wlan0.dns1 208.67.222.222
setprop net.dns1 208.67.222.222
setpop net.wlan0.dns1 208.67.222.222

die 3 zeilen als ganzes kopieren (wlan muss eingeschaltet sein, verbunden sein braucht man nicht)
und in terminal emulator einfügen (führt es direkt aus)
getprop | grep dns (als check)

hab mal meinen pc als wifi-spot eingerichtet und wireshark laufen lassen,
von google afwall aufs phone geladen, alle häkchen in afwall raus, dann wird sämtlicher traffic geblockt.
dns anfragen ala clients.google.com laufen ins leere..
erlaubt man allen traffic in afwall, kann man sich "unliebsame" url's aus wireshark rauspicken und in hosts packen..
 
J

J1nX3rS

Neues Mitglied
Hallo zusammen.
Bin gerade bissl am Verzweifeln.
habe jetzt auch seit kurzem ein Y330. Nun wollte ich es rooten, aber ich komme nicht weiter. Downgrade auf B123 habe ich erfolgreich durchgeführt. Danach habe ich dann King Root installiert (ver.: 1.2.29), aber egal was ich mache, das Handy wird nicht erkannt. Es kommt immer die Meldung: Not connected ... obwohl debugging mode aktiviert ist. Was mache ich falsch ?
 
thor2001

thor2001

Stammgast
@J1nX3rS

Wenn du es eh schon erfolgreich Downgraded hast, sollten die Treiber eigentlich funktionieren.

Wir sprechen schon von Kingo Root, oder?
 
J

J1nX3rS

Neues Mitglied
Ja, ich versuchs mit Kingo Root. Ich bekomme immer die Meldung (Bild im Anhang)
Build Number ist korrekt (B123). USB Kabel direkt am PC (Win7 64bit). Ich habe auch schon mehrere USB Kabel und Ports ausprobiert. Immer der gleiche Fehler.
 

Anhänge

thor2001

thor2001

Stammgast
@J1nX3rS

Wenn du schon andere Kabel und Ports probiert hast, bin ich auch ratlos.

Evtl. anderer PC.

Evtl. anderes Rootprogramm (z.B. iRoot, ehemals vRoot).

Gruß
 
T

Tubii

Experte
Moinsen,
Mal eine Frage
Seitdem ich die Build 123 drauf habe ist meine Datenverbindung piss langsam, Zugangspunkte (APN) habe ich schon zurueck gesetzt & auch die Datenverbindung an sich ist so korekt.
Nun wollte ich mal sehen ob es an der Build liegt oder nicht und die Rom_0 wieder drauf ziehen, Die frage stellt sich nun, Wie stelle ich das an, Finde nur die zum Downgrade aber net zum Upgrage o.0
 
thor2001

thor2001

Stammgast
@Tubii

Zurücksetzen schon einmal ausprobiert?

Update/"Backup einspielen" funktioniert analog dem Downgrade.
Preloader, USER und Cache deselektieren, Flashen und danach ein Factory Reset.
 
T

Tubii

Experte
Ogott o.O Was meinst du mit dem 'deselektieren' ?

Und zuruecksetzen .. Naja .. Das Problem ist ich weiß nicht ob das Internet von dem Handy gedrosselt ist oder ob es an der Rom liegt, Jedoch war es erst so nachdem die Build 123 drauf war ... Daher finde ich das schon sehr komisch ..

Also muss ich eigentlich die Rom_0 (die ich mir gesichert habe) deselektieren & dann diese Flashen ?

Und den Satz mit Update/Backup verstehe ich nicht ganz

[Kurz eine Frage zu Build 123 incl. Root]
Desweiteren weißt du wieso Freedom die Meldung gibt : Write permissions on system partition are required in order to use Freedom.

Kann ja englisch , Fuer mich heißt das dass die System Partition keine Schreibrechte bzw. SU rechte hat ... Habe doch aber Root o0, Kann ich das mir Root Explorer nicht nachtragen bei System/etc ?
EDIT : Selber bemerkt das dort beim Berechtigungen aendern ueberall ein Fehler kommt .. Gott is das Handy locked ... -.-'
Von meinem Note 3 kenn ich so ein Pipifax nicht :D
 
Zuletzt bearbeitet: