Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

P30 Pro P30 Pro & Pi-Hole - seit FW 10.1.0.123 keine Werbefilterung mehr?

  • 42 Antworten
  • Neuester Beitrag
Diskutiere P30 Pro & Pi-Hole - seit FW 10.1.0.123 keine Werbefilterung mehr? im Huawei P30 / P30 Pro / P30 Lite Forum im Bereich Huawei Forum.
F

Fonetic

Ambitioniertes Mitglied
Ist das vielleicht irgendein IPv6 Problem? Fällt mir jetzt auf die schnelle nichts ein...

Bei mir übrigens das gleiche.. pivpn geht zwar, aber die DNS anfragen werden nicht über den pihole geleitet.
 
Zuletzt bearbeitet:
3Komma14

3Komma14

Fortgeschrittenes Mitglied
Schon seltsam... Bin gerade unterwegs und da bin ich immer per OpenVPN mit meinem Heimnetzwerk verbunden und habe keine Probleme.
@Siutsch hast du in Erwägung gezogen, dein Smartphone Mal komplett zurückzusetzen?
 
J

Jr08

Ambitioniertes Mitglied
Adguard VPN funktioniert auch weiterhin, also lokal auf dem Telefon.

Ich hatte bei der 10.0 den Bug das ab und an das LTE Symbol aufgeblitzt ist. Das ist behoben. Eventuell rührt es daher?
 
3Komma14

3Komma14

Fortgeschrittenes Mitglied
@Jr08 was meinst du?
AdGuard hat mit der DNS-Konfig im Heimnetzwerk doch nichts zu tun
 
J

Jr08

Ambitioniertes Mitglied
Adguard Filter auch DNS, halt über eigene Server
Beitrag automatisch zusammengefügt:

Wenn ich irgendwas testen kann, sehr gern.
 
Zuletzt bearbeitet:
S

Siutsch

Neues Mitglied
@3Komma14
(War ein paar Tage unterwegs ...)

Nee, zurück gesetzt habe ich nichts, würde ich auch ungern.

Bin gespannt, ob man hier noch irgendwas heraus findet, so kann es ja nicht bleiben.
 
F

Fonetic

Ambitioniertes Mitglied
Für mich ist nach wie vor fraglich, wie das Huawei im Flugmodus, verbunden mit WLAN, das WLAN hat aber kein DNS Server, trotzdem Anfragen auflösen kann... private DNS ist aus, in den WiFi Einstellungen ist zweimal die pihole ip als DNS Server hinterlegt... Und das lustige, pihole ist vom Strom getrennt... wie geht das??????

Kann doch nur ein Bug sein.. da whatismydns sagt, dass der DNS Server Google sei.
Oder es ist ne Art Feature, bei fehlendem DNS Server einen von Google zu nehmen.. nur wurde hier nicht beachtet, das der DNS immer läuft und der vom dhcp vergebene ignoriert wird
 
Zuletzt bearbeitet:
S

Siutsch

Neues Mitglied
@Dr.No
In dem Link wird nur beschrieben, wie man statische Adressen eingibt, also nichts neues.
Auch wenn man manuell bei beiden DNS Servern den gleichen (Pi-Hole) eingibt, ändert das nichts.
Wie hier ja schon mehrfach beschrieben, scheint das P30 Pro nach dem Update auf 10.1 immer einen eigenen DNS Server zu wählen, weder den per DHCP zugewiesenen (wie bis zur 10.0), noch den statisch eingetragenen, was definitiv ein Bug ist, oder schlimmer, von Huawei gewollt.
Wenn es sogar einer in China ist, dann tracken die seit diesem Update fleißig deie kompletten URLs mit, was ich ganz und gar nicht toll finde.
Ich hoffe, irgendjemand hat einben Draht zu deren Hotline oder Support und steckt das da mal, damit das schleunigst wieder behoben wird. Ich hab das bisher nichts gefunden.
 
F

Fonetic

Ambitioniertes Mitglied
So Leute, DURCHBRUCH!!!!!!!
Habs ENDLICH geschafft!

Nachdem ich die google DNS (sorry für den Ausdruck) Kacke in der Fritzbox komplett blockiert und umgebogen habe, werden die ADs auf dem HUAWEI und nun in dem gesamten Netzwerk blockiert! Auch der tail auf den pihole.log zeigte mir, dass die gesamten Ads in den Apps und auf dem gesamten Gerät geblockt bzw. durch den pihole aufgelöst werden!

Folgendes hab ich gemacht:
How to Block Google DNS on Fritz Box - Unlocator Support

Habe noch in der Blacklist der FB die DNS von google (dns.google) eingetragen, hat aber nichts gebracht, erst als ich die IPv4 Routen umgebogen habe und die FB neugestartet habe, hat es endlich gegriffen und auf dem HUAWEI werden alle ads geblockt auch in den Apps!!
 
T

triagony

Neues Mitglied
Danke! Hat geklappt. :)
 
F

Fonetic

Ambitioniertes Mitglied
Mit dem Handy stimmt doch was nicht....
Sind zwei 30er Pro und das Verhaltensmuster beider Geräte ist so ziemlich gleich, nur das eine hat eben par tausend Requests mehr...

pihole.png
 
Zuletzt bearbeitet:
3Komma14

3Komma14

Fortgeschrittenes Mitglied
Den gleich Werbemüll habe ich seit dem heutigen Update auf meinen Mate 20 ebenfalls.
 
B

bin_einverstanden

Stammgast
Wieso ned gleich einen proxy? Ich habe einen Router der kann vieles gleich dort Blocken.
 
3Komma14

3Komma14

Fortgeschrittenes Mitglied
@bin_einverstanden das Smartphone umgeht es einfach intern!
Es stört sich absolut nicht an der Konfiguration des Netzwerkes.
Und das Blocken von 8.8.8.8 und 8.8.4.4 scheint auch keine Lösung zu sein.
Jedenfalls bei mir, funktioniert der Push von Gmail nicht mehr.
Heißt also damit zu leben bis ein neues Gerät gefunden ist.
 
B

bin_einverstanden

Stammgast
🥳 Einfach einen Proxy Server nutzten funktioniert bei mir 1A.
 
3Komma14

3Komma14

Fortgeschrittenes Mitglied
@bin_einverstanden und nochmals... Funktioniert bei mir definitiv nicht!
 
B

bin_einverstanden

Stammgast
3Komma14 schrieb:
Funktioniert bei mir definitiv nicht!
Dann hast du etwas falsch eingestellt. Bei mir funktioniert der Proxy schon seit Jahren perfekt.
 
3Komma14

3Komma14

Fortgeschrittenes Mitglied
@bin_einverstanden funktionierte bei mir auch immer klasse, bis EMUI 10.1 kam. Seitdem funktioniert es nicht mehr. Und ich freue mich total für dich. Nur hilft mir das eben nichts.
 
B

bin_einverstanden

Stammgast
Bei mir lauft das mit den proxy 1A auch mit der aktuellen FW.
 
Ähnliche Themen - P30 Pro & Pi-Hole - seit FW 10.1.0.123 keine Werbefilterung mehr? Antworten Datum
4
5
7