[Diskussion zur Anleitung] Wiederherstellung der IMEI-Nummer

F

fakeraol

Ambitioniertes Mitglied
In einer Diskussion zum i9300 habe ich gelesen, daß es da eine Umstellung des Formates der EFS-Partition gab und man bei dem gerät evtl. ein aktuelleres baseband flashen müsse.

Könnte das beim i9100 evtl. auch der fall sein, daß das Baseband aktualisiert werden muß beim Umstieg von CM 10.1.3 auf CM11-Snapshot-M11 ?
 
F

fakeraol

Ambitioniertes Mitglied
So, hab viel gelesen und einige Fragen.

Ich hab außer dem CM das PhilZ Touch Recovery 6.48.4 basierend auf CWM 6.0.5.0 drauf, bin mir jetzt garnicht so sicher, ob das überhaupt kompatibel ist (an die Möglichkeit hatte ich garnicht gedacht). Könnte es daran liegen? CM nochmal flashen, um auf dessen integriertes CWM zu kommen? Oder TWRP ?

Außerdem sagten mehrere "alteingesessene" User, daß eine fehlende Baseband-Anzeige auf einen Fehler beim Flashen des Modems hindeuten könnte. Da ich nicht weiß, ob die zum Rom passen müssen, hab ich bisher nichts unternommen ("Vorsicht ist die Mutter ..."), hab aus Obihörnchens Modem-Tread das XXLS8 Modem gezogen.

Besser das Recovery ersetzen, oder das Modem flashen? Oder... ?

PS:
Laut https://www.android-hilfe.de/forum/root-custom-roms-modding-fuer-samsung-galaxy-note-2.790/recovery-n710x-philz-6-48-4-cwm-6-0-4-7-06-07-2014.429723.html ist es KitKat-ready.



PS(2):
Bis auf *#06# funktioniert auch kein anderer Code, die IMEI ist leer, bei anderen Codes heißt es "Mobilfunknetz nicht verfügbar."
Hab jetzt auch den kompletten Tread einmal durchgelesen, allerdings scheint sich hier keiner mehr rein zu verirren. :-(
 
Zuletzt bearbeitet:
D

DerPet

Neues Mitglied
Nabend,

Telefon S2 bekommen zum drüber schauen ob noch was zu retten ist....

es war die letzte EPL Version drauf (E-Plus).

Basband=Unbekannt
Build=JZO54K.I9100XWLSS
IMEI=Null/Null
PDA=XWLSS
PHONE=Unknown
CSC=XXLS9

EFS gesichert als erstes..
dann einteilige EPL STOCK...
nun versuchte ich die LQ2 STOCK...
dann diverse DBT und auch einen Root-Kernel...
kTOOL...
G2Repair...
alles brachte nichts.

in Post 1557 hat KST66 so viel INPUT geleistet das ich es gleich mal versucht hab ^^, eMMC i.O.... aber ich kann die EFS nicht Flashen ...er failt jedesmal...
meine vermutung liegt auf einem defekten Bauteil, ist das soweit anzunehmen oder lieg ich da jetzt so falsch? :confused2:

Greez Pet
Ps: IMEI ist unter der Batterie vorhanden, und aber weder OVP noch Kaufbeleg ^^
 
kiliot99

kiliot99

Erfahrenes Mitglied
Muss auch meine IMEI wiederherstellen. Ich habe nur nicht gefunden, wie ich Schreibrechte auf dem Ordner erhalte... Root habe ich und der Dateimanager hat auch alle Rechte.

Edit: Der Inhalt wurde gelöscht. Habe jetzt wieder eine IMEI, allerdings fängt diese mit 004999 an und das Mobilfunknetzt ist weiterhin nicht verfügbar :(
Kann mir bitte jemand weiterhelfen?
Viiiielen Dank im Voraus :smile:
 
Zuletzt bearbeitet:
Nick Knight

Nick Knight

Ehrenmitglied
@kiliot99
Wenn Du ein Backup mit HC-KTool gemacht hattest, ist es doch einfach die Daten der efs Partion mit dieser App auch wiederherzustellen.
Oder hattest Du anderes ein Backup erstellt?

Gruß Nick Knight
 
K

KongoOtto124

Neues Mitglied
Tach allerseits

Ich gehöre leider auch zu denjenigen die Kein Backup des efs Ordners gemacht haben.
Ich habe den Ordner eigentlich eher unabsichtlich einfach auf den Desktop meines Rechners gezogen und wollte jetzt mal Fragen, ob mir die Sicherheitskopie was nützt?

Cheers Martin
 
html6405

html6405

Gewerbliches Mitglied
Jap im Normalfall schon, welches Handy hast du denn?
 
K

KongoOtto124

Neues Mitglied
Guten Morgen.

Ich hab das Galaxy S2 I9100.
Androidversion: 4.1.2
Kernel 3.0.31 -889555 SMP PREEMPT KST2013
 
html6405

html6405

Gewerbliches Mitglied
Ok und soll die IMEI jetzt restored werden oder war das nur eine allgemeine Frage?
 
K

KongoOtto124

Neues Mitglied
Ja
wär nicht schlecht wenn ich die wiederhergestellt bekomme. Ich habs auch schonmal mit der "9 Schritte" Variante probiert und mit GSII Repair. hat alles nichts geholfen.
 
html6405

html6405

Gewerbliches Mitglied
also jetzt bin ich aber gespannt, wird dir die Basisband in den Einstellungen angezeigt?
Es könnte ja auch an der Hardware liegen, kannst du mir kurz erläutern wie es eigentlich dazu kam?
Wenn die nv_data deines Ordners noch gültig ist und kein Hardwarefehler vorliegt,
kann ich sie dir locker wiederherstellen.
 
K

KongoOtto124

Neues Mitglied
Also Ich fang mal an...

Basisband, Phone , EMEI sind unbekannt.
Das Telefon hab ich von der Mutter eines Freundes mit dem Hinweis das etwas nicht so richtig funktioniert, bekommen.
Ich hab ne Sim reingesteckt und nichts hat sich getan. daraufhin google bemüht und die EMEI abgerufen. Ergebniss null/null.
Daraufhin hab ich n bissl herumexperimentiert :blushing:
( rumgeflasht ... erst hab ich CM rom draufgemacht. danach auf 4.0.3 und dann wieder auf 4.1.2. )
Ich hab außer beim CM die "9Schritte Anleitung" gemacht hat nirgends geklappt... (warscheinlich hab ich da irgend etwas falsch gemacht oder übersehen)

Das Flashen hat bis auf einen bootloop ganz gut geklappt.
 
html6405

html6405

Gewerbliches Mitglied
Ok also das schreit leider schon fast nach defekten Basebandprozessor, denn ich denke die Mutter deines Freundes hat nicht herumexperimentiert.
Das lässt sich aber ganz leicht rausfinden, könnte dir per TeamViewer schnell nachsehen wo das Problem liegt.
 
K

KongoOtto124

Neues Mitglied
Ok das klingt gut.
Ich muss das aber erst noch installieren.
 
html6405

html6405

Gewerbliches Mitglied
gut, schreib mir dann per PN und am Besten wäre es, wenn du 4.1.2 (stock) drauf hast.
 
D

Der-Matti

Neues Mitglied
Ich habe Mist gemacht .... >_<*

Hintegrund:
Da die Handys meiner Frau und mir (beide i9100) schlechten Empfang hatten, habe ich die RIL mit dem Tool "GetRIL" angepasst. Funktionierte wunderbar. Von 1 Balken Empfang auf 100%.
Nach einem Reboot war dann die IMEI weg und die Handys funktionierten nur noch im WLAN.

Habe letzte Nacht bis 2 Uhr gegoogelt und einiges ausprobiert:
- mit dem Tool "GS2 repair" ein Backup vom /efs Ordner gezogen (SD Card)
- unter Zuhilfenahme von "X-Plore File Explorer" unter einer Anleitung versucht die .nv-data.bin / .nv-date.bin.md5 zu rekonstruieren (([Anleitung] Wiederherstellung der IMEI-Nummer
- auf beiden Handys vergebens
~ Fallback auf Stock ROM nach Anleitung ((Galaxy S2: Von einer Custom ROM zurück zum Original – GFX-Stylez.blog
~ im Stock-ROM wird die IMEI wieder angezeigt
~ Philz touch und das Custom ROM Slim 5.1.1 wieder installiert ... IMEI weg >_<*

Fällt noch jemandem was schlaues ein?
Vielen Dank im Voraus für eure Hilfe

UPDATE:
Keine Ahnung warum, aber mein Handy geht wieder. Das von meiner Frau aber noch nicht - es hat weder Baseband noch IMEI Anzeige
 
Zuletzt bearbeitet:
L

leechseed

Gast
Galaxy Sim Unlock App installieren - efs Backup machen - Daten austauschen - efs Backup wieder einspielen. So hab ich das gemacht als alles verloren schien. ;)
 
aTg!s

aTg!s

Stammgast
Hi, mir ist während des Ladens das S2 vom Sofa gefallen, Deckel ab, Akku rausgeflogen. Jetzt findet es keine SIM-Karte mehr und IMEI ist weg / steht auf Null.
Das EFS-Backup hatte ich unter der Stock-Rom angelegt. Jetzt habe ich CM13.
Basisband vom Backup: I9100XXLS8
Buildnummer vom Backup: JZO54K.I9100XWLSD

Muss ich eventuell auf diese zurück? hc-ktool meckert, dass er die efs.img nicht lesen kann.
 

Anhänge

Zuletzt bearbeitet von einem Moderator:
Oben Unten