Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

Stock ROM fürs Darkside?

  • 91 Antworten
  • Neuester Beitrag
Diskutiere Stock ROM fürs Darkside? im Wiko Darkside Forum im Bereich Wiko Forum.
AM-I-ROOT?

AM-I-ROOT?

Erfahrenes Mitglied
Kennt jemand zufälligerweise eine Quelle über welche sich diese beziehen ließe?

*****************
Nachtrag:
hier einmal vorerst die StockRom aus dem franz. Forum, falls die Stock Recovery auch benötigt wird, kann diese nachträglich installiert werden (siehe hier)

Wiko_Darkside_Stock_Rom_with_CWM_Recovery.zip

Installation erfolgt über SP Flash Tools (einfach der Anleitung/ den Links von User voom folgen, siehe Posting #3). Hab die ROM selbst noch nicht ausprobiert.

****************
 
Zuletzt bearbeitet:
voom

voom

Stammgast
Quelle: [ROM] Stock du Wiko Darkside au format SP Flash Tool - Wiko Darkside - Développement, Rom & Tutoriels - Forum de FrAndroid

Sinngemäß, meine Übersetzung, ohne Gewähr! ;)

Beim Durchführen dieser Aktionen sollten Sie wissen, dass immer ein Risiko besteht. Sie sollten vorher ein Backup durchführen. (Anleitung für das Erstellen eines Backups (frz.)). Sie sind selbst für alle Schäden verantwortlich, die sich aus dem Befolgen dieser Anleitung ergeben könnten.

Agrimok hat ein flashbares Stock-Rom meines Darkside via SP Flash Tool exportiert, es ist mit dem Original identisch ausser dass es CWM Recovery und nicht das Stock Recovery beinhaltet. Es ist für jene gedacht, die ihr Darkside gebrickt haben oder die ein alternatives ROM installiert haben und nicht zufrieden sind und daher zum Stock zurückkehren möchten.

Anleitung und Links:

Stock-ROM des Wiko Darkside Android 4.2.1 Version P18


Vorbereitung

-Im Besitz eines Wiko Darkside sein
-Die Treiber müssen installiert sein
-SP Tool herunterladen: SP_Flash_Tool_exe_v3.1312.0.139
-Das ROM-Image herunterladen : https://mega.co.nz/#!KsgAXLgD!DvLP3xd_sRESYSucUZ8kRiEOmEY5S28WbYEedH7jouY
-Für alle Fälle ein Backup des derzeitigen Systems erstellen (Link zu Anleitung frz.)


Das ROM Installieren

-Die zwei heruntergeladenen Dateien (Flash Tool und Image) entpacken
-Die Datei "Flash_tool.exe" mit Adminrechten starten (die Datei ist im Ordner "SP_Flash_Tool_v3.1312.0.139")
-Auf "scatter loading" klicken
- Die Datei "MT6589_Android_scatter_emmc.txt" aus dem zuvor entpackten Ordner "StockDarksideSPTool" auswählen
-Option auswählen > USB Mode selected
-Option auswählen > DA Download All > Speed > Force to High Speed selected
-Auf "Firmware Upgrade" klicken
-Das Darkside ausschalten und mindestens 2 Minuten warten
-Darkside nicht einschalten
-Das Darkside mit dem USB-Kabel anschliessen
-Das SP Tool seine Arbeit machen lassen und nicht unterbrechen, da man sonst das Gerät bricken könnte
-Das kann bis zu 5 Minuten dauern
-Wenn es fertig ist, sollte ein grüner Kreis zu sehen sein
-Nachdem der grüne Kreis erscheint, das Darkside einschalten
-Nun hat man das Stock-ROM wie am ersten Tag (alle eigenen Daten sind natürlich weg)

Das ROM wurde von Agrimok und Baptman93a (Frandroid-Forum) getestet und es gab keine Probleme. Vor allem wenn man das Doodle 2 ROM installiert hat und ein Problem mit dem internen Anwendungs-Speicher hat (1GB statt 4GB verfügbar) kann man so das Gerät wieder in den ursprünglichen Zustand zurücksetzen.
 
Zuletzt bearbeitet:
voom

voom

Stammgast
Danke für den Link, dann stimmt das ja weitestgehend... Die 2 Minuten beziehen sich dann wohl darauf, da man hier den Akku nicht rausnehmen kann, dass das Gerät mindestens 2 Minuten aus sein sollte, bevor man weitermacht...
 
AM-I-ROOT?

AM-I-ROOT?

Erfahrenes Mitglied
Danke für die Antworten. Mir ging es um ein originales Image von Wiko. Also die Stock-ROM (.sbf) mit Stock-Recovery, welche unter Umständen via ADB flashbar wäre.
 
D

Draz

Neues Mitglied
Genau diese Stock-ROM würde mich auch interessieren, eine die über ADB zu flashen wäre.
 
voom

voom

Stammgast
Interessieren würde mich das auch, aber das oben genannte ist immerhin schonmal ein Lichtblick, falls jemand sein Gerät gebrickt haben sollte... ;)
 
D

Draz

Neues Mitglied
Meins habe ich gebrickt.
Leider komme ich mit dem Flash tool nicht weiter. Bekomme keine USB-Verbindung zum Darkside, egal mit welchen Treibern. Nur über Update via adb im recovery mode habe ich eine Verbindung zum Darkside, aber da verlangt es die originale Update-Datei. Gibt es diese vielleicht irgendwo im Netz?
 
voom

voom

Stammgast
Hast Du denn die Treiber installiert, die oben in der Anleitung verlinkt sind? Bist Du mal genau nach der Anleitung vorgegangen? Benutzt Du das Originalkabel?
 
D

Draz

Neues Mitglied
Habe alle Varianten mit Treibern, Computern und Kabeln schon durch.
Meine letzte Hoffnung wäre die originale Update-Datei über sideload adb.
 
AM-I-ROOT?

AM-I-ROOT?

Erfahrenes Mitglied
alternativ könntest noch versuchen die StockRom eines anderen bauähnlichen Chinamobiles zu flashen ( aber ohne EBR u. MBR), wenns eh schon tot ist wärs den Versuch wert.

bspw. vom Star S5 ist eine im Netz zu finden schaus dir mal an.
 
AM-I-ROOT?

AM-I-ROOT?

Erfahrenes Mitglied
@grayson: hast du dort schon ein solches image gefunden? ich rede nicht von zip dateien, welche via CWM eingespielt werden.

@draz: hier gäbs die ROM zum S5
 
G

grayson

Ambitioniertes Mitglied
Hallo,

ich habe mal die Dateien sowohl fürs Darkside wie auch für das Stairway geladen. Liegen auf "Mega-Servern" ohne Limit.

Jeweils ca. 320 MB groß, darin enthalten die Original Stock Daten der entsprechenden ROM`s. Lassen sich mit dem SP-Tool flashen.

Enhalten im Darkside Ordner u.a.:

boot.img, chache.img, die EBR`s, scatter-Datei, recovery.img, secro.img,system.img und die userdata.img und mehr.

Alles was das Herz begehrt. Damit und der Anleitung zum SP-Tool solltest Du das Darkside wieder in den Originalzustand bekommen.

Grüße
Grayson

Der ursprüngliche Beitrag von 09:33 Uhr wurde um 09:52 Uhr ergänzt:

Hallo,

für das Stairway habe ich die Anleitung aus dem ChinaMobiles-Forum genommen:

[MTK65xx] Flashen einer Firmware mit SPFlashtool [Schnellanleitung] | Chinamobiles.org

ist auf Deutsch ;-)

- Treiber ja hat etwas gedauert (habe ein MacBook mit Original Win7) dazu gibt es auch eine Anleitung wenn es mit den Treibern etwas hackelt:

Anleitung MTK65XX USB VCOM Treiber Installation + Test: [CWM Recovery Flash] | Chinamobiles.org

- Original Kabel wurde verwendet.

Hat bisher 2 mal super funktioniert.

Das Gefrickele mit dem USB Treiber ist nervig doch taucht wie in der Anleitung beschrieben der "Preloader...USB" im Geräte Manager auf, Du installierst die USB Treiber und startest den Rechner neu, dann funktioniert das SP-Tool so wie in der Anleitung von "rWx". Keine Sorge wenn Du das Gerät nicht siehst, im SP-Tool siehst Du es dann wenn der Flash beginnt.

Musste es auch er lernen, dauert etwas doch die User aus dem ChinaMobiles Forum sind geduldig (auch mit EX-Apflern) und die Anleitungen sehr gut.

Frankreich nutze ich nur zum suchen der Downloads da dort die Wiko`s verbreitet sind.

Grüße
Grayson

P.S. mein Stock Rom für das Stairway kommt auch aus dem "WikoandCo.fr" Forum und hat super funktioniert.
 
voom

voom

Stammgast
Ich hab jetzt das Image geflasht wegen meines OTA-Problems (siehe Thread "Update V8") - leider hat das immer noch keinen Erfolg gebracht, also ich kann immer noch keine Update installieren, obwohl ich jetzt doch eigentlich wirklich wieder im Originalzustand bin...

Andere Frage: es müsste doch mit dem Flashtool möglich sein, die Stock-Recovery aus einem Gerät zu laden und statt der CWM Recovery hier als Image mit in das Verzeichenis zu legen. Dann hätte man doch das, was AM-I-ROOT sucht? Ich würde die CWM nämlich auch gerne wieder durch die Stock Recovery ersetzen, für alle Garantie-Fälle...

Der ursprüngliche Beitrag von 12:41 Uhr wurde um 13:25 Uhr ergänzt:

Na super, jetzt geht gar nichts mehr... Das Gerät ist in einem Loop, bei dem es nicht mehr über das erste Wiko-Logo hinausgeht und bei dem ich es nicht mehr komplett ausschalten kann. D.h. ich kann auch kein Image mehr flashen, weil es dazu ja aus sein muss. Batterie rausnehmen entfällt hier ja als Option. :cursing:

Was jetzt?
 
voom

voom

Stammgast
Beides schon versucht... Ich kriege es nicht komplett ausgeschaltet. Es startet immer sofort wieder neu. Derzeit fällt mir nichts ein, ausser warten bis die Batterie leer ist, was ja bis zu Tagen dauern kann... (Ich hab sogar schon mal unter die Aluabdeckung geschaut, aber die Batterie dort abzuklemmen ist auch nicht so einfach möglich, da besteht mit meinen Mitteln zu sehr die Gefahr, dass ich das Gerät dann komplett schrotte...)

Äh, ich glaube das Recovery ist das Problem. Ich habe versucht, ein Stock-Recovery zu flashen, unter der Annahme, dass ich wenn es schief geht ja wieder das funktionierende Image hier aus dem Thread flashen kann, mit dem CWM Recovery. Dass das Gerät nicht mehr aus zu kriegen ist, auf die Idee bin ich nicht gekommen...

Der ursprüngliche Beitrag von 14:22 Uhr wurde um 14:27 Uhr ergänzt:

Was ich mich jetzt noch frage ist, wenn ich es aus diesem Zustand nicht mehr rauskriege, ob das dann jemand noch erkennen kann, woran es liegt, wenn ich es einschicke... Sonst würd ich halt sagen, es sei nach einem OTA-Update in diese Bootloop geraten und ...

Der ursprüngliche Beitrag von 14:27 Uhr wurde um 14:34 Uhr ergänzt:

Edit: schau mal hier:

Wiko Darknight startet nicht mehr!

sollte helfen.
Beim Darknight kann man anscheinend den Akku rausnehmen... Wenn das ginge, könnte ich wieder mit dem SP Tool flashen.... Alles andere geht nicht weil ich ja jetzt keine funktionierende Recovery drauf hab...
 
G

grayson

Ambitioniertes Mitglied
Hallo,

hast Du schon versucht es mit dem SP-Flash-Tool direkt mit dem Stock Image dazu?

Als alles wie beschrieben in der Anleitung anklicken/aktivieren, den Download im Tool anklicken und dann erst das Darkside anschließen?

Grayson
 
voom

voom

Stammgast
Ja, wie gesagt - dafür muss das Gerät ausgeschaltet sein - im derzeitigen Status wird es nicht erkannt. Heut Vormittag hab ich ja erst erfolgreich das Image mit den SP Tools geflasht, dann habe ich die gleiche Prozedur nochmal gemacht nur eben mit einem recovery.img das die Stock-Recovery sein sollte. Die ist vermutlich nicht i.O. Das Flashen hat geklappt, aber nach dem Neustart das beschriebene Bild: es startet sich immer wieder nach eine Weile neu, wenn das Wiko-Logo da war, der Schirm wieder schwarz wurde aber mit Backlight an. Es geht nie ganz aus und ist auch nicht auszuschalten, es sei denn es gäbe eine geheime Tastenkombi, die nicht in irgendeinen Modus rebootet, sondern das Gerät wirklich komplett ausmacht.