Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

[Anleitung] SP Flash Tool einrichten und Anwenden unter Windows

  • 212 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung] SP Flash Tool einrichten und Anwenden unter Windows im Anleitungen für MediaTek-Geräte im Bereich Weitere Hersteller allgemein.
volvocarl

volvocarl

Ambitioniertes Mitglied
Im XDA ist es so ohne Englisch schwierig :(.
Geht aber trotzdem nicht, das gleiche Problem.
Steht da was, ob ich in den Entwickler-Einstellungen irgendwas anklicken muss. Debug oder irgendwas. das ist bei den anderen Phones meist so gewesen.
Oder es gibt noch "Bootloader-Entsperrung zulassen". Hatte ich zwar eigentlich schon alles probiert...
 
Miss Montage

Miss Montage

Ehrenmitglied
Es wäre mir neu, dass UMI den Bootloader sperrt, aber mein Verdacht ging auch in die Richtung. In der XDA-Anleitung steht aber nichts davon. Du kannst USB-Debugging aktivieren, ist meines Wissens für das Flash Tool aber auch nicht nötig.
Was Du noch versuchen kannst: Nimm TWRP und Scatterdatei vielleicht mal aus dem SP Flash Tool-Verzeichnis und verschiebe sie in einen separaten Ordner.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Einen Hinweis habe ich noch gefunden: Falls Du mehrere Programme nebenher laufen hast, bitte schließen, und vielleicht nochmal andere USB-Anschlüsse durch testen. Das Flash Tool scheint immer noch Probleme mit USB 3.0 zu haben
 
N2k1

N2k1

Ehrenmitglied
Versuchst Du es mit - oder ohne Akku?
Startet das Gerät noch - oder geht gar nichts mehr?
 
M

mobilematic

Ambitioniertes Mitglied
Ich weis nicht Weiter :( und brauche eure Hilfe.
gestern wollte ich nach der Anleitung mein Star 7599 mit dem Stock ROM flaschen.
Nach dem klicken von "download" kommt erst das rote Balken und bei 100% nach ca 15sec ein BROM ERROR :S_FT_ENABLE DRAM_FAIL (4032) Fehler.
Habe im SP Flash Tool die einstellungen: "download only" + "firmware upgrade" ausprobiert., leider immer der gleiche Fehler. Beim googeln finde ich zusammen mit der Bezeichnung des Fehlers dass das Handy gebrickt sein soll. Nein es ist nichrt der Fall, da ich das Handy normal starten kann.
Wer kamm mir helfen? Wie kan ich den BROM Fehler übergehen und was es überhaupt ist?
Habe zwei Screenshots eingefügt und beid dem ersten ist der Fehler zu sehen.
Übrigens komischerweise will dasSP Flash Tool keinen UBOOT flaschen (sehe Foto) und im ROM Ordner ist auch keine Datei die Uboot heißt. Ist das normal?
 

Anhänge

Miss Montage

Miss Montage

Ehrenmitglied
Die Fehlermeldung deutet ja eher auf einen Kompatibilitätsfehler hin, muss aber nicht sein. Hast Du mal versucht, beim Verbinden die Lauter- oder Leiser-Taste zu betätigen? Außerdem ist mir aufgefallen, dass Deine Flash-Tool-Version schon relativ alt ist, da würde ich ggf. mal eine neuere (5.1604 aufwärts) ausprobieren.
Was Uboot betrifft: Gibt es im ROM-Ordner ein lk.bin? Dafür könntest Du den Pfad manuell setzen.
 
K

Kaltfront

Ambitioniertes Mitglied
Hi, ich versuche das Elephone P9000 zu flashen da der Recovery Modus Tod ist....
Ich habe Windows 10 Pro was Aktuell ist und bin nach dieser Anleitung vorgegangen.
Jedoch kommt schon eine Fehlermeldung das dass Handy also USB gerät nicht erkannt wird und dann ist der Treiber welcher ein Ausrufezeichen im Gerätemanager hat auch wieder weg und das Handy lädt weiter den Akku auf.
So kann ich Natürlich nicht Fflashen, Flashtool erkennt Natürlich das Handy auch gar nicht.
Wenn das Handy an ist erkennt es Windows normal.
Irgendeiner eine Idee?
 
K

Kaltfront

Ambitioniertes Mitglied
Hat sich erledigt, ich habe mein alten Laptop mit Win7 benutzt und es "ging" jedenfalls hat mir Flashtool gesagt das er erfolgreich geflasht hat..... tja nun hab ich ein Briefbeschwerer denn nach dem flash ging das Handy nicht mehr an. Es wird am PC nicht mehr erkannt. An der Steckdose passiert auch nichts.
Soviel zum Thema Elephone.
 
N2k1

N2k1

Ehrenmitglied
Kaltfront schrieb:
Soviel zum Thema Elephone.
Was kann ELEPHONE dafür, daß Du das Telefon zerflasht hast?
Aber es gibt kaum eine Möglichkeit diese Geräte komplett zu schrotten.
Wenn es nun gar nicht mehr erkannt wird - man aber ausschließen kann, daß es an einer defekten Buchse liegt - dann muß nur der Preloader neu geflasht werden, den Du wohl zerschossen hast.
Dazu darf nur der (passende) Preloader im Flashprogramm aktiviert werden und erst danach wieder die komplette Firmware aufspielen.
Warum Du jedoch den Preloader zerschießt, wenn Du lediglich die Recovery-Partition flashen willst, ist für mich nicht nachvollziehbar.

PS: Ich nutze Win10 seit es Win10 gibt - und beim Flashen hatte ich noch nie Probleme!
Selbst unter der aktuellen Insider-Preview gibt es mit den Treibern keine Probleme!Screenshot_2.png Screenshot_3.png Screenshot_4.png
 
Miss Montage

Miss Montage

Ehrenmitglied
@N2k1: Kaltfronts Gerät läuft wieder, siehe mein Link in Post #49.
 
N2k1

N2k1

Ehrenmitglied
Danke für den Hinweis.
Aber es zeigt, daß auch hier erst auf den Hersteller gewettert wird - auch wenn man selbst den Schaden verursacht hat.
Zudem wurde ja auch behauptet, daß es unter Win10 Probleme gäbe - so wie auch viele unter Linux nicht in der Lage sind, die udev-Regeln einzustellen.
 
K

Kaltfront

Ambitioniertes Mitglied
Hm? Ich hab schon Zig Handys unter Windows 10 geflasht (ohne Probleme) und denke ehr das es ein Treiber Problem war.
Das das Handy zerflasht war sehe ich nicht als meine Schuld an sonst hätte ich es nicht Wiederbeleben können in dem ich alles genauso gemacht habe ;)
Zumal ich gegen Elephone ehr wegen dem Touchscreen Ausfall und dem Fingerprint Ausfall gewettert habe ;)
Na ja und das der Recovery nach einem Update weg ist, hatte ich auch noch nie ^^ Ich denke das sind gute Gründe um sich gegen ein Hersteller zu Entscheiden
 
N2k1

N2k1

Ehrenmitglied
Kaltfront schrieb:
Ich habe Windows 10 Pro was Aktuell ist und bin nach dieser Anleitung vorgegangen.
Das klingt nicht nach einem routiniertem "Flasher".
Kaltfront schrieb:
Jedoch kommt schon eine Fehlermeldung das dass Handy also USB gerät nicht erkannt wird und dann ist der Treiber welcher ein Ausrufezeichen im Gerätemanager hat auch wieder weg und das Handy lädt weiter den Akku auf.
Da das Verhalten normal ist, ist dies ein weiteres Indiz dafür
Kaltfront schrieb:
ich habe mein alten Laptop mit Win7 benutzt und es "ging" jedenfalls hat mir Flashtool gesagt das er erfolgreich geflasht hat
Die Frage ist hier, was geflasht wurde (und die hast Du nicht beantwortet)
Kaltfront schrieb:
nach dem flash ging das Handy nicht mehr an
s.o.
Kaltfront schrieb:
Es wird am PC nicht mehr erkannt.
Mit fehlendem Preloader normal.
Kaltfront schrieb:
Soviel zum Thema Elephone.
Und wo war nun der Bezug zum Touch?
Kaltfront schrieb:
Ich hab schon Zig Handys unter Windows 10 geflasht (ohne Probleme)
Wieso ist dann der Treiber fehlerhaft?
Kaltfront schrieb:
Das das Handy zerflasht war sehe ich nicht als meine Schuld an
Was hast Du denn nun wie geflasht?
Kaltfront schrieb:
Zumal ich gegen Elephone ehr wegen dem Touchscreen Ausfall und dem Fingerprint Ausfall gewettert habe
Davon steht da oben aber nichts.
Kaltfront schrieb:
Na ja und das der Recovery nach einem Update weg ist, hatte ich auch noch nie ^^
Das ist bei den Nexus-Geräten Standard. Hier wird beim Update Root und das Custom-Recovery entfernt.
 
K

Kaltfront

Ambitioniertes Mitglied
Ich spare mir jetzt mal das alberne zitieren in Stichpunkten.

Ich habe die ganz Normale Original Firmware geflasht.
Das ich das mit dem gelben Ausrufezeichen usw geschrieben habe liegt einzig und allein daran weil ich den Fehler und meine Vorgehensweise genau erläutern wollte damit das auch jeder versteht der es liest.
Und ja ich lese bei Handys die ich noch nie hatte immer bevor ich flashe eine Anleitung, was ist daran jetzt falsch?
Zum Recovery, das Handy hatte kein Rot oder CFW aber soweit ich weiß hat jedes Android Smartphone ein Recovery, was auch Logisch ist denn über diesen setzt er ja das Gerät auf Werkseinstellung zurück.
Auch beim Nexus und ich hatte damals das 5er gab es bzw gibt es eine Stock recovery.
Aber lustig wie hier die Beiträge Penibel auseinander genommen werden wenn da wer Langeweile hat ^^
 
Miss Montage

Miss Montage

Ehrenmitglied
Da @Kaltfront 's P9000 wieder läuft, halte ich diese Diskussion ehrlich gesagt auch für müßig: ein Eigen"verschulden" konnte ich seiner Schilderung nicht entnehmen. Deshalb fände ich es sinnvoll, den Thread für weitere Fragen und Problemschilderungen übersichtlich zu halten ;).
 
M

mobilematic

Ambitioniertes Mitglied
Ich habe den Flash Vorgang mit allen Tastenkombinationen und verschiedenen Flash- Tool ausprobviert und der BROM Error kommt immer :( Sogar am andereren Windows 7 Rechner. Treiber sind eigentlich ok, weil im Gerätemanager zu sehen. Die rote Balke ist dann beim 100% und dann taucht gleich der Fehlrer auf.
Hat jemand noch eine Idee wie ich diesen Fehler beheben kann?

LG.
 
N2k1

N2k1

Ehrenmitglied
BROM Error ist meist die Folge einer falschen Scatter-Datei oder gar einer falschen Firmware.
 
M

mesh66

Fortgeschrittenes Mitglied
Hallo,
Ich möchte mein Elephone P9000 flashen.
Wenn ich das Flash Tool öffne und die passende Scatter Datei öffne, kann ich kein Hacken setzen. Was mache ich falsch?